To prepare your database for upgrading to version 2.1, remove the conname constraint from the bucket_info table.

Prerequisites

  • Verify that the old version of VMware Cloud Director Object Storage Extension is uninstalled.
  • Verify that you upgraded your PostgreSQL database to version 9.5 or later.
  • Verify that you backed up your database.

Procedure

  1. Log in to the PostgreSQL database as a database administrator.
  2. Retrieve the OID of the conname constraint for the bucket_info table.
    SELECT conname
    FROM pg_constraint
    WHERE conrelid =
        (SELECT oid
        FROM pg_class
        WHERE relname like 'bucket_info');
    The system returns the OID string. For example, ukb9c15fhp50s53gs8pntjaq5qt. Copy the OID so that you can use it in the next step.
  3. Remove the constraints from the bucket_info table.
    ALTER TABLE bucket_info
           DROP CONSTRAINT IF EXISTS {OID};
  4. (Optional) Delete the tables that are not used in VMware Cloud Director Object Storage Extension 2.1.
    DROP TABLE IF EXISTS um_storage_can_id;
     
    DROP TABLE IF EXISTS um_storage_user_id;
     
    DROP TABLE IF EXISTS pwc_object_info;

Results

Your PostgreSQL database is prepared for the upgrade to VMware Cloud Director Object Storage Extension 2.1.