While creating your SDDC and connecting a VPC and subnet to connect to in your AWS account, you are unable to select a subnet.

Problem

While deploying an SDDC, there is a step in which you select an Amazon VPC and subnet in your AWS account to connect to your SDDC. You might be unable to select a subnet during this step. A message in the UI indicates that you do not have capacity in any of your current subnet AZs.

Cause

You must select a subnet in the same availability zone (AZ) as your SDDC. Currently, it isn't possible to ensure which AZ your SDDC will match up to. If you have only created a single subnet, it might be in the incorrect AZ and not available for selection in this step.

Solution

  1. Create an appropriate subnet in each availability zone in your Amazon VPC.