Symptom:
Users are unable to access the VMware Data Services Manager console or API.
Potential Cause:
Validate that both IP addresses on the Provider VM are reachable. Also, compare the Provider VM uptime with the uptime of the systemd-networkd
service running on the VM. If both IP addresses are not reachable and the VM uptime is considerably greater than the service uptime, the systemd-networkd
service was likely restarted after VM boot.
Explanation:
The Provider VM and Database VM each have two network interfaces. eth0 must be the VM's default gateway. Source-based routing is required for eth1.
Routing rules are removed when the systemd-networkd
service is restarted. VMware Data Services Manager takes care of configuring source-based routing during the VM's boot. However, VMware Data Services Manager cannot detect a systemd-networkd
service restart that is initiated after the VM is booted. If the service happens to be restarted after boot, you must manually run a script to re-configure source-based routing.
Solution:
Log in to the VM as the root
user.
Manually run the VMware Data Services Manager script that configures source-based routing:
root@vm$ /opt/vmware/tdm-provider/bin/configure_src_based_routing.sh
Validate that access to the VMware Data Services Manager console and API has been restored.
Impact:
While the VMware Data Services Manager service is unreachable, there is no impact on database uptime, nor on a client's ability to connect to a database.