Applications configured to use DirectFlex can sometimes cause conflicts with other programs, which can cause the application to stop unexpectedly.

Problem

An application was configured to launch using DirectFlex, and the program stopped unexpectedly.

Cause

DirectFlex uses "hooks" to be notified of processes launching and exiting, and this technique sometimes conflicts with other software, particularly security and antimalware products.

Solution

  1. User Environment Manager provides advanced policy settings to resolve conflicts with specific third-party applications. Check Knowledge Base article 2145286 for the policies you can use with specific vendors.
  2. Or, you can blacklist one or more executables, so that they are not affected by the hooking mechanism by creating a Blacklist.xml file (this file does not exist by default).
    1. Create a new folder called DirectFlex within the \\Server\FlexConfigShare\General\FlexRepository folder.
    2. Create a new Blacklist.xml file with the following lines.
      <?xml version="1.0" encoding="utf-8"?>
      <userEnvironmentSettings>
      <setting type="blacklist" list="" />
      </userEnvironmentSettings>
    3. Add the executables you want to exclude in the field, list.
      For example, list="notepad.exe|calc.exe|regedit.exe".
      Note: Use | to specify more than one executable.
    4. Save the Blacklist.xml file with UTF8 encoding.

Solution

Depending on the solution you chose, the conflicts are resolved, or the hooking mechanism is disabled for specific applications. If you chose to blacklist the application hooking, you will need to configure the User Environment Manager configuration file for the application to import and export at login and logout.