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Using VMware Fusion

Using VMware Fusion describes how to use VMware Fusion® to create, use, and manage virtual machines. It
also describes how to install, configure, upgrade, and uninstall Fusion.

Intended Audience
This information is intended for anyone who wants to install, upgrade, or use Fusion.
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Updated Information 1
Using VMware Fusion is updated with each release of the product or when necessary.

This table provides the update history of Using VMware Fusion.
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Revision Description

EN-001869-02 n Added “About VMware Fusion Pro,” on page 14.
n Added support for Windows Server 2012 to “Creating

a Microsoft Windows Virtual Machine,” on page 44.
n Corrected “Select a Keyboard and Mouse Profile,” on

page 34 by removing a procedure step no longer
supported.

n Updated Moving and Copying Files and Text Between
Virtual Machines and Your Mac to add information on
moving and copying files or text between a Mac OS
virtual machine and a Mac host.

n Corrected Copy and Paste Between Virtual Machines
and Your Mac Using Keyboard Shortcuts to state that
the Enable Key Mappings preference is required to
copy and paste between virtual machines and the Mac.
Also added a statement that copying and pasting files
or folders between a Mac OS virtual machine and the
Mac is not supported.

n Updated “View Shared Folders in a Windows Guest by
Using Windows Explorer,” on page 82 by adding
options for viewing shared folders.

n Added “View Shared Folders in a Mac OS Guest,” on
page 83.

n Updated “Enable Shared Folders or Mirrored Folders
for a Virtual Machine,” on page 88 to add information
on the shortcut added when the Enable Shared
Folders checkbox is enabled.

n Changed the "Clean Up a Virtual Hard Disk" to “Clean
Up a Virtual Machine,” on page 115 to reflect the
supported functionality.

n Added “Using Virtual DiskManager,” on page 117.
n Updated “Show the Mac Power Supply Status in the

Virtual Machine,” on page 136 to state that showing the
Mac power supply status is not supported in Mac OS
virtual machines.

EN-001869-01 n Updated “Virtual Hardware Specifications,” on
page 18 to add a statement clarifying OpenGL3.3
support.

n Added “Resize the Virtual Machine Display to Fit,” on
page 30.

n Updated “Enable or Disable Mac Host Shortcuts on the
Keyboard and Mouse Preference Pane,” on page 35 to
add a step for customizing how the virtual machine
maps the Mac Command key to the Windows
command key.

n Added “Set Fusion Display Resolution Preferences,”
on page 36 for global preference settings.

n Updated “Set Default Applications Preferences,” on
page 37 to add the VMRC option.

n Updated “Create a Virtual Machine by Using Windows
Easy Install and a Disc Image File,” on page 46 to add
saving the virtual machine to a shared folder.

n Updated “Create a Virtual Machine by Using Windows
Easy Install and a Disc Image File,” on page 46 to add
saving the virtual machine to a shared folder.

n Updated “Create a Virtual Machine by Using Linux
Easy Install and an Installation CD,” on page 48 to
add saving the virtual machine to a shared folder.

n Updated “Create a Virtual Machine by Using Linux
Easy Install and an Image File,” on page 49 to add
saving the virtual machine to a shared folder.
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Revision Description

n Added “Creating a Shared Virtual Machine in Fusion,”
on page 50.

n Updated “Create a Virtual Machine for Any Supported
Operating System,” on page 52 to add saving the
virtual machine to a shared folder.

n Corrected “Upload a Virtual Machine to a Remote
Server,” on page 55 to remove the reference to
Workstation Pro. Fusion does not support uploading a
virtual machine to a server running Workstation Pro.

n Corrected “Upload a Virtual Machine to VMware
vCloud Air,” on page 55 to remove a note stating that
only Windows virtual machines can be uploaded to
VMware vCloud Air.

n Corrected “Download a Virtual Machine from a
Remote Server,” on page 56 to remove the reference to
Workstation Pro. Fusion does not support
downloading a virtual machine from a remote server
running Workstation Pro.

n Added “Export a Virtual Machine to OVF Format,” on
page 63.

n Updated “Clone a Virtual Machine,” on page 70 by
removing a statement that you cannot create full or
linked clones from single virtual machine access mode.
Single virtual machine access mode was deprecated in
a previous release.

n Added “Power on a Virtual Machine to Firmware in
Fusion Pro,” on page 76 for the option supported in
Fusion 8.1.

n Updated “Open a Windows Application While You
Are In Unity View,” on page 81 to remove references
to Linux applications. Beginning with Fusion 8.0, Unity
View on Linux is no longer supported.

n Updated “Guest Operating Systems That Support
Shared Folders,” on page 87 to remove deprecated
guest operating systems.

n Updated “Add a Shared Folder,” on page 89 to add
the Open in Guest option supported in Fusion 8.1.

n Updated “Delete a Snapshot,” on page 92 to add a
statement that you cannot delete an active snapshot.

n Added a statement to “Enable Default Applications,”
on page 101 that the Run Windows applications from
your Mac's Applications folder option is not available
for shared virtual machines.

n Added “Configuring Display Resolution Settings,” on
page 104 for virtual machine settings.

n Updated “Enable Accelerated 3D Graphics,” on
page 104 to add the Battery life option and the shared
graphics memory option.

n Updated “Enable Retina Display Support,” on page 105
to add the Automatically adjust user interface size in
the virtual machinecheck box and make other
corrections.

n Updated “Clean Up a Virtual Machine,” on page 115 to
add information on how cleaning up a hard disk cleans
up unconsolidated snapshot files.

EN-001869-00 Initial release.
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Getting Started with Fusion 2
With Fusion, you can run personal computer (PC) applications and devices on your Intel-based Mac.

Designed for the Mac user, Fusion takes advantage of the security, flexibility, and portability of virtual
machines to run Windows and other x86 operating systems at the same time as Mac OS X.

This chapter includes the following topics:

n “About VMware Fusion,” on page 13

n “About VMware Fusion Pro,” on page 14

n “System Requirements for Fusion,” on page 14

n “Install Fusion,” on page 14

n “Start Fusion,” on page 15

n “How-to Videos,” on page 15

n “Take Advantage of Fusion Online Resources,” on page 15

About VMware Fusion
Take a quick look at what Fusion does and how it works.

What Fusion Does
Fusion enables you to run your Windows applications and PC-only devices on your Intel-based Mac. You
can run multiple operating systems and applications at the same time, along with your Mac applications.
The operating systems and applications are isolated in secure virtual machines.

How Fusion Works
Fusion maps the physical hardware resources to the virtual machine’s resources, so each virtual machine has
its own processor, memory, disks, I/O devices and so on. Each virtual machine is the full equivalent of a
standard x86 computer, although it is represented in a single file package on the Mac.

After you install Fusion and create a virtual machine, you can install and run complete, unmodified
operating systems, and associated application software in the virtual machine, just as on a physical PC.
Operating systems you can use include Windows, Linux, and Mac OS X. Fusion offers the benefits of having
a second PC without its added expense, physical setup, and maintenance.

The operating system of the computer on which you run Fusion is called the host. Mac OS X and Mac OS X
Server are the only hosts supported for Fusion. The virtualized operating system you run inside Fusion is
called the guest.
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About VMware Fusion Pro
Fusion Pro provides advanced virtualization features for managing the virtual machines on your Mac.

Fusion Pro provides the following virtualization features:

n Clone a virtual machine

n Ability to power on a virtual machine to firmware

n Export a virtual machine to OVF format

n Restrict a virtual machine

n Set a keyboard shortcut for a virtual machine

n Create advanced custom networking configurations

n Connect to a remote server

n Connect to vCloud Air

System Requirements for Fusion
Verify that you have the following minimum system requirements for installing and using Fusion.

n Any Mac with a 64-bit Intel processor. Compatible with Core 2 Duo, Xeon, i3, i5, i7, or later processors.

n Mac OS X 10.9.0 or later for the host OS. Mac OS X 10.10 or later is recommended.

n Operating system installation media (disk or disk image) for virtual machines. Windows operating
systems are available separately from Microsoft and other retailers.

Important   Fusion does not provide any operating systems for installation on virtual machines that
you create with Fusion. You must provide the operating system installation media.

n 4 GB of memory, 8 GB recommended.

n 750 MB of free disk space for Fusion, and at least 5 GB of free disk space for each virtual machine.

Note   You must have enough memory to run Mac OS X, plus the memory required for each guest
operating system and for applications on the Mac and in the virtual machines.

Install Fusion
You install Fusion in the same way you install other Mac OS X applications.

Installation of Fusion does not modify existing virtual machines.

Prerequisites

n Verify that you have the administrator password for your Mac.

n Download the Fusion installer file to your Mac. You can obtain the Fusion installer file from the
VMware website.

n Verify that you have the appropriate license key. For example, if you are using VMware Fusion Pro, you
must provide a Fusion Pro license key to activate the Fusion Pro features.

For information about installing Fusion Pro for Horizon FLEX, see the VMware Horizon FLEX Client User
Guide.

Using VMware Fusion
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Procedure

1 Double-click the Fusion .dmg file to open it.

The contents of the disk image appear in the Fusion Finder window.

2 In the Finder window, drag the VMware Fusion icon to the Applications folder icon.

3 When prompted, type your administrator user name and password.

Fusion is installed in the Applications folder on your Mac.

Start Fusion
Start using Fusion.

Prerequisites

Verify that you have the administrator password for your Mac.

Procedure

1 In the Applications folder, double-click VMware Fusion.

The Virtual Machine Library window appears. From this window, you can start working with virtual
machines.

2 (Optional) To save Fusion in the Dock, right-click the icon, and select Options > Keep in Dock.

How-to Videos
Watch online videos about using Fusion.

If you are new to Fusion, watch some how-to videos to become familiar with Fusion features.

Procedure

n In Fusion, click Help > Video Tutorials to access a wide variety of topics that help you get started with
Fusion.

n You can also access these videos from the VMware Fusion Learning Center at 
http://www.vmwarefusionlearningcenter.com.

What to do next

On the VMware Fusion Product Support Web page you can find support and troubleshooting information
for running Windows and Linux on the Mac, such as Windows activation issues, sharing data, working with
virtual disks, and many other topics. See the VMware Fusion Product Support Center at 
http://www.vmwarefusionlearningcenter.com.

Take Advantage of Fusion Online Resources
Go to the VMware Fusion home page and support page for product news, FAQs, more resources, and the
online community.

To learn about available VMware support offerings, registering a product, or creating a technical support
request, see the VMware support portal at http://www.vmware.com/go/fusionsupport

You can also find information about using Fusion at the following self-help sources:

n The VMware Fusion Learning Center has video tutorials, FAQs, community forums, and more to help
you get up and running with Fusion.

Chapter 2 Getting Started with Fusion
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n Self-paced video tutorials and answers to frequently asked questions through the VMware support
portal at http://www.vmware.com/go/fusionsupport. Use the Advanced Help tab to view the list of
tutorials.

n VMware recommends joining the VMware Fusion Community at 
http://www.vmware.com/go/fusionforums. (In English.) The VMware Fusion Community is where
Fusion users can exchange information, questions, and comments to get the most out of Fusion.

n The VMware Knowledge Base provides troubleshooting information, solutions to error messages, and
some best practice information for most VMware products. To find information on a specific problem
you encounter in Fusion, select VMware Fusion in the product list and search for your problem by key
word at http://kb.vmware.com.

n For answers to frequently asked questions about Fusion, go to 
http://www.vmware.com/products/fusion/faqs.html.
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Understanding Fusion 3
Fusion harnesses virtualization to give you a powerful tool to run PC applications and devices on your Mac.

This chapter includes the following topics:

n “Virtual Machines and What Fusion Can Do,” on page 17

n “Navigating and Taking Action by Using the Fusion Interface,” on page 21

Virtual Machines and What Fusion Can Do
With Fusion, you can run virtual machines inside your Mac, which gives you access to a wide range of
Windows and other x86 operating systems and applications.

What Is a Virtual Machine?
A virtual machine is a software computer that, like a physical computer, runs an operating system and
applications.

A virtual machine typically contains a display, a hard disk or disks, one or more processors, memory, a
CD/DVD drive, a network adapter, and a USB controller. All of these components are virtualized. That is,
these elements of a virtual machine are all created by software and stored in files on your Mac.

The virtual machine runs in a window on your Intel-based Mac. You install an operating system and
applications in the virtual machine and operate it as you would a physical computer. An operating system
cannot distinguish between a virtual machine and a physical machine, nor can applications or other
computers on a network. What you can do with a physical machine (install software, save files, add
additional drives, and so on) you can do with a virtual machine.

Virtual machines are fully supported by Fusion with the underlying physical hardware. For example, you
can configure a virtual machine with virtual components that are completely different from the physical
components that are present on the underlying hardware. Virtual machines on the same physical host can
run different kinds of operating systems (Windows, Linux, Mac OS X, and others).

Fusion Capabilities
With Fusion, you can create, open, and run VMware virtual machines, and use PC-specific hardware with a
Mac.

With Fusion, you can perform the following tasks:

n Run x86 operating systems, including Windows, Linux, Mac OS X Server, and others, on Mac OS X
without rebooting.

n Run Windows and Linux applications on your Intel-based Mac.

n Run most Windows 3D applications that require DirectX 9 or DirectX 10 on your Mac.
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n Import virtual machines created with Parallels Desktop, Microsoft Virtual PC for Mac, or virtual
machines that use the OVF (Open Virtualization Format) standard.

n Migrate your physical Windows PC to a Fusion virtual machine with the integrated Migration
Assistant.

n Access USB devices, such as video cameras and high-speed disks, from a virtual machine.

n Drag files between your Intel-based Mac OS X host machine and virtual machines running other x86
operating systems.

n Fusion works with VMware virtual machines created with different VMware products. For more
information, see “Virtual Machine Compatibility,” on page 133

Supported Guest Operating Systems
Fusion supports more than 100 guest operating systems, including most versions of Windows, Mac OS X,
Mac OS X Server and Linux.

For guest operating system support, visit http://www.vmware.com/go/hcl

You can also go to the VMware Web site and click the Support tab. Under Support Resources, click the
Compatibility Guides link.

Virtual Hardware Specifications
Each virtual machine has a standard virtual hardware configuration for chip set, BIOS, ports, and so on. The
amount of memory and number of processors depends on your Mac.

Processor
n One virtual processor on a host system with one or more logical processors

n Up to eight virtual processors (eight-way virtual symmetric multiprocessing, or Virtual SMP™ ) on a
host system with at least four logical processors

n The following configurations have two logical processors:

n A multiprocessor Mac with two or more physical CPUs

n A single-processor Mac with a multicore CPU

Chip Set
n Intel 440BX-based motherboard

n NS338 SIO

n 82093AA IOAPIC

BIOS
n PhoenixBIOS 4.0 Release 6 with VESA BIOS

Memory
n Up to 64 GB, depending on the available memory on your Mac, virtual machine hardware version, and

guest operating system support

Using VMware Fusion
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n Total memory available for all virtual machines is limited only by the amount of memory on the Mac

Note   If you assign too much memory to your virtual machines and have them all running at the same
time, your Mac might slow down because of heavy disk swapping. As a best practice, make sure the
total memory that Fusion and all running virtual machines uses stays below 70 percent of your total
Mac memory.

Graphics
n VGA

n SVGA

n 128MB 3D accelerated video with DirectX 9.0c with Shader Model 3 and OpenGL 2.1 for Windows XP
as the guest OS

n 256MB 3D accelerated video with DirectX 9.0EX with Aero and OpenGL 2.1 for Windows Vista and
later as the guest OS

n 3D accelerated video with DirectX 10 with OpenGL 3.3 for Windows Vista and later as the guest OS.
DirectX 10 requires OSX 10.10 or later on the host and hardware version 12 and later. DirectX 10 also
requires a GPU version of Intel HD4000 or later, Nvidia GeForce 650M or later, or AMD Radeon HD
5750 or later. The VMware guest operating system OpenGL driver for Windows and Linux supports the
OpenGL 3.3 core profile only. The OpenGL3.3 compatibility profile is not supported.

n To use the GL_EXT_texture_compression_s3tc and GL_S3_s3tc Open Graphics Library (OpenGL)
extensions in a Windows XP or Windows 7 or later guest operating system, you must install Microsoft
DirectX End-User Runtime in the guest operating system. OpenGL is an application program interface
that is used to define 2D and 3D computer graphics. You can download Microsoft DirectX End-User
Runtime from the Microsoft Download Center Web site.

IDE Devices
n Up to four devices. Any of these devices can be a virtual hard disk or CD/DVD drive

n IDE virtual disks up to 8 TB

n CD/DVD drive can be a physical device on the host or client system, or an ISO image file or a DMG
image file

SATA Devices
n Up to 120 SATA devices: 4 controllers and 30 devices per controller

n SATA virtual disks up to 8 TB

SCSI Devices
n Up to 60 devices. Any of these devices can be a virtual hard disk or CD/DVD drive

n SCSI virtual disks up to 8 TB

n LSI Logic LSI53C10xx Ultra320 SCSI I/O controller. For Windows XP guest systems, this requires an
add-on driver from the LSI Logic Web site. On the Web site, select Support & Downloads, click the link
for downloading drivers, and select the controller in the drop-down menu to find the driver to
download.

n Mylex (BusLogic) BT-958 compatible host bus adapter. For Windows XP and Windows Server 2003
guest systems, this requires an add-on driver from the VMware Web site. See 
http://www.vmware.com/download/fusion/drivers_tools.html.

Chapter 3 Understanding Fusion
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Printers
n Driver-free printing. Automatic replication of host printers in guest virtual machines, including PCL

and PostScript printers

n Local and network-attached printers

Floppy Drives
n Up to two 1.44MB floppy devices

n Virtual floppy devices use floppy image files only

Serial (COM) Ports
n Up to four serial (COM) ports

n Virtual serial ports support only output to a file

n One serial port can be used for driver-free printing

Parallel (LPT) Ports
n Up to three bidirectional parallel (LPT) ports

n Virtual parallel ports support only output to a file

USB Ports
n Supports high-speed USB 2.0 and super-speed USB 3.0

n Supports most devices, including USB printers, scanners, PDAs, hard disk drives, memory card readers
and digital cameras, as well as streaming devices such as webcams, speakers, and microphones

Keyboard
n 104-key Windows 95/98 enhanced

Mouse and Drawing Tablets
n PS/2 mouse

n USB mouse

n USB drawing tablets

Ethernet Card
n Up to 10 virtual Ethernet cards are supported.

Virtual Networking
n Three virtual hubs are configured by default for bridged, host-only, and NAT networking.

n Support for most Ethernet-based protocols, including TCP/IP v4, Microsoft Networking, Samba, Novell
NetWare, and Network File System.

n Built-in NAT supports client software using TCP/IP v4, FTP, DNS, HTTP, WINS, and Telnet, including
VPN support for PPTP over NAT.

n Create additional virtual networks to create isolated logical networks. This feature is available only with
Fusion Pro.

Using VMware Fusion
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n Support for IPv6 for NAT only applies to additional virtual networks, and is available only with Fusion
Pro.

Sound
n Sound output and input using the Mac default input and output settings.

n Emulates Creative Labs Sound Blaster ES1371 AudioPCI sound card. MIDI input, game controllers and
joysticks are not supported.

n HDAudio

Solid-State Drives
If your host machine has a physical solid-state drive (SSD), the host informs guest operating systems they
are running on an SSD.

This allows the guest operating systems to optimize behavior. How the virtual machines recognize SSD and
use this information depends on the guest operating system and the disk type of the virtual disk (SCSI,
SATA, or IDE).

n On Windows 8, Windows 10, Ubuntu, and Red Hat Enterprise Linux virtual machines, all drive types
can report their virtual disks as SSD drives.

n On Windows 7 virtual machines, only IDE and SATA virtual disks can report their virtual disks as SSD.
SCSI virtual disks only report as SSD when used as a system drive in a virtual machine, or as a
mechanical drive when used as a data drive inside a virtual machine.

n On Mac virtual machines, only SATA virtual disks are reported as SSD. IDE and SCSI virtual disks are
reported as mechanical drives.

Use the virtual machine operating system to verify your virtual machine is using SSD as its virtual disk.

Navigating and Taking Action by Using the Fusion Interface
With Fusion interface elements, you can access your virtual machines and manage Fusion.

VMware Fusion Toolbar
You can use icons on the toolbar to initiate actions or change settings.

You can use the VMware Fusion toolbar to change the state of the virtual machine (for example, power on,
suspend, reboot), access its snapshots, or view and change settings for the virtual machine.

You can see the VMware Fusion toolbar in the virtual machine window in Single Window view and in the
Virtual Machine Library based on your selection to show or hide the toolbar in the View menu. See “Show
or Hide the Fusion Toolbar,” on page 40.

Perform Actions on Your Virtual Machines From the Virtual Machine Library
Window

The Virtual Machine Library window shows the virtual machines you created or powered on in Fusion.

Procedure

1 Select Window > Virtual Machine Library to access the Virtual Machine Library window.

Chapter 3 Understanding Fusion
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2 Use one of the controls in the window to perform an action with an existing virtual machine, or to
create a virtual machine.

Option Action

Start a virtual machine Click the play button on the thumbnail image of the virtual machine.

Suspend a virtual machine Select the thumbnail image of the virtual machine and click the suspend
button in the toolbar.

Add notes about a virtual machine Select the virtual machine and click Virtual Machine > Get Info. Type
notes in the Notes field of the General settings for the virtual machine.

Rename a virtual machine Double-click on the name of virtual machine and type a new name.

Determine the location of a virtual
machine's files

a Control-click the virtual machine.
b Select Show in Finder.

Change the settings for a virtual
machine

Click Settings to open the Settings window for that virtual machine. Some
settings can be changed only if the virtual machine is powered off.

Add a virtual machine to the Virtual
Machine Library window

Drag the virtual machine package icon or the virtual machine's .vmx file to
the window.

Remove a virtual machine from the
Virtual Machine Library window

Shut down or power off the virtual machine. Select the virtual machine
and click Delete.
Removing a virtual machine from the Virtual Machine Library window is
not the same as deleting the virtual machine from your hard disk.

Create a new virtual machine,
import a virtual machine, or migrate
a physical computer

Use the File menu to create a new virtual machine, import a virtual
machine, or migrate a PC.

 

Using the Home Pane to Create a Virtual Machine or Obtain One from Another
Source

You can create a virtual machine, or migrate a physical PC.

Power On the Boot Camp Partition as a Virtual Machine
You can use the contents of your Boot Camp partition at the same time that you are running your Mac
operating system. To do so, you use Fusion to power on the Boot Camp partition as a virtual machine.

Boot Camp is Apple software that enables an Intel-based Mac to run Windows operating systems. Boot
Camp requires you to choose between Mac or Windows at boot time. Boot Camp creates separate Mac and
Windows partitions on your hard disk to create a dual-boot environment. When you use your Windows
Boot Camp partition as a Fusion virtual machine, you can perform the following tasks:

n Use your Boot Camp virtual machine and your Mac without rebooting and switching between them.

n Share files between your Boot Camp virtual machine and your Mac, through shared folders, dragging
files, or cutting and pasting text.

Note   Windows reactivation complications can occur if you do not install VMware Tools. In such a case, if
you reactivate Windows in your Boot Camp virtual machine, and subsequently boot your Boot Camp
partition natively, you will be prompted to reactivate Windows. Reactivating Windows in your native Boot
Camp partition will result in your Boot Camp virtual machine requiring reactivation the next time you
power it on, and so forth. Installing VMware Tools solves this problem.

Prerequisites

You must have a Boot Camp partition in place before you start this procedure.

You must have administrator privileges to use the Boot Camp partition as a virtual machine.

Using VMware Fusion
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Procedure

1 Select Window > Virtual Machine Library.

2 In the Virtual Machine Library window, click the Boot Camp thumbnail in the list of virtual machines,
which identifies the partition that Fusion detected.

3 (Optional) Type your Mac password to access the Boot Camp partition.

Fusion creates a virtual machine that uses your Boot Camp partition and starts Windows.

4 Follow the onscreen instructions and restart your virtual machine when prompted.

After Windows boots from your Boot Camp virtual machine, Fusion starts the installation of VMware
Tools. VMware Tools enables full virtual machine functionality and optimizes performance for your
Boot Camp partition when you use the partition as a virtual machine.

5 When the VMware Tools installation is complete, reboot your computer.

What to do next

The first time you power on your Boot Camp virtual machine after you install VMware Tools, you must
reactivate Windows.

Using the Fusion Applications Menu
You can access virtual machine applications, guest operating system functions, and Fusion functions from
the applications menu icon that appears in the Apple menu bar.

With the Fusion applications menu, you can think about your virtual computing environment in terms of
applications rather than virtual machines. The applications menu is a single source for finding every
application on every virtual machine on your Mac.

The applications menu is useful when you use Unity view as your working environment. You can access the
contents of the Windows start menu without having the taskbar visible and can access the Virtual Machine
and View menu without having Fusion be the active application.

n Set Up the Applications Menu on page 23
You can set up the Fusion applications menu for quick access to applications in your virtual machines
from your Mac.

n Find a Guest Application by Using the Applications Menu on page 24
You can find and open any virtual machine application from the applications menu that is always
present in the Apple menu bar on the Mac.

Set Up the Applications Menu
You can set up the Fusion applications menu for quick access to applications in your virtual machines from
your Mac.

You can also use the applications menu to access Fusion functions, such as the power commands and the
views, and, in the case of Windows, some functions, like the run command.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Applications Menu.

Chapter 3 Understanding Fusion

VMware, Inc.  23



4 Select an option from the Show applications menu in menu bar drop-down menu.

Option Description

Always Applications menu appears, even if Fusion is not running.

Never Applications menu never appears, even if Fusion is running.

Only when Fusion is running Applications menu appears only when Fusion is running.
 

5 (Optional) Add items to the applications menu.

a Click the add (+) button to see the applications and other items available in the virtual machine.

b Click, shift-click, or -click the items to appear in the applications menu and click Add.

6 (Optional) Remove items from the applications menu.

a Select the item in the list to remove.

b Click the remove (-) button.

7 (Optional) Click Applications menu keyboard shortcut and select a shortcut from the drop-down
menu to enable a shortcut.

Find a Guest Application by Using the Applications Menu
You can find and open any virtual machine application from the applications menu that is always present in
the Apple menu bar on the Mac.

Procedure

1
Click the applications menu status item ( ) in the Apple menu bar.

The applications menu appears, displaying the most recently accessed virtual machine in the blue title
bar.

2 Click the pop-up menu in the title bar and select the virtual machine that contains the application you
want.

The list displays recently used applications. Depending on the operating system, it also displays
applications listed in a start menu or applications menu for that virtual machine.

3 In the list, find the application to open.

4 (Optional) If the application name does not appear in the list, you can show more applications.

n Click All Programs.

n Type the name of the application in the search field.

5 Click the icon to open the application.

Using Different Views in the Fusion Interface
You can view the Fusion interface in Single Window view, Full Screen view, and Unity view. These views
enable you to work with your applications and virtual machines in different ways.

Use Single Window View to Have Your Virtual Machine Appear in a Single Window
on the Mac Desktop
In Single Window view, the virtual machine appears in a single window that you can resize and move with
the mouse.

In Single Window view, you can see and use the VMware Fusion toolbar.
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n Switch to Single Window View on page 25
To see the Mac desktop and the virtual machine desktop at the same time, switch to Single Window
view.

n Return to Another View from Single Window View on page 25
To have the desktop of your virtual machine fill your display or set of displays, or to see a guest
application in a window on the Mac desktop, exit Single Window view.

Switch to Single Window View

To see the Mac desktop and the virtual machine desktop at the same time, switch to Single Window view.

In Single Window view, the virtual machine appears in a single window that you can resize and move with
the mouse.

Procedure

u Switch to Single Window view.

n In Full Screen view with the Full Screen title bar, select View > Single Window.

n In Full Screen view without the Full Screen Minibar, use the keyboard shortcut +Control+F to
switch to Single Window view.

n In Unity view, use the keyboard shortcut +Shift+U to switch to Single Window view.

Return to Another View from Single Window View

To have the desktop of your virtual machine fill your display or set of displays, or to see a guest application
in a window on the Mac desktop, exit Single Window view.

Procedure

n To have the desktop of your virtual machine fill your entire display or set of displays, from the
VMware Fusion menu bar, select View > Full Screen.

n To display guest application windows directly on your Mac desktop without seeing the virtual
machine's desktop, select View > Unity.

Use Unity View to Display Guest Applications Directly on a Mac Desktop
To work with your virtual machine applications from the Mac desktop without the Fusion interface, use
Unity view.

In Unity view, your virtual machine's window is hidden, and your open virtual machine applications appear
in the Mac dock. You can use the virtual machine applications just as you use your native Mac applications.

n About Unity View on page 26
Unity view is supported in several Windows operating systems, and enables you to use many Mac
functions with your guest applications.

n Switch to Unity View on page 26
You can switch to Unity view from an application open in another view.

n Use the Waiting for Unity Window to Interact with the Guest Operating System on page 27
Some operating system activities that require a response do not appear in Unity view. Fusion displays
the Waiting for Unity window to enable you to respond.

n View the Windows Taskbar and System Tray in Unity View on page 27
You can have the Windows taskbar or system tray visible while in Unity view.
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n Connect a USB Device in Unity View on page 27
You must manually connect USB devices when your virtual machine is running in Unity view.

n Switch to Another View From Unity View on page 28
To see the desktop of the virtual machine, you can switch from Unity view to Single Window view or
Full Screen view.

About Unity View

Unity view is supported in several Windows operating systems, and enables you to use many Mac functions
with your guest applications.

Unity view is fully supported in virtual machines running Windows XP, Windows Vista, Windows 7,
Windows 8, and Windows 10. Unity view is experimentally supported in virtual machines running
Windows Server 2003 (32-bit and 64-bit), 2008, and 2012.

You can use the  + C,  + X, and  + V Mac keyboard shortcuts to copy, cut, and paste text between your
Mac applications and virtual machine applications displayed in Unity view. You can also use the Mission
Control feature with virtual machine applications in Unity view, and you can use  + Tab to switch
between applications.

You can keep your virtual machine applications in the dock after you power off your virtual machine and
quit Fusion. To use a virtual machine application, click the application in the dock to launch Fusion and
open the application. You can also set virtual machine applications to open when you start up your Mac and
log in.

You can access, in Unity view, all your available virtual machine applications by using the always-on
Applications menu. See “Using the Fusion Applications Menu,” on page 23.

Switch to Unity View

You can switch to Unity view from an application open in another view.

Prerequisites

Unity view works only if VMware Tools is installed in the virtual machine.

Procedure

1 In your Windows XP, Windows Vista, Windows 7, Windows 8, or Windows 10 virtual machine, open
the applications to use in Unity view.

2 Switch to Unity View using one of the following methods:

a From the View menu, select Unity.

b Use the keyboard shortcut +Shift+U

c From the Application menu, click Unity.

d Click the Fusion icon in the tool bar.

The virtual machine window is hidden. The open applications are displayed in windows on the Mac
desktop and as icon tiles in the Mac dock.

What to do next

To exit Unity view, bring the Fusion application back up and select View and either Single Window or Full
Screen.
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Use the Waiting for Unity Window to Interact with the Guest Operating System

Some operating system activities that require a response do not appear in Unity view. Fusion displays the
Waiting for Unity window to enable you to respond.

Procedure

n In the Waiting for Unity window, follow prompts to respond to the dialogs.

When you are finished responding, the virtual machine returns to Unity view.

n Respond to the virtual machine's operating system by exiting Unity view.

a Click Exit Unity.

b Perform any activities that the guest operating system requires.

c To return to Unity view, select View > Unity.

View the Windows Taskbar and System Tray in Unity View

You can have the Windows taskbar or system tray visible while in Unity view.

Procedure

n Show the taskbar by selecting View > Show Taskbar in Unity.

The Hide System Tray option is dimmed.

n Hide the taskbar by selecting View > Hide in Unity.

n Show the system tray by selecting View > Show System Tray in Unity.

n Hide the system tray by selecting View > Hide System Tray in Unity

When they are set to show, these elements also remain visible when you switch to work in non-Windows
applications.

Connect a USB Device in Unity View

You must manually connect USB devices when your virtual machine is running in Unity view.

Note   Fusion does not support USB adapters for connecting displays to your virtual machines.

Procedure

1 Plug the USB device into your Mac.

The selection dialog appears.

2 Select the system to which you want to connect the device.

The action you take depends on how many virtual machines are open.

Option Description

If you have one virtual machine
powered on

Select Connect to Mac or Connect to OS of your open virtual machine.

If you have two or more virtual
machines powered on

In the pop-up menu, select Connect to your Mac or Connect to virtual
machine name for the selected virtual machine. Click OK.
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Switch to Another View From Unity View

To see the desktop of the virtual machine, you can switch from Unity view to Single Window view or Full
Screen view.

Prerequisites

Fusion must be the active application, so that the Fusion menu appears at the top of the display.

Procedure

u Exit Unity view.

Option Action

Have your virtual machine appear in
a single window on the Mac
desktop.

From the VMware Fusion menu bar, select View > Single Window.

Have the desktop of your virtual
machine fill your entire display or
set of displays.

From the VMware Fusion menu bar, select View > Full Screen.

 

The open applications appear in the Fusion virtual machine window.

Use Full Screen View To Make Your Virtual Machine Desktop Fill Your Display
In Full Screen view, Fusion fills your entire display or set of displays with the desktop of your virtual
machine.

In this view you do not see the Mac dock. You can show or hide the VMware Fusion menu bar. This view
looks as if you are using a machine dedicated to running your guest operating system. You have access to
the toolbar by moving the cursor to the top of the display to reveal the toolbar. Optionally, a subset of Fusion
functions are available via the compact Full Screen Minibar.

n Switch Fusion to Full Screen View on page 28
You can switch to Full Screen view from another view.

n Hide the VMware Fusion Menu Bar in Full Screen View on page 29
When you are in Full Screen view, the VMware Fusion menu bar hides until you hover the cursor at
the top of the Full Screen display. You can set the VMware Fusion menu bar to hide all the time.

n Set the Full Screen Minibar on page 29
When you are in Full Screen view, you can use the Full Screen Minibar to access some virtual machine
controls such as state change and some Virtual Machine menu options.

n Return to Another View from Full Screen View on page 30
To see the Mac desktop and the virtual machine desktop at the same time, or to see a guest application
in a window on the Mac desktop, switch to Unity view or Single Window view.

Switch Fusion to Full Screen View

You can switch to Full Screen view from another view.

Procedure

u Switch to Full Screen view.

n Click the Enter Full Screen button in the toolbar at the top of the virtual machine window.

n From the View menu, select Full Screen.

n Use the +Control+F keyboard shortcut to switch to Full Screen view.
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The Fusion virtual machine window expands to fill the full screen (or screens if you have multiple displays
and have Fusion configured to use them all). When possible, a new space is created for easy navigation
using Mission Control.

Hide the VMware Fusion Menu Bar in Full Screen View

When you are in Full Screen view, the VMware Fusion menu bar hides until you hover the cursor at the top
of the Full Screen display. You can set the VMware Fusion menu bar to hide all the time.

The Full Screen menu bar behavior applies to running virtual machines.

Procedure

u Set the Hide Menu Bar in Full Screen option.

n Select View > Hide Menu Bar in Full Screen.

n Use the  + Shift +M keyboard shortcut to hide or show the VMware Fusion menu bar in Full
Screen view.

Set the Full Screen Minibar

When you are in Full Screen view, you can use the Full Screen Minibar to access some virtual machine
controls such as state change and some Virtual Machine menu options.

In Full Screen view, the virtual machine window expands to fill the full screen, or screens if you are using
multiple displays. In this view you do not see the Mac dock. However, you can access some Virtual
Machine menu options by using the Full Screen Minibar. The Full Screen Minibar contains the Fusion
suspend and run button for the virtual machine, some virtual machine options, and the return to Single
Window view button.

Procedure

1 Select View > Full Screen.

The virtual machine view changes to Full Screen view and the Full Screen Minibar appears on the right
side of the screen by default.

2 Select the button in the Minibar with the gear icon and set the Full Screen Minibar behavior from the
Full Screen Minibar menu.

Option Description

Always Show The Full Screen Minibar is always visible.

Automatically Hide and Show For running virtual machines, the Full Screen Minibar is visible if you
move the pointer over its position at the edge of the display. For virtual
machines that are not running, the Full Screen Minibar always appears.

Always Hide The Full Screen Minibar never appears. Use the +Control+F keyboard
shortcut to exit Full Screen view.

Position on Screen Set where the Full Screen Minibar appears: Top, Left, Bottom, or Right
edge. You can also drag and drop the Full Screen Minibar to different
positions in a single display or you can drag it to another display if you
have more than one display.

 

Note   The Full Screen Minibar can be moved to a different side of the display by dragging.
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Return to Another View from Full Screen View

To see the Mac desktop and the virtual machine desktop at the same time, or to see a guest application in a
window on the Mac desktop, switch to Unity view or Single Window view.

To have your virtual machine appear in a single window on the Mac desktop, exit to Single Window view.
To display guest application windows directly on your Mac desktop without seeing the virtual machine's
desktop, exit to Unity view.

Procedure

n To exit Full Screen to Single Window view, in the Full Screen title bar, select View > Single Window, or
use the keyboard shortcut +Control+F.

n To exit Full Screen to Unity view, in the Full Screen title bar, select View > Unity, or use the keyboard
shortcut +Shift+U.

Resize the Virtual Machine Display to Fit
You can force the virtual machine display to fit the current screen or window size.

This option is disabled when the virtual machine is in Unity View or when the virtual machine display
cannot be resized.

Procedure

u Select View > Resize Virtual Machine to Fit

The virtual machine display is resized to fit the current screen or window.

Using Multiple Displays
Fusion supports multiple displays. Fusion detects up to ten displays and can automatically adjust when
displays are plugged in or unplugged, and change in resolution and orientation.

Use Multiple Displays in Unity View
Fusion detects multiple displays by default. You can drag a window in Unity view to any available display
without having to change settings.

For multiple displays and virtual machines in Unity view, do not use the display settings within the guest
operating system. Fusion does not support any changes made there.

Use All Displays in Full Screen View
You can set Fusion Full Screen view to use all of the displays attached to your Mac.

Procedure

1 Select View > Use All Displays in Full Screen if Use Single Display in Full Screen Mode is enabled.

Use All Displays in Full Screen is not supported for Mac OS X guests.

2 Select View > Full Screen if you are in another view.

Move Full Screen View to One of Multiple Displays
When you have multiple displays, you can specify one of them to use Full Screen view for a Fusion virtual
machine.

You can have a virtual machine to run in Full Screen view on a single display out of many, rather than use
all of the displays. You can have different virtual machines in Full Screen view on different monitors.
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Procedure

1 In the menu bar, select View > Single Window if you are in another view.

2 Drag the Fusion virtual machine window to the display you want to use for Full Screen view.

3 (Optional) In the menu bar, select View > Use Single Display in Full Screen if Fusion is set to use all
displays in Full Screen view.

4 In the menu bar, select View > Full Screen.

The Fusion virtual machine window fills the specified display.

Resize the Virtual Machine Display to Fit
You can force the virtual machine display to fit the current screen or window size.

This option is disabled when the virtual machine is in Unity View or when the virtual machine display
cannot be resized.

Procedure

u Select View > Resize Virtual Machine to Fit

The virtual machine display is resized to fit the current screen or window.
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Configuring Fusion 4
You can configure Fusion so that it looks and works in ways that fit your needs.

This chapter includes the following topics:

n “Setting Fusion Preferences,” on page 33

n “Customizing the Fusion Display,” on page 40

n “Keep a Windows Application in the Mac Dock,” on page 41

n “Set a Virtual Machine Application to Open When You Log In To Your Mac,” on page 41

n “Contents of the Virtual Machine Package,” on page 41

n “Work with Virtual Machine Packages,” on page 42

Setting Fusion Preferences
You can set preferences that control the behavior of Fusion.

Set General Preferences
You can set how your mouse works, how your virtual machines behave when you quit Fusion, and other
general operations.

Procedure

1 Select VMware Fusion > Preferences.

2 Click General.

3 In the When closing a virtual machine section, select how Fusion behaves when you close a virtual
machine.

Option Description

Suspend the virtual machine The virtual machine is suspended when you close the virtual machine
window.
If you close a virtual machine window with this preference selected, when
you next open the virtual machine, it restarts with applications running
and files open much as they would be after you suspended and resumed a
laptop computer.

Power off the virtual machine The virtual machine is powered off when you close the virtual machine
window.

Confirm before closing Fusion opens a dialog box that asks for confirmation before closing the
virtual machine window. To run virtual machines in the background, you
must select this option.
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4 In the Gaming section, select a setting that fits how you expect to use your mouse.

Option Description

Auto-detect Mouse for Games Fusion detects when it needs to lock a mouse to a virtual machine window
for correct operation during gaming. If no game is detected, the mouse
works in the normal fashion. This is the default setting.

Never Optimize Mouse for Games In some cases, the autodetect function can detect nongame applications as
games. Use this option to turn autodetect off so that the mouse can work in
the normal fashion for these applications.

Always Optimize Mouse for Games In some cases, the autodetect function fails to recognize a game. Use this
option to have correct mouse operation for gaming in this instance.

 
5 (Optional) In the Updates section, select the Automatically check for updates check box to have Fusion

check for software updates when it starts.

A message alerts you when a new version of Fusion is available to download and install. If you do not
select the Automatically check for updates check box, you can check for updates manually at any time
by selecting VMware Fusion > Check for Updates.

6 In the Feedback section, set how to handle data collection by VMware.

If you select the check box, certain anonymous data is sent to VMware when you update the software.
Knowing how Fusion customers use the current version can help VMware make decisions about future
versions of the product. You can click Learn More to see the privacy policy and the kind of data to be
collected. Deselect the check box if you do not want to participate in the program.

Select a Keyboard and Mouse Profile
Fusion provides standard keyboard and mouse profiles for each language it supports.

You can assign each virtual machine its own profile.

Procedure

1 Select VMware Fusion > Preferences and click Keyboard & Mouse.

2 Select a profile from the Keyboard & Mouse Profile drop-down menu.

3 Select Edit Profiles.

4 (Optional) Add or remove a profile using the add (+) button and the delete (-) button.

5 Click Done.

Set Key Mappings on the Keyboard and Mouse Preferences Pane
You can map certain key combinations on your Mac keyboard to keys on your virtual machine.

The following mappings are supported:

n Key to Key

n Set of Modifiers to Modifier

n Set of Modifiers + Key to Key

You cannot stack key mappings. You cannot create one key mapping and include that key mapping as part
of another key mapping.

Procedure

1 Select VMware Fusion > Preferences and click Keyboard & Mouse.

2 Click Key Mappings to go to the Key Mappings pane.
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3 Select the Enable Key Mappings check box.

4 (Optional) Select the Enable Language Specific Key Mappings check box if you want to incorporate
key mappings related to the keyboard layout for the language you selected in the Input Menu (as
shown by the flag icon in the menu bar).

When you change the Input Menu to a supported keyboard layout, additional key mappings are
appended to the key mapping list. Fusion supports U.K. English, Belgian, Danish, French, Swiss French,
and German. This feature is not available for Mac OS X Server virtual machines.

5 Change the key mapping settings.

Option Description

Turn a key mapping on or off Click the check box to the left of the Mac Shortcut.

Edit a key mapping Double-click the Mac Shortcut or Virtual Machine Shortcut to change and
make that change in the Edit Key Mapping dialog.

Add a key mapping Click the add (+) button and define the new key mapping in the Edit Key
Mapping dialog.

Delete a key mapping Select the key mapping and click the remove (-) button.

Restore the default settings Click Restore Defaults.
 

Set Mouse Shortcuts on the Keyboard and Mouse Preference Pane
In Fusion, you can use shortcuts to operate a single-button mouse as a two-button or three-button mouse.

The defaults are Control + primary button to mimic the secondary mouse button (right-click) and  +
primary button to mimic a third button.

You can change the shortcut.

Procedure

1 Select VMware Fusion > Preferences and click Keyboard & Mouse.

2 Click Mouse Shortcuts to go to the Mouse Shortcuts pane.

3 Double-click the mouse shortcut and hold down the keys for the new shortcut.

To restore the defaults, click Restore Defaults.

Enable or Disable Mac Host Shortcuts on the Keyboard and Mouse Preference
Pane

By default in Fusion, global keyboard shortcuts that the Mac operating system or third-party applications
have registered are sent to the Mac operating system instead of your virtual machine.

Examples of global Mac keyboard shortcuts include Command-Tab (switch applications) and F9, F10, and
F11 (Exposé commands). You set these shortcuts and commands in the Mac OS X System Preferences.

You can use the Mac Host Shortcuts pane to disable all these shortcuts while you use Fusion. This action
applies only to Single Window view and Full Screen view. In Unity view, all Mac OS shortcuts are always
enabled.

Procedure

1 Select VMware Fusion > Preferences and click Keyboard & Mouse.

2 Click Mac Host Shortcuts to go to the Mac Host Shortcuts pane.

3 To enable or disable all shortcuts, select or deselect the Enable Mac OS Host Keyboard Shortcuts check
box.
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4 To customize how the virtual machine maps the Mac Command key ( ) to the Windows command
key, select the option from the drop-down menu.

Option Description

Either Command Key Use either Mac Command key to map to the Windows command key.

Left Command Key Use the left Mac Command key to map to the Windows command key.

Right Command Key Use the right Mac Command key to map to the Windows command key.
 

The Mac OS commands are not editable here. You must make any changes to them in the Mac OS System
Preferences.

Enable Fusion Shortcuts on the Keyboard and Mouse Preference Pane
Fusion has several keyboard shortcuts for Fusion commands when you are in Single Window view or Full
Screen view. You can enable or disable these shortcuts in Fusion Preferences.

Procedure

1 Select VMware Fusion > Preferences and click Keyboard & Mouse.

2 Click Fusion Shortcuts to go to the Fusion shortcuts pane.

3 Select or deselect an item in the list.

Set Fusion Display Resolution Preferences
You can set preferences for how Fusion virtual machines appear in both single window mode and full
screen mode.

These preferences apply by default to all of your virtual machines. You can change these settings for specific
virtual machines. For more information, see “Configuring Display Resolution Settings,” on page 104.

Procedure

1 Select VMware Fusion > Preferences.

2 Select Display.

3 Select the Single Window resolution setting.

This setting specifies how all virtual machines appear in single window mode.

Option Description

Stretch the virtual machine in the
window

When the virtual machine window is resized, the virtual machine display
is stretched to fill the window with the resolution unchanged.

Resize the virtual machine and the
window

The virtual machine display is resized to fit the single window.
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4 Select the Full Screen resolution setting.

This setting specifies how all virtual machines appear in full screen mode.

Option Description

Center the virtual machine in the
screen

When the virtual machine enters Full Screen view mode, the virtual
machine display is centered on the screen with the resolution unchanged.

Stretch the virtual machine in the
screen

When the virtual machine enters Full Screen view mode, the virtual
machine display is stretched to fill the screen space with the resolution
unchanged.

Resize the virtual machine to fit the
screen

The virtual machine display is resized to fit the full screen.

 

Set Default Applications Preferences
You can set applications from the Mac or the virtual machines to be used to open different categories of
URLs.

You can open the following categories of URLs:

n RSS feeds (feed)

n File transfers (FTP, SFTP)

n Web pages (HTTP, HTTPS)

n Mail (mailto)

n VMRC (VMware Remote Console)

n Newsgroups (news)

n Remote sessions (Telnet, SSH)

If you make a Web browser the default from within a virtual machine, the default setting for how Fusion
handles URLs does not change. The next time you start or resume the virtual machine, or change the URL
preferences, the Fusion settings overwrite the changes that you make in the guest machine.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Default Applications.

4 Click Configure.

5 Set or change the preference.

Option Description

Add a category of URL to the
Default Applications pane

Click the add (+) button and select a URL category from the pop-up menu.

Set or change an application to use
to open a category of URL

Select an application from the pop-up menu to the right of the appropriate
Open [category] with check box. You can select from all available
applications on your Mac and in your virtual machines.

Remove a URL category Click the remove (-) button to the right of the pop-up menu for the
category.
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Creating Custom Networks
With Fusion Pro, you can change key networking settings, add and remove virtual custom networks, and
create custom virtual networking configurations. The changes that you make affect all virtual machines that
connect to the custom network running on the host system.

You can create custom networks to accomplish the following tasks:

n Add additional NAT configurations for scenarios in which a virtual machine shares the IP address and
MAC address of your Mac.

n Add additional virtual private network (VPN) configurations between virtual machines and the host
system.

For either type of custom network, you can specify which subnet is used by Fusion and whether to connect a
physical network on the host system to the custom network.

Add a NAT Configuration
With Fusion Pro, you can add additional NAT configurations for scenarios in which a virtual machine
shares the IP address and MAC address of your Mac.

By default, Fusion provides one Share with my Mac configuration that uses NAT. You can add additional
NAT configurations to perform actions such as turning off the DHCP service or using a subnet IP or subnet
mask other than the default.

Prerequisites

n Verify that you have a Fusion Pro license.

n Verify that you know the administrator password.

Procedure

1 Select VMware Fusion > Preferences and click Network.

2 Click the lock icon, type the administrator password, and click OK.

3 Click the plus sign (+) under the list of networks.

4 Select Allow virtual machines on this network to connect to external networks (using NAT).

5 (Optional) Click the check box to Enable IPv6 and enter the IPv6 Prefix in the text box.

6 (Optional) To connect a physical network on the host system to this private network, select Connect the
host Mac to this network.

7 (Optional) To use a local DHCP service to distribute IP addresses to virtual machines on the network,
select Provide addresses on this network via DHCP.

8 (Optional) To change the subnet IP address or subnet mask, modify the addresses in the Subnet IP and
Subnet Mask text boxes.

9 Click Apply.

The network that you configured is now available to the virtual network adapters associated with virtual
machines on your Mac.
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Add a Private Network Configuration
With Fusion Pro, you can add additional virtual private network (VPN) configurations between virtual
machines and the host system.

Multiple virtual machines configured with this type of host-only networking are on the same network. The
VMware DHCP server can provide addresses on the network.

You might want to set up multiple private networks on the same computer in the following situations:

n To have two virtual machines connected to one private network, and other virtual machines connected
to another private network to isolate the network traffic on each network

n To test routing between two virtual networks

n To test a virtual machine that has multiple network interface cards, without using any physical network
adapters

Prerequisites

n Verify that you have a Fusion Pro license.

n Verify that you know the administrator password.

Procedure

1 Select VMware Fusion > Preferences and click Network.

2 Click the lock icon, type the administrator password, and click OK.

3 Click the plus sign (+) under the list of networks.

4 Verify that the following check box is not selected: Allow virtual machines on this network to connect
to external networks (using NAT).

5 (Optional) To connect a physical network on the host system to this private network, select Connect the
host Mac to this network.

6 (Optional) To use a local DHCP service to distribute IP addresses to virtual machines on the network,
select Provide addresses on this network via DHCP.

7 (Optional) To change the subnet IP address or subnet mask, modify the addresses in the Subnet IP and
Subnet Mask text boxes.

8 Click Apply.

The network that you configured is now available to the virtual network adapters associated with virtual
machines on your Mac.

Enable Dictation
Dictation allows you to use your voice instead of typing. You must enable Dictation in Fusion to use it with
guest operating systems.

Procedure

1 Select VMware Fusion > Preferences and click Keyboard & Mouse.

2 Select a profile to use from the Keyboard & Mouse Profile drop-down menu.

3 Click Mac Host Shortcuts to go to the Mac Host Shortcuts pane.

4 Make note of how your virtual machine maps the Command key to the Windows key.

5 Assign a hot key to start dictation in the virtual machine.
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Customizing the Fusion Display
You can customize the Fusion display to fit the way you work with virtual machines.

n Show or Hide the Fusion Toolbar on page 40
If you prefer working on your Mac without toolbars hidden when you aren't using them, you can hide
the Fusion toolbar in the virtual machine window.

n Customize the Fusion Toolbar on page 40
You can add or remove icons from the toolbar.

n Resize the Fusion Display and Resolution on page 40
You can use the mouse to resize the virtual machine window.

Show or Hide the Fusion Toolbar
If you prefer working on your Mac without toolbars hidden when you aren't using them, you can hide the
Fusion toolbar in the virtual machine window.

Procedure

u Click View > Show/Hide Toolbar.

Customize the Fusion Toolbar
You can add or remove icons from the toolbar.

Prerequisites

You must use Single Window view to customize the toolbar.

Procedure

1 Select View > Customize Toolbar.

The list of all the tools available for the toolbar appears.

2 Drag tools between the list and the toolbar.

Use the Show pop-down menu to set the toolbar display to Icon & Text, Icon Only, or Text Only.

3 Click Done.

Resize the Fusion Display and Resolution
You can use the mouse to resize the virtual machine window.

Prerequisites

Changing the display resolution by resizing the window works only if VMware Tools is installed and is up
to date in the virtual machine.

Procedure

u With the pointer over the resize control at the lower-right corner of the virtual machine window, hold
down the primary mouse button and drag the handle to resize the window.

The display resolution adjusts to the new window size.
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Keep a Windows Application in the Mac Dock
You can place an icon tile for a Windows application in your Mac dock, where you can open the application
in the same way that you open your Mac applications. You can access your virtual machine's applications
without having to use the VMware Fusion menu bar or the guest operating system interface.

Procedure

1 Switch to Unity view with the application open.

The application appears in the Mac dock.

2 Control-click or right-click the application in the dock and select Options > Keep in Dock.

Set a Virtual Machine Application to Open When You Log In To Your
Mac

For convenience, you might want to have an application on your virtual machine open whenever you start
your Mac.

Procedure

1 Switch to Unity view with the application open.

The application appears in the Mac dock.

2 Control-click or right-click the application in the dock and select Options > Open at Login.

Contents of the Virtual Machine Package
The files that describe a virtual machine are bundled in a package in Mac OS X.

Virtual machine files have different functions, as shown in Table 4-1. Some of these files, like the lock files,
are created when the virtual machine runs.

Table 4‑1.  Files in the Virtual Machine Package

File Description

Virtual disk file(s) *.vmdk This can be a single large file or many 2GB portions,
depending on how you set up your disk and if you have
snapshots.

Configuration file *.vmx A plain text file describing the virtual machine, such as
which files it uses, how much RAM it gets, and a variety of
other settings.

BIOS file *.nvram This contains information such as the virtual machine's
boot order.

Log file vmware.log This is a plain text file that contains information on the
most recent run of the virtual machine. The next-most-
recent is called vmware-0.log, then vmware-1.log, and
finally vmware-2.log. If you ever have a problem with
Fusion, you might be asked to provide this file.

Lock files *.lck These files are created for the configuration and disk files
when the virtual machine is running.

Memory files *.vmem Snapshot files are an example of memory files.
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Work with Virtual Machine Packages
When you create a virtual machine, Fusion stores the virtual machine files as a single package. This feature
lets you move an entire virtual machine as a single entity.

A package (sometimes called a bundle) has the extension .vmwarevm. When you move the package, all virtual
machine files are included.

You might need to access the virtual machine package files during troubleshooting.

Note   Editing the configuration file can cause problems. Make a backup copy of the file before you make
any changes.

Prerequisites

Fusion must not be running during virtual machine file editing.

Procedure

1 In the Finder, select the virtual machine package.

By default, virtual machine packages are located in your home folder/Documents/Virtual Machines.

2 Control-click or right-click the package and select Show Package Contents.

3 Perform one of the following tasks.

n Copy the log file (vmware.log) to provide for troubleshooting analysis.

n Open the configuration file (*.vmx) in a text editor to modify it. You can find instructions for how to
modify the file in the Fusion release notes or from appropriate support personnel.
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Creating Virtual Machines 5
You can create virtual machines, import virtual machines created elsewhere, and migrate virtual machines
converted from physical PCs. If you have Fusion Pro, you can also clone existing virtual machines.

This chapter includes the following topics:

n “Create a Virtual Machine,” on page 43

n “Upload a Virtual Machine to a Remote Server,” on page 55

n “Upload a Virtual Machine to VMware vCloud Air,” on page 55

n “Download a Virtual Machine from a Remote Server,” on page 56

n “Migrate an Existing Physical PC to a Virtual Machine,” on page 56

n “Importing Windows Virtual Machines,” on page 60

n “Export a Virtual Machine to OVF Format,” on page 63

n “Installing and Using VMware Tools,” on page 64

n “Cloning Virtual Machines with Fusion Pro,” on page 68

Create a Virtual Machine
How you create a virtual machine depends on its guest operating system. Virtual machines created using
Fusion 6 and later are created with SATA virtual disks or CD drives.

n Creating a Microsoft Windows Virtual Machine on page 44
You can create a virtual machine that uses a Microsoft Windows operating system as its guest
operating system.

n Creating a Linux Virtual Machine in Fusion on page 48
You can create a virtual machine that uses a Linux distribution as its guest operating system.

n Creating a Mac OS X Virtual Machine in Fusion on page 50
You can install OS X Server or OS X Client in a virtual machine. Fusion creates the virtual machine,
opens the OS X installation assistant, and installs VMware Tools. VMware Tools loads the drivers
required to optimize a virtual machine's performance.

n Creating a Shared Virtual Machine in Fusion on page 50
You can create a shared virtual machine in Fusion that can be accessed by all users on the local Mac
host.

n Create a Virtual Machine from a Mac Recovery Partition on page 51
You can use the recovery partition on your Mac to create virtual machines running Mac OS X.
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n Create a Virtual Machine on a Remote Server on page 51
You can create a virtual machine on a remote server, but certain requirements must be met for the
server.

n Create a Virtual Machine for Any Supported Operating System on page 52
You can create a virtual machine with a guest operating system that does not have an Easy Install
option if the guest operating system is supported by Fusion.

n Power On the Boot Camp Partition as a Virtual Machine on page 53
You can use the contents of your Boot Camp partition at the same time that you are running your Mac
operating system. To do so, you use Fusion to power on the Boot Camp partition as a virtual machine.

n Activate Windows in a Virtual Machine on page 54
In some cases you must activate Windows when you create, import, or migrate a virtual machine.

Creating a Microsoft Windows Virtual Machine
You can create a virtual machine that uses a Microsoft Windows operating system as its guest operating
system.

Fusion creates your virtual machine, selects the default Windows installation options, and installs VMware
Tools, which loads the drivers required to optimize your virtual machine's performance. You can also have
Windows Easy Install make your home folder available to Windows as a shared folder, so you can share files
between the virtual machine and your Mac, and other sharing options.

Windows Easy Install is available for the following Windows operating systems:

n Windows 10, Windows 8, Windows 7, Windows Vista, and Windows XP

n Windows Server 2012, Windows Server 2008, Windows Server 2003, Windows 2000 Server

Note   You must provide the operating system software and its product key. Fusion does not include any
operating system or license.

If you are not using one of these Windows operating systems in your virtual machine, or if you are using
Windows but want to install the operating system manually, you can use the procedure for creating a virtual
machine for any supported operating system.

Create a Virtual Machine by Using Windows Easy Install
When you create a Microsoft Windows virtual machine, you can use the Fusion Windows Easy Install
feature to install the Windows operating system you supply and to install VMware Tools in your virtual
machine.

Prerequisites

n If you are installing the guest operating system from an image file, verify that the ISO image file is in a
directory that is accessible to the host system.

n If you are installing the guest operating system from a physical disc, insert the operating system
installation disc into your Mac.

Important   Fusion does not include any operating systems to install in virtual machines that you create.
You must obtain the operating system and any necessary product keys.

Procedure

1 Select File > New.

The Create a New Virtual Machine assistant starts.
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2 Click Install from disc or image.

3 Select the disc or ISO image.

Option Description

ISO image file a Click Use another disc or disc image, browse to the .iso file for the
operating system, and click Open to identify the file.

b Select the file from the list in the Create a New Virtual Machine
window, and click Continue.

Physical disc Select the disc you inserted into the Mac from the list and click Continue.
If the disc does not appear in the list, click Use another disc or disc image
and browse to the location of the disc.

 
4 In the Windows Easy Install panel, select Use Easy Install.

5 Type the following information and click Continue.

n Display Name or Account Name

For Windows XP and earlier, the entry in the Display Name text box appears in Info windows as
the name your Windows software is registered to. It is not the Windows user name.

n Password (optional)

The entry in the Password text box is the password for the Windows administrator account only.

n Windows Product key

Fusion does not provide the product key. The product key is included in the materials from the
Windows operating system vendor.

6 In the Integration panel, indicate how basic file sharing is handled in the new virtual machine.

Option Description

More Seamless Fusion shares the documents and applications on your Mac with
Windows. Files on your Mac that Windows supports open in Windows.
Windows can modify your Mac’s documents, so install and regularly
update Windows antivirus software.

More Isolated Fusion does not share the documents and applications on your Mac with
Windows. To copy files between your Mac and Windows, use drag and
drop.

 
You can change these settings after the virtual machine is created by selecting Virtual Machine >
Settings and using the Sharing panel.
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7 In the Finish panel, you can use default settings to finish the virtual machine creation, or you can
customize the settings before the creation is finished.

Option Action

To create the virtual machine
according to the specifications
listed in the Finish panel

a Click Finish.
b Indicate the folder in which to save the virtual machine. The default is

your user/Documents/Virtual Machines folder.
c (Optional) To share the virtual machine with other users on the Mac

host, save the virtual machine to the Shared folder and select the
Share this virtual machine with other users on this Mac check box.
Deselect the check box to save to the Shared folder but not share the
virtual machine with other users on the Mac host. See “Creating a
Shared Virtual Machine in Fusion,” on page 50.

To change disk size or other
standard settings of the virtual
machine

a Click Customize Settings.
b Save the new virtual machine.
c Make changes to the virtual machine’s disk size, processor usage,

removable devices, and other configurations on the Settings window.
 

Fusion starts the new virtual machine, installs the operating system, and installs VMware Tools.

Create a Virtual Machine by Using Windows Easy Install and a Disc Image File
When you create a Microsoft Windows virtual machine, you can use the Fusion Windows Easy Install
feature to install the Windows operating system you supply and to install VMware Tools in your virtual
machine.

Prerequisites

Important   Fusion does not include any operating systems to install in virtual machines that you create.
You must obtain the operating system and any necessary product keys.

Procedure

1 Select File > New.

The Create a New Virtual Machine assistant starts.

2 Click Install from disc or image.

3 Click Use another disc or disc image and browse for the .iso file for the operating system. Click Open
to identify the file.

4 Select the file from the list in the Create a New Virtual Machine window, and click Continue.

5 In the Windows Easy Install panel, select Use Easy Install.

6 Enter the following and click Continue.

n Display Name or Account Name

For Windows XP and earlier, the entry in the Display Name field appears in Info windows as the
name your Windows software is registered to. It is not the Windows user name.

n Password (optional)

The entry in the Password field is the password for the Windows administrator account only.

n Windows Product key

Fusion does not provide the product key. The product key is included in the materials from the
Windows operating system vendor.
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7 In the Integration panel, indicate how basic file sharing is handled in the new virtual machine.

Option Description

More Seamless Fusion shares the documents and applications on your Mac with
Windows. Files on your Mac that Windows supports open in Windows.
Windows can modify your Mac’s documents, so install and regularly
update Windows antivirus software.

More Isolated Fusion does not share the documents and applications on your Mac with
Windows. To copy files between your Mac and Windows, use drag and
drop.

 
You can change these settings after the virtual machine is created by selecting Virtual Machine >
Settings > Sharing.

8 In the Finish panel, you can use default settings to finish the virtual machine creation, or you can
customize the settings before the creation is finished.

Option Action

To create the virtual machine
according to the specifications
listed in the Finish panel

a Click Finish.
b Indicate the folder in which to save the virtual machine. The default is

your user/Documents/Virtual Machines folder.
c (Optional) To share the virtual machine with other users on the Mac

host, save the virtual machine to the Shared folder and select the
Share this virtual machine with other users on this Mac check box.
Deselect the check box to save to the Shared folder but not share the
virtual machine with other users on the Mac host. See “Creating a
Shared Virtual Machine in Fusion,” on page 50.

To change disk size or other
standard settings of the virtual
machine

a Click Customize Settings.
b Save the new virtual machine.
c Make changes to the virtual machine’s disk size, processor usage,

removable devices, and other configurations on the Settings window.
 

Fusion starts the new virtual machine, installs the operating system, and installs VMware Tools.

Install McAfee AntiVirus Plus in a Windows Virtual Machine
VMware recommends running antivirus software to ensure a secure and safe Windows experience on your
Mac.

VMware has partnered with McAfee, Inc. to offer Fusion users a complimentary 90-day subscription to
McAfee AntiVirus® Plus.

Prerequisites

McAfee AntiVirus Plus is supported on the following guest operating systems:

n Windows 10 (32- and 64-bit)

n Windows 8 (32- and 64-bit)

n Windows 7 SP1 x64

n Windows 7 SP1 x86

n Windows Vista SP2 x64

n Windows Vista SP2 x86

n Windows XP SP3

n Windows 2000 Professional SP4
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Procedure

1 Access the installer for the antivirus software.

n When you create a virtual machine, after VMware Tools installs, a dialog appears prompting you to
install McAfee AntiVirus Plus. Click Install to start downloading McAfee AntiVirus Plus.

n In an existing Windows virtual machine, select Virtual Machine > Install McAfee AntiVirus Plus.
The McAfee installation wizard appears.

2 Click Next in the McAfee Security Center window to install the antivirus software into your Windows
virtual machine.

Creating a Linux Virtual Machine in Fusion
You can create a virtual machine that uses a Linux distribution as its guest operating system.

Fusion creates your virtual machine, selects the default Linux installation options, and installs VMware
Tools, which loads the drivers required to optimize your virtual machine's performance. You can also have
Linux Easy Install make your home folder available to Linux as a shared folder, so that you can share files
between the virtual machine and your Mac.

Linux Easy Install is available for the following operating systems:

n Ubuntu 7.10 and later

n Ubuntu Server Edition 8.10 and later

n Red Hat Enterprise Linux 3 and later

n SUSE Linux Enterprise Desktop/Server 10 and later

n Open SUSE 11.3 and later

If you are not using one of these Linux operating systems in your virtual machine, or if you are using Linux
but want to install the operating system manually, you can use the procedure for creating a virtual machine
for any supported operating system.

Create a Virtual Machine by Using Linux Easy Install and an Installation CD
When you create a Linux virtual machine, you can use the Fusion Linux Easy Install feature to install the
Linux operating system you provide and to install VMware Tools in your virtual machine.

Prerequisites

You must obtain the operating system installation image. Fusion does not include any operating systems to
install in virtual machines that you create.

Procedure

1 Select File > New.

The Create a New Virtual Machine assistant starts.

2 Click Install from disc or image.

3 If it is the correct operating system, ensure that Install this operating system is selected and click
Continue to go to the Linux Easy Install panel.

4 In the Linux Easy Install panel, select Use Easy Install.

a Enter your Display Name, Account Name, and Password.

b Select Make your home folder accessible to the virtual machine to have Linux Easy Install
configure your home folder as a shared folder, so you can share files between the virtual machine
and your Mac.
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5 (Optional) If you selected to make your home folder accessible, select either Read only or Read & Write
for your virtual machine.

6 In the Finish panel, you can use default settings to finish the virtual machine creation, or you can
customize the settings before the creation is finished.

Option Action

To create the virtual machine
according to the specifications
listed in the Finish panel

a Click Finish.
b Indicate the folder in which to save the virtual machine. The default is

your user/Documents/Virtual Machines folder.
c (Optional) To share the virtual machine with other users on the Mac

host, save the virtual machine to the Shared folder and select the
Share this virtual machine with other users on this Mac check box.
Deselect the check box to save to the Shared folder but not share the
virtual machine with other users on the Mac host. See “Creating a
Shared Virtual Machine in Fusion,” on page 50.

To change disk size or other
standard settings of the virtual
machine

a Click Customize Settings.
b Save the new virtual machine.
c Make changes to the virtual machine’s disk size, processor usage,

removable devices, and other configurations on the Settings window.
 

Fusion starts the new virtual machine, installs the operating system, and installs VMware Tools.

Create a Virtual Machine by Using Linux Easy Install and an Image File
When you create a Linux virtual machine, you can use the Fusion Linux Easy Install feature to install the
Linux operating system you provide and to install VMware Tools in your virtual machine.

Prerequisites

You must obtain the operating system installation image. Fusion does not include any operating systems to
install in virtual machines that you create.

Procedure

1 Select File > New.

The Create a New Virtual Machine Assistant starts.

2 Click Continue without disc to go to the Installation Media panel.

3 In the Installation Media panel, click Use operating system installation disc or image.

4 Use the pop-down menu to browse for the .iso file for the operating system.

5 In the Operating System panel, ensure that the operating system and version for the new virtual
machine are correct, or select the correct operating system and version from the pop-down menus.

6 Click Continue.

7 In the Linux Easy Install panel, select Use Easy Install.

a Enter your Display Name, Account Name, and Password.

b Select Make your home folder accessible to the virtual machine to have Linux Easy Install
configure your home folder as a shared folder, so you can share files between the virtual machine
and your Mac.

8 If you selected to make your home folder accessible, select either Read only or Read & Write for your
virtual machine.
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9 In the Finish panel, you can use default settings to finish the virtual machine creation, or you can
customize the settings before the creation is finished.

Option Action

To create the virtual machine
according to the specifications
listed in the Finish panel

a Click Finish.
b Indicate the folder in which to save the virtual machine. The default is

your user/Documents/Virtual Machines folder.
c (Optional) To share the virtual machine with other users on the Mac

host, save the virtual machine to the Shared folder and select the Share
this virtual machine with other users on this Mac check box. Deselect
the check box to save to the Shared folder but not share the virtual
machine with other users on the Mac host. See “Creating a Shared
Virtual Machine in Fusion,” on page 50.

To change disk size or other
standard settings of the virtual
machine

a Click Customize Settings.
b Save the new virtual machine.
c Make changes to the virtual machine’s disk size, processor usage,

removable devices, and other configurations on the Settings window.
 

Fusion starts the new virtual machine, installs the operating system, and installs VMware Tools.

Creating a Mac OS X Virtual Machine in Fusion
You can install OS X Server or OS X Client in a virtual machine. Fusion creates the virtual machine, opens
the OS X installation assistant, and installs VMware Tools. VMware Tools loads the drivers required to
optimize a virtual machine's performance.

OS X virtual machines that you create in Fusion can run on any Apple-branded hardware that uses Intel
processors. The Apple licensing agreement defines the situations when it is permissible to virtualize OS X.
Fusion does not change these terms or enable OS X on non-Apple hardware. You cannot use a Mac OS
virtual machine in another VMware product, such as Workstation Pro.

Fusion supports the following Mac OS X Server and Mac OS X Client versions for the guest OS:

n Mac OS X Server 10.5, 10.6, 10.7, 10.8, 10.9, 10.10, 10.11

n Mac OS X Client 10.7, 10.8, 10.9, 10.10, 10.11

Fusion does not support the following features for Mac OS X virtual machines:

n Drag-and-drop between host Mac and guest Mac

n Multiple displays

n 3D Accelerated graphics

n Unity Mode

To install the operating system, use the procedure for creating a virtual machine for any supported
operating system. See “Create a Virtual Machine for Any Supported Operating System,” on page 52.

Creating a Shared Virtual Machine in Fusion
You can create a shared virtual machine in Fusion that can be accessed by all users on the local Mac host.

When a virtual machine is created in Fusion, it is saved to the default /Documents/Virtual Machines folder.
This folder has limited permissions that allow only the creator of the virtual machine to use it. To allow
other users on the Mac host to access the virtual machine, save it to the /Users/Shared folder on the Mac.

With a shared virtual machine, the user can log out of the current account on the Mac host, and another user
on the Mac host can log in to access the virtual machine.
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The Run Windows applications from your Mac's Applications folder option is not available on shared
virtual machines.

Important   Shared virtual machines in Fusion work differently than shared virtual machines in
Workstation Pro. In Workstation Pro, a shared virtual machine is a virtual machine on the host system that
remote Workstation Pro users can access as a remote virtual machine. In Fusion, shared virtual machines
can be accessed only on the local Mac host.

Create a Virtual Machine from a Mac Recovery Partition
You can use the recovery partition on your Mac to create virtual machines running Mac OS X.

Prerequisites

n You must have a recovery partition on your Mac to create this kind of virtual machine.

n You must have Mac OS X 10.9 or later.

Procedure

1 Select File > New.

The Create a New Virtual Machine assistant starts.

2 Click More options > Install OS X from the recovery partition.

3 Select a recovery partition and click Continue.

If you have more than one recovery partition, a list of partitions is presented.

4 In the Finish panel, you can use default settings to finish the virtual machine creation, or you can
customize the settings before the creation is finished.

Option Action

To create the virtual machine
according to the specifications
listed in the Finish panel

a Click Finish.
b Indicate the folder in which to save the virtual machine. The default is

your user/Documents/Virtual Machines folder. You do not need to
save the virtual machine on the same disk as the recovery partition.

c (Optional) To enable the virtual machine to be shared with other users
on the Mac host, save the virtual machine to the Shared folder.
Deselect the Share this virtual machine with other users on this Mac
check box if you want to save to the Shared folder but not share the
virtual machine with other users on the Mac host.

To change disk size or other
standard settings of the virtual
machine

a Click Customize Settings.
b Save the new virtual machine. You do not need to save the virtual

machine on the same disk as the recovery partition.
c Make changes to the virtual machine’s disk size, processor usage,

removable devices, and other configurations on the Settings window.
 

Create a Virtual Machine on a Remote Server
You can create a virtual machine on a remote server, but certain requirements must be met for the server.

Prerequisites

n You have login credentials for the server where you want to create the virtual machine.

n The server is defined in the Virtual Machine Library.

n Sufficient space exists on the server to accommodate the virtual machine.
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n The remote server is running VMware Workstation Pro, VMware ESXi or VMware vCenter Server.

Important   Fusion does not include operating systems to install in virtual machines that you create. You
must obtain the operating system and any necessary product keys.

Procedure

1 Select File > New.

The Create a New Virtual Machine assistant starts.

2 Click Create a virtual machine on a remote server.

3 Click Continue.

4 Select the server from the list in the Choose a Server window, and click Continue.

5 Select the host and datastore from the Choose a Host and Datastore window, and click Continue.

6 (Optional) If the server supports folders, select a folder location for the virtual machine and click
Continue.

7 Select a hardware version from the Choose a Hardware Version drop-down menu, and click Continue.

8 Select the guest operating system for the virtual machine and click Continue.

9 Configure the virtual disk by creating a virtual disk or use an existing virtual disk. If you create a
virtual disk, use the disk size slider to specify the size of the virtual disk and specify the bus type. Click
Continue.

The Finish window appears.

10 (Optional) Change the name of the new remote virtual machine.

11 Click Finish.

The new remote virtual machine appears in Virtual Machine Library under the remote server.

Create a Virtual Machine for Any Supported Operating System
You can create a virtual machine with a guest operating system that does not have an Easy Install option if
the guest operating system is supported by Fusion.

Prerequisites

n If you are installing the guest operating system from an image file, verify that the ISO image file is in a
directory that is accessible to the host system.

n If you are installing the guest operating system from a physical disc, insert the operating system
installation disc into your Mac.

Important   Fusion does not include any operating systems to install in virtual machines that you create.
You must obtain the operating system and any necessary product keys.

Procedure

1 Select File > New.

The Create a New Virtual Machine assistant starts.

2 Click Install from disc or image.

3 Insert the operating system installation CD into your Mac.

If you are using an operating system installation disc image file (ISO) or an existing virtual disk, click
Use another disc or disc image and browse to the location of the file.
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4 Click Continue.

If you are installing a Windows or Linux operating system, the Easy Install panel appears.

5 (Optional) Deselect Use Easy Install and click Continue to skip this panel of the assistant.

6 In the Finish panel, you can use default settings to finish the virtual machine creation, or you can
customize the settings before the creation is finished.

Option Action

To create the virtual machine
according to the specifications
listed in the Finish panel

a Click Finish.
b Indicate the folder in which to save the virtual machine. The default is

your user/Documents/Virtual Machines folder.
c (Optional) To share the virtual machine with other users on the Mac

host, save the virtual machine to the Shared folder and select the
Share this virtual machine with other users on this Mac check box.
Deselect the check box to save to the Shared folder but not share the
virtual machine with other users on the Mac host. See “Creating a
Shared Virtual Machine in Fusion,” on page 50.

To change disk size or other
standard settings of the virtual
machine

a Click Customize Settings.
b Save the new virtual machine.
c Make changes to the virtual machine’s disk size, processor usage,

removable devices, and other configurations on the Settings window.
 

What to do next

After you install the operating system in the virtual machine, install VMware Tools.

Power On the Boot Camp Partition as a Virtual Machine
You can use the contents of your Boot Camp partition at the same time that you are running your Mac
operating system. To do so, you use Fusion to power on the Boot Camp partition as a virtual machine.

Boot Camp is Apple software that enables an Intel-based Mac to run Windows operating systems. Boot
Camp requires you to choose between Mac or Windows at boot time. Boot Camp creates separate Mac and
Windows partitions on your hard disk to create a dual-boot environment. When you use your Windows
Boot Camp partition as a Fusion virtual machine, you can perform the following tasks:

n Use your Boot Camp virtual machine and your Mac without rebooting and switching between them.

n Share files between your Boot Camp virtual machine and your Mac, through shared folders, dragging
files, or cutting and pasting text.

Note   Windows reactivation complications can occur if you do not install VMware Tools. In such a case, if
you reactivate Windows in your Boot Camp virtual machine, and subsequently boot your Boot Camp
partition natively, you will be prompted to reactivate Windows. Reactivating Windows in your native Boot
Camp partition will result in your Boot Camp virtual machine requiring reactivation the next time you
power it on, and so forth. Installing VMware Tools solves this problem.

Prerequisites

You must have a Boot Camp partition in place before you start this procedure.

You must have administrator privileges to use the Boot Camp partition as a virtual machine.

Procedure

1 Select Window > Virtual Machine Library.

2 In the Virtual Machine Library window, click the Boot Camp thumbnail in the list of virtual machines,
which identifies the partition that Fusion detected.
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3 (Optional) Type your Mac password to access the Boot Camp partition.

Fusion creates a virtual machine that uses your Boot Camp partition and starts Windows.

4 Follow the onscreen instructions and restart your virtual machine when prompted.

After Windows boots from your Boot Camp virtual machine, Fusion starts the installation of VMware
Tools. VMware Tools enables full virtual machine functionality and optimizes performance for your
Boot Camp partition when you use the partition as a virtual machine.

5 When the VMware Tools installation is complete, reboot your computer.

What to do next

The first time you power on your Boot Camp virtual machine after you install VMware Tools, you must
reactivate Windows.

Activate Windows in a Virtual Machine
In some cases you must activate Windows when you create, import, or migrate a virtual machine.

When you install Windows on a computer, you must activate it to use it. You activate Windows either over
the Internet or by phone with Microsoft Support. When the Windows operating system starts up, it checks
to see if it is running on the same hardware on which it was originally installed. If the hardware has
changed, the Windows operating system requires reactivation.

If you install Windows as a guest operating system in a new virtual machine, it requires activation the same
as if you had installed it on a physical computer. If you import a virtual machine from another source, if you
run the Boot Camp partition as a virtual machine, or if you migrate a physical PC to a virtual machine,
Windows recognizes that the virtual hardware is different.

The type of license you have for your Windows operating system can affect how you activate Windows after
you start to use it in a Fusion virtual machine.

n With an OEM license, Windows is tied directly to the hardware on which it was loaded by the
manufacturer. Most pre-installed versions of Windows have OEM licenses. OEM licenses generally
cannot be transferred to another computer, or to a virtual machine. If you use the Fusion Migrate Your
PC feature to migrate one of these types of systems to a virtual machine, you might be required to
purchase a second license (or product key) from Microsoft. If a second product key is required, you can
get that through the Microsoft representative when you call Microsoft Support to activate the operating
system now residing in the virtual machine.

n With a retail license, when you buy Windows from a vendor, the license enables you to change
platforms as often as you want. In this case, you can reactivate Windows over the Internet, or by phone
with Microsoft Support.

n With an enterprise license, you can move the operating system around freely.

Prerequisites

Install VMware Tools in the virtual machine before you activate Windows. VMware Tools keeps track of the
activation keys. Without VMware Tools installed, you must reactivate Windows each time you start up the
virtual machine.

Procedure

u Activate Windows online or by phone.

The Help and Support item on the Windows Start menu enables you to find specific information about
activation for that version of the operating system.

What to do next

If you have activation questions, contact Microsoft.
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Upload a Virtual Machine to a Remote Server
When you upload a virtual machine to a remote server, Fusion Pro copies the virtual machine to the remote
host and datastore that you select. The original virtual machine remains on the host system.

Prerequisites

Verify that the following conditions are met:

n You have login credentials for the server where you want to upload the virtual machine.

n The server is defined in the Virtual Machine Library.

n Sufficient space exists on the server to accommodate the virtual machine.

n The remote server is running VMware ESXi or VMware vCenter Server.

n The virtual machine is not encrypted. You cannot upload an encrypted virtual machine.

n The virtual machine is not powered on or suspended. It must be powered off.

Procedure

1 Select File > Connect to Server.

2 Enter the name of the host server or click the Recent Servers drop-down menu to select a server from
the list.

3 Enter your login credentials and click Connect.

4 Select a virtual machine from the Virtual Machine Library.

5 Drag the virtual machine to the server.

6 In the Upload Virtual Machine dialog box, select a host and a datastore folder or shared folder.

7 Click Upload.

Upload a Virtual Machine to VMware vCloud Air
When you upload a virtual machine to VMware® vCloud® Air™, Fusion Pro copies the virtual machine to
the VMware vCloud Air server and the virtual data center that you select. The original virtual machine
remains on the host system.

Prerequisites

n Verify that the virtual machine is not encrypted. You cannot upload an encrypted virtual machine.

n Verify that the remote host supports the hardware version of the virtual machine. if the remote host
does not support the hardware version, you receive an error message.

n Verify that the virtual machine is turned off.

n Verify that you have login credentials for VMware vCloud Air.

For more information about VMware vCloud Air, see the vCloud Air - Virtual Private Cloud OnDemand User's
Guide.

Procedure

1 Select File > Connect to VMware vCloud Air.

2 Enter your user name and password for the VMware vCloud Air server and click Connect.

3 Select a virtual machine from the Virtual Machine Library.

4 Drag the virtual machine to the server.
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5 Type a new name for the virtual machine.

6 Select a virtual data center to store the uploaded virtual machine.

7 Click Upload to upload the virtual machine to the virtual data center.

Download a Virtual Machine from a Remote Server
Your users can download a virtual machine from a remote server.

Prerequisites

Verify that the following conditions are met:

n You have login credentials for the server where you want to download the virtual machine.

n The server is defined in the Virtual Machine Library.

n Sufficient space exists on the Mac host to accommodate the virtual machine.

n The remote server is running VMware ESXi or VMware vCenter Server.

n The virtual machine is not powered on or suspended. It must be powered off.

Procedure

1 Select File > Connect to Server.

2 Enter the name of the host server or click the Recent Servers icon to select a server from the list of
recently accessed servers.

3 Enter your login credentials and click Connect.

4 Select a virtual machine from the remote server.

5 Drag the virtual machine to the Virtual Machine Library.

6 Click Save.

Migrate an Existing Physical PC to a Virtual Machine
You can migrate your existing Windows PC onto your Mac. Fusion recreates your PC as a virtual machine,
and you can continue to use your PC applications and files.

Prerequisites

n Migrate Your PC is supported for Windows operating systems from Windows XP up to and including
Windows 10.

n Your Mac must be running Mac OS X 10.9 or later.

Procedure

1 Set Up Your Mac to Accept the Transfer of Files from Your PC on page 57
You must set sharing and firewall system preferences on your Mac to allow the transfer of files needed
to create the virtual machine from the physical PC.

2 Connect to Your PC for Migration on page 57
You can choose what kind of connection with which to migrate your PC.

3 Disable UAC for Windows Vista and Later Before Migrating on page 58
To successfully migrate your PC to Fusion, you must disable User Account Control (UAC) before
using the Migrate Your PC feature.
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4 Install and Run the Fusion PC Migration Agent on Your PC on page 58
For your Mac to be able to connect to your physical PC and start the migration, you must install the
Fusion PC Migration Agent on your PC.

5 Run the Migration Assistant on Your Mac on page 59
The Migration Assistant connects to your physical PC and performs the conversions and transfers of
files necessary to create the virtual machine on your Mac.

6 Ensure that VMware Tools is Installed in the Migrated Virtual Machine on page 59
Install VMware Tools to enhance the performance of the guest operating system.

Set Up Your Mac to Accept the Transfer of Files from Your PC
You must set sharing and firewall system preferences on your Mac to allow the transfer of files needed to
create the virtual machine from the physical PC.

Procedure

1 Select System Preferences in the Apple menu and click Sharing in the Internet & Network section.

2 Select File Sharing, and click Options.

3 Select Share files and folders using SMB for the appropriate accounts and click Done.

4 Click Show All to return to System Preferences.

5 Click Security in the Personal section and click Firewall to go to the Firewall panel.

6 Make sure incoming connections for SMB file sharing is allowed.

7 Close the System Preferences window.

What to do next

Determine how to connect your Mac to your physical PC.

Connect to Your PC for Migration
You can choose what kind of connection with which to migrate your PC.

You can migrate your PC over a direct connection, a wired network, or a wireless network.

Procedure

u Implement your preferred connection.

Option Description

Direct connection Use an ethernet cable or a firewire cable to connect your PC directly to
your Mac. This provides the fastest connection.

Wired network Connect your PC and your Mac to the same network using ethernet cables.

Wireless network Connect your PC or Mac to a wireless network. The migration process is
significantly slower over a wireless network.
If you migrate over a wireless network, set the screen saver on your
physical PC to wait longer than the migration will take. Right-click on the
PC desktop and select Properties. Select the Screen Saver tab, set Wait to
9999, and click OK.

 

What to do next

If your physical PC is running Windows Vista, Windows 7, Windows 8, or Windows 10, disable UAC on it
before proceeding. Otherwise, load the PC Migration Agent on your physical PC.
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Disable UAC for Windows Vista and Later Before Migrating
To successfully migrate your PC to Fusion, you must disable User Account Control (UAC) before using the
Migrate Your PC feature.

Procedure

1 Open the Control Panel on your PC.

2 Select User Accounts.

3 Select Change User Account Control Settings and move the slider to Never notify.

4 Restart your PC.

What to do next

Install the Fusion PC Migration Agent on your physical PC.

Install and Run the Fusion PC Migration Agent on Your PC
For your Mac to be able to connect to your physical PC and start the migration, you must install the Fusion
PC Migration Agent on your PC.

Prerequisites

If your Windows PC does not have a password, you must create a password before beginning the migration
process. You can go to User Accounts in the Control Panel to create a password.

You must perform the migration on an Administrator account.

Procedure

1 Set the power options on your Windows physical PC so that your monitor and hard disks do not turn
off automatically and your system does not go to standby.

a In the Control Panel, click Power Options.

b On the Power Schemes panel, set Turn off monitor, Turn off hard drives, and System standby to
Never.

2 (Optional) If you migrate over a wireless connection, set your physical PC's screen saver to wait longer
than the migration will take.

a Right-click on the PC desktop and select Properties.

b Select the Screen Saver tab, set Wait to 9999, and click OK.

3 Download VMware Fusion PC Migration Agent from the Fusion product downloads page under
Drivers and Tools.

4 Run the installer file.

5 Click Next on the installation wizard's welcome page, click I accept the terms of the License
Agreement on the license agreement page, and click Next.

6 Select the folder in which you want to save the PC Migration Agent, and click Next.

7 Click Install.

8 Click Finish.

9 Restart your PC.
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The VMware Fusion PC Migration Agent window appears on your PC, displaying the four-digit passcode
needed for opening communications between your Mac and this PC.

The passcode is good only when the window is open. If you close the window and restart the Agent, or if
you restart the PC, a new passcode replaces the old one.

What to do next

Leave the PC Migration Agent running so that the Migration Assistant on your Mac can communicate with
it. See “Run the Migration Assistant on Your Mac,” on page 59.

Run the Migration Assistant on Your Mac
The Migration Assistant connects to your physical PC and performs the conversions and transfers of files
necessary to create the virtual machine on your Mac.

Prerequisites

n Your Mac and PC must be on the same network and remain powered on during the migration.
Although you can migrate your PC over a wireless network, the process is significantly faster if you
connect your Mac and PC with a network cable.

n The PC Migration Agent must be running on your PC and displaying a four-digit passcode.

Procedure

1 Select File > Migrate Your PC.

The Migration Assistant appears.

2 Click Continue.

The Connect to Your PC panel appears.

3 Type the four-digit passcode displayed by the PC Migration Agent on the PC and click Continue.

4 Type your user name and password for the PC, and click Continue.

5 Indicate where to save the new virtual machine on your Mac.

Fusion saves virtual machines in your user/Documents/Virtual Machines folder by default. You can
change the location by clicking Choose and using the Finder.

6 Click Continue to start the migration.

The assistant displays a progress bar and an estimate of time remaining.

7 Click Finish.

Your PC is replicated in a virtual machine accessible from the Virtual Machine Library.

What to do next

Ensure that VMware Tools is installed on the virtual machine.

Ensure that VMware Tools is Installed in the Migrated Virtual Machine
Install VMware Tools to enhance the performance of the guest operating system.

Note   Sometimes Windows finishes detecting changes before the VMware Tools installation is complete,
and displays a dialog prompting you to restart. Do not restart until you are prompted by VMware Tools.
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Prerequisites

The Migration Assistant has run, and a completed, but powered off, virtual machine appears in Single
Window view.

Procedure

1 Start the virtual machine.

VMware Tools starts installing.

2 (Optional) Log in to Windows.

3 (Optional) Make the VMware Tools installation visible in Windows 8, Windows 7, and Windows Vista.

The VMware Tools installation dialog does not appear automatically in Windows 8, Windows 7, and
Windows Vista.

a
Click the Interactive Services Detection icon ( ).

b Click View the message in the Interactive Services Detection window.

4 When prompted by VMware Tools, restart the virtual machine.

What to do next

If the VMware Tools installation does not complete properly, install VMware Tools manually. See “Installing
and Using VMware Tools,” on page 64.

You might have to reactivate your Windows operating system in the new virtual machine when you power
it on.

Importing Windows Virtual Machines
You can import into Fusion virtual machines that you created with Parallels Desktop, Microsoft Virtual PC,
as well as virtual machines using the Open Virtualization Format (OVF).

Fusion can import virtual machines created with Parallels, Microsoft Virtual PC, or OVF.

When you import a Parallels or Virtual PC virtual machine, Fusion creates a VMware virtual machine based
on the original virtual machine. The import process is nondestructive, so you can continue to use the
original source virtual machine with the product you use to create the source virtual machine.

Fusion can also import the contents of the Boot Camp partition as a virtual machine, creating a completely
new VMware virtual machine based on the partition. This is a separate entity, not tied to the partition like
the virtual machine described in “Power On the Boot Camp Partition as a Virtual Machine,” on page 22. You
can then reclaim the space by deleting the Boot Camp partition, which restores the drive to a single volume.

Supported Guest Operating Systems for Import
A guest operating system is the system that runs in a virtual machine. Fusion supports importing Parallels
and Virtual PC virtual machines with certain operating systems.

Fusion supports importing the following operating systems:

n Microsoft Windows 10

n Microsoft Windows 8

n Microsoft Windows 7

n Microsoft Windows Vista

n Microsoft Windows XP Service Pack 3
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n Microsoft Windows XP Service Pack 2

Virtual machines must be powered off before you import them.

If your copy of Windows was not licensed with a volume-license key, you might need to reactivate it when it
starts inside Fusion.

How Importing Affects Settings
You might have to modify the imported virtual machine, depending on settings and virtual hardware.

The imported VMware virtual machine contains an exact copy of the disk state from your source virtual
machine, with the exception of some hardware-dependent drivers and sometimes the mapped drive letters.
Imported virtual machines are created with IDE or SCSI virtual disks. You can manually change the disk to
SATA when the import process is complete.

Settings from the Source Computer
The following settings from the source computer remain identical:

n Operating system configuration (computer name, security ID, user accounts, profiles and preferences,
and so on)

n Applications and data files

n The volume serial number of each disk partition

Because the target and the source virtual machines or system images have the same identities (name, SID,
and so on), running both on the same network can result in conflicts. To redeploy the source virtual machine
or system image, ensure that you do not run both the source and target images or virtual machines on the
same network at the same time.

For example, if you use the Fusion Importer to test the viability of running a Parallels or Virtual PC virtual
machine as a VMware virtual machine without first decommissioning the original non-VMware machine,
you must resolve the duplicate ID problem first.

Changes to Virtual Hardware
Most imported applications should function correctly in the VMware virtual machine because their
configuration and data files have the same location as the source virtual machine. Applications might not
work if they depend on specific characteristics of the underlying hardware such as the serial number or the
device manufacturer.

When you troubleshoot after a virtual machine import, notice the following potential hardware changes:

n CPU model and serial numbers (if activated) can be different after the import. They correspond to the
physical computer hosting the VMware virtual machine.

n Ethernet adapter can be different (AMD PCNet or VMXnet) with a different MAC address. Each
interface’s IP address must be individually reconfigured.

n Graphics card can be different (VMware SVGA card).

n Numbers of disks and partitions are the same, but each disk device can have a different model and
different manufacturer strings.

n Primary disk controllers can be different from the source machine’s controllers.

n Applications might not work if they depend on devices that are not available from within a virtual
machine.
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Import a Parallels or Virtual PC Virtual Machine
You can import existing third-party virtual machines and run them in Fusion.

Procedure

1 Select File > Import.

2 Browse to the existing virtual machine you want to import and click Open.

3 Type the name for the imported virtual machine in the Save As field and indicate where to save it.

The default destination is the Virtual Machines folder created by Fusion.

Fusion displays the disk space needed for the import, and the space available on the current disk.

4 Click Import.

When the import is complete, you see the virtual machine added to the virtual machine list, in the
powered-off state.

5 Click Finish.

Fusion installs VMware Tools after the virtual machine powers on, and reboots the system after the
Tools installation is complete.

You have a separate Fusion version of the third-party virtual machine.

Import the Boot Camp Partition
You can import the Boot Camp partition as a virtual machine, creating a VMware virtual machine that
copies the partition.

Procedure

1 Select Window > Virtual Machine Library.

2 In the Virtual Machine Library window, select Boot Camp partition and click Import.

3 Change the name for the imported virtual machine in the Save As field from the default Boot Camp to
something unique, and indicate where to save it.

The default destination is the Virtual Machines folder created by Fusion.

Fusion displays the disk space needed for the import, and the space available on the current disk.

4 Click Import.

When the import is complete, you see the virtual machine added to the virtual machine list, in the
powered-off state.

5 Click Finish.

Fusion installs VMware Tools after the virtual machine powers on, and reboots the system after the
Tools installation is complete.

Import an Open Virtualization Format Virtual Machine
You can import an Open Virtualization Format (OVF) virtual machine and run it in Fusion. You can import
both .ovf and .ova files.

Fusion converts the virtual machine from OVF format to VMware runtime (.vmx) format.
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OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual
machines. For example, you can import OVF virtual machines exported from Workstation Pro into Fusion.
You can import OVF 1.0 and later files only.

You can also use the standalone OVF Tool to convert an OVF virtual machine to VMware runtime format.
For information about using the OVF Tool, see the OVF Tool User Guide.

Prerequisites

Download or copy the OVF virtual machine file (.ovf or .ova file) to a location that is accessible to your
Mac.

Procedure

1 Select File > Import.

2 Click Choose file and browse to the .ovf or .ova file and click Open.

3 Type the name for the imported virtual machine in the Save As text box and indicate where to save it.

The default destination is the Virtual Machines folder created by Fusion.

Fusion displays the disk space needed for the import, and the space available on the current disk.

4 Click Import.

Fusion performs OVF specification conformance and virtual hardware compliance checks. A status bar
indicates the progress of the import process.

After the import is complete, the virtual machine appears in the virtual machine library and in a separate
virtual machine window. The virtual machine is shut down.

Export a Virtual Machine to OVF Format
You can export a virtual machine from Fusion Pro to Open Virtualization Format (OVF). You can export
both .ovf and .ova files.

Fusion Pro converts the virtual machine from VMware runtime (.vmx) format to OVF format.

OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual
machines. OVF format provides a complete specification of the virtual machine, including the full list of
required virtual disks and the required virtual hardware configuration. The virtual hardware configuration
includes CPU, memory, networking, and storage. An administrator can quickly provision an OVF-formatted
virtual machine with little or no intervention.

You can also use the standalone version of OVF Tool to convert a virtual machine that is in VMware runtime
format to an OVF virtual machine. The standalone version of OVF Tool is installed in the Fusion Pro
installation directory under Contents/Library/VMware OVF Tool . See the OVF Tool User Guide
documentation on the VMware Web site for information about using OVF Tool.

Prerequisites

n Verify that the virtual machine is not encrypted. You cannot export an encrypted virtual machine to
OVF format.

n Verify that the virtual machine is powered off.

Procedure

1 Select the virtual machine and select File > Export to OVF.

2 Enter a name for the OVF file and specify a directory in which to save it.

3 Specify whether to export the virtual machine as an OVF, a folder with separate files, or as an OVA, a
single-file archive.
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4 Click Export to start the OVF export process.

The export process can take several minutes. A status bar indicates the progress of the export process.

Installing and Using VMware Tools
VMware Tools is a suite of utilities that enhances the performance of the virtual machine's guest operating
system and improves management of the virtual machine.

For example, the following features are just some of the features that are available only if VMware Tools is
installed:

n Significantly faster graphics performance and Windows Aero on operating systems that support Aero

n The Unity feature, which enables an application in a virtual machine to appear on the host desktop like
any other application window

n Shared folders between host and guest file systems

n Copying and pasting text, graphics, and files between the virtual machine and the host or client desktop

n Improved mouse performance

n Synchronization of the clock in the virtual machine with the clock on the host or client desktop

n Scripting that helps automate guest operating system operations

n Enables guest customization for virtual machines.

Although the guest operating system can run without VMware Tools, you would lose important
functionality and convenience.

You can use the Windows Easy Install or Linux Easy Install feature to install VMware Tools as soon as the
operating system is finished installing.

In the case of Windows Easy Install or Linux Easy Install, Fusion installs VMware Tools as soon as it finishes
installing the operating system. When you finish installing the operating system in your new virtual
machine by any other means (rebooting the virtual machine when prompted), install VMware Tools.

Not all features are supported on all guests.

You can use the VMware Tools control panel to set various options that optimize your guest operating
system for use in a virtual machine.

Installing or Upgrading VMware Tools
Installing VMware Tools is part of the process of creating a new virtual machine, and upgrading VMware
Tools is part of the process of keeping your virtual machine up to current standards.

How you install or upgrade VMware Tools depends on the operating system and the source you use for the
tools.

VMware upgrades VMware Tools frequently to support new devices and to add enhancements that improve
the performance of your virtual machines. When you upgrade Fusion, you should also upgrade VMware
Tools.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this
notification option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon

( ) when a VMware Tools upgrade is available.
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Manually Install or Upgrade VMware Tools in a Windows Virtual Machine
All supported Windows guest operating systems support VMware Tools.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh
the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools
to enhance the performance of the virtual machine's guest operating system and improve virtual machine
management, or you can continue using the existing version to provide more flexibility and avoid downtime
in your environment.

Prerequisites

n Power on the virtual machine.

n Verify that the guest operating system is running.

n If you connected the virtual machine’s virtual CD/DVD drive to an ISO image file when you installed
the operating system, change the setting so that the virtual CD/DVD drive is configured to autodetect a
physical drive.

The autodetect setting enables the virtual machine's first virtual CD/DVD drive to detect and connect to
the VMware Tools ISO file for a VMware Tools installation. This ISO file looks like a physical CD to
your guest operating system. Use the virtual machine settings editor to set the CD/DVD drive to
autodetect a physical drive.

n Log in as an administrator unless you are using an older Windows operating system. Any user can
install VMware Tools in a Windows 95, Windows 98, or Windows ME guest operating system. For
operating systems newer than these, you must log in as an administrator.

Procedure

1 On the host, from the VMware Fusion menu bar, select Virtual Machine > Install VMware Tools.

If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2 If you are installing VMware Tools for the first time, click OK on the Install VMware Tools information
page.

If autorun is enabled for the CD-ROM drive in the guest operating system, the VMware Tools
installation wizard starts.

3 If autorun is not enabled, to manually launch the wizard, click Start > Run and enter D:\setup.exe,
where D: is your first virtual CD-ROM drive. Use D:\setup64.exe for 64-bit Windows guest operating
system.

4 Follow the on-screen instructions.

5 If the New Hardware wizard appears, follow the prompts and accept the defaults.

6 If you are installing a beta or RC version of VMware Tools and you see a warning that a package or
driver is not signed, click Install Anyway to complete the installation.

7 When prompted, reboot the virtual machine.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
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Manually Install or Upgrade VMware Tools in a Linux Virtual Machine
For Linux virtual machines, you manually install or upgrade VMware Tools by using the command line.

Prerequisites

n Power on the virtual machine.

n Verify that the guest operating system is running.

n Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating
system.

Procedure

1 On the host, from the VMware Fusion menu bar, select Virtual Machine > Install VMware Tools.

If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2 In the virtual machine, log in to the guest operating system as root and open a terminal window.

3 Run the mount command with no arguments to determine whether your Linux distribution
automatically mounted the VMware Tools virtual CD-ROM image.

If the CD-ROM device is mounted, the CD-ROM device and its mount point are listed as something like
this:

/dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)

4 If the VMware Tools virtual CD-ROM image is not mounted, mount the CD-ROM drive.

a If a mount point directory does not already exist, create it.

mkdir /mnt/cdrom

Some Linux distributions use different mount point names. For example, on some distributions the
mount point is /media/VMware Tools rather than /mnt/cdrom. Modify the command to reflect the
conventions that your distribution uses.

b Mount the CD-ROM drive.

mount /dev/cdrom /mnt/cdrom

Some Linux distributions use different device names or organize the /dev directory differently. If
your CD-ROM drive is not /dev/cdrom or if the mount point for a CD-ROM is not /mnt/cdrom,
modify the command to reflect the conventions that your distribution uses.

5 Change to a working directory, for example, /tmp.

cd /tmp

6 Delete any previous vmware-tools-distrib directory before you install VMware Tools.

The location of this directory depends on where you placed it during the previous installation. Often
this directory is placed in /tmp/vmware-tools-distrib.

7 List the contents of the mount point directory and note the filename of the VMware Tools tar installer.

ls mount-point

8 Uncompress the installer.

tar zxpf /mnt/cdrom/VMwareTools-x.x.x-yyyy.tar.gz

The value x.x.x is the product version number, and yyyy is the build number of the product release.

If you attempt to install a tar installation over an RPM installation, or the reverse, the installer detects
the previous installation and must convert the installer database format before continuing.
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9 If necessary, unmount the CD-ROM image.

umount /dev/cdrom 

If your Linux distribution automatically mounted the CD-ROM, you do not need to unmount the
image.

10 Run the installer and configure VMware Tools.

cd vmware-tools-distrib

./vmware-install.pl

Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running.

11 Follow the prompts to accept the default values, if appropriate for your configuration.

12 Follow the instructions at the end of the script.

Depending on the features you use, these instructions can include restarting the X session, restarting
networking, logging in again, and starting the VMware User process. You can alternatively reboot the
guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Install or Upgrade VMware Tools in a Mac OS X Virtual Machine
For Mac OS X Server virtual machines you install or upgrade VMware Tools using an installer assistant.

Prerequisites

n Power on the virtual machine.

n Verify that the guest operating system is running.

Procedure

1 On the host, from the VMware Fusion menu bar, select Virtual Machine > Install VMware Tools.

If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2 Open Install VMware Tools on the VMware Tools virtual disc, follow the prompts in the installer
assistant, and click OK.

The virtual machine restarts to have VMware Tools take effect.

Repair or Change Modules in Windows Virtual Machines
If you have problems with enhanced graphics display or mouse actions or with features that depend on
VMware Tools, you might need to repair or modify installed modules.

Occasionally, some new modules are not installed during a VMware Tools upgrade. You can manually
install new modules by modifying installed modules.

Important   Do not use the guest operating system’s Add/Remove Programs item in the Windows Control
Panel to repair or modify VMware Tools.

Prerequisites

n Power on the virtual machine.

n Log in to the guest operating system.
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Procedure

1 On the host, from the VMware Fusion menu bar, select Virtual Machine > Install VMware Tools.

If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2 If autorun is not enabled for the CD-ROM drive, to manually launch the VMware Tools installation
wizard, click Start > Run and enter D:\setup.exe, where D: is your first virtual CD-ROM drive.

3 On the Welcome page of the wizard, click Next.

4 Specify whether to repair or modify the modules.

n Click Repair to repair the files, registry settings, and so on of components that are already installed.

n Click Modify to specify which modules are installed.

5 Follow the on-screen instructions.

What to do next

If features still do not work, uninstall VMware Tools and reinstall.

Uninstalling VMware Tools
If the upgrade process of VMware Tools is incomplete, you can uninstall and then reinstall the VMware
Tools.

Prerequisites

n Power on the virtual machine.

n Log in to the guest operating system.

Procedure

u Select a method to uninstall VMware Tools.

Operating System Action

Windows 7, 8, 8.1, or Windows 10 In the guest operating system, select Programs > Uninstall a program.

Windows Vista and Windows Server
2008

In the guest operating system, select Programs and Features > Uninstall a
program.

Windows XP and earlier In the guest operating system, select Add/Remove Programs.

Linux Log in as root and enter vmware-uninstall-tools.pl in a terminal
window.

Mac OS X Server Use the Uninstall VMware Tools application, found
in /Library/Application Support/VMware Tools.

 

What to do next

Reinstall VMware Tools.

Cloning Virtual Machines with Fusion Pro
Installing a guest operating system and applications can be time consuming. With Fusion Pro, you can make
many copies of a virtual machine from a single installation and configuration process.

Clones are useful when you must deploy many identical virtual machines to a group. For example, an MIS
department can clone a virtual machine that has a suite of preconfigured office applications for each
employee. You can also configure a virtual machine that has a complete development environment and
clone it repeatedly as a baseline configuration for software testing.
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The existing virtual machine is called the parent virtual machine. Two types of clones are available for
creation: linked clones and full clones. Linked clones are created more quickly than full clones, but are
dependent on the parent virtual machine. Full clones take longer to create, but are completely independent
of the parent virtual machine.

Changes made to a clone do not affect the parent virtual machine, and changes made to the parent virtual
machine do not appear in a clone. The MAC address for a clone is different from the parent virtual machine.

Using Linked Clones
A linked clone is a copy of a virtual machine that shares virtual disks with the parent virtual machine in an
ongoing manner. You can create linked clones only by using Fusion Pro.

Because a linked clone is created from a snapshot of the parent, disk space is conserved and multiple virtual
machines can use the same software installation. All files available on the parent at the moment you take the
snapshot continue to remain available to the linked clone.

Ongoing changes to the virtual disk of the parent do not affect the linked clone, and changes to the disk of
the linked clone do not affect the parent. A linked clone must have access to the parent. Without access to
the parent, you cannot use a linked clone.

Because linked clones are created quickly, you can create a unique virtual machine for each task. You can
also share a virtual machine with other users by storing the virtual machine on your local network where
other users can quickly make a linked clone. For example, a support team can reproduce a bug in a virtual
machine, and an engineer can quickly make a linked clone of that virtual machine to work on the bug.

You can make a linked clone from a linked clone, but the performance of the linked clone degrades. It is
recommended that you make a new linked clone of the original parent virtual machine, when possible. If
you make a full clone from a linked clone, the full clone is an independent virtual machine that does not
require access to the linked clone or its parent.

Important   You cannot delete a linked clone snapshot without destroying the linked clone. You can safely
delete the snapshot only if you also delete the clone that depends on it. Also, moving the linked clone or the
parent virtual machine breaks the connection between the linked clone and parent.

Since a linked clone has a dependency on the parent, you cannot delete a parent if it has a clone. You must
first delete all linked clones and snapshots before you can delete the parent virtual machine.

Using Full Clones
A full clone is a complete and independent copy of a virtual machine. A full clone shares nothing with the
parent virtual machine after the cloning operation. Ongoing operation of a full clone is separate from the
parent virtual machine. You can create full clones only with Fusion Pro.

Because a full clone does not share virtual disks with the parent virtual machine, full clones generally
perform better than linked clones. Full clones take longer to create than linked clones. Creating a full clone
can take several minutes if the files involved are large.

Because a full clone duplicates only the state of the virtual machine at the instant of the cloning operation, it
does not have access to snapshots of the parent virtual machine.

You can delete a full clone without affecting the parent virtual machine.
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Clone a Virtual Machine
You can clone virtual machines only if you have Fusion Pro. You do not need to find and manually copy the
parent virtual machine files.

Note  
n You can access cloning options from the right-click menu, Virtual Machine menu and snapshot

manager.

n You cannot create linked clones from encrypted virtual machines.

n You cannot create linked or full clones from restricted virtual machines.

n You cannot create linked or full clones from Boot Camp virtual machines.

n You can create full clones from encrypted virtual machines.

n You can create a cloned virtual machine from the powered off snapshot of the parent virtual machine.

Prerequisites

n Familiarize yourself with the types of clones. See “Using Linked Clones,” on page 69 and “Using Full
Clones,” on page 69.

n If making a linked or full clone from the current state of a virtual machine, power down the virtual
machine.

Procedure

1 (Optional) To create a clone from the current state of a virtual machine:

a Select a virtual machine from the Virtual Machine Library.

b Click Virtual Machine and select either Create Full Clone or Create Linked Clone, depending on
the type of clone you want to create.

Fusion takes a snapshot of the selected virtual machine when creating a linked clone.

2 (Optional) To create a clone from a snapshot of a virtual machine:

a Select a virtual machine from the Virtual Machine Library.

b Click Snapshots.

c Select a snapshot and right-click. Select either Create Full Clone or Create Linked Clone,
depending on the type of clone you want to create.

3 Type a name for the clone and click Save.

A full clone can take several minutes to create, depending on the size of the virtual disk that is being
duplicated.

The clone appears in the Virtual Machine Library.

A linked clone virtual machine is designated by a clone badge in the Virtual Machine Library. The parent
virtual machine name is shown under the virtual machine name in the Virtual Machine Library display. In
snapshot manager, a snapshot which has a linked clone virtual machine is designated with a snapshot
badge.

What to do next

If the parent virtual machine uses a static IP address, change the static IP address of the clone before the
clone connects to the network to prevent IP address conflicts.
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Although the cloning process creates a new MAC address for the clone, other configuration information,
such as the virtual machine name and static IP address configuration, is identical to that of the parent virtual
machine.
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Working with your Virtual Machines 6
You can work with virtual machines in the same way that you can work with physical machines. Your Mac
and virtual machines can also interact.

This chapter includes the following topics:

n “Running Fusion Pro and Virtual Machines,” on page 73

n “Open a Windows Application While You Are In Unity View,” on page 81

n “Open a Windows or Linux Application from the Applications Menu,” on page 82

n “Moving and Sharing Files with Your Mac,” on page 82

n “Sharing Applications Between Your Mac and Your Windows Virtual Machines,” on page 83

n “Keep a Windows Application in the Mac Dock,” on page 84

n “Switch Between Virtual Machines That Are Powered On,” on page 84

n “Using Mac Input Devices in a Virtual Machine,” on page 85

n “Force Virtual Machines to Grab Keyboard and Mouse Input,” on page 85

Running Fusion Pro and Virtual Machines
You can start up, shut down, suspend, pause, resume, restart, and reset your virtual machines. You can send
power commands to either the guest operating system or the virtual machine.

Open an Existing Virtual Machine
You can open an existing virtual machine from the Virtual Machine Library window or from the
applications menu.

For information about using Fusion Pro to open a Horizon FLEX virtual machine, see the VMware Horizon
FLEX Client User Guide.

Procedure

n Open a virtual machine from the Virtual Machine Library.

a Select Window > Virtual Machine Library.

b Select a virtual machine from the list of recognized virtual machines.

c Click the run button.
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n Open a virtual machine from the applications menu

a
Click the applications menu status item ( ) in the menu bar.

The applications menu appears, displaying the most recently accessed virtual machine in the blue
title bar.

b Click the pop-up menu in the title bar and select the virtual machine.

c Click Resume or Start Up.

Browse for a Virtual Machine
One way to open an existing virtual machine is to find and open its package file.

Procedure

1 Select File > Open.

2 In the file selection window, find and select the virtual machine package or configuration file for the
virtual machine to open.

Virtual machine package files have the extension .vmwarevm. Virtual machine configuration files have
the extension .vmx. You can view a file's extension by selecting File > Get info.

3 Click the Open button.

Fusion opens the virtual machine and powers it on.

Open a Virtual Machine From the Finder
You can open an existing virtual machine from its package file.

Procedure

1 In the Finder, browse to the Virtual Machines folder (usually in your user/Documents folder) and find
the package or configuration file for the virtual machine.

Virtual machine package files have the extension .vmwarevm. Virtual machine configuration files have
the extension .vmx.

2 (Optional) You can view a file's extension by selecting File > Get info.

3 Double-click the virtual machine package or configuration file to open the virtual machine in Fusion.

If Fusion is not running, it starts automatically.

Start a Virtual Machine's Operating System
You can start a powered-off guest operating system in your virtual machine.

Certain actions, such as making changes to the virtual machine configuration, require having a virtual
machine open without the operating system powered on. After the action is complete, you can start the
operating system.

Using VMware Fusion

74  VMware, Inc.



Procedure

u Start the virtual machine's operating system, depending on the state of the virtual machine and guest
operating system.

u If the virtual machine is not running, open the virtual machine from the Finder or Virtual Machine
Library.

Fusion starts the virtual machine's operating system when you open the virtual machine.

u If the virtual machine is already open in Fusion, but the operating system is shut down, select
Virtual Machine > Start Up.

Open a Virtual Machine Without Powering On
Some configuration tasks require that the virtual machine be powered off. In the Virtual Machine Library
you can access a virtual machine without powering it on.

Procedure

1 In the Virtual Machine Library window, select the virtual machine to work on.

2 (Optional) If the virtual machine to configure is displayed as Suspended or Powered on, open the
virtual machine and power it off.

n Use the Shut Down button in the toolbar

n Use the Shut Down command in the Virtual Machine menu.

Fusion opens the virtual machine without powering it on or opening it in a window.

3 Click the Settings button.

You can make changes to the settings that require that the virtual machine be powered off.

Shut Down a Virtual Machine's Operating System
You can shut down the guest operating system in your virtual machine.

You can use several methods to shut down your virtual machine's operating system. This is the preferred
method.

Procedure

u Select Virtual Machine > Shut Down.

Suspend and Resume a Virtual Machine in Fusion
The suspend and resume feature is useful to save the current state of a virtual machine and continue work
later from the same state, even if you quit Fusion in the interim.

Fusion does not support suspending and resuming in Boot Camp virtual machines. Suspending and
resuming rely on being able to save a known state that will not change. You can boot natively into Windows
in the Boot Camp partition. When you do so, the known state is lost and data loss occurs.

Procedure

u Take one of the following actions.

n Select Virtual Machine > Suspend to suspend your virtual machine.

You can also set a Fusion preference to suspend the virtual machine when you close the virtual
machine window.

n Select Virtual Machine > Resume to resume your virtual machine.
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Cancel a Resume Command
You can cancel a resume command while Fusion is restoring the virtual machine state.

When you resume a suspended virtual machine, Fusion displays two progress bars in order. The second bar
has a cancel button.

Procedure

u Click the cancel button before the progress bar is 100 percent filled.

Power on a Virtual Machine to Firmware in Fusion Pro
In Fusion Pro, you can power on or restart a virtual machine to firmware.

The power on to firmware option is available for local and remote virtual machines, but the option is not
available for vCloud Air virtual machines. The power on to firmware option is not available if the virtual
machine is suspended.

The power on to firmware option is supported in Fusion Pro 8.1.

Procedure

u Click Virtual Machine > Power on to firmware.

If the virtual machine is powered off, the virtual machine boots directly to firmware. If the virtual
machine is powered on, you are prompted to restart your virtual machine. Click Restart.

Pause a Virtual Machine
Pausing a virtual machine stops the current state of a virtual machine. When you resume a paused virtual
machine, the state of the virtual machine is exactly the same as when you paused it.

Note   The current state of the virtual machine is not saved when you pause a virtual machine. If you quit
Fusion while a virtual machine is paused, Fusion suspends or shuts down the virtual machine depending on
your Fusion preferences.

Procedure

u Click Virtual Machine > Pause.

What to do next

Resume the virtual machine when you are ready to work with it again.

Restart a Virtual Machine
You can restart a virtual machine without restarting your Mac.

Procedure

u Restart the virtual machine operating system.

n In the virtual machine, restart the operating system as you would in a physical computer.

The restart method depends on the operating system running in the virtual machine.

n In Fusion, select Virtual Machine > Restart.
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Reset a Virtual Machine
You can select a Fusion command to reset a virtual machine, much as you would press the reset button on a
physical computer when it becomes unresponsive.

Caution   Resetting the virtual machine can cause data loss.

Procedure

u Press the Option key and click Virtual Machine > Force Restart, the hard power option, to reset the
operating system in your virtual machine.

Uninstall a Virtual Machine by Using the Finder
You can uninstall a virtual machine by deleting its files.

One method for uninstalling a virtual machine is to use the Finder to delete the virtual machine package.

Prerequisites

Shut down or power off the virtual machine.

Exit Fusion.

Procedure

1 Browse to the Virtual Machines folder (usually in your user/Documents folder) and select the virtual
machine to uninstall.

2 Move the virtual machine package file to the Trash.

What to do next

Open Fusion. If you see the uninstalled virtual machine in the Virtual Machine Library, right-click it and
select Delete.

Uninstall a Virtual Machine by Using the Virtual Machine Library
You can uninstall a virtual machine by deleting its files.

One method for uninstalling a virtual machine is to use the Virtual Machine Library to delete the virtual
machine files.

Prerequisites

Shut down or power off the virtual machine.

Procedure

1 Select Window > Virtual Machine Library.

2 Click the thumbnail of the virtual machine to uninstall.

3 Select Edit > Delete.
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4 In the Remove Virtual Machine dialog box, select a method of uninstalling the virtual machine.

Depending on the type of virtual machine you are uninstalling, you might be presented with different
options for deleting the virtual machine.

Option Action

Move to Trash Removes the virtual machine from the Virtual Machine Library window
and moves all the virtual machine files to the Trash.

Keep File Removes the virtual machine from the Virtual Machine Library window,
but does nothing to the virtual machine files in the Virtual Machines
folder.

Delete Permanently Removes the virtual machine from the Virtual Machine Library window
and deletes the virtual machine files permanently. The files are deleted
permanently and not moved to the trash.

 

Send the Ctrl-Alt-Delete Command to a Virtual Machine
You can use a Fusion command to send the Ctrl-Alt-Delete keystroke combination to a Windows virtual
machine.

Procedure

u You can send the keystroke combination in any of the following ways.

n Select Virtual Machine > Send Ctrl-Alt-Del.

n If you are using an external PC keyboard, press Ctrl+Alt+Del.

n On a full-sized Mac keyboard, press Fwd Del+Ctrl+Option. The  Forward Delete key is below the
Help key.

n On a Mac laptop keyboard, press Fn+Ctrl+Option+Delete.

Send Special Key Commands to a Windows or Linux Virtual Machine
If your keyboard does not have the full range of keys that can be found on some keyboards, you can still
send special key commands to the guest operating system.

Procedure

1 Select Virtual Machine > Send Key.

2 Select the key command from the pop-up menu. See “Special Key Commands,” on page 78.

Fusion sends the key command to the guest operating system on the virtual machine.

Special Key Commands
You can use special key commands with a virtual machine.

The Send Key item on the Virtual Machine menu contains a number of key commands that might not be
available on all keyboards.

Table 6‑1.  Special Key Commands

Key commands that can be sent to the virtual machine with the Send Key menu item

Help (Insert)

Home

End

 (Forward Delete)
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Table 6‑1.  Special Key Commands (Continued)

Key commands that can be sent to the virtual machine with the Send Key menu item

Caps Lock

Clear (Num Lock)

Scroll Lock

Print Scrn

Pause

Break

Menu

F8

F9

F10

F11

F12

F13

F14

F15

F16

変換 (Henkan)

無変換 (Muhenkan)

ひらがな (Hiragana)

Switch Power Commands from the Default Options
You can switch the Fusion power command options from the default options that appear in the Virtual
Machine menu.

If your virtual machine defaults to the soft options, holding down either the Option key or the Alt key

switches the commands in the Virtual Machine menu and the applications menu ( ) to the hard options,
and the reverse.

Note   Pressing the Option or Alt key affects only the power commands in the Virtual Machine menu and
the applications menu. Pressing the Option or Alt key does not affect the power buttons in the toolbar.

Procedure

1 Select Virtual Machine to display the Virtual Machine menu.

2 Hold down the Option key (Mac keyboards) or Alt key (PC keyboards) and select an alternative power
option.

Table 6‑2.  Power commands

Soft Option Hard Option

Start Up Force Start Up

Resume Force Resume

Shut Down Force Shut Down
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Table 6‑2.  Power commands (Continued)

Soft Option Hard Option

Suspend Force Suspend

Restart Force Restart

See “Options for Fusion Power Commands,” on page 80 for descriptions of the power commands.

Options for Fusion Power Commands
You can configure your virtual machine to have soft or hard power options.

The way the Fusion power commands work depends on the way your virtual machine is configured. If the
virtual machine was created in Fusion, the power commands default to soft options. The commands take
effect on the guest operating system. Virtual machines created in other VMware products might default to
hard power options. These commands act on the virtual machine the way the power and reset buttons work
on a physical computer's power supply.

Table 6‑3.  Soft and Hard Options for Power Commands in the Virtual Machine Menu

Command Result

Start Up (soft option)
Force Start Up (hard option)

These commands have the same effect: the virtual
machine's operating system is started.

Resume (soft option) Triggers a resume script to run. You can customize this
script. For more information, see the document Installing
and Configuring VMware Tools at 
http://www.vmware.com/pdf/vmware-tools-installation-
configuration.pdf.

Force Resume (hard option) Resumes the virtual machine from a suspended state.

Shut Down (soft option) Sends a shut down signal to the guest operating system.
An operating system that recognizes this signal shuts down
gracefully. Not all guest operating systems respond to a
shut down signal from this button. If your operating
system does not respond, shut down from the operating
system, as you would with a physical machine.

Force Shut Down (hard option) Works the way a power switch works on a computer's
power supply. The virtual machine is abruptly powered off,
with no consideration for work in progress. This action can
result in data loss. When possible, shut down the virtual
machine's operating system before you power off the
virtual machine.

Suspend (soft option) Triggers a suspend script to run. You can customize this
script. For more information, see the document Installing
and Configuring VMware Tools at 
http://www.vmware.com/pdf/vmware-tools-installation-
configuration.pdf.

Force Suspend (hard option) The Force Suspend command suspends the virtual
machine.

Using VMware Fusion

80  VMware, Inc.

http://www.vmware.com/pdf/vmware-tools-installation-configuration.pdf
http://www.vmware.com/pdf/vmware-tools-installation-configuration.pdf
http://www.vmware.com/pdf/vmware-tools-installation-configuration.pdf
http://www.vmware.com/pdf/vmware-tools-installation-configuration.pdf


Table 6‑3.  Soft and Hard Options for Power Commands in the Virtual Machine Menu (Continued)

Command Result

Restart (soft option) Sends a restart signal to the guest operating system. An
operating system that recognizes this signal shuts down
gracefully and restarts. Not all guest operating systems
respond to a restart signal from this button. If your
operating system does not respond, restart from the
operating system, as you would with a physical machine.

Force Restart (hard option) Works as a reset switch. The virtual machine is abruptly
reset, with no consideration for work in progress. When
possible, shut down the virtual machine's operating
system. Use the reset option only as a last resort when the
virtual machine's operating system is unresponsive.

Open a Windows Application While You Are In Unity View
When a virtual machine is running in Unity view, you do not see the guest operating system's desktop, but
you can open an application without it.

When you are working with applications in an operating system, you can use several methods to start an
application. In some cases, you click an icon on the desktop or use a start menu or its equivalent. When you
use Unity view with a virtual machine, you cannot use those methods because only the active application
windows appear on your Mac's desktop.

Procedure

n Select the application directly from the applications menu.

a
Click the applications menu status item ( ) in the Apple menu bar.

b Click the pop-up menu in the title bar and select the virtual machine that contains the application
you want.

c Click the application icon in the list, or find it by clicking All Programs.

n Keep a virtual machine application in the Mac dock.

a Switch to Unity view with the application open.

The application appears in the Mac dock.

b Control-click or right-click the application in the dock and select Options > Keep in Dock.

The application remains in the dock, where you can open it even if Fusion is not currently running.

n Show the Windows taskbar to use the start menu.

a Select View > Show Taskbar in Unity.

You might have to move the location of the Mac dock to see the taskbar.

b Click the Start menu and select the application.
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Open a Windows or Linux Application from the Applications Menu
The applications menu appears as a status item in the Apple menu bar on your Mac, so that you can open a
virtual machine application regardless of where you are in the interface.

Procedure

n

Select the application directly from the applications menu ( ). See “Find a Guest Application by
Using the Applications Menu,” on page 24.

n Use the Applications menu to search for the application.

Moving and Sharing Files with Your Mac
With Fusion, you can move and share files between a virtual machine and your Mac.

View Shared Folders in a Windows Guest by Using Windows Explorer
You can use Windows Explorer to view shared folders between your Mac and Windows.

Procedure

1 Open Windows Explorer.

2 View shared folders using one of the following methods:

n Click on the VMware Shared Folders shortcut.

n In the Address bar, type \\vmware-host\Shared Folders\.

n In the Address bar, type Z:.

When the Enable Shared Folders setting is enabled, Fusion creates a network drive that maps
the \\vmware-host\Shared Folders directory to the Z drive.

The Windows Explorer window displays your shared folders.

View Shared Folders in a Windows Guest by Mapping Them as a Drive
You can view your shared folders between your Mac and Windows by mapping them as a drive in
Windows.

Procedure

1 Start Windows Explorer.

2 Navigate to My Computer or Computer.

3 Run the command to map a network drive.

Option Description

Windows Vista, Windows 7,
Windows 8, Windows 10

Click Map Network Drive

Windows operating systems other
than Vista, Windows 7, Windows 8,
Windows 10

Click Tools > Map Network Drive

 
4 Select a drive to map.

5 In the Folder field, type \\vmware-host\Shared Folders\.
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6 Click Finish.

Your shared folders appear in Windows Explorer on the drive that you mapped.

View Shared Folders in a Linux Guest
You can go to specific directories to find your shared folders.

Procedure

u Open the /mnt/hgfs directory in File Explorer to view shared folders on a Linux guest.

View Shared Folders in a Mac OS Guest
You can view folders that are shared between the Mac OS guest and the Mac host.

Procedure

1 Open the Mac OS guest.

2 Click the VMware Shared Folders shortcut on the guest OS desktop.

The guest OS desktop displays your shared folders.

Sharing Applications Between Your Mac and Your Windows Virtual
Machines

In the Applications panel of the virtual machine Settings window, you can set up Fusion so that your Mac
can open applications in a virtual machine or so that a virtual machine can open applications on your Mac,
or both.

Open a File in a Virtual Machine with an Application on Your Mac
When you select a file in your virtual machine, you can open it with the appropriate application on your
Mac.

Prerequisites

Verify that the following conditions are met:

n You turned on Shared Folders in the Sharing panel of the virtual machine Settings window.

n You enabled Open your Windows files and web links using Mac applications in the Default
Applications panel of the Settings window.

n You selected a folder or folders to share.

n The file to open is located in one of the shared folders.

Procedure

n To open a file one time, right-click the file, select Open With and select Default Host Application.

Fusion determines the appropriate application on the Mac and uses that application to open the file.

n To always open a particular file with the Mac application, right-click the file, select Properties, click
Change for Opens With, and select Default Host Application in the Open With dialog box.

Whenever you open this file, it opens in the Mac application.
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n To always open files of this type with the Mac application, right-click the file, select Open With, select
Default Host Application > Choose Program, and select Always use the selected program to open this
kind of file.

Fusion determines the appropriate application on the Mac and uses that application whenever you
open any file of this type.

Open a File on Your Mac with an Application in a Virtual Machine
You can open a file on your Mac with the appropriate application in one of your virtual machines.

For Windows virtual machines, you can open the Mac file with a virtual machine application as a one-time
event, or you can set the application to be used whenever you open the file.

Prerequisites

Verify that the following conditions are met:

n You turned on Shared Folders in the Sharing panel of the virtual machine Settings window.

n You selected a folder or folders to share.

n The file to open is located in one of the shared folders.

n You enabled Shared Folders in the Default Applications panel of the Settings window.

Procedure

n For a one-time event, right-click the file, select Open With, and select an application from the menu.

Because you can find the same application across many virtual machines, the menu entry shows the
name of the virtual machine and the application name.

The file opens in the application that appears in the menu.

n To always open with the virtual machine application, right-click the file, select Get Info and select an
application from the Open with pop-up menu.

n (Optional) Click Change All to use the application to open all files of this type.

Whenever you open this file, it launches in the application that you selected.

Keep a Windows Application in the Mac Dock
You can place an icon tile for a Windows application in your Mac dock, where you can open the application
in the same way that you open your Mac applications. You can access your virtual machine's applications
without having to use the VMware Fusion menu bar or the guest operating system interface.

Procedure

1 Switch to Unity view with the application open.

The application appears in the Mac dock.

2 Control-click or right-click the application in the dock and select Options > Keep in Dock.

Switch Between Virtual Machines That Are Powered On
You can operate multiple virtual machines at the same time, and can switch between them easily.

Procedure

u Select the virtual machine to work with from the Window menu within Fusion.
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Using Mac Input Devices in a Virtual Machine
To use Mac keyboards, mice, and trackpads in a virtual machine, you sometimes must change settings and
use key combinations as equivalents to PC commands.

Enable the Secondary Button in an Apple Mighty Mouse
In a virtual machine, the Apple Mighty Mouse does not perform a right-click when you Control-click. You
must enable the secondary button to perform a right-click in a virtual machine.

Procedure

1 Select VMware Fusion > Preferences and click Keyboard & Mouse.

2 Select the Secondary Button check box.

3 (Optional) To change the shortcut for the secondary button, double-click the current shortcut, select a
new shortcut, and click OK.

Using Mac Keyboards in a Virtual Machine
Because PC and Mac keyboards differ, you must press certain key combinations to enable certain PC
commands on a Mac keyboard.

For keys with no keyboard equivalent, Fusion provides the Send Key item in the Virtual Machine menu.

For keys with no keyboard equivalent, Fusion provides the Send Key item in the Virtual Machine menu.

Table 6‑4.  PC and Mac Keyboard Equivalents

PC Keyboard Apple External Keyboard
MacBook and MacBook Pro Built-In
Keyboard

F1-F12 F1-F12 fn+F1 . . . fn+F12

Print Screen F14 (use Send Key)

Scroll Lock F15 (use Send Key)

Pause/Break F16 (use Send Key)

Backspace delete delete

delete 
(Forward Delete)

delete fn+delete

Insert (toggles overwrite) help (early models) (use Send Key and select Help item)

Num Lock clear fn+num lock F6

Command
(Windows logo key—between Ctrl and
Alt keys)

Alt alt option alt option

Force Virtual Machines to Grab Keyboard and Mouse Input
You can set the virtual machine to grab mouse and keyboard input. When input is grabbed, the mouse
pointer is confined to the virtual machine window, and all keyboard and mouse input is directed to the
virtual machine.

Ordinarily, with VMware Tools installed, when you click in the virtual machine, Fusion directs keyboard
and mouse input to the virtual machine. When you click on your Mac desktop, keyboard and mouse input is
directed to your Mac host. You can force all input to the virtual machine.
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Procedure

u Force grab or force release keyboard and mouse input.

Option Action

Force a virtual machine to grab
keyboard and mouse input

On the keyboard, press Cmd+G.

Force a virtual machine to release
keyboard and mouse input

On the keyboard, press Ctrl+ .
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Sharing Files Between Windows and
Your Mac 7

You can set up shared folders in guest operating systems to share files between your Mac and your
Windows and other virtual machines.

In the Sharing panel of a virtual machine's Settings window, you can select shared folders on your Mac to
make available to the virtual machine. This feature requires VMware Tools.

You can mirror folders in your Windows virtual machine and in your Mac. Mirrored folders match key
folders in the virtual machine with their corresponding Mac folders: Desktop, Documents, Downloads,
Movies, Music, and Pictures.

To use shared folders, you must configure your virtual machine settings to enable shared folders and to
specify which directories on your Mac are to be shared. The shared folders can be in your Mac file system or
they can be network directories accessible from your Mac.

The guest operating system determines how shared folders appear. You can view shared folders in certain
Windows and Linux guest operating systems. For a list, see “Guest Operating Systems That Support Shared
Folders,” on page 87. Before you can view shared folders, you must enable and configure the shared
folders function.

Note   Do not open a file in a shared folder from more than one application at a time. For example, do not
use an application on the Mac’s operating system and another application in the virtual machine’s operating
system to open the same file at the same time. If one of the applications writes to the file, data might be
corrupted.

This chapter includes the following topics:

n “Guest Operating Systems That Support Shared Folders,” on page 87

n “Guest Operating Systems That Support Mirrored Folders,” on page 88

n “Enable Shared Folders or Mirrored Folders for a Virtual Machine,” on page 88

n “Add or Remove a Mirrored Folder,” on page 88

n “Add a Shared Folder,” on page 89

n “Remove a Shared Folder,” on page 89

Guest Operating Systems That Support Shared Folders
You can use shared folders with virtual machines that are running certain operating systems.

Fusion supports shared folders in certain Windows, Mac OS X, and Linux operating systems.

n Windows 10

n Windows 8.1
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n Windows 8

n Windows 7

n Windows Server 2012

n Windows Server 2008

n Windows Server 2003

n Windows Vista

n Windows XP

n Mac OS X 10.6, 10.7, 10.8, 10.9, 10.10, 10.11

n Supported Linux guest operating systems with a kernel version of 2.4 or later

Guest Operating Systems That Support Mirrored Folders
You can use mirrored folders with virtual machines that are running a variety of Windows operating
systems.

Fusion supports mirrored folders in these Windows operating systems.

n Windows 10

n Windows 8

n Windows 7

n Windows Vista

n Windows XP

Fusion does not support mirrored folders for Windows 2000 and earlier, or for Windows Server 2003 and
Windows Server 2008. For virtual machines with unsupported guest operating systems, the choices are
disabled in the Sharing panel of the Settings window.

Enable Shared Folders or Mirrored Folders for a Virtual Machine
Before you can identify which folders to share or mirror, you must configure your virtual machine to share
folders.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Systems Settings in the Settings window, click Sharing.

4 Select the Enable Shared Folders check box.

This action enables shared folders. It also enables mirrored folders for supported Windows guest
operating systems. On Windows and Mac OS virtual machines, a VMware Shared Folders shortcut is
created on the guest operating system. Click on the shortcut to view the shared folders.

Add or Remove a Mirrored Folder
With Fusion mirrored folders you can map special folders on your Mac, such as Desktop, Documents,
Downloads, Movies, Music, and Pictures, to their counterparts in certain Windows virtual machines.

Procedure

1 Select Window > Virtual Machine Library.
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2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Sharing.

4 Select the Enable Shared Folders check box.

5 In the Mirrored Folders section, select the Mac folders to mirror and deselect any folders that you do
not want mirrored.

Add a Shared Folder
You can share files between virtual machines and your Mac by using shared folders.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Systems Settings in the Settings window, click Sharing.

4 Select the Enable Shared Folders check box.

On Windows and Mac OS virtual machines, a VMware Shared Folders shortcut is created on the guest
operating system.

5 Click the add (+) button at the bottom of the display box.

6 In the Finder sheet, find the location of the folder to share, select it, and click Add.

7 In the Permissions field, set the virtual machine permission on the contents of the Mac's shared folder.

Option Description

Read & Write Enables the virtual machine to change the contents of the shared folder on
your Mac.

Read Only Prevents the virtual machine from changing the contents of the shared
folder on your Mac.

 
Permission settings on your Mac also determine access to files in the shared folder. Read-only
permission on a file or folder takes precedence over the Shared Folder permission setting.

8 (Optional) Click the Open in Guest button to open the shared folder in the virtual machine.

This option is available only for Windows virtual machines that are powered on. The Open in Guest
option was added in Fusion 8.1.

Remove a Shared Folder
You can remove a folder from the list of shared folders to stop sharing it.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Systems Settings in the Settings window, click Sharing.

4 In the display box at the top of the Sharing panel, select the folder to remove.

5 Click the remove (-) button at the bottom of the display box.
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Protecting Your Virtual Machines 8
You can protect your virtual machines from data loss and other problems by using snapshots, AutoProtect,
complimentary anti-virus software, and backup applications.

This chapter includes the following topics:

n “Snapshots,” on page 91

n “AutoProtect,” on page 93

n “Install McAfee AntiVirus Plus in a Windows Virtual Machine,” on page 94

n “Copy a Virtual Machine to External Media,” on page 95

n “Using Time Machine When You Have Fusion on Your Mac,” on page 95

Snapshots
Taking a snapshot in Fusion lets you preserve the state of the virtual machine so that you can return to that
state.

You might take a snapshot any time you are about to take an action in your virtual machine and you are
unsure of the consequences. For example, you might take a snapshot before you make a change to your
virtual machine's system software, such as an operating system upgrade or a major configuration change. If
something doesn't work as expected after the change, you can restore the snapshot to return the virtual
machine to its previous state.

You might also take a snapshot before you go on to the Internet, or log in to an unknown network. If your
computer acquires a software virus or spyware, you can restore the snapshot to return the virtual machine
to its previous uninfected state.

A snapshot captures the entire state of the virtual machine at the time you take the snapshot.

n Memory state – Contents of the virtual machine memory

n Settings state – Virtual machine settings

n Disk state – State of all the virtual disks

A snapshot is not the same as a backup. It is not a copy of your virtual machine.

View Snapshots for a Virtual Machine
The Snapshots window shows all of the snapshots for a virtual machine.

The Snapshots window shows manual snapshots and AutoProtect snapshots.
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Procedure

1 Select the virtual machine to view snapshots for in one of the following ways.

n Select the virtual machine from the Virtual Machine Library.

n Open the virtual machine.

2 Open the Snapshots window for the selected virtual machine in one of the following ways.

n Select Virtual Machine > Snapshots.

n Click the Snapshots button in the virtual machine toolbar.

Take a Snapshot
Take a snapshot of the virtual machine's current state from the Snapshots window for that virtual machine.

The virtual machine does not need to be powered on for you to take a snapshot.

You cannot take a snapshot of a Boot Camp virtual machine. Snapshots rely on being able to save a known
state that will not change. This is not possible with Boot Camp, in which you can boot natively into
Windows in the Boot Camp partition. Once that happens, the known state would be lost and data loss
would occur.

Procedure

1 In the Snapshots window of the virtual machine, select the Current State if it is not selected.

2 Click Take.

3 Name the new snapshot and give it a description in the dialog.

4 Click Take.

Fusion takes the snapshot of the current state of the virtual machine.

5 Close the Snapshots window.

Restore a Virtual Machine to the State in a Snapshot
You can restore a virtual machine to an earlier state.

Procedure

1 Select Virtual Machine > Snapshots.

2 Select the snapshot to restore.

3 Click Restore.

4 Click either Save to save a snapshot of the current state before you restore the virtual machine to the
selected snapshot state, or Don't Save a snapshot.

The virtual machine is restored to the state that the selected snapshot captured.

Delete a Snapshot
You can manually delete snapshots that you no longer need or to make more disk space available.

The virtual disk files that a snapshot creates do not contain the entire contents of the virtual machine's
virtual disk. When you delete a snapshot, you must consolidate the changes that it captured into the
original, parent virtual disk.

You cannot delete the snapshot showing the "Current State" of the virtual machine.
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Prerequisites

Allocate enough time for virtual disk consolidation. If a snapshot captured a state considerably different
from the earlier state, for example, a service pack upgrade, the consolidation might take up to a few hours.

Procedure

1 Select Virtual Machine > Snapshots.

2 Select the snapshot to delete.

Option Action

To select multiple adjacent
snapshots.

Shift-click

To select multiple snapshots that
are not adjacent.

Command-click

 
3 Click Delete.

4 Click Delete to confirm that you want to delete the snapshot.

The snapshot is deleted and virtual disk consolidation takes place.

AutoProtect
Fusion can take snapshots of the state of your virtual machine at intervals with the AutoProtect function.
This feature is in addition to manual snapshots, which you can take at any time.

Use AutoProtect to instruct Fusion to take a snapshot automatically every 30 minutes, every hour, or every
day.

Set Up Automatic Snapshots with AutoProtect
Fusion can take snapshots of the state of a virtual machine automatically at set intervals, with the
AutoProtect function. This function is in addition to manual snapshots, which you can take at any time.

When you turn on AutoProtect, you set the maximum number of AutoProtect snapshots to keep at a time.
After this number is reached, Fusion deletes the oldest AutoProtect snapshot in the range to make room for
the newest snapshot.

This number setting can affect the number of manual snapshots that you can take and keep. You can have no
more than 100 snapshots for a virtual machine, and depending on the types and sizes of the virtual disk
files, this number can be less. If the total of AutoProtect snapshots reach the limit, you cannot take manual
snapshots.

Fusion uses this setting to estimate the minimum amount of hard disk space the AutoProtect snapshots will
use. That information appears at the bottom of the panel. The maximum amount of hard disk space can be
significantly more than the estimate, depending on the amount of changes you make between snapshots.

Note   When you have manual or AutoProtect snapshots of a virtual machine, you cannot add or modify its
virtual hard disk.

Procedure

1 Open a virtual machine, or select it in the Virtual Machine Library.

2 Select Virtual Machine > Snapshots.

3 Click AutoProtect Settings.

4 Select the Enable AutoProtect check box.
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5 Select the frequency of snapshots.

6 Select the number of AutoProtect snapshots to retain.

After this number is reached, Fusion deletes the oldest AutoProtect snapshot in the range to make room
for the newest snapshot.

7 Click Done to apply the AutoProtect settings.

8 Close the Snapshots view and return to the virtual machine.

Prevent the Deletion of an AutoProtect Snapshot
When AutoProtect takes a new snapshot, it deletes the oldest snapshot to maintain the allowable number
that you set. You can prevent the deletion of an AutoProtect snapshot.

Procedure

1 In the Snapshots window, hover the cursor over the AutoProtect snapshot to keep, and click the
information button (i).

2 Click Keep Snapshot.

Fusion considers the AutoProtect snapshot the same as a snapshot taken manually. AutoProtect will not
delete this snapshot when the next AutoProtect snapshot is taken.

Install McAfee AntiVirus Plus in a Windows Virtual Machine
VMware recommends running antivirus software to ensure a secure and safe Windows experience on your
Mac.

VMware has partnered with McAfee, Inc. to offer Fusion users a complimentary 90-day subscription to
McAfee AntiVirus® Plus.

Prerequisites

McAfee AntiVirus Plus is supported on the following guest operating systems:

n Windows 10 (32- and 64-bit)

n Windows 8 (32- and 64-bit)

n Windows 7 SP1 x64

n Windows 7 SP1 x86

n Windows Vista SP2 x64

n Windows Vista SP2 x86

n Windows XP SP3

n Windows 2000 Professional SP4

Procedure

1 Access the installer for the antivirus software.

n When you create a virtual machine, after VMware Tools installs, a dialog appears prompting you to
install McAfee AntiVirus Plus. Click Install to start downloading McAfee AntiVirus Plus.

n In an existing Windows virtual machine, select Virtual Machine > Install McAfee AntiVirus Plus.
The McAfee installation wizard appears.

2 Click Next in the McAfee Security Center window to install the antivirus software into your Windows
virtual machine.
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Copy a Virtual Machine to External Media
Because virtual machines are files, you can back them up by making a copy.

Although virtual machines run other programs and manipulate files, they are still files themselves. Because
of this, you can back them up by making a copy to external media and restore the virtual machines by
copying back.

Note   You cannot copy a Boot Camp virtual machine, because instead of having a virtual hard disk, the
Fusion virtual machine uses the Boot Camp partition.

Prerequisites

Shut down or power off the virtual machine and shut down Fusion.

Procedure

1 Connect to the media to which you will be copying the virtual machine.

2 Browse to the Virtual Machines folder (usually in your user/Documents folder) and select the virtual
machine to copy.

3 Right-click and select Copy "virtual machine name".

4 Open the external media in the Finder, right-click and select Paste Item.

The contents of the virtual machine package is copied to the external media. You can reverse the process to
restore the copied virtual machine to your Mac.

Using Time Machine When You Have Fusion on Your Mac
If you use Time Machine, exclude virtual machines from the backup.

Any change to a virtual machine's virtual hard disk file results in the entire file being backed up. When you
have a 40GB virtual machine, having Time Machine back it up every hour can fill a hard disk quickly.

n Exclude a Virtual Machine From Time Machine on page 95
To prevent problems with your virtual machines and to save space on your backup media, you should
not back up virtual machines with Time Machine.

n Use Shared and Mirrored Folders If You Back Up Your Mac With Time Machine on page 96
To use Time Machine to back up data and documents from your virtual machines, keep those files on
the Mac.

Exclude a Virtual Machine From Time Machine
To prevent problems with your virtual machines and to save space on your backup media, you should not
back up virtual machines with Time Machine.

If you do not exclude virtual machines from Time Machine backups, Time Machine can back up a virtual
machine while it is running. Restoring from this kind of backup would overwrite your current virtual
machines with versions that are incomplete and potentially damaged. For the recommended method of
backing up virtual machines, see “Copy a Virtual Machine to External Media,” on page 95.

Procedure

1 Open the Mac's System Preferences and click Time Machine.

2 Click Options.

3 Click the add (+) button at the bottom of the Do not back up list.
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4 Browse to your Documents folder on the Mac, select the Virtual Machines folder, and click Exclude.

The Virtual Machine folder appears in the Do not back up list, and displays the total memory used by
all your virtual machines.

5 Click Done, and close the Time Machine window.

Use Shared and Mirrored Folders If You Back Up Your Mac With Time Machine
To use Time Machine to back up data and documents from your virtual machines, keep those files on the
Mac.

When you use Shared Folders and Mirrored Folders in your virtual machines, you save your documents and
data as files on the host, not in the guests. This means that although you exclude virtual machines from
Time Machine backups, Time Machine can back up the files in the Shared and Mirrored folders because they
do not reside in the virtual machines. See “Enable Shared Folders or Mirrored Folders for a Virtual
Machine,” on page 88

Prerequisites

Exclude your virtual machines from Time Machine.

Procedure

u Enable Shared or Mirrored folders.
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Configuring Your Virtual Machines 9
You can configure the way your virtual machine uses the Mac system hardware and attached devices. You
can manage your virtual hard disks.

This chapter includes the following topics:

n “Fusion General System Settings,” on page 97

n “Set a Virtual Machine to Start When Fusion Starts,” on page 98

n “Setting Virtual Processors and Memory,” on page 99

n “Enable Default Applications,” on page 101

n “Configuring Keyboard and Mouse Profiles,” on page 102

n “Enable a CD/DVD Drive on a Remote Virtual Machine,” on page 103

n “Enable a Floppy Drive on a Remote Virtual Machine,” on page 103

n “View the Status of a Server or Remote Virtual Machine,” on page 104

n “Configuring Display Resolution Settings,” on page 104

n “Enable Hot Keys for Virtual Machines,” on page 106

n “Configure Discrete Graphics Management,” on page 107

n “Set the Default Printer for a Virtual Machine,” on page 107

n “Add a Device,” on page 108

n “Select a Startup Device,” on page 129

n “Encrypting and Restricting a Virtual Machine,” on page 130

n “Virtual Machine Compatibility,” on page 133

n “Configuring Guest Isolation Options for a Virtual Machine,” on page 135

n “Managing Advanced Settings,” on page 136

Fusion General System Settings
You can find basic information about your virtual machine in the General system settings.

The General system settings of the virtual machine include the virtual machine name, the guest operating
system, and notes. You can change some of the settings directly in this panel.
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Table 9‑1.  General System Settings

Setting Description

Name Name of the virtual machine that you specified when you
created it. This name appears in the Virtual Machine
Library. You can change the name of the virtual machine at
any time.

OS Guest operating system installed in the virtual machine.
This name is typically provided as the guest operating
system you selected when you created the virtual machine.
You can change the guest operating system listed here if
you uninstall the guest operating system and install a
different one.

Notes You can add notes about this virtual machine, its use, or
other information at any time.

Start automatically when Fusion launches Starts the virtual machine when you start Fusion.

Note   Restricted virtual machines only show a subset of the full settings.

The General system settings also include information about the virtual machine's hard disk. You can also use
the Clean up Virtual Machine option to free up space on your Mac. For more information, see “Clean Up a
Virtual Machine,” on page 115.

Set a Virtual Machine to Start When Fusion Starts
You can set any virtual machine to start when you start Fusion.

You can set any number of virtual machines to start when you start Fusion. You must select this option in
each virtual machine that you want to start when Fusion launches.

Setting a virtual machine to start when Fusion starts can be useful if you have many virtual machines that
you want to start. You might want to start a virtual machine when Fusion starts if you use a laptop to run
one virtual machine that you always want to resume every time you start Fusion.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, select General.

4 Select the Start automatically when VMware Fusion launches check box.

The virtual machine starts each time you start Fusion.
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Setting Virtual Processors and Memory
You can configure processor settings for a virtual machine, including the number of processors, the amount
of virtual memory available, and whether to enable hypervisor applications and code profiling applications.

Set the Number of Virtual Processors
You can increase performance of a virtual machine by making more processors available because more tasks
can be performed simultaneously. When you assign a virtual processor to the virtual machine, it reduces the
processor resources that are available to your Mac.

For Windows virtual machines running mostly office and Internet productivity applications, using multiple
virtual processors is not beneficial, so the default single virtual processor is ideal. For server workloads and
compute-intensive applications, adding extra virtual processors may provide an increase in application
performance.

Application Recommended number of processors

Desktop applications 1 processor

Server operating systems 2 processors

Video encoding, modeling, and scientific 4 processors

In some circumstances, adding additional processors can decrease the overall perfomance of the virtual
machine and your Mac. This can occur if the operating system or application is not using the processors
efficiently. In this case, reducing the number of processors is recommended.

Assigning all processors on the Mac to the virtual machine results in extremely poor performance. Mac OS X
must continue to perform background tasks even if no Mac applications are running. If you assign all
processors to a virtual machine, this prevents important Mac tasks from being completed.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Processors & Memory.

4 Select the number of processor cores for the virtual machine.

Information about your selected number of processors is displayed at the bottom of the Processors &
Memory window.

5 Restart the virtual machine.

Set the Amount of Virtual Memory
Certain applications in the virtual machines might perform better with more memory available. Having
more memory available to the guest operating system can facilitate caching, which can improve
performance of the virtual machine. You can change the amount of virtual memory available to a virtual
machine.

For the best balance of performance between Windows and Mac applications, do not give Windows too
much memory, because it might cause your Mac to become slower. For Windows XP, 512MB of memory is
ideal for Internet and office productivity applications.
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For Windows Vista, Windows 7, Windows 8 and Windows 10, 1GB of memory is ideal for Internet and office
productivity applications. 1GB of memory is appropriate for both the 32-bit and 64-bit versions of Windows
7, Windows 8 and Windows 10. If your Mac has at least 6GB of memory, Fusion uses 2GB of memory as the
default for 64-bit versions of Windows 7, Windows 8 or Windows 10 guests. These settings are the default
memory settings for Windows virtual machines that Fusion Easy Install creates.

Note   Manufacturer recommendations do not generally take virtualization into account in terms of
performance. Good performance relies on balancing the needs of the Mac with the needs of the virtual
machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Processors & Memory.

4 Set the amount of memory to allocate to the virtual machine by using the slider control.

The memory slider control displays the recommended amount of memory for your virtual machine.

Set Advanced Processor Options
You can enable hypervisor applications, applications that use performance counters, or both in certain
virtual machines.

With Fusion virtual machines, you have the following advanced options:

n You can run hypervisor applications such as Workstation Pro and Fusion inside a virtual machine. For
example, you can use Fusion to create a virtual machine, install Workstation Pro in that virtual machine,
and then use that version of Workstation Pro to create a virtual machine.

n You can use code profiling applications such as VTune or OProfile to optimize or debug software that
runs inside a virtual machine.

The Enable hypervisor applications in this virtual machine setting has some relation to the advanced
virtual machine setting called Preferred virtualization engine. If you enable hypervisor applications, any
selection you make for the Preferred virtualization engine setting is overridden and the setting called Intel
VT-x with EPT is used.

The preferred engine you choose is a preference only. If you select a preference that does not work for a
virtual machine, a different virtualization engine is usually used. For this reason, as a best practice, do not
use the Enable hypervisor applications in this virtual machine setting for older Windows operating
systems. If you do, the virtual machines will not be able to use binary translation, and the operating system
will not be able to resolve certain race conditions.
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The Enable hypervisor applications in this virtual machine setting has no relation to enabling a guest
operating system that has a hypervisor built into it. For example, to enable the hypervisor for Windows 8
built-in Hyper-V, do not use the Enable hypervisor applications in this virtual machine setting. Instead,
change the operating system listed in the General virtual machine settings to Hyper-V (unsupported).
Furthermore, if you have a virtual machine with a Windows Hyper-V guest operating system, if you select
the Enable hypervisor applications in this virtual machine check box and then clear it, you will no longer
be able to run hypervisor applications.

Important   If you enable either of these settings and then move the virtual machine to another host system,
make sure the new host system uses the same kind of CPU.

Prerequisites

n Verify that the virtual machine is compatible with Fusion 8 or later virtual machines.

n Verify that the virtual machine does not have an older guest operating system, such as Windows
versions prior to Windows XP.

n Verify that the host system has a CPU that is recent enough to support Virtualized Intel VT-x/EPT,
performance counters, or both. For example, host CPUs that support advanced options include Intel
CPUs based on the Nehalem, Westmere, or Sandy Bridge microarchitectures. With the current Intel
naming convention, these processors include Intel Core i processors, such as Intel Core i5.

If the host system does not have a processor that supports hypervisor applications and you enable
hypervisor application in the virtual machine, when the virtual machine starts, you see the message:
"Virtualized intel VT-x/EPT is not supported on this platform. Continue without virtualized

Intel VT-x/EPT?"

n Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Processors & Memory.

4 Click to expand Advanced Options and select the check boxes for the options that you want to use.

Enable Default Applications
You can set up Fusion so that certain applications open files regardless of whether the files reside on your
Mac or in the virtual machine.

The Default Applications setting also adds applications from your virtual machine to your Mac
Applications menu and Spotlight.

Prerequisites

n Verify that VMware Tools is installed.

n If your virtual machine is suspended, power it on.

Procedure

n Select Window > Virtual Machine Library.

n Select a virtual machine in the Virtual Machine Library window and click Settings.

n Under System Settings in the Settings window, click Default Applications.
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n Select the defaults for application sharing between your Mac and the virtual machine.

You can enable more than one of these options at the same time.

Option Description

Open your Mac files and web links
by using Windows applications

You can use applications in your virtual machine to open files that reside
on your Mac. For example, you can open a Microsoft Word document
stored on your Mac in a Microsoft Office application in your virtual
machine.

Open your Windows files and web
links using Mac applications

You can use your Mac applications to open files in your virtual machines.

Run Windows applications from
your Mac's Applications folder

Find applications that you installed in Windows in your Mac's
Applications folder or using Spotlight. This option requires VMware Tools.
The virtual machine must be running to enable this option. This option is
not available on shared virtual machines.

 

n (Optional) Click Configure to assign the applications used to manage mail, Web pages, and so on. See 
“Set Default Applications Preferences,” on page 37.

n (Optional) Click Restore Applications to restore the applications listed in your Mac Application folder
to only those that Windows does not include by default.

If you deleted any of the Windows applications not included by default from the Mac Application
folder, the deleted applications are restored.

If you added any applications that are included by default to your Mac's application folder, those
applications are deleted from the Mac Application folder.

n (Optional) Click Clean Up Applications to delete any Windows applications in the Mac Application
folder that are not being used by any of your virtual machines.

App Nap Support
Fusion 7.0 or later supports the App Nap feature, which places UI applications running in the background
in a reduced system resource state.

You do not have to disable App Nap for Fusion 7 or later.

Configuring Keyboard and Mouse Profiles
These profiles specify how Mac key combinations and mouse shortcuts are mapped to shortcuts on a virtual
machine, including key combinations for Windows 8 shortcuts.

With keyboard and mouse profiles, you can also specify whether keyboard shortcuts are sent to your Mac
instead of the virtual machine, and you can specify which Fusion-specific keyboard shortcuts to enable.

Although you can also create and edit keyboard and mouse profiles in Fusion preferences, you use virtual
machine settings to choose which profile to use for a particular virtual machine.

You can edit the default profiles provided by Fusion, or you can create additional profiles, either by adding
a new one or by duplicating and editing one of the existing profiles.

n Profile maps common Macintosh key combinations such as +C and +X to their Windows and
Linux counterparts, such as Control+C and Control+X, respectively.

n Mac Profile has very few keyboard mappings. Most keystrokes are passed directly to the Mac OS X
guest.

n Windows 8 Profile has a set of key mappings specifically for Windows 8 features, such as pressing
Windows-C to open the Charms bar.
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Fusion includes a Windows 8 specific profile because many keyboard shortcuts specific to Windows 8
include the Windows key, which normally maps to the  key on Mac OS X. Unfortunately, many of
these  key combinations are also used for system hot keys in Mac OS X. To avoid conflicts, the
Windows 8 profile allows you to use the key combination +shift to map to the Windows key in
Windows 8. You can, however, configure a different key combination.

Enable a CD/DVD Drive on a Remote Virtual Machine
You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You
can access or install software from a physical CD/DVD drive on to your remote virtual machine.

Prerequisites

Verify that the following conditions are met:

n You have login credentials for the server where the virtual machine is hosted.

n The virtual machine is powered on.

Procedure

1 Select File > Connect to Server.

2 Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3 Enter your login credentials and click Connect.

4 Select Virtual Machine > Settings.

5 Click CD/DVD Drive.

6 Select the Enable CD/DVD Drive check box.

7 Select a remote disc image from the Choose a remote disc image drop-down menu.

8 (Optional) Expand Advanced options and select a bus type from the drop-down menu.

9 (Optional) Click Remove CD/DVD Drive to return to the CD/DVD drive that your virtual machine
uses.

Enable a Floppy Drive on a Remote Virtual Machine
You can enable a floppy drive and select a disk image on a virtual machine hosted on a remote server. You
can access or install software from a physical floppy drive on to your remote virtual machine.

Prerequisites

Verify that the following conditions are met:

n You have login credentials for the server where the virtual machine is hosted.

n The virtual machine is powered on.

Procedure

1 Select File > Connect to Server.

2 Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3 Enter your login credentials and click Connect.

4 Select Virtual Machine > Settings.

5 Click Floppy.

6 Click the Enable Floppy Drive check box.
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7 Select a floppy image from the drop-down menu.

View the Status of a Server or Remote Virtual Machine
You can view the power state, CPU use, and disk space use of a server or the configuration information of a
remote virtual machine.

Prerequisites

Verify that you have login credentials for the server where the virtual machine is hosted. The server cannot
be a vCenter Server host.

Procedure

1 Select File > Connect to Server.

2 Type the name of the server, or select a server from the Recent Servers drop-down menu.

3 Type your login credentials and click Connect.

4 Select a server to view CPU use, memory use, and available storage information.

5 Select a virtual machine to view snapshot, configuration file, and hardware compatibility information.

Configuring Display Resolution Settings
You can configure display resolution settings for your virtual machine to enable 3D accelerated graphics,
retina display support, and single window and full screen settings.

Enable Accelerated 3D Graphics
On certain virtual machines, Fusion provides support for accelerated 3D graphics.

On virtual machines running Windows XP and later, Fusion provides support for DirectX 9.0c with Shader
Model 3 and OpenGL 2.1 accelerated 3D graphics.

On virtual machines running Windows Vista and later, Fusion provides support for DirectX 10 with Open
GL 3.3. Hardware version 12 is required.

On virtual machines running Linux, Fusion provides support for OpenGL 3.3 to support accelerated 3D
graphics. Hardware version 12 is required. Linux kernel and Mesa 3D versions that support 3D accelerated
graphics are required.

Prerequisites

Shut down or power off the virtual machine. You cannot change these settings while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Display.

4 Select the Accelerate 3D graphics check box.

The version of DirectX supported by your hardware version is displayed.

5 Select the Battery life menu item from the drop-down menu.

You can select the option to use high-performance graphics for 3D applications only to conserve battery
life. You can select the menu item to always use high-performance graphics, but this selection results in
shorter battery life.
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6 Select the shared graphics memory item from the drop-down menu.

Enable Retina Display Support
The Retina display options control the appearance of virtual machines on displays with high pixel density.

Prerequisites

n Verify that you are using a Retina display or another high-pixel density display.

n Verify that you are using hardware version 11 or later. Hardware version 12 is recommended.

n Verify that the latest version of VMware Tools is installed.

n For best appearance and performance, in the Display pane of System Preferences on the Mac host, select
Best for Display in Mac OS X 10.9.5 or Default for Display in Mac OS X 10.10 and later.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Display.

4 Select the Use full resolution for Retina display check box.

When the Use full resolution for Retina display option is on, the virtual machine resolution is set to
the full Retina display resolution.

When the Use full resolution for Retina display option is off, the virtual machine resolution is set to
half of the Retina display resolution. This setting matches the non-Retina display size, but might appear
pixelated.

5 Select the options for Scaled high resolution.

Option Description

Unity Only Use high resolution scaling for Unity View only.

Unity and Full Screen Use high resolution scaling for Unity View and Full Screen modes.

Unity and Single Window Use high resolution scaling for Unity View and Single Window modes.

All View Modes Use high resolution scaling for all view modes.
 

6 (Optional) Select the Automatically adjust user interface size in the virtual machine check box.

Configure Resolution Settings for Virtual Machine Display
You can configure the resolution settings that determine how a virtual machine is displayed.

Prerequisites

n Verify that you are using a Retina display or another high-pixel density display.

n Verify that you are using hardware version 11 or later, preferably hardware version 12.

n Verify that the latest version of VMware Tools is installed.

n For best appearance and performance, select Best for Display in the Display pane of System
Preferences on the Mac host.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.
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3 Under System Settings in the Settings window, click Display.

You use the Virtual Machine Resolution options to select the display settings for single window mode
and full screen mode.

4 Select the Single Window resolution setting.

This setting specifies how the virtual machine displays in single window mode.

Option Description

Use Fusion Display Preferences Uses the global Fusion display preference setting. See “Set Fusion Display
Resolution Preferences,” on page 36.

Stretch the virtual machine in the
window

When the virtual machine window is resized, the virtual machine display
is stretched to fill the window with the resolution unchanged.

Resize the virtual machine and the
window

The virtual machine display is resized to fit the single window.

 
5 Select the Full Screen resolution setting.

This setting specifies how the virtual machine is displayed in full screen mode.

Option Description

Use Fusion Display Preferences Uses the global Fusion display preference setting. See “Set Fusion Display
Resolution Preferences,” on page 36.

Center the virtual machine in the
screen

When the virtual machine enters Full Screen view mode, the virtual
machine display is centered on the screen with the resolution unchanged.

Stretch the virtual machine in the
screen

When the virtual machine enters Full Screen view mode, the virtual
machine display is stretched to fill the screen space with the resolution
unchanged.

Resize the virtual machine to fit the
screen

The virtual machine display is resized to fit the full screen.

 

Enable Hot Keys for Virtual Machines
If you have Fusion Pro, you can create a keyboard shortcut to define a hot key combination to launch a
virtual machine.

n The hot key combination must contain at least one key modifier, such as Control or Command, plus
another modifier.

n A hot key combination must be unique to one virtual machine.

n The hot key cannot be a function or a specially defined key such as Return, Escape, Insert, Delete,
Home, End, Page Up, Page Down, F key, Print Screen, Scroll Lock, Pause, or the arrow keys.

n You cannot assign a hot key combination to an application.

n You cannot use the Tab key as a hot key.

Procedure

1 Select VMware Fusion > Preferences.

2 Select the Enable per-virtual machine keyboard shortcuts check box.

3 Select Window > Virtual Machine Library.

4 Select a virtual machine in the Virtual Machine Library window and click Settings.

5 Under System Settings in the Settings window, click Keyboard & Mouse.

6 Type the keyboard shortcut to use to trigger the virtual machine.
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Configure Discrete Graphics Management
With discrete graphics management, you can manage battery use and performance of applications that use
3D graphics in a virtual machine.

Prerequisites

n Verify that your MacBook Pro has an integrated graphics card and a discrete graphics card. Discrete
graphics management enables the operating system to switch between the two cards.

n Verify that 3D graphics are enabled.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click Display.

4 Verify that the Accelerate 3D Graphics check box is selected.

5 Select a graphics performance option from the Battery life drop-down menu.

Option Description

Don't Use High Performance
Graphics (Longer Battery Life)

Maximizes battery life.

Use High Performance Graphics for
3D Applications Only

Balances battery life and 3D graphics performance.

Always Use High Performance
Graphics (Shorter Battery Life)

Minimizes battery life.

 

Set the Default Printer for a Virtual Machine
When you use Fusion, all printers installed on your Mac are automatically added to your virtual machine.

Your virtual machine uses the default printer on the Mac as its default printer, unless you change it on the
Printer panel in Settings.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click Printer.

4 Select the Share Mac printers with Windows check box.

5 Select the default printer for this virtual machine.

Option Description

Match the default printer on the Mac Print jobs from this virtual machine go to the printer set as default on your
Mac.

Allow a different default printer Print jobs from this virtual machine go to the printer you set as default
using the virtual machine’s operating system preferences. For example,
you set the printer default by selecting Start > Printers and Faxes in a
Windows XP virtual machine.
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Add a Device
You can add removable devices to use with your virtual machine.

You can add the following devices to a virtual machine:

n network adapters

n hard disks

n camera

n CD/DVD

n sound card

n USB and Bluetooth

n serial ports

n parallel ports

Configuring the Network Connection
Configure and implement Fusion virtual networking components on your virtual machine to connect to
other virtual machines in your networking environment.

Fusion supports only Ethernet-based networking, but provides several options for connecting to networks.

n A virtual machine can use NAT to share the IP address of your host system.

n You can configure a virtual machine to bridge to a specific network interface on the host system. Fusion
supports IPv6 in bridged networking.

n You can create a VPN that includes only the virtual machines on your host system.

Note   Fusion Pro includes advanced networking features. With these advanced features, you can change
key networking settings, add and remove virtual networks, and create custom virtual networking
configurations. The changes that you make affect all virtual machines running on the host system. For
example, you can specify which subnet is used by Fusion or if a network adapter asks for confirmation
before running in promiscuous mode.

This feature is available in the Fusion Preferences dialog box. To add custom network configurations, you
must provide the administrator password.

In Fusion, when you edit settings for a virtual network adapter, you can choose from several types of
network connections.
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Table 9‑2.  Network Connection Options

Option Description

Share with my Mac If you want to connect to the Internet or other TCP/IP network using your Mac dial-
up networking connection and you are not able to give your virtual machine an IP
address on the external network, choosing this option is often the easiest way to
give the virtual machine access to that network. The virtual machine does not have
its own IP address on the external network. The virtual machine obtains a private IP
address from the VMware virtual DHCP server.

Bridged Networking items In the Bridged Networking list, you see various choices for bridging to one of the
network interfaces on your Mac, including wireless and Ethernet. Using one of
these options is often the easiest way to give your virtual machine access to a
network.
With one of these bridged networking options, the virtual machine appears as an
additional computer on the same physical Ethernet network as your Mac. The
virtual machine can use any of the services available on the network to which it is
bridged, including file servers, printers, gateways, and so on. Likewise, any physical
host or other virtual machine configured with bridged networking can use
resources of that virtual machine.

Private to my Mac When you use this type of network connection, the virtual machine is connected to
your Mac’s operating system on a virtual private network, which normally is not
visible outside your Mac. Multiple virtual machines configured with host-only
networking on the same Mac are on the same network.

n Connect and Set Up the Network Adapter on page 109
You can connect the virtual network adapter for the virtual machine and set the type of networking to
use.

n Assign a MAC Address to a Virtual Machine Manually on page 110
You can assign a MAC address manually if you need to ensure that the same MAC address is always
assigned to the virtual network adaptor for a virtual machine.

n Add a Network Adapter on page 111
You can add up to ten virtual network adapters to a virtual machine.

n Change the Network Adapter on a Remote Virtual Machine on page 111
You can enable and change the virtual network adapter for a virtual machine hosted on a remote
server. Your virtual machine will have access to multiple networks.

n Remove a Network Adapter on page 112
You can remove network adapters from your virtual machine.

Connect and Set Up the Network Adapter
You can connect the virtual network adapter for the virtual machine and set the type of networking to use.

Prerequisites

Fusion does not support bridged networking to a VPN. If you have set a VPN to have the top priority in
your Mac system preferences, lower its priority if you intend to use bridged networking with autodetect in
your virtual machine.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click Network Adapter.
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4 Select the Connect Network Adapter check box.

Fusion retains and reapplies the setting you select when you start up the virtual machine.

5 Select the networking type.

Option Description

Share with my Mac The virtual machine does not have its own IP address on the external
network. The virtual machine obtains a private IP address from the
VMware virtual DHCP server.

Bridged Networking items You see various choices for bridging to one of the network interfaces on
your Mac, including wireless and Ethernet. Using one of these options is
often the easiest way to give your virtual machine access to a network.
When you select any of the network types other than Autodetect, you can
click System Preferences to see details of the physical network settings for
your host system.

Private to my Mac The virtual machine is connected only to the host operating system, using
a virtual private network, which is not visible outside your Mac.

 
6 (Fusion Pro) Use Advanced options to make the selected virtual machine's network adapter prompt for

permission before running in promiscuous mode.

If the check box is not selected, the virtual machine does not prompt for confirmation before allowing
this network adapter to run in promiscuous mode. This feature is useful when creating nested ESXi
servers with Fusion Pro.

Assign a MAC Address to a Virtual Machine Manually
You can assign a MAC address manually if you need to ensure that the same MAC address is always
assigned to the virtual network adaptor for a virtual machine.

Assign a MAC address manually instead of allowing Fusion to assign it to be sure that the following
situations occur:

n The same MAC address is always assigned to the virtual network adaptor for a given virtual machine,
even if the virtual machine is moved.

n A unique MAC address for each virtual machine within a networked environment

When a physical machine is converted to a virtual machine, the MAC address of the network adapter is
changed. For software in which the licensing is linked to the MAC address, this can be a problem. Manually
assigning the correct MAC address is the solution.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click Network Adapter.

4 Click Advanced options.

5 Enter a new MAC address.

n Type a known MAC address.

n Click Generate for Fusion to create a unique address.
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Add a Network Adapter
You can add up to ten virtual network adapters to a virtual machine.

Prerequisites

n Familiarize yourself with the various types of network configurations. See “Configuring the Network
Connection,” on page 108.

n Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Click Network Adapter.

5 Click Add.

6 Either select a network configuration from the list or, if you have Fusion Pro, click Configure below the
list to create a new network.

What to do next

For more information about creating a custom network, see “Creating Custom Networks,” on page 38. For
more information about configuring a new network adapter, see “Connect and Set Up the Network
Adapter,” on page 109.

Change the Network Adapter on a Remote Virtual Machine
You can enable and change the virtual network adapter for a virtual machine hosted on a remote server.
Your virtual machine will have access to multiple networks.

Prerequisites

Verify that the following conditions are met:

n You have login credentials for the server where the virtual machine is hosted.

n The virtual machine is powered on.

Procedure

1 Select File > Connect to Server.

2 Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3 Enter your login credentials and click Connect.

4 Select Virtual Machine > Settings.

5 Click Network Adapter.

6 Select the network adapter from the Network Connection drop-down menu.
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Remove a Network Adapter
You can remove network adapters from your virtual machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click Network Adapter.

4 Under Advanced options, click Remove Network Adapter.

5 Click Remove in the confirmation dialog box.

Managing Virtual Hard Disks
You can add, remove, and resize virtual hard disks.

If you want to add more disk space to your virtual machine, you can resize your existing virtual hard disk,
or add a separate, additional hard disk.

Note   Having manual or AutoProtect snapshots in your virtual machine prevents you from making
changes to a virtual hard disk. You must delete the snapshots before you can make a change.

Create a Virtual Hard Disk
You might require more disk space in a virtual machine, for example, if you want to install a large
application or work with a large number of files. You can increase the size of the virtual disk already
associated with your virtual machine, or you can add a new virtual disk. You can create a virtual hard disk
to add to a virtual machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Click New Hard Disk.

5 Click Add.

A new hard disk appears. The new hard disk is selected and a default file name appears in the File
name pop-up menu.

6 (Optional) Change the file name for the new virtual hard disk.

a Select the file name in the pop-up menu and select Save As.

b Type the file name for the hard disk in the Save as field and click Save.
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Fusion creates the virtual disk file with this name and stores it in the bundle directory.

7 Use the Disk size slider to set the maximum size for the hard disk.

The maximum size for any hard disk is 8TB.

8 (Optional) Under Advanced options, set the Bus type for the hard disk to IDE, SCSI, or SATA.

Changing this setting is recommended only for advanced users. Fusion selects the bus type that is most
appropriate for the virtual machine guest operating system.

9 Set your disk space configuration, depending on the constraints of the file system.

Option Description

Pre-allocate disk space Can give better performance for your virtual machine. If you allocate all
the disk now, you cannot use the VMware Tools shrink disk feature later.
Allocating all disk space now is a time-consuming operation that cannot be
canceled, and requires as much physical disk space as you specify for the
virtual disk.

Split disk into multiple files Default. Some file systems, such as FAT and UFS, cannot support very
large files. Use this option if your virtual machine will be used in a hard
drive with a file system that does not support very large files. This option
splits your virtual disk into multiple files. Also, use this option if you
might place the virtual machine on an external FAT drive or if you might
move the virtual machine to an external drive.

 
10 Click Apply.

The hard disk is created. View the new hard disk in Settings > Removable Devices of the virtual
machine.

Resize a Hard Disk
You can increase the usable space in a virtual hard disk. You cannot reduce the size of a hard disk. You
cannot make a blank hard disk smaller after it has been formatted.

Prerequisites

Having manual or AutoProtect snapshots in your virtual machine prevents you from making changes to a
virtual hard disk. You must delete the snapshots before you can make a change.

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 In the Settings window, click the hard disk you want to resize.

4 Use the Disk size slider to set the new size.

The maximum disk size for any hard disk is 8TB.

5 (Optional) Under Advanced options, set the Bus type for the hard disk to IDE, SCSI, or SATA.

Changing this setting is recommended only for advanced users. Fusion selects the bus type that is most
appropriate for the virtual machine guest operating system.
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6 Set your disk space configuration, depending on the constraints of the file system.

Option Description

Pre-allocate disk space Can give better performance for your virtual machine. If you allocate all
the disk now, you cannot use the VMware Tools shrink disk feature later.
Allocating all disk space now is a time-consuming operation that cannot be
canceled, and requires as much physical disk space as you specify for the
virtual disk.

Split disk into multiple files Default. Some file systems, such as FAT and UFS, cannot support very
large files. Use this option if your virtual machine will be used in a hard
drive with a file system that does not support very large files. This option
splits your virtual disk into multiple files. Also, use this option if you
might place the virtual machine on an external FAT drive or if you might
move the virtual machine to an external drive.

 
7 Apply the changes and choose automatic or manual partition resize for Windows guests.

Option Description

Click Apply. For Windows guests, the partition is automatically resized when the hard
disk is resized.

Click Apply while pressing the
Option key.

The hard disk is resized but the partition is not. To manually resize the
partition of the guest, see “Resize a Windows Partition with the Disk
Management Tool,” on page 114.

 
Fusion displays a progress dialog box as it rebuilds the virtual disk.

Resize a Windows Partition with the Disk Management Tool
When you enlarge your virtual hard disk, you must also enlarge your guest operating system's partition to
take advantage of the additional space.

Fusion resizes the guest operating system's partition when you resize the virtual hard disk. If you held
down the Option key when you clicked Apply to resize the disk, you can manually resize the Windows
partition. For Windows Vista and Windows 7 or later, you can use the operating system's Disk Management
tool to resize a partition.

Prerequisites

Verify that your virtual hard disk is big enough to accept the increase in partition size. See “Resize a Hard
Disk,” on page 113.

Procedure

1 Right-click Computer and select Manage.

2 Double-click Storage.

3 Double-click Disk Management.

4 In the list, right-click the partition to expand and select Extend Volume.

5 Follow the prompts to resize the partition and click Finish.

The partition item in the Disk Management pane displays its new size.

6 Close the Computer Management window
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Clean Up a Virtual Machine
You can shrink and defragment certain virtual machines to free up space on your Mac.

When you delete files from your virtual machine, Fusion does not return the space to your Mac. Cleaning up
the virtual machine performs the following operations:

n Shrinks the virtual machine and returns freed space to your Mac.

Note   Only Windows virtual machines return freed space to your Mac.

n Defragments the virtual machine.

n Consolidates any unconsolidated snapshot files left on the virtual machine.

Unconsolidated snapshot files can be left on the virtual machine when manually deleting a snapshot
fails.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under System Settings in the Settings window, click General.

4 Click Clean Up Virtual Machine.

This option is only available when a Windows virtual machine has disk space to reclaim, or when any
virtual machine has unconsolidated snapshot files.

Fusion displays a progress dialog box as it cleans up the virtual machine.

Add an Existing Virtual Hard Disk
You can add an existing virtual hard disk to a virtual machine. You can copy or move the disk to your
virtual machine, or share it between virtual machines.

Caution   Moving the virtual hard disk can break other virtual machines that are using the virtual hard
disk, because this is the equivalent of removing the hard disk from one physical computer and installing it
in another.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Click Existing Hard Disk.

5 Click Add Device.

6 In the Open dialog, navigate to the location of the existing .vmdk hard disk file.
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7 Select the method for adding the virtual hard disk file.

Option Description

Make a separate copy of the virtual
disk

Default. Copies the virtual hard disk file to this virtual machine’s package.
Copying the virtual hard disk ensures that no conflicts exist between this
virtual machine and any other virtual machine that might be using the
virtual hard disk.

Share this virtual disk with the
virtual machine that created it

Virtual hard disk file remains in its original location. This might cause a
conflict if it is also being used by that original virtual machine.

Take this disk away from the virtual
machine currently using it

Moves the virtual hard disk file to this virtual machine’s package.

 
8 Click Open.

9 Click Apply.

Fusion displays a progress dialog box if you select to copy the virtual disk.

Add a VMDK on a Remote Virtual Machine
You can add a virtual hard disk and select a disk image on a virtual machine hosted on a remote server.

Prerequisites

Verify that the following conditions are met:

n You have login credentials for the server where the virtual machine is hosted.

n The virtual machine is powered off.

Procedure

1 Select File > Connect to Server.

2 Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3 Enter your login credentials and click Connect.

4 Select Virtual Machine > Settings.

5 Click Add Device.

6 Click Hard Disk.

7 Select a .vmdk file from the File name drop-down menu.

8 Use the disk size slider to specify the size of the virtual disk.

9 (Optional) Expand Advanced options and select a bus type and choose how to allocate the disk space.

Remove a Hard Disk
You can remove a virtual hard disk from your virtual machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 In the Settings window, click the hard disk to remove from the virtual machine.
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4 Under Advanced options, click Remove Hard Disk.

5 In the confirmation window, select the option for removing the hard disk.

Option Description

Keep File The virtual hard disk is disconnected from the virtual machine, but the
hard disk files remain in the virtual machine package.

Move to Trash The virtual hard disk files are deleted from the virtual machine package.
 

Using Virtual DiskManager
Virtual Disk Manager (vmware-vdiskmanager) is a Fusion utility that you can use to create, manage, and
modify virtual disk files from the command line or in scripts.

Virtual Disk Manager is included when Fusion is installed. With Virtual Disk Manager, you can enlarge a
virtual disk so that its maximum capacity is larger than it was when you created it. This feature is useful if
you need more disk space in a given virtual machine, but do not want to add another virtual disk or use
ghosting software to transfer the data on a virtual disk to a larger virtual disk.

You can also use Virtual Disk Manager to change how disk space is allocated for a virtual hard disk. You can
preallocate all the disk space in advance or configure the disk to grow as more disk space is needed. If you
allocate all the disk space but later need to reclaim some hard disk space on the host system, you can convert
the preallocated virtual disk into a growable disk. The new virtual disk is still large enough to contain all the
data in the original virtual hard disk. You can also change whether the virtual hard disk is stored in a single
file or split into 2GB files.

The Virtual Disk Manager file, vmware-vdiskmanager, is located in the Applications/VMware
Fusion.app/Contents/Library directory.

Configuring the CD/DVD Drive
You can connect the virtual machine's CD/DVD drive to the Mac physical CD/DVD drive or to a CD or DVD
ISO image.

n Add a CD/DVD Drive on page 118
You can add a virtual CD/DVD drive to a virtual machine.

n Remove a CD/DVD Drive on page 118
You can remove a physical or virtual CD/DVD drive from your virtual machine.

n Connect and Set Up a CD/DVD Drive on page 118
You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

n Connect and Disconnect the CD/DVD Drive Without Using the Settings Window on page 119
You can use the buttons on the status bar to connect and disconnect devices.

n Create a CD/DVD Image on page 119
You can use the Apple Disk Utility to create CD/DVD disk images.

n Enable a CD/DVD Drive on a Remote Virtual Machine on page 119
You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote
server. You can access or install software from a physical CD/DVD drive on to your remote virtual
machine.

Chapter 9 Configuring Your Virtual Machines

VMware, Inc.  117



Add a CD/DVD Drive
You can add a virtual CD/DVD drive to a virtual machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Click CD/DVD Drive.

5 Click Add.

6 Configure the drive.

Option Description

Automatically detect physical
CD/DVD

The virtual machine detects your Mac CD/DVD drive.

Specify physical CD/DVD Directs the virtual machine’s CD/DVD drive to a physical drive.

Use disk image Directs the virtual machine’s CD/DVD drive to an ISO image. Click the
pop-up menu to browse for and select the ISO image file.

 

Remove a CD/DVD Drive
You can remove a physical or virtual CD/DVD drive from your virtual machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click the CD/DVD drive to remove.

4 Under Advanced options, click Remove CD/DVD Drive.

Connect and Set Up a CD/DVD Drive
You can set up a CD/DVD drive so that it is always detected, or so that you must connect it manually.

You can disable the Automatically detect physical CD/DVD feature while the virtual machine is powered
on, but you must power off the virtual machine before you can enable this feature. Use the Shut Down
command in the Virtual Machine menu.

If your CD/DVD drive is a USB device, Fusion handles it as a USB device, not a CD/DVD drive. See 
“Configuring the USB Controller and Connecting USB Devices,” on page 123.

Procedure

1 Select Window > Virtual Machine Library.
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2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click the CD/DVD drive to connect.

4 Select the Connect CD/DVD Drive check box.

Connect and Disconnect the CD/DVD Drive Without Using the Settings Window
You can use the buttons on the status bar to connect and disconnect devices.

Procedure

u Click the CD/DVD device button in the status bar.

Create a CD/DVD Image
You can use the Apple Disk Utility to create CD/DVD disk images.

Procedure

1 Start the Mac Disk Utility by going to Applications/Utilities/Disk Utility on your Mac.

2 Insert the CD/DVD for which you need an image.

3 In the Disk Utility window, select the CD/DVD disk and click New Image.

4 In the Image Format pop-down menu, select DVD/CD Master

5 In the Encryption pop-down menu, select None.

6 Save the CD/DVD image to the chosen location.

What to do next

To attach the images to a virtual machine, see “Connect and Set Up a CD/DVD Drive,” on page 118.

Enable a CD/DVD Drive on a Remote Virtual Machine
You can enable a CD/DVD drive and select a disk image on a virtual machine hosted on a remote server. You
can access or install software from a physical CD/DVD drive on to your remote virtual machine.

Prerequisites

Verify that the following conditions are met:

n You have login credentials for the server where the virtual machine is hosted.

n The virtual machine is powered on.

Procedure

1 Select File > Connect to Server.

2 Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3 Enter your login credentials and click Connect.

4 Select Virtual Machine > Settings.

5 Click CD/DVD Drive.

6 Select the Enable CD/DVD Drive check box.

7 Select a remote disc image from the Choose a remote disc image drop-down menu.

8 (Optional) Expand Advanced options and select a bus type from the drop-down menu.

9 (Optional) Click Remove CD/DVD Drive to return to the CD/DVD drive that your virtual machine
uses.
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Configuring a Floppy Device
You can add a virtual floppy device to a virtual machine and configure the floppy device to connect to a
floppy image file.

You can also connect and disconnect the floppy device in Fusion. A virtual machine can have no more than
two floppy devices.

Add a Floppy Device
You can add a floppy device to your virtual machine to access data on a floppy disk image file.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

You must have a floppy image file with one of the following filename extensions:

n .flp

n .img

n .dsk

n .fdd

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Click Floppy Drive.

5 Click Add.

6 Browse to the floppy image file and select it.

7 Click Open.

What to do next

Configure the new floppy device, as described in “Connect and Set Up a Floppy Device,” on page 120.

Connect and Set Up a Floppy Device
You can configure how your virtual machine can use a floppy device to access data on a floppy disk image
file.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Select the floppy device in the source list in the Other Devices panel.

5 Select or deselect the Connected check box to connect or disconnect the floppy device.

6 (Optional) Select Read only to make the contents of the floppy device read-only.
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7 Select Use floppy image and click Choose to browse for the floppy image file to connect the floppy
device to a floppy image file.

If you are working with a virtual machine that is configured to use a physical floppy drive, or any type
of floppy device other than a floppy image file, the Use a custom unsupported setting option is
selected. Fusion supports only floppy image files for use with a virtual floppy device.

Create a Floppy Disk Image
To read data from a floppy disk to a virtual machine, you must create a disk image that the virtual machine
can recognize.

Some operating systems require you to use floppy disks to install them. Because the Mac does not include a
physical floppy drive, and because Fusion supports floppy images only, you must use a USB floppy drive to
create floppy images.

The Apple Disk Utility can create floppy disk images for this purpose.

Procedure

1 Attach a USB floppy drive to your Mac.

2 Start the Mac Disk Utility by going to Applications/Utilities/Disk Utility on your Mac.

3 Insert the floppy disk for which you need an image.

4 In the Disk Utility window, select the floppy disk and click New Image.

5 In the Image Format pop-up menu, select read/write.

6 In the Encryption pop-up menu, select None.

7 Save the floppy disk image to the chosen location.

8 In the Finder, right-click on the created floppy image and select Get Info.

9 In Name & Extension, change the file extension from .dmg to .flp and close the Get Info window.

Confirm the change when prompted.

10 (Optional) Repeat the process for each floppy disk to create.

What to do next

To attach the images to a virtual machine, see “Connect and Set Up a Floppy Device,” on page 120.

Enable a Floppy Drive on a Remote Virtual Machine
You can enable a floppy drive and select a disk image on a virtual machine hosted on a remote server. You
can access or install software from a physical floppy drive on to your remote virtual machine.

Prerequisites

Verify that the following conditions are met:

n You have login credentials for the server where the virtual machine is hosted.

n The virtual machine is powered on.

Procedure

1 Select File > Connect to Server.

2 Enter the name of the host server or select a server from the Recent Servers drop-down menu.

3 Enter your login credentials and click Connect.

4 Select Virtual Machine > Settings.

Chapter 9 Configuring Your Virtual Machines

VMware, Inc.  121



5 Click Floppy.

6 Click the Enable Floppy Drive check box.

7 Select a floppy image from the drop-down menu.

Configuring the Sound Card
A virtual machine can have only one sound card. You can add a sound card only if you remove the existing
sound card.

Connect the Sound Card
You can enable your virtual machine to use the Mac's sound device.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click Sound Card.

4 Select the Connect Sound Card check box.

5 Select the Output Device and Input Device

6 (Optional) Select the Enable Echo Cancellation check box if there is sound echo in your virtual
machine.

Connect and Disconnect a Sound Adapter Without Using the Settings Window
You can use the buttons on the status bar to connect and disconnect devices.

Procedure

u Click the sound device button in the status bar.

Add a Sound Adapter
You can add a sound adapter if one was previously removed.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Click Sound Card and click Add.

5 Select the output and input device to add.
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Remove a Sound Adapter
Before you can add a new sound adapter, you must remove the existing one.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click Sound Card.

4 Click Remove Sound Card.

5 Click Remove in the confirmation dialog box.

Add a Camera to a Virtual Machine
You can enable one or more cameras on a virtual machine.

Prerequisites

Verify that the following conditions are met:

n You have one or more cameras on the host system, either built-in or connected to a USB device.

n The virtual machine uses hardware version 11 or later.

n The virtual machine is local to your Mac, rather than hosted on a remote server.

Procedure

1 Select Virtual Machine > Settings.

2 Click Add Device.

3 Select Camera.

4 Click Add.

Ordinarily, the default camera of the host system is added to the virtual machine. You can select a
camera by name. If a named camera is chosen, the camera of your virtual machine is connected
explicitly to that camera. In that case, the camera might not connect if you move the virtual machine to
another host, or if you remove the named camera from the host system.

Configuring the USB Controller and Connecting USB Devices
You can configure the virtual USB controller to enable USB 3.0 and 2.0 support. You can also configure the
virtual USB controller to connect USB devices to the virtual machine when such devices are connected to the
Mac while the virtual machine is active. The settings you select can persist across several VMware products,
such as Workstation Pro and VMware Horizon 6.

If you have a Mac that supports connecting USB 3.0 devices, guest operating systems can connect to USB 3.0
devices as USB 3.0 and connect to USB 2.0 devices as USB 2.0. However, guests with virtual USB 2.0
hardware will have issues when connecting to USB 3.0 devices. An example of a guest operating system that
does not have virtual USB 3.0 hardware is Windows XP. Depending on the specific device, performance
might be slow or partial, or the device might fail to connect.

Chapter 9 Configuring Your Virtual Machines

VMware, Inc.  123



Guests on older Macs can have virtual USB 3.0 virtual hardware, but both USB 2.0 and USB 3.0 devices will
connect in USB 2.0 mode. Guests with virtual USB 2.0 hardware will also use USB 2.0 mode for USB 2.0 and
USB 3.0 devices.

Note   Fusion does not support USB adapters for connecting displays to your virtual machines.

Add the USB Controller
You can add a virtual USB controller to allow your virtual machine to work with the USB devices that are
connected to your Mac.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click USB & Bluetooth.

4 Under Advanced USB options, use the drop-down menu to select how Fusion should respond when a
USB device is plugged in to your Mac.

Note   Support for USB 3.0 SuperSpeed devices requires a suitably equipped Mac and a guest
operating system that supports USB 3.0 devices.

Remove the USB Controller
You can remove a USB controller from your virtual machine.

When you remove the USB controller, you cannot connect a USB device to the virtual machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click USB & Bluetooth.

4 Under Advanced USB options, click Remove USB Controller.

5 Click Remove in the confirmation dialog box.

Choose Where to Connect a USB Device When You Plug It In
When a virtual machine is running, you can select whether a USB device connects to your Mac or to your
virtual machine when you plug the device in.

With Fusion, you can select what system a USB device connects to when you plug it in. You can also set that
choice as the default connection whenever you attach that device in the future.

Prerequisites

Fusion must be open, with a virtual machine powered on.
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Procedure

1 Plug the USB device into your Mac.

The selection dialog box appears. If no dialog box appears, you already set a default connection for this
device in the USB settings panel.

2 (Optional) To make your connection selection the default for this device in the future, select Remember
my choice and do not ask again.

You can change this default at any time in the USB & Bluetooth settings panel.

3 Select the system to which you want to connect the device.

The action you take depends on how many virtual machines are open.

Option Description

If you have one virtual machine
powered on

Select Connect to Mac or Connect to OS of your open virtual machine.

If you have two or more virtual
machines powered on

In the pop-up menu, select Connect to your Mac or Connect to virtual
machine name for the selected virtual machine. Click OK.

 

Set the Default Plug-In Action for a USB Device
You can set whether a USB device connects to your Mac or to your virtual machine whenever you attach the
device.

This setting can be different for each virtual machine. If you set the default plug-in action for a virtual
machine, but the virtual machine is not powered on when you attach the device, the device attaches to the
Mac.

Prerequisites

Fusion must be open, with a virtual machine powered on.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click USB & Bluetooth.

4 Select the USB device in the list.

5 Under Advanced USB options, select the plug-in behavior for the device.

Option Description

Ask what to do Fusion asks if you want to attach the device to the Mac or the virtual
machine.

Connect to this virtual machine Only the virtual machine recognizes the device. The Mac does not
recognize the device.

Connect to your Mac Only the Mac recognizes the device. The virtual machine does not
recognize the device.
This option is the default behavior. VMware recommends that printers
connect to the host, not to the guest.

 

Connect and Disconnect USB Devices
You can connect USB devices to your virtual machines through your Mac.

Connecting a USB device to the virtual machine makes the USB device unavailable to your Mac.
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If your CD/DVD drive is a USB device, Fusion handles it as a USB device, not a CD/DVD drive.

Prerequisites

If you disconnect a USB device and reconnect it right away, it will reconnect to the virtual machine that it
was previously connected to. To change the connection, reconnect to a different USB port on your Mac.

Procedure

1 Select Window > Virtual Machine Library.

2 Under Removable Devices in the Settings window, click USB & Bluetooth.

3 In the Connect USB devices section, select or deselect the check box next to the USB device to connect or
disconnect that device.

Connect and Disconnect a USB Device Using the Virtual Machine Toolbar
You can use the buttons on the status bar to connect and disconnect devices.

Procedure

1 Click the device button in the status bar.

2 Click Connect name of device.

Connect a USB Smart Card Reader
You connect a USB smart card reader with a process different from the process used for other USB devices.

When you attach a smart card reader to your computer, the reader appears as two separate USB devices in
the Fusion interface. You can use smart cards in virtual mode or USB passthrough mode. These mode are
mutually exclusive. You must pick one or the other.

n Virtual mode (Recommended): The smart card reader device is available as Virtual model name of your
smart card reader USB Smart Card Reader. After the virtual reader is connected to the virtual machine, it
appears as Virtual the model name of your smart card reader USB Smart Card Reader under the device
list in the guest operating system. In virtual mode, the smart card reader can be shared among
applications on the host and among applications within different guests on the host.

n USB passthrough mode: The smart card reader device is available as model name of your smart card reader
USB Smart Card Reader. When you connect the reader to the guest, it appears as model name of the
smart card reader USB Smart Card Reader under the device list in the guest operating system. In USB
passthrough mode, a single virtual machine directly controls the physical smart card reader. A USB
passthrough smart card reader cannot be used by applications on the host or by applications within
other virtual machines. Use USB passthrough mode only if connection in virtual mode does not work
well for your computing environment.

Note   Disconnect your current mode before you switch to a different mode.

Procedure

n For virtual mode, select Virtual Machine > USB & Bluetooth > Connect the model name of your smart
card reader USB Smart Card Reader.

When you select the virtual mode device, the passthrough mode the model name of your smart card
reader Smart Card Reader device no longer appears, except in Linux virtual machines.

n For USB passthrough mode, select Virtual Machine > USB & Bluetooth > Connect the model name of
your smart card reader USB Smart Card Reader.

n To disconnect either mode, select Virtual Machine > USB & Bluetooth and the device to disconnect,
and click Disconnect.
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USB Connection Dialog Box Disappears Before Connection Can Be Made
In rare cases, a USB device disconnects itself before Fusion can recognize it.

Problem

When you plug in a USB device, the Fusion EasyConnect dialog box appears, but disappears before you
have an opportunity to take an action. The USB device is then not visible to either your Mac or your virtual
machine.

Cause

Some USB devices disconnect very quickly if they do not receive an immediate response upon connection.
Occasionally, Fusion USB EasyConnect does not produce a response in the time required by these USB
devices.

To work around this problem, you must configure the virtual machine so that Fusion connects unknown
devices without first having to ask about the type of connection.

Solution

1 Shut down or power off the virtual machine.

2 Select Window > Virtual Machine Library.

3 Select a virtual machine in the Virtual Machine Library window and click Settings.

4 Under Removable Devices in the Settings window, click USB & Bluetooth.

5 Under Advanced USB options, if the first option is set to Ask what to do, change the setting to Connect
to this virtual machine or Connect to your Mac.

6 Start up the virtual machine.

Plugging in a USB device results in it being connected to the virtual machine or Mac, depending on
your setting, without going through the USB EasyConnect dialog. The device is also visible to the
Fusion interface, so you can see it in Settings > USB & Bluetooth.

Add a Parallel Port
You can add a parallel port to your virtual machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Click Parallel Port.

5 Click Add.

6 Browse to the location to save the output file of the virtual parallel port.

7 Type a name for the file in the Save As field.

8 Click Save.
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Add a Serial Port
You can add a serial port to your virtual machine.

Prerequisites

Shut down or power off the virtual machine. You cannot change the setting while the virtual machine is
powered on or suspended.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Click Add Device.

4 Click Serial Port.

5 Click Add.

6 Browse to the location to save the output file of the virtual serial port.

7 Type a name for the file in the Save As field.

8 Click Save.

Sharing Bluetooth Devices with a Virtual Machine
You can attach a Bluetooth device to a virtual machine

Fusion supports these types of Bluetooth devices:

n Cell phones

n GPS receivers

n Serial Port Profile (SPP) devices

n Most other devices

Fusion has limited support for these types of Bluetooth devices:

n Input devices (HID): Can be attached to guests when using Linux/Mac OS hosts, but not on Windows
hosts.

OBEX File Transfer: Outgoing (guest to device) transfers only. Guest may not act as an OBEX server.

Fusion does not support these types of Bluetooth devices:

n Headphones

n Headsets

n Hands-free audio devices

Fusion has the following limitations for Bluetooth support:

n Only out going connections are allowed. A virtual machine may establish a connection to a remote
Bluetooth device, but remote devices do not see services that virtual machines try to advertise.

n Virtual machines cannot change the name, class, or discoverability of the host's Bluetooth adapter. The
host is exclusively in control over setting whether other Bluetooth devices can discover the host, and
what name is used.
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n The host is exclusively in control of the pairing process and collecting or displaying PIN numbers. The
guest may scan for devices, and initiate a connection with any device. If pairing is required, the pairing
dialog box appears on the host, not in the guest. From the guest's perspective, the device appears to pair
without having needed a PIN.

n Any vendor-specific capabilities on the host's Bluetooth radio are not passed through to the guest. For
example, some radios provide a vendor-specific command to change their BDADDR. These commands
do not appear in the guest. The guest sees a generic VMware-brand radio.

n The virtual Bluetooth controller itself is not part of snapshots. During snapshots, it is disconnected and
reconnected. Any ongoing connections with Bluetooth devices are terminated at the time of a snapshot.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Removable Devices in the Settings window, click USB & Bluetooth.

4 Select the Share Bluetooth devices with the virtual machine check box.

The virtual Bluetooth radio appears in the guest. You might see notifications from the guest OS that
new hardware was detected. No action is required because the driver is automatically installed.

5 Use the guest's Bluetooth interface to search for nearby devices to pair with. Devices appear in the list
as they are detected.

6 Select the device you want to connect with and select to connect to it.

7 Pair the device with the host.

If you have not paired this device with this host before, you are prompted to do so now. The host may
ask you for a PIN, or may display a PIN to be entered on the device.

After the device pairs, the device is now available in the guest.

Select a Startup Device
You can select the device to use to start up your virtual machine.

This function is not available for a Mac OS X Server virtual machine.

Prerequisites

Verify that the virtual machine is running. The change does not take effect if the virtual machine is not
running.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Startup Disk.

4 Click the startup device to use.

5 Click Restart.

You can also hold down the Option key and click Restart to firmware to restart the virtual machine in
firmware setup mode.

The guest operating system restarts and boots from the selected device.
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Encrypting and Restricting a Virtual Machine
Encrypt and restrict your virtual machine to control the use of the virtual machine and access to its contents.

When you encrypt a virtual machine, you set a password that is required to open the virtual machine. You
can remove the encryption or change the password at any time.

Note   Large virtual machines, such as those that exceed 50GB, might generate a low disk space warning.

If you have Fusion Pro, you can also turn on restrictions, so that users are prevented from modifying the
virtual machine. When you enable restrictions, users are prevented from removing virtual devices, changing
the memory allocation, modifying removable devices, and changing the virtual hardware compatibility.

You can optionally force users to change the encryption password if they move or copy the virtual machine.
For example, a teacher might provide a copy of the virtual machine to all students in the class and set this
restriction so that all students must create their own encryption password.

You can also cause the virtual machine to expire at a pre-set date and time. When the virtual machine
expires, the user is denied access to the virtual machine. You can extend an expired virtual machine by
removing the restriction or setting another date and time.

When you turn on restrictions, you set a restrictions password. After restrictions are turned on, you cannot
make changes to the virtual machine configuration settings or restrictions policies unless you first turn
restrictions off. To turn off restrictions, you must enter the restrictions password.

The restrictions feature is available only if you have Fusion Pro.

Encrypt and Restrict a Virtual Machine
You can encrypt your virtual machine with a password to control access to the virtual machine and its
contents. If you have Fusion Pro, you can also enable restrictions for the virtual machine to prevent users
from changing certain virtual machine settings and to set an expiration date and time for the virtual
machine.

When you enable restrictions for a virtual machine, you can set an expiration date and time for the virtual
machine.

Use these guidelines when configuring encryption and restrictions:

n If you have a Fusion license, you can enable and disable encryption only if the virtual machine does not
already have restrictions enabled.

n If restrictions are already enabled for a virtual machine, you can change encryption and restrictions
settings only if you have a Fusion Pro license. If you have a Fusion license, encryption and restrictions
settings are read-only. You can change only the encryption password.

n Restrictions policies are enforced only on virtual machines that are compatible with Fusion 5 and later.

Prerequisites

n Suspend or shut down the virtual machine.

n If you plan to turn on restrictions for the virtual machine, verify that you have a Fusion Pro license.

Note   These instructions do not apply to Horizon FLEX virtual machines. To create a Horizon FLEX virtual
machine, you must use Fusion Pro with a Horizon FLEX license. For information about encrypting and
enabling restrictions for Horizon FLEX virtual machines, see the VMware Horizon FLEX Administration Guide.

Procedure

1 Select Window > Virtual Machine Library.
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2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Encryption & Restrictions.

4 Select Enable Encryption and set the encryption password.

The password must be six characters or longer.

Important   Make a record of the encryption password. If you forget the encryption password, Fusion
does not provide a way to retrieve it.

5 (Optional) Select Remember Password to store the encryption password in the Keychain password
management system on your Mac.

6 Click OK.

7 (Optional) (Fusion Pro only) To enable restrictions for the virtual machine, perform these steps.

a Select Enable Restrictions and set the restrictions password.

Important   Make a record of the restrictions password. If you forget the restrictions password,
Fusion does not provide a way to retrieve it.

b Click Configure.

c On the Restrictions tab, select the appropriate restriction options.

Option Description

Require the user to change the
encryption password

Requires the user to change the encryption password for the virtual
machine if the virtual machine is moved or copied.

Allow USB devices to be
connected to this virtual machine

USB device connections are allowed.

 
d On the Expiration tab, set the appropriate expiration options.

Option Description

Restrictions Management Server Specify any server that supports the HTTPS protocol to use as a trusted
time source for the virtual machine.

Server contact frequency Set the frequency with which the virtual machine will contact the
server for a time check.

Maximum time the virtual machine
can be used without server
contact

Select how many days the virtual machine can be used without having
to contact the time server.

Expire the virtual machine after Set the date and time on which the virtual machine will expire. After
the virtual machine expires, you can delete or extend the expiration
date.

 
e On the Messages tab, specify custom messages to show when the virtual machine has expired or is

about to expire.

f On the Certificates tab, add certificates the virtual machine will trust when contacting the time
server.

g Click Save.

h Click the Lock icon to lock restrictions on the virtual machine.

After a virtual machine is locked, users must provide the restrictions password to edit the current
restrictions.
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The virtual machine is encrypted. Users must provide the encryption password to open, start, and resume
the virtual machine.

If you enabled restrictions for the virtual machine, many virtual machine configuration settings are hidden
from the user of the virtual machine. To change these hidden virtual machine settings, users must have
Fusion Pro and provide the restrictions password.

If you set an expiration date for the virtual machine, the virtual machine verifies the time and compares it to
the expiration date when it is powered on. While running, the virtual machine periodically checks the time
and stores all successful time stamps as the last trusted timestamp. If the last trusted timestamp exceeds the
date set for the virtual machine expiration, the user receives a warning message and the virtual machine is
suspended.

Change the Password for an Encrypted Virtual Machine
You can change the password for an encrypted virtual machine at any time.

Prerequisites

n Suspend or power off the virtual machine.

n Verify that you have the password for the encrypted virtual machine.

You must use Fusion Pro with a Horizon FLEX license to change the encryption password for a
Horizon FLEX virtual machine.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Encryption & Restrictions.

4 Click Change Password.

5 Type the old password for the virtual machine.

6 Type the password to use to encrypt the virtual machine.

Remember this password. You cannot access the virtual machine without it.

7 Type the password again.

8 (Optional) Select Remember Password to store the password in the Keychain password management
system on your Mac.

9 Click OK.

The encryption password for the virtual machine is changed.

Remove Encryption From a Virtual Machine
You can remove encryption from a virtual machine at any time.

Prerequisites

n Suspend or power off the virtual machine.

n Verify that you have the password for the encrypted virtual machine.

You must use Fusion Pro with a Horizon FLEX license to remove encryption from a Horizon FLEX virtual
machine.
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Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Encryption & Restrictions.

4 (Optional) Deselect the Enable Restrictions check box, if it is selected.

You cannot remove encryption from a virtual machine while restrictions are enabled.

5 Deselect the Enable Encryption check box.

6 Type the password for the virtual machine.

7 Click OK.

Encryption is removed from the virtual machine. You no longer not need a password to access the virtual
machine and its contents.

Store the Password for an Encrypted Virtual Machine in Keychain
You can store the password for an encrypted virtual machine in your Mac's Keychain password
management system at any time. Mac Keychain remembers the password for you.

Prerequisites

n Suspend or power off the virtual machine.

n Verify that you have the password for the encrypted virtual machine.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Select the Remember Password check box.

4 Type the password for the virtual machine.

5 Click OK.

The password for the encrypted virtual machine is stored in Keychain.

Virtual Machine Compatibility
The compatibility of a virtual machine with different versions of Fusion and other VMware products is
based on its hardware version. The hardware version of a virtual machine is established by the version of
Fusion that was used to create the virtual machine.

Consider upgrading the hardware version of your virtual machine if you upgrade Fusion or if you want to
use the virtual machine in other VMware products.

You must power off a virtual machine before you change its hardware version.
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Change the Hardware Compatibility of a Virtual Machine
The latest virtual machine hardware version available yields the best performance and most reliable
behavior from the applications running in your virtual machine.

Virtual machines with hardware version 10 or later are created with SATA hard disks or CD drives.
Upgrading your virtual machine from hardware version 9 or earlier does not change any devices in your
virtual machine to SATA. If you want to use SATA disks or drives with your virtual machine, you must
manually change the disk and drive types.

Prerequisites

n Evaluate the applications running in your virtual machine to determine which hardware version to
select. Some applications might have specific hardware requirements offered through a virtual machine
hardware version older than the latest available version.

n Consider taking a snapshot of the virtual machine. If changing the hardware version of your virtual
machine results in undesirable behavior, you can revert to the snapshot taken before the hardware
version upgrade.

n Shut down or power off your virtual machine before you change its hardware version.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Compatibility.

4 Under Advanced options, select a hardware version from the Use Hardware Version drop-down menu.

When you select a hardware compatibility setting, a list of the VMware products that are compatible
with that setting appears. For example, if you select hardware version 10, a list of VMware products that
this version supports appears. Limitations for the selected hardware version also appear.

Some hardware options might not be available for selection, for example, older hardware versions that
your current version of Fusion does not support.

5 (Optional) Click Revert to return to the hardware version that your virtual machine uses. When you
revert your hardware version, you can view the compatibility and limits of your current hardware
version.

6 Click Apply to change the virtual machine hardware version.

7 Click Close.

The hardware version of the virtual machine is changed.

What to do next

Power on the virtual machine.

Choose the Hardware Version for a Virtual Machine
Upgrading the hardware version of your virtual machine improves performance by increasing the memory
limit, the number of processors utilized, and the amount of disk space available to the virtual machine.

Prerequisites

Verify that you have the latest version of VMware tools installed.
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Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Compatibility.

4 Under Advanced options, select a hardware version from the Use Hardware Version drop-down menu.

Hardware version 12 enables higher performance of the virtual machine, including improved
accelerated 3D graphics rendering.

Configuring Guest Isolation Options for a Virtual Machine
With the isolation option, you can restrict file operations between the virtual machine and the host system,
and between the virtual machine and other virtual machines.

To configure guest isolation options for a selected virtual machine, select Virtual Machine > Settings and
select Isolation.

The following restrictions apply:

n VMware Tools must be installed in the guest operating system to use guest isolation features.

n You cannot configure these options for a remote virtual machine.

n If the virtual machine is running Mac OS as the guest operating system, you can copy and paste text
between the guest operating system and the host, but copying files is not supported.

Note   The drag and drop and copy and paste operations are enabled by default. You might want to disable
these operations to prevent files from being accidentally transferred between the virtual machine and the
host system.

Table 9‑3.  Isolation Options

Option Description

Enable drag and drop When this check box is deselected, the following options are restricted.
n Drag and drop files from the host system to a Linux or Windows guest

operating system.
n Drag and drop files from the guest operating system to the host system.
n Drag files from a file manager to an application that supports drag and

drop, or from applications such as zip file managers that support drag-
and-drop extraction of individual files.

To enable these operations, select the check box.

Enable copy and paste When this check box is deselected, the following operations are restricted.
n Copy and paste text and files from the host system to a Linux or

Windows guest operating system.
n Copy and paste from the guest operating system to the host system.
n Copy and paste text and files from one virtual machine to another.
To enable these operations, select the check box.
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Managing Advanced Settings
You can monitor the power supply status, enable VNC access, or make changes to other advanced functions
for your virtual machine.

Configure Time Synchronization Between Guest and Host Operating Systems
You can configure whether the clock on the guest operating system is synchronized with the clock on the
host.

If you turn on this advanced setting for time synchronization, the VMware Tools service, which runs inside
the guest operating system, checks once every minute to determine whether the clocks on the guest and host
operating systems still match. If not, the clock on the guest operating system is synchronized to match the
clock on the host.

For more information about how VMware Tools time synchronization works and for instructions to turn it
off completely, see the document called Installing and Configuring VMware Tools at 
http://www.vmware.com/pdf/vmware-tools-installation-configuration.pdf.

Prerequisites

Disable other periodic time synchronization mechanisms. Most guests have clock synchronization turned on
by default.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Advanced.

4 Select the Synchronize time check box.

Show the Mac Power Supply Status in the Virtual Machine
You can set the virtual machine to display the status of your Mac power supply.

When this feature is enabled, information about the Mac power status is passed to the virtual machine. The
virtual machine can display the remaining charge on a battery and suspend or hibernate when the battery
charge runs low. This feature is not supported in Mac OS virtual machines.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Advanced.

4 Select the Pass power status to VM check box.

Change the Preferred Virtualization Engine
You can set a virtualization engine that is different than the default.

By default, Fusion selects the virtualization engine best suited to your virtual machine's operating system
and your Mac's processor. You can override the automatic setting and select a specific virtualization engine.
If you are not familiar with the options, keep the default setting.

Procedure

1 Select Window > Virtual Machine Library.
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2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Advanced.

4 Select an option from the Preferred virtualization engine menu.

Option Description

Automatic The Fusion default setting.

Auto Replay Option unsupported in Fusion. A virtual machine created in
Workstation Pro might have this set as a value.

Binary Translation A virtualization technique for the x86 architecture in which the instruction
stream is inspected and machine instructions that are not virtualizable are
replaced with safe code.

Intel VT-x The Intel implementation of hardware-assisted virtualization, a technique
in which the CPU allows software to specify instructions that are not
virtualizable to cause traps, making them virtualizable. All Intel Macs have
this feature.

Intel VTx with EPT EPT (Extended Page Tables) is an improvement to hardware-assisted
virtualization technology that provides virtual MMU (Memory
Management Unit) support.

Custom Indicates an option unsupported in Fusion.
 

Troubleshooting Your Virtual Machine
You can decide what level of troubleshooting information to collect for your virtual machines.

The level of troubleshooting information collected can effect the performance of your virtual machine.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Advanced.

4 Select an option from the Troubleshooting menu.

Option Description

Default Fusion determines the best setting for your virtual machine.

None Fusion gathers no troubleshooting information from your virtual machine.
This setting enables your virtual machine to run as fast as possible.

Hang/Crash Fusion gathers correctness information about hangs or crashes in the
virtual machine.

Performance Fusion gathers performance information, such as when an operation is
taking too long in the virtual machine.

 

What to do next

From the VMware Fusion menu bar, select Help > Collect Support Information to collect troubleshooting
information that Fusion has gathered about a selected virtual machine. Fusion creates a .zip file on your
desktop to contain troubleshooting data.
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Change Hard Disk Buffering
Fusion automatically sets hard disk buffering according to what guest operating system you use, but you
can change the setting.

Hard disk buffering can increase performance of your virtual machine. Hard disk buffering can also
consume more memory on your Mac host than operating unbuffered. Fusion enables or disables hard disk
buffering based on your virtual machine's operating system.

For all Windows Vista and later guest operating systems, Fusion defaults to unbuffered I/O for Mac hosts.
The same is true for all Windows 2000, 2003, XP, and XP 64-bit guests newly created with this version of
Fusion. All other guests default to buffered I/O on Mac hosts.

If you are not familiar with the options, keep the default setting.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Advanced.

4 Select an option from the Hard disk buffering menu.

Option Description

Automatic Fusion determines your operating system and enables or disables hard
disk buffering depending on which type of buffering provides the best
performance.

Enabled The virtual machine's operating system uses buffered I/O.

Disabled The virtual machine's operating system uses unbuffered I/O.
 

Set Password Requirement for Opening a Boot Camp Virtual Machine
If you have a virtual machine that powers on the Boot Camp partition, you can set whether a password is
required each time you open it.

Prerequisites

You must have a Boot Camp partition on your Mac, and you must have created a virtual machine to power
it on.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Advanced.

4 Select the password requirement by setting Administrative privileges for Boot Camp disks.

Option Description

Never ask When you open a Boot Camp virtual machine in Fusion, you do not need
to enter a password.

Always ask Each time you open a Boot Camp virtual machine, you must enter the
password of the administrator account on the Mac.
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Enable a VNC Client to Access the Virtual Machine Remotely
You can configure a virtual machine to allow any virtual network computer (VNC) client to access the
virtual machine by connecting to your Mac.

VNC software enables you to view and interact with one computer from any other computer or mobile
device anywhere on the Internet. VNC software is cross-platform, enabling remote control between different
types of computers.

Table 9-4 describes the ways in which you can set up VNC.

Table 9‑4.  Options for VNC

Option Description

Remote Desktop, Screen Sharing, or Third-party VNC
server on the Mac host

n Enables control of the entire host Mac, including
Fusion and any other applications.

n The connection to the server is made by using the
host's IP address or hostname.

VNC server provided by Fusion n Available for each virtual machine.
n Must use unique ports that are not already in use on

the host Mac.
n Enables control of the virtual machine whenever it is

powered on, even before the guest operating system is
running.

n The connection to the server is made by using the
host's IP address or hostname.

VNC server inside the virtual machine's guest operating
system

n The VNC server is installed in the same way as any
other application inside the virtual machine.

n Enables control of only the guest operating system and
is available only after the guest operating system starts
up.

n When using bridged networking, the connection to the
server is made by using the guest's IP address or
hostname.

This procedure describes how to use the VNC server provided by Fusion to enable a VNC Client to access
the virtual machine remotely.

Procedure

1 Select Window > Virtual Machine Library.

2 Select a virtual machine in the Virtual Machine Library window and click Settings.

3 Under Other in the Settings window, click Advanced.

4 Select the Remote display over VNC check box.

5 (Optional) Type a password.

Because data sent over VNC is unencrypted, do not use your regular password.

6 Identify the port on the Mac.

The default port is 5900. If you enabled screen sharing on the Mac, port 5900 might already be in use
and you must use another port, such as 5901. For multiple virtual machines, increment the port number
for each additional virtual machine.

Your virtual machine is now visible to VNC clients.
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Upgrading Fusion 10
You can upgrade to a new version of Fusion in several ways.

Use these procedures to upgrade Fusion.

This chapter includes the following topics:

n “Upgrade Fusion with Autoupdate,” on page 141

n “Upgrade Fusion From a Download,” on page 142

n “Upgrade Fusion to a Fully Licensed Version After the Evaluation Period,” on page 142

n “Upgrading VMware Tools,” on page 143

n “Uninstalling Fusion,” on page 143

n “Force Virtual Machine Processes to Quit,” on page 144

Upgrade Fusion with Autoupdate
Fusion has a built-in software updater that checks for updates to Fusion and VMware Tools and downloads
and installs the updates.

When the Automatically check for updates check box is selected in VMware Fusion > Preferences, Fusion
checks for updates each time it starts. If Fusion detects a new version, it displays the Software Update
window. The Software Update window has the following options.

Skip This Version Select this option if you do not want to upgrade to the version described.
Fusion ignores this version in any later Autoupdate checks. If you change
your mind later, you can select VMware Fusion > Check for Updates to have
Fusion display the Software Update window again.

Remind Me Later Fusion closes the Software Update window. The next time Fusion starts, the
Software Update window appears.

Download and Install Fusion downloads the update files to your Mac and installs the updates.

Prerequisites

Verify that the Automatically check for updates check box is selected in VMware Fusion > Preferences.

Although Fusion can shut down your running virtual machines as part of this procedure, VMware
recommends that you manually shut down or suspend your virtual machines before you begin.

Procedure

1 In the Software Update window, click Download and Install.

Fusion downloads the update files to your Mac.

VMware, Inc.  141



2 At the Ready to install update prompt, shut down any running virtual machines and click Install and
Restart.

Fusion downloads the update files to your Mac, displays a progress bar during the installation, and
restarts when the installation is complete.

Upgrade Fusion From a Download
If you have an earlier version of Fusion, you can upgrade to the current version by manually downloading
the Fusion disk image from the VMware Web site.

If you are upgrading Fusion, VMware recommends that you first remove the version of Fusion installed on
your Mac. The process of installing, upgrading, and uninstalling Fusion does not modify existing virtual
machines.

Prerequisites

Verify that all of your virtual machines are shut down and that Fusion is not running.

Procedure

1 Drag the previous version of Fusion to the trash.

Fusion is in the Applications folder on your Mac.

2 Download Fusion from the VMware Web site at http://www.vmware.com/mac/.

a Click the Download link and follow the subsequent links for an Electronic Download Distribution.

b Click the download link and save the application to your Mac.

The Fusion disk image is saved to your default download directory. The filename is VMware-Fusion-
x.x.x-xxxxxx.dmg, where x.x.x is the application version and xxxxxx is the build number for the
download release.

3 Double-click the VMware-Fusion-x.x.x-xxxxxx.dmg file to mount it.

4 Double-click the VMware Fusion icon to copy Fusion to your Mac and start it.

Upgrade Fusion to a Fully Licensed Version After the Evaluation
Period

To continue using Fusion after using a free evaluation version or after an existing license has expired, you
must purchase a license on the VMware Web site.

Procedure

1 Select VMware Fusion > Buy Now or Enter License.

2 License your Fusion installation.

Option Action

You have a license key Type the license key.

You do not have a license key a Click Buy.
b On the VMware Fusion page on the VMware Web site, select the

version of Fusion to buy and click the corresponding button.
c Follow the instructions to process your order.
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Upgrading VMware Tools
You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install
newer versions of VMware Tools.

The guest operating system checks the version of VMware Tools when you power on a virtual machine. The
status bar of your virtual machine displays a message when a new version is available.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this
notification option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon
when a VMware Tools upgrade is available.

To install a VMware Tools upgrade, you can use the same procedure that you used for installing VMware
Tools the first time. Upgrading VMware Tools means installing a new version.

For Windows and Linux guest operating systems, you can configure the virtual machine to automatically
upgrade VMware Tools. Although the version check is performed when you power on the virtual machine,
on Windows guest operating systems, the automatic upgrade occurs when you power off or restart the
virtual machine. The status bar displays the message Installing VMware Tools ... when an upgrade is in
progress.

Important   After you upgrade VMware Tools on Linux guest operating systems, new network modules
are available but are not used until you either restart the guest operating system or stop networking, unload
and reload the VMware networking kernel modules, and restart networking. This behavior means that even
if VMware Tools is set to automatically upgrade, you must restart or reload network modules to make new
features available.

This strategy avoids network interruptions and allows you to install VMware Tools over SSH.

Upgrading VMware Tools on Windows guest operation systems automatically installs the WDDM graphics
drivers. The WDDM graphics driver makes the sleep mode available in guest OS power settings to adjust
the sleep options. For example, you can use the sleep mode setting Change when the computer sleeps to
configure your guest OS to automatically go to sleep mode after a certain time or prevent your guest OS
from automatically switching to sleep mode after being idle for some time.

Some features in a particular release of a VMware product might depend on installing or upgrading to the
version of VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not
always necessary. Newer versions of VMware Tools are compatible with several host versions. To avoid
unnecessary upgrades, evaluate whether the added features and capabilities are necessary for your
environment.

Uninstalling Fusion
Uninstalling Fusion does not modify existing virtual machines.

Uninstall Fusion
You can uninstall Fusion from the Applications folder.

Prerequisites

Power off or suspend all running virtual machines and quit Fusion.

Procedure

u Drag the VMware Fusion application from the Applications folder on your Mac to the trash.
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Force Virtual Machine Processes to Quit
If your computer prevents you from upgrading or uninstalling Fusion, you might have to use the Mac
Activity Monitor to correct the problem.

In rare circumstances, the operating system in a virtual machine can quit unexpectedly in a way that leaves
some virtual machine processes running. This situation can prevent you from upgrading or uninstalling
Fusion. In this case, the installation or uninstallation Assistant might display a message that indicates that
you cannot install or uninstall Fusion. To work around this problem, you can use the Mac Activity Monitor
to force virtual machine processes to quit.

Procedure

1 In the Finder, select Applications > Utilities and double-click Activity Monitor to open the Activity
Monitor.

2 Select All Processes.

3 In the Process Name column, select VMware Fusion.

4 Select View > Quit Process.

5 In the Quit Process window, select Force Quit.
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powering on virtual machines  74
preferences

anonymous usage statistics sent to
VMware  33

checking for software updates
automatically  33

closing virtual machines  33
default applications  37
Fusion, setting  33
setting Fusion shortcuts  36
setting key mappings  34
setting language-specific key mappings  34
setting mouse shortcuts  35

preferences, Fusion display resolution  36
printer, matching Mac's default printer  107
private network configuration  39
processors

enabling hypervisor applications  100
setting the number for a virtual machine  99

profiles for keyboard and mouse shortcuts  102
promiscuous mode,ESXi vNIC  109
protecting virtual machines from data loss  91

R
RAM, setting virtual  99
rebooting virtual machines  76
recovery partition, virtual machine  51
remote server, creating a virtual machine on  51
remote sessions, setting application for opening

URLs  37
remote virtual machine  111
remote virtual machines, viewing status  104
removable devices  108
remove  132
removing  23
repairing VMware Tools installations  67
resetting virtual machines  77
resize virtual machine display to fit  30, 31
resizing a virtual hard disk  113
restarting virtual machines  76
restricted virtual machine, expiration  130
restriction type  130
restrictions password  130
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resuming virtual machines
canceling  76
from the Full Screen Minibar  29

Retina display  105
reverting to a snapshot  92
RSS feeds, setting application for opening

URLs  37

S
SATA  61, 112, 134
SCSI  61
serial ports, adding  128
setting the startup device for the virtual

machine  129
settings

debugging checks  33
general preferences  33

sftp, setting application for opening URLs  37
shared folders

adding  89
adding a mirrored folder  88
enabling  88
guest operating systems that support  87
removing  89
removing a mirrored folder  88
Time Machine backup of  96
using  87
viewing in a Linux guest  83
viewing in a Mac OS guest  83
viewing in a Windows guest  82

shared virtual machine  50
sharing files between virtual machines and the

Mac  87
shortcuts

setting for Fusion  36
setting for mouse  35

shutting down virtual machines  75
Single Window view

exiting  25
switching to  25, 28
switching between Full Screen view and  25,

30
using  24

smart card reader  126
snapshots

automatic with AutoProtect  93
deleting  92
preventing deletion  94
restoring  92
taking  92
using  91
viewing  91

solid-state drives  21

sound adapters
adding in virtual machines  122
connecting and configuring in virtual

machines  122
connecting and disconnecting using the status

bar  122
removing  123

sound card, configuring in virtual machines  122
special key commands, sending to a virtual

machine  78
SSD  21
ssh, setting application for opening URLs  37
start  15
starting virtual machines  74
statistics, anonymously sent to VMware  33
status bar, showing and hiding  40
suspending virtual machines  75
SVGA driver, installed with VMware Tools  64
synchronizing time between a virtual machine

and the host operating system  64
system requirements,Fusion  14
system tray, viewing in Unity view  27

T
tar installer  66
taskbar, viewing in Unity view  27
telnet, setting application for opening URLs  37
time, synchronizing between a virtual machine

and the host operating system  64
time synchronization  136
Time Machine, excluding virtual machines when

using  95
toolbar

customizing  40
showing and hiding  40

troubleshooting
forcing virtual machine processes to quit  144
settings  137
virtual machine  137

tutorials, online video  15

U
uninstalling, Fusion  143
uninstalling a virtual machine  77
uninstalling VMware Tools  68
Unity view

connecting a USB device  27
opening virtual machine applications in  81
responding to the guest operating system

while in  27
switching between Full Screen view and  30
switching between Single Window view

and  25

Index
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switching between virtual machines that are
powered on  84

switching to  26
using  26
using applications menu  24
using Command+Tab with  26
using Exposé feature with  26
using Mac keyboard shortcuts with  26
using multiple displays in  30
viewing Windows taskbar and system tray  27
VMware Tools required for  64

updated information  9
updates, setting preference to check for Fusion

updates automatically  33
upgrading Fusion  141, 142
upgrading VMware Tools

Linux (tar installer)  66
Mac OS X  67
Microsoft Windows  65
process overview  143

uploading virtual machines  55
URL, setting application to use to open  37
USB camera  123
USB controller

adding to a virtual machine  124
configuring in virtual machines  123
removing  124

USB devices
connecting automatically  124, 125
connecting a smart card reader  126
connecting and disconnecting  125, 126
connecting in Unity view  27
connecting when plugging in  124
connection dialog disappears  127
default plug in action  125

USB install  14

V
video tutorials  15
view

Full Screen  28, 30
Single Window  25, 28
switching from Full Screen  30
switching from Single Window  25
Unity  26
using to work with an application or virtual

machine  24
viewing snapshots  91
virtual disks

adding existing to virtual machine  115
copying to virtual machine  115

moving to virtual machine  115
SSD  21

virtual machine hardware version  134
virtual machines

adding
a CD/DVD drive  118
a sound adapter  122
floppy devices  120
mirrored folders  88
parallel ports  127
serial ports  128
shared folders  89
USB controller  124

adding a network adapter  111
adding notes  21
adding to the Virtual Machine Library

window  21
applications, opening automatically

when you log into the Mac  41
automatic snapshots with AutoProtect  93
browsing for  74
cleaning up and defragmenting  115

configuring
a floppy device  120
CD/DVD drives  117
sound card  122
USB controller  123

connecting a smart card reader  126
connecting and configuring

CD/DVD drives  118
floppy devices  120
sound adapters  122
USB devices  124–126

connecting and configuring the network
adapter  109

converting from a physical PC  56, 59
copying  95
creating  43
creating from the Boot Camp partition  22, 53
creating with Mac OS X Server as operating

system  50
deleting  77
description  17
determining the location of files  21
downloading to remote host  56
enabling a printer  107
enabling shared folders  88
files stored in packages  41, 42
forcing virtual machine processes to quit  144
grabbing mouse and keyboard input  85
importing from Microsoft Virtual PC  60, 62
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importing from OVF or OVA virtual
machines  62

importing from Parallels Desktop  60, 62
importing the Boot Camp partition  60, 62
managing  97
moving and sharing files with the Mac  82
opening  74, 75
opening existing  73
opening applications from the Applications

menu  82
opening applications in Unity view  81
opening recently used  73
operating  73
performance profiling applications  100
powering off  75, 80
powering on  74
preferences for closing  33
preventing deletion of an AutoProtect

snapshot  94
protecting  91
rebooting  76
releasing mouse and keyboard input  85
remote access with VNC  139

removing
a sound adapter  123
CD/DVD drives  118
from the Virtual Machine Library

window  21
hard disks  116
mirrored folders  88
shared folders  89
USB controller  124

removing a network adapter  112
renaming  21
reordering in the Virtual Machine Library

window  21
resetting  77
resizing the display  40
restarting  76
restoring an earlier state  92
resuming  75, 76
reverting to a snapshot  92
running hypervisor applications  100
sending special key commands  78
sending the Ctrl-Alt-Del command  78
setting one always to run at Fusion startup  21
setting the number of virtual processors  99
setting the startup device  129
sharing files with the Mac  87
showing host power supply status  136
shutting down  75
starting  74

suspending  75
switching between hard and soft power

commands  79
switching between virtual machines that are

powered on  84
switching the CD/DVD connection between the

host CD/DVD and a CD or DVD ISO
image  118

uninstalling  77
uploading to remote host  55
uploading to VMware vCloud Air  55
using Mac input devices with  85
using Mac keyboards with  85
using shared folders  87

virtual memory, setting the amount  99
virtual processors  99

virtual disk, optimize behavior  21
Virtual Disk Manager  117
virtual hardware specifications  18
virtual machine

clone  68, 69
expiration date  130
from recovery partition  51

Virtual Machine Library window
adding a virtual machine  21
determining the location of virtual machine

files  21
Home pane  22
removing virtual machines from  21
reordering virtual machines in  21
using  21

virtual machine resolution settings  105
virtual machine window, illustrated  21
virtual machine, shared  50
virtual machine, automatic start  98
Virtual PC, importing into Fusion  60, 62
virtualization engine, setting the preferred  136
VMDK  116
VMware Tools

copying and pasting text between virtual
machines and hosts  64

faster graphics performance with  64
icon with upgrade notification  64, 85
improved mouse performance with  64
installing in a migrated virtual machine  59
required for dragging and dropping files  64
required for synchronization of time between

the virtual machine and the host  64
required for Unity view  26, 64
synchronizing time between a virtual machine

and the host operating system  64
upgrading  64
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VMware Tools installation
Linux (tar installer)  66
Mac OS X  67
Microsoft Windows  65
repairing  67

VMware Tools upgrade
Linux (tar installer)  66
Mac OS X  67
Microsoft Windows  65
process  143

VNC, accessing the virtual machine
remotely  139

VPN (virtual private network)  39

W
waiting for unity window  27
WDDM driver, installed with VMware Tools  64
Web pages, setting application for opening

URLs  37
Windows

activating  54
running together with Mac OS  73

Windows Easy Install
creating a virtual machine with  44, 46
Windows operating systems available with  44

X
x86  13
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