NSX must be installed and configured, including integration with the target vCenter Server, before deploying the HCX appliance.

  • In the destination environment, NSX Manager must be installed and integrated with the target vCenter Server. Minimum supported NSX versions:

    • NSX for vSphere 6.4.8 and higher.

    • NSX-T 2.4 and higher.

  • An NSX Data Center Enterprise Plus license is required to activate HCX systems and provide access to HCX Advanced features.
    Note: HCX Advanced is a requirement for HCX Enterprise in all deployments except for VMware HCX for Cloud on AWS, which includes support for all HCX Advanced services as well as select HCX Enterprise features and services.
  • The NSX Manager must be registered during the HCX install with the admin user.

    • If the NSX Manager IP or FQDN uses self-signed certificates, it may be necessary to trust the NSX system manually using the Import Cert by URL interface in the HCX Appliance Management interface.

  • The HCX Deployment Cluster (selected during the Compute Profile creation) must be NSX Prepared:

  • NSX requires a Transport Zone capable of creating overlay networks:

  • When NSX-T is registered, both Overlay and VLAN segments can be used during the Network Profile creation.
  • In multi-vCenter deployments using NSX for vSphere, where HCX is connected with primary and secondary NSX Managers, the secondary NSX Manager must have a local transport zone. Otherwise, HCX is not able to use the transport zone to deploy the Interconnect appliances.

  • In NSX-T deployments, HCX supports integration with networking objects created with the NSX Simplified UI/API only.
  • Deployment of HCX in environments with multiple Data Centers prepped for NSX and a single vCenter (sharing transport zones and datastores) is not supported.
Note: The HCX Network Extension service has additional NSX requirements. See Requirements for Network Extension.