View Composer requires an SQL database to store data. The View Composer database must reside on, or be available to, the View Composer server host.

If a database server instance already exists for vCenter Server, View Composer can use that existing instance if it is a version listed in 1. For example, View Composer can use the Microsoft SQL Server instance provided with vCenter Server. If a database server instance does not already exist, you must install one.

View Composer supports a subset of the database servers that vCenter Server supports. If you are already using vCenter Server with a database server that is not supported by View Composer, continue to use that database server for vCenter Server and install a separate database server to use for View Composer and View database events.

Important:

If you create the View Composer database on the same SQL Server instance as vCenter Server, do not overwrite the vCenter Server database.

The following table lists the supported database servers and versions. For a complete list of database versions supported with vCenter Server, see the VMware Product Interoperability Matrixes at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.

The versions of vCenter Server listed in the table column headings are general. For specific supported update versions of each vCenter Server release, see the VMware Product Interoperability Matrixes at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.

Table 1. Supported Database Servers for View Composer

Database

vCenter Server 5.5

vCenter Server 5.1

vCenter Server 5.0

vCenter Server 4.1

Microsoft SQL Server 2012 Express

(32- and 64-bit)

Yes

Yes

Yes

No

Microsoft SQL Server 2012 (SP1) Standard and Enterprise

(32- and 64-bit)

Yes

Yes

Yes

No

Microsoft SQL Server 2008 Express (R2 SP2)

(64-bit)

Yes

Yes

Yes

No

Microsoft SQL Server 2008 (SP3), Standard, Enterprise, and Datacenter

(32- and 64-bit)

No

Yes

Yes

Yes

Microsoft SQL Server 2008 (R2 SP2), Standard and Enterprise

(32- and 64-bit)

Yes

Yes

Yes

Yes

Oracle 10g Release 2, Standard, Standard ONE, and Enterprise [10.2.0.4]

(32- and 64-bit)

No

Yes

Yes

Yes

Oracle 11g Release 2, Standard, Standard ONE, and Enterprise [11.2.0.3]

(32- and 64-bit)

Yes

Yes

Yes

Yes