You cannot assign a ThinApp template to a machine or desktop pool.

Problem

Horizon Administrator returns an assignment error when you attempt to assign a ThinApp template to a machine or desktop pool.

Cause

Either the ThinApp template contains an application that is already assigned to the machine or desktop pool, or the ThinApp template was previously assigned to the machine or desktop pool with a different installation type.

Solution

If the template contains a ThinApp application that is already assigned to the machine or desktop pool, create a new template that does not contain the application or edit the existing template and remove the application. Assign the new or modified template to the machine or desktop pool.

To change the installation type of a ThinApp application, you must remove the existing application assignment from the machine or desktop pool. After the ThinApp application is uninstalled, you can assign it to the machine or desktop pool with a different installation type.