The JMP Server installer requires specific SQL Server database versions to perform the JMP Server installation.

JMP Server supports the following SQL Server versions and editions in the two supported workload environments: proof-of-concept (PoC) or production.

Table 1. Database Requirements for JMP Server

Workload Type

Database Server

Version

Edition

Proof-of-Concept (PoC)

SQL Server Express 2014

64-bit

Free

Production

SQL Server 2012 (SP1, SP2, SP3, and SP4)

64-bit

Standard and Enterprise

Production

SQL Server 2014 (SP1 and SP2 with CU7 or later)

64-bit

Standard and Enterprise

Production

SQL Server 2016 (SP1 with CU6 or later)

64-bit

Standard and Enterprise

Before running the JMP Server installer, you must create the SQL Server database that the JMP Server installer uses during the installation process. See Create a SQL Server Database for JMP Server for details.

You must also provide the login credentials that the JMP Server installer must use to connect to the SQL Server database that you created. You can select the type of authentication that the JMP Server installer uses. The default used is the Windows authentication. Whether you select the Windows authentication or SQL Server authentication, the login credentials that the JMP Server installer uses must already exist in the SQL Server instance before you can begin installing JMP Server. See Create a SQL Server Login for the JMP Server Host for details.

In addition, you must create a SQL Server login for the Windows Server user account that you plan to use to install the JMP Server. This Windows user must be configured to have the proper credentials to modify the SQL Server database you created.

If your SQL Server is enabled with TLS encryption, you must export its TLS certificate and import the certificate into your JMP Server instance to enable an encrypted communication with the SQL Server.