The Linux device on which you install Horizon Client, and the peripherals it uses, must meet certain system configurations that have been tested and are officially supported by VMware.

Note: These system requirements pertain to the Horizon Client for Linux that VMware makes available. In addition, several VMware partners offer thin and zero client devices for VMware Horizon deployments. The vendor and model of the thin or zero client device, and the configuration that an enterprise chooses to use, determine the features available for each client device and the operating systems supported. For information about the vendors and models for these client devices, see the VMware Compatibility Guide, available on the VMware website.
Architecture
x64, ARM
Memory
At least 2 GB of RAM
Operating system

Horizon Client for Linux has been tested on the following operating systems for this release.

Operating System Version
Ubuntu 64-bit 18.04, 20.04
Red Hat Enterprise Linux (RHEL) 64-bit 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3
Note: On RHEL 8.x systems, Horizon Client only supports the X11 display server protocol. The Wayland display server protocol is not supported.
OpenSSL requirement

Horizon Client requires a specific version of OpenSSL. The correct version is automatically downloaded and installed.

Horizon Connection Server, Security Server, and Horizon Agent
Horizon Client requires the latest maintenance release of one of the following:
  • Horizon 2006 or later
  • Horizon 7 version 7.5 or later

If client systems connect from outside the corporate firewall, it is good practice for you to use a Unified Access Gateway appliance or security server. With a Unified Access Gateway appliance or security server, client systems do not require a VPN connection.

Note: Security servers are not supported in Horizon 2006 or later.
Display protocol
  • VMware Blast
  • PCoIP
  • RDP
Screen resolution on the client system
Minimum: 1024 X 768 pixels
Hardware requirements for VMware Blast and PCoIP
  • x64-based processor with SSE2 extensions, with an 800 MHz or faster processor speed
  • Available RAM above system requirements to support various monitor setups. Use the following formula as a general guide:
    20 MB + (24 * (# monitors) * (monitor width) * (monitor height))
    
    As a rough guide, you can use the following calculations:
    1 monitor: 1600 x 1200: 64 MB
    2 monitors: 1600 x 1200: 128 MB
    3 monitors: 1600 x 1200: 256 MB
    
Hardware requirements for RDP
  • x64-based processor with SSE2 extensions, with an 800 MHz or faster processor speed
  • 128 MB RAM
Software requirements for Microsoft RDP
Use the latest rdesktop version available.
Software requirements for FreeRDP
If you plan to use an RDP connection to Horizon desktops and you prefer to use a FreeRDP client for the connection, you must install the correct version of FreeRDP and any applicable patches. See Install and Configure FreeRDP.
Other software requirements
Horizon Client also has certain other software requirements, depending on the Linux distribution you use. Allow the Horizon Client installation wizard to scan your system for library compatibilities and dependencies. The following list of requirements pertains only to Ubuntu distributions.
  • libudev.so.0
    Note: libudev0 is required to run Horizon Client. By default, libudev0 is not installed in some systems.
  • To support idle session timeouts: libXsso.so.1.
  • To improve performance when using multiple monitors, enable Xinerama.