Real-Time Audio-Video works with standard webcam, USB audio, and analog audio devices, and with standard conferencing applications like Skype, WebEx, and Google Hangouts. To support Real-Time Audio-Video, your View deployment must meet certain software and hardware requirements.

This feature is supported on the following versions of Horizon Client for Linux:

  • Horizon Client 3.2 or a later release that is available from VMware.

  • Horizon Client 2.2 or a later release that is available from third-party vendors.

View remote desktop

The desktops must have View Agent 5.3 or later, or Horizon Agent 7.0 or later, installed. For View Agent 5.3 desktops, the desktops must also have the corresponding Remote Experience Agent installed. For example, if View Agent 5.3 is installed, you must also install the Remote Experience Agent from View 5.3 Feature Pack 1. See the View Feature Pack Installation and Administration document for View. If you have View Agent 6.0 or later, or Horizon Agent 7.0 or later, no feature pack is required. Real-Time Audio-Video is not supported in remote applications.

Horizon Client computer or client access device

  • In Horizon Client 3.4 and earlier, Real-Time Audio-Video is supported on x86 devices only. In Horizon Client 3.5 and later, it is supported on x86 and x64 devices. This feature is not supported on ARM processors. The client system processor must have at least two cores.

  • Horizon Client requires the following libraries:

    • Video4Linux2

    • libv4l

    • Pulse Audio

    The plug-in file (/usr/lib/pcoip/vchan_plugins/libmmredir_plugin.so in Horizon Client 3.5 and earlier, /usr/lib/pcoip/vchan_plugins/libviewMMDevRedir.so in Horizon Client 4.0) has the following dependencies.:

    libuuid.so.1
    libv4l2.so.0
    libspeex.so.1
    libudev0
    libtheoradec.so.1
    libtheoraenc.so.1
    libv4lconvert.so.0
    libjpeg.so.8
    

    All of these files must be present on the client system or the Real-Time Audio-Video feature will not work. Note that these dependencies are in addition to the dependencies required for Horizon Client itself.

  • The webcam and audio device drivers must be installed, and the webcam and audio device must be operable, on the client computer. To support Real-Time Audio-Video, you do not have to install the device drivers on the desktop operating system where the agent is installed.

Display protocol for View

  • PCoIP

  • VMware Blast (requires Horizon Client 4.0 or later and Horizon Agent 7.0 or later)

Real-Time Audio-Video is not supported in RDP desktop sessions.