Real-Time Audio-Video works with standard webcam, USB audio, and analog audio devices, and with standard conferencing applications like Skype, WebEx, and Google Hangouts. To support Real-Time Audio-Video, your View deployment must meet certain software and hardware requirements.

View remote desktop

The desktops must have View Agent 5.2 or later, or Horizon Agent 7.0 or later, installed. For View Agent 5.2 desktops, the desktops must also have the corresponding Remote Experience Agent installed. For example, if View Agent 5.2 is installed, you must also install the Remote Experience Agent from View 5.2 Feature Pack 2. See the View Feature Pack Installation and Administration document for View. If you have View Agent 6.0 or later, or Horizon Agent 7.0 or later, no feature pack is required. To use Real-Time Audio-Video with RDS desktops and remote applications, you must have Horizon Agent 7.0.2 or later.

Horizon Client computer or client access device

  • Real-Time Audio-Video is supported on x86 and x64 devices. This feature is not supported on ARM processors. The client system must meet the following minimum hardware requirements.

    Resolution

    Frame Rate

    CPU

    Required Memory

    320 x 240

    15 FPS

    2 core, 1800 MHz

    105 MB

    640 x 480

    15 FPS

    2 core, 2700 MHz

    150 MB

    1280 x 720

    15 FPS

    4 core, 3400 MHz

    210 MB

  • Horizon Client requires the following libraries:

    • Video4Linux2

    • libv4l

    • Pulse Audio

    The plug-in file (/usr/lib/pcoip/vchan_plugins/libviewMMDevRedir.so) has the following dependencies.:

    libuuid.so.1
    libv4l2.so.0
    libspeex.so.1
    libudev0
    libtheoradec.so.1
    libtheoraenc.so.1
    libv4lconvert.so.0
    libjpeg.so.8
    

    All of these files must be present on the client system or the Real-Time Audio-Video feature will not work. Note that these dependencies are in addition to the dependencies required for Horizon Client itself.

  • The webcam and audio device drivers must be installed, and the webcam and audio device must be operable, on the client computer. To support Real-Time Audio-Video, you do not have to install the device drivers on the desktop operating system where the agent is installed.

Display protocol for View

  • PCoIP

  • VMware Blast (requires Horizon Agent 7.0 or later)

Real-Time Audio-Video is not supported in RDP desktop sessions.