VMware Horizon Client
for Linux User Guide
Modified on 06 SEP 2018
VMware Horizon Client for Linux 4.9

VMware Horizon Client for Linux User Guide

You can find the most up-to-date technical documentation on the VMware website at:
https://docs.vmware.com/
If you have comments about this documentation, submit your feedback to
docfeedback@vmware.com

VMware, Inc.
3401 Hillview Ave.
Palo Alto, CA 94304
www.vmware.com
Copyright © 2012–2018 VMware, Inc. All rights reserved. Copyright and trademark information.
VMware, Inc.

2

Contents
VMware Horizon Client for Linux User Guide

5

1 How Do I Log In? 6
2 Connecting to Remote Desktops and Published Applications 7
Setting the Certificate Checking Mode in Horizon Client

7

Connect to a Remote Desktop or Published Application

8

Connect to Published Applications Using Unauthenticated Access
Log Off or Disconnect

9

10

Disconnecting from a Server

11

3 Using Remote Desktops and Published Applications 12
Share Access to Local Folders and Drives with Client Drive Redirection
Internationalization

14

Copying and Pasting Text

14

Saving Documents in a Published Application

15

Switch Remote Desktops or Published Applications
Using the Seamless Window Feature
Use Display Scaling

12

15

15

16

Using DPI Synchronization

16

Using the Session Collaboration Feature

17

Invite a User to Join a Remote Desktop Session
Manage a Collaborative Session
Join a Collaborative Session

17

18

19

4 Using External Devices 21
Keyboards and Monitors

21

Use USB Redirection to Connect USB Devices
USB Redirection Limitations

23

25

Using the Real-Time Audio-Video Feature for Webcams and Microphones
When You Can Use a Webcam

26

Select a Default Microphone on a Linux Client System
Using Serial Port Redirection

26

27

27

Enable the Relative Mouse Feature for a Remote Desktop

29

Set Printing Preferences for a Virtual Printer Feature on a Remote Desktop

30

5 Troubleshooting Horizon Client 32
Restart a Remote Desktop

VMware, Inc.

32

3

VMware Horizon Client for Linux User Guide

Reset a Remote Desktop or Published Applications
Uninstall Horizon Client for Linux
Problems with Keyboard Input

34

34

What to Do If Horizon Client Quits Unexpectedly
Connecting to a Server in Workspace ONE Mode

VMware, Inc.

33

35
35

4

VMware Horizon Client for Linux User
Guide
This document, VMware Horizon Client for Linux User Guide, explains how to use VMware Horizon
Client™ for Linux to connect to and use remote desktops and published applications.

®

Horizon Client communicates with a server, which acts as a broker between the client device and remote
desktops and published applications. You enter credentials into Horizon Client, the server authenticates
your credentials, and then the server finds the remote desktops and published applications that you are
entitled to use.
For information about the software installed on your remote desktops, contact your system administrator.
This document assumes that Horizon Client for Linux is already installed and configured on your client
system. For information about installing and configuring Horizon Client for Linux, see the VMware Horizon
Client for Linux Installation and Setup Guide document.
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How Do I Log In?

1

Before you can log in and connect to a remote desktop or published application, a system administrator at
your company must set up your user account. If your system administrator has not set up your user
account, you cannot use Horizon Client or HTML Access.
If Horizon Client prompts you for a server name and domain name, your system administrator must tell
you the server name to type and the domain to select. At some companies, Horizon Client connects to
the correct server and selects the correct domain automatically.
If you do not know your user name or password or how to reset your password, contact the system
administrator at your company.
When you are ready to log in and get started, see Connect to a Remote Desktop or Published
Application.
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Connecting to Remote Desktops
and Published Applications

2

Horizon Client makes it easy to work on remote desktops and published applications from your local client
device, giving you on-the-go access from any location.
This chapter includes the following topics:
n

Setting the Certificate Checking Mode in Horizon Client

n

Connect to a Remote Desktop or Published Application

n

Connect to Published Applications Using Unauthenticated Access

n

Log Off or Disconnect

n

Disconnecting from a Server

Setting the Certificate Checking Mode in Horizon Client
Server certificate checking occurs for connections between Horizon Client and a server. A certificate is a
digital form of identification, similar to a passport or a driver's license.
Your system administrator might ask you to set the certificate checking mode in Horizon Client to make
sure that you can successfully connect to a server. At some companies, an administrator might set the
certificate checking mode and prevent you from changing it in Horizon Client.
If a Horizon administrator has allowed it, you can set the certificate checking mode. To set the certificate
checking mode, start Horizon Client and select File > Preferences from the menu bar. You have three
choices:
n

Never connect to untrusted servers. This setting means that you cannot connect to the server if
any of the certificate checks fail. An error message lists the checks that failed.

n

Warn before connecting to untrusted servers. This setting means that you can click Continue to
ignore the warning if a certificate check fails because the server uses a self-signed certificate. For
self-signed certificates, the certificate name is not required to match the server name that you entered
in Horizon Client.

n

Do not verify server identity certificates. This setting means that no certificate checking occurs.

VMware, Inc.
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Connect to a Remote Desktop or Published Application
After logging in to a server, you can connect to the remote desktops and published applications that you
are authorized to use.
If your administrator has allowed it, you can configure the certificate checking mode for the TLS/SSL
certificate presented by Connection Server. To determine which mode to use, see Setting the Certificate
Checking Mode in Horizon Client.
If you want to use an account configured with unauthenticated access to launch published applications,
see Connect to Published Applications Using Unauthenticated Access for information.
Prerequisites

Obtain the following information from your Horizon administrator:
n

Instructions about whether to turn on a VPN (virtual private network) connection.

n

Server name to use for connecting to the server.

n

If the port is not 443, the port number to use for connecting to the server.

n

Credentials for logging in, such as an Active Directory user name and password, RSA SecurID user
name and passcode, RADIUS authentication user name and passcode, or smart card personal
identification number (PIN).

n

Domain name for logging in.

Procedure

1

If a VPN connection is required, turn on the VPN.

2

Either open a terminal window and enter vmware-view or search the applications for VMware
Horizon Client, and double-click the icon.

3

If you are prompted for RSA SecurID credentials or RADIUS authentication credentials, enter the
user name and passcode and click OK.

4

If you are prompted for a user name and password, supply Active Directory credentials.
a

Type the user name and password of a user who is entitled to use at least one desktop or
application pool.
If the Domain drop-down menu is disabled, you must type the user name as domain\username
or username@domain.

5

b

(Optional) Select a domain value from the Domain drop-down menu.

c

Click OK.

If the desktop security indicator turns red and a warning message appears, respond to the prompt.

VMware, Inc.
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6

7

(Optional) To configure display settings for a remote desktop, right-click the remote desktop icon and
select Settings.
Option

Action

Select a display protocol

If a Horizon administrator has allowed it, use the Connect Via drop-down menu
to select the display protocol.

Select a display layout

Use the Display drop-down menu to select a window size or to use multiple
monitors.

(Optional) To mark the remote desktop or published application as a favorite, right-click the remote
desktop or published application icon and select Mark as Favorite from the context menu that
appears.
A star icon appears in the upper-right corner of the remote desktop or published application name.
The next time you log in, you can click the Show Favorites button to find this application or desktop
quickly.

8

Double-click a remote desktop or application to connect.
If you are connecting to a session-based remote desktop, which is hosted on a Microsoft RDS host,
and if the desktop is already set to use a different display protocol, you will not be able to connect
immediately. You will be prompted to either use the protocol that is currently set or have the system
log you off of the remote operating system so that a connection can be made with the protocol you
selected.

After you are connected, the client window appears.

Connect to Published Applications Using Unauthenticated
Access
You can connect to published applications using an unauthenticated access account with Horizon Client.
Prerequisites

Obtain the following information from your Horizon administrator:
n

Instructions about whether to turn on a VPN (virtual private network) connection.

n

Name of server on which you have unauthenticated access to remote applications.

n

If the port is not 443, the port number to use for connecting to the server.

n

An Unauthenticated Access user account to use for logging in anonymously, if necessary.

n

Instructions about whether to select Log in anonymously using Unauthenticated Access in
Horizon Client.

If your system administrator instructs you to configure the certificate checking mode, see Setting the
Certificate Checking Mode in Horizon Client.

VMware, Inc.
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Procedure

1

If a VPN connection is required, turn on the VPN.

2

Either open a terminal window and enter vmware-view or search the applications for VMware
Horizon Client, and double-click the icon.

3

In the Horizon Client home screen, select File > Log in anonymously using Unauthenticated
Access from the menu bar, if it is not already selected.

4

Connect to the Connection Server that is configured for unauthenticated access.
n

If the server that you need has not yet been added, double-click the + Add Server button if no
servers have yet been added or click the + New Server button in the menu bar to add a new one,
and enter the name of the Connection Server or a security server, and click Connect.

n

If the server that you need is displayed in the Horizon Client home screen, right-click the icon for
the server and select Connect from the context menu.

You might see a message that you must confirm before the login dialog box appears.
5

In the Server Login dialog box, specify the unauthenticated access account to use.
a

Select a user account from the drop-down list of existing unauthenticated access accounts.
The default user account has (default) displayed next to it.

b

(Optional) Click Always use this account if you want to bypass the Server Login dialog box the
next time you connect to the server.

c

Click OK.

The application selector window appears and displays the published applications that the
unauthenticated access account is authorized to use.
Note If you had selected the Always use this account option during a previous unauthenticated
access login session, you will not be prompted for the account to use for the current unauthenticated
access session. To deselect this option, right-click the icon for the server in the Horizon Client home
screen, and select Forget the saved Unauthenticated Access account from the context menu.
6

To start an application, double-click the application icons to launch it.
The application window appears.

7

Exit the application after you are done using it.
The Disconnect from Session dialog box appears asking if you want to disconnect from the server.

If the session timeout specified by your Horizon administrator is reached, the session is automatically
disconnected from the server.

Log Off or Disconnect
If you disconnect from a remote desktop without logging off, applications in the remote desktop might
remain open. You can also disconnect from a server and leave published applications running.

VMware, Inc.
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You can log off from a remote desktop even if you do not have the remote desktop open. This feature has
the same result as sending Ctrl+Alt+Del to the remote desktop and then clicking Log Off.
Procedure
n

Disconnect without logging off.
Option

Action

Also quit Horizon Client

Click the Close button in the corner of the window or select File > Quit from the
menu bar.

Select a different remote desktop on
the same server

Select Desktop > Disconnect from the menu bar.

Select a remote desktop on a different
server

Select File > Disconnect from server from the menu bar.

Note A Horizon administrator can configure remote desktops to log off automatically when they are
disconnected. In that case, any open applications in the remote desktop are stopped.
n

Log off and disconnect from a remote desktop.
Option

Action

From within the remote desktop

Use the Windows Start menu to log off.

From the menu bar

Select Desktop > Disconnect and Log off.
If you use this procedure, files that are open on the remote desktop are closed
without being saved first.

n

Log off when you do not have a remote desktop open.
a

From the Home screen with desktop shortcuts, select the desktop and select Desktop > Log off
from the menu bar.

b

If prompted, supply credentials for accessing the remote desktop.

If you use this procedure, files that are open on the remote desktop are closed without being saved
first.

Disconnecting from a Server
After you have finished using a remote desktop or published application, you can disconnect from the
server.
To disconnect from a server, click the Disconnect from Server icon in the upper-left corner of the
desktop and application selector window, or select File > Disconnect from Server in the Horizon Client
menu bar, or press Ctrl+O.

VMware, Inc.
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Using Remote Desktops and
Published Applications

3

Horizon Client includes additional features to help you use remote desktops and published applications
on your local client device.
This chapter includes the following topics:
n

Share Access to Local Folders and Drives with Client Drive Redirection

n

Internationalization

n

Copying and Pasting Text

n

Saving Documents in a Published Application

n

Switch Remote Desktops or Published Applications

n

Using the Seamless Window Feature

n

Use Display Scaling

n

Using DPI Synchronization

n

Using the Session Collaboration Feature

Share Access to Local Folders and Drives with Client
Drive Redirection
With the client drive redirection feature, you can share folders and drives on the local client system with
remote desktops and published applications.
Shared drives can include mapped drives and USB storage devices.
In a Windows remote desktop, shared folders and drives appear in the This PC folder or in the Computer
folder, depending on the Windows operating system version. In a published application, such as Notepad,
you can browse to and open a file in a shared folder or drive.
The client drive redirection feature requires that the following library files be installed. On some thin-client
machines, these library files might not be installed by default.
n

libsigc-2.0.so.0

n

libglibmm-2.4.so.1

The client drive redirection settings apply to all remote desktops and published applications.

VMware, Inc.
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Prerequisites

To share folders and drives with a remote desktop or published application, a Horizon administrator must
enable the client drive redirection feature.
Procedure

1

2

Open the Settings dialog box with the Sharing panel displayed.
Option

Description

From the desktop and application
selector window

Right-click a remote desktop or published application icon, select Settings, and
click Sharing. Alternatively, select Connection > Settings from the menu bar
and click Sharing.

From the Sharing dialog box when you
connect to a remote desktop or
published application

Click Allow to share, or Deny to not share, your home directory.

From within a remote desktop

Select Connection > Settings from the menu bar and click Sharing.

Configure the client drive redirection settings.
Option

Action

Share a specific folder or drive with
remote desktops and published
applications

Click the Add button, browse to and select the folder or drive to share, and click
OK.

Stop sharing a specific folder or drive

Select the folder or drive in the Folder list and click the Remove button.

Give remote desktops and published
applications access to files in your
home directory

Select the Share your home folder: home-directory check box.

Share USB storage devices with
remote desktops and published
applications

Select the Allow access to removable storage check box. The client drive
redirection feature shares all USB storage devices inserted in your client system
and all FireWire and Thunderbolt-connected external drives automatically.

Note If a USB device is already connected to a remote desktop or published
application with the USB redirection feature, you cannot share a folder on the
USB device.

Selecting a specific device to share is not necessary.
Note USB storage devices already connected to a remote desktop or published
application with the USB redirection feature are not shared.
If this check box is deselected, you can use the USB redirection feature to
connect USB storage devices to remote desktops and published applications.
Do not show the Sharing dialog box
when you connect to a remote desktop
or published application

VMware, Inc.

Select the Do not show dialog when connecting to a desktop or application
check box.
If this check box is deselected, the Sharing dialog box appears the first time you
connect to a remote desktop or published application. For example, if you log in to
a server and connect to a remote desktop, you see the Sharing dialog box. If you
then connect to another remote desktop or published application, you do not see
the dialog box. To see the dialog box again, you must disconnect from the server
and log in again.

13

VMware Horizon Client for Linux User Guide

What to do next

Verify that you can see the shared folders from within the remote desktop or published application.
n

In a Windows remote desktop, open File Explorer and look in the This PC folder, or open Windows
Explorer and look in the Computer folder, depending on the Windows operating system version.

n

In a published application, select File > Open or File > Save As and navigate to the folder or drive.

The folders and drives that you selected for sharing might use one (or more) of the following naming
conventions.
Naming Convention

Example

folder-name on desktop-name

jsmith on JSMITH-W03

folder-name (drive-number:)

jsmith (Z:)

folder-name on desktoptop-name (drive-number:)

jsmith on JSMITH-W03 (Z:)

For some Horizon Agent versions, a redirected folder can have two entrances, such as under Devices
and drives and Network locations in Windows 10, and both entrances can appear at the same time. If
all the volume labels (from A: through Z:) are already in use, the redirected folder has only one entrance.

Internationalization
The user interface and documentation are available in English, Japanese, French, German, Simplified
Chinese, Traditional Chinese, Korean, and Spanish.
If you are using a Ubuntu 10.4 Linux client system and you want to display the client user interface in a
language other than English, you must set the client system to use a locale that uses UTF-8 encoding.

Copying and Pasting Text
You can copy text to and from remote desktops and published applications. A Horizon administrator can
configure this feature so that copy and paste operations are allowed only from the client system to a
remote desktop or published application, or only from a remote desktop or published application to the
client system, or both, or neither.
This feature is available if you use the VMware Blast display protocol or the PCoIP display protocol.
Remote applications are supported with Horizon 6.0 or later.
You can copy text from Horizon Client to a remote desktop or application, or the reverse, but the pasted
text is plain text.
You cannot copy and paste graphics. You also cannot copy and paste files between a remote desktop
and the file system on the client computer.

VMware, Inc.
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Saving Documents in a Published Application
With certain published applications, such as Microsoft Word or WordPad, you can create and save
documents. Where these documents are saved depends on your company's network environment. For
example, your documents might be saved to a home share mounted on your local computer.
Contact your system administrator to find out where documents created in published applications are
saved in your environment.

Switch Remote Desktops or Published Applications
If you are connected to a remote desktop, you can switch to another remote desktop. You can also
connect to a published application while you are connected to a remote desktop.
Procedure
u

Select a remote desktop or application from the same server or a different server.
Option

Action

Choose a different desktop or
application on the same server

Perform one of the following actions:

Choose a different desktop or
application on a different server

n

If you are logged in to a remote desktop and you want to switch to another
remote desktop or application that is already running on your client, select the
desktop or application from the View menu.

n

If you are logged in to a remote desktop or application and you want to switch
to another desktop or application that is not running, select File > Return to
Desktop and Applications List from the menu bar and then launch the
desktop or application from the selector window.

n

From the desktop and application selector window, double-click the icon for
the other desktop or application. That desktop or application opens in a new
window so that you have multiple windows open, and you can switch between
them.

Perform either of the following actions:
n

If you want to keep the current desktop or application open and also connect
to a remote desktop or application on another server, start a new instance of
Horizon Client and connect to the other desktop or application.

n

If you want to close the current desktop and connect to a desktop on another
server, go to the desktop selector window, click the Disconnect icon in the
upper-left corner of the window, and confirm that you want to log off of the
server. You will be disconnected from the current server and any open
desktop or application sessions. You can then connect to a different server.

Using the Seamless Window Feature
With the Seamless Window feature, you can interact with an application that is running on a remote
desktop as if it was a locally running application.
Beginning with Horizon Client 4.9 for Linux, the Seamless Window feature is enabled by default and
available for all supported Linux systems.

VMware, Inc.

15

VMware Horizon Client for Linux User Guide

Use Display Scaling
Users that have poor eyesight or high-resolution screens, such as 4K monitors, generally have scaling
enabled by setting the DPI (Dots Per Inch) on the client system to greater than 100 percent. The DPI
setting controls the size of the text, apps, and icons. A lower DPI setting makes them appear smaller and
a higher setting makes them appear bigger. With the Display Scaling feature, remote desktops support
the client machine's scaling setting and appear normal-sized rather than very small.
Note The DPI Scaling feature is not supported on Raspberry Pi devices and does not work with
published applications.
In a multiple-monitor setup, using display scaling does not affect the number of monitors and the
maximum resolutions that Horizon Client supports. When display scaling is allowed and is in effect,
scaling is based on the DPI setting of the system.

Using DPI Synchronization
The DPI Synchronization feature ensures that the DPI setting in a remote desktop or published
application matches the client system's DPI setting. When you start a new remote session, Horizon Agent
sets the DPI value in the remote session to match the DPI value of the client system.
Note The DPI synchronization feature is not supported on Raspberry Pi devices.
The DPI Synchronization feature cannot change the DPI setting for active remote sessions. If you
reconnect to an existing remote session, the Display Scaling feature scales the remote desktop
appropriately.
The DPI Synchronization feature is enabled by default. A Horizon administrator can disable the DPI
synchronization feature. End users cannot enable or disable the feature from Horizon Client.
Not all remote desktops support the DPI Synchronization feature. For more information, see the VMware
Horizon Client for Linux Installation and Setup Guide.
When the DPI Synchronization feature and the Display Scaling feature are both enabled, only one feature
takes effect at any given time. Display scaling occurs only when DPI synchronization has not yet taken
effect (that is, before the DPI setting on the remote desktop matches the DPI setting on the client system),
and display scaling stops working after the DPI settings match.
Following are tips for using the DPI Synchronization feature.
n

If you start a remote session on a client system that has a DPI setting of more than 100 percent, and
then use the same session on another client system that has a different DPI setting of more than 100
percent, you must log out and log back in to the remote session on the second client system to make
DPI synchronization work on the second client system.

VMware, Inc.
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Using the Session Collaboration Feature
You can use the Session Collaboration feature to invite other users to join an existing remote desktop
session.

Invite a User to Join a Remote Desktop Session
When the Session Collaboration feature is enabled for a remote desktop, you can invite other users to
join an existing remote desktop session.
By default, you can send Session Collaboration invitations by email, in an instant message (IM), or by
copying a link to the clipboard and forwarding the link to users. To use the email invitation method, an
email application must be installed. To use the IM invitation method, Skype for Business must be installed
and configured. You can invite only users that belong to a domain that the server allows for
authentication. You can invite up to five users by default.
A Horizon administrator can disable the email and IM invitation methods, change the maximum number of
collaborators, and disable the Session Collaboration feature. For information about how the Session
Collaboration feature behaves at your company, contact your system administrator.
The Session Collaboration feature has the following limitations.
n

If you have multiple monitors, only the primary monitor is shown to session collaborators.

n

You must select the VMware Blast display protocol when you create a remote desktop session. The
Session Collaboration feature does not support PCoIP or RDP sessions.

n

Anonymous collaboration is not supported. Session collaborators must be identifiable through
Horizon-supported authentication mechanisms.

n

Session collaborators must have Horizon Client 4.7 or later for Windows, Mac, or Linux installed, or
they must use HTML Access 4.7 or later. If a session collaborator has an unsupported version of
Horizon Client, an error message appears when the user clicks a collaboration link.

n

You cannot use the Session Collaboration feature to share Linux remote desktop sessions or
published application sessions.

Prerequisites

To invite users to join a remote desktop session, a Horizon administrator must enable the Session
Collaboration feature.
Procedure

1

Connect to a remote desktop for which the session collaboration feature is enabled.
You must use the VMware Blast display protocol.

2

In the system tray in the remote desktop, click the VMware Horizon Collaboration icon, for example,
.
The collaboration icon looks different depending on the Windows operating system version.

VMware, Inc.
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3

When the VMware Horizon Collaboration dialog box opens, enter the user name (for example,
testuser or domain\testuser) or the email address of the user that you want to join the remote
desktop session.
The first time you enter the user name or email address of a particular user, you must click Look up
"user", enter a comma (,), or press the Enter key to validate the user. The session collaboration
feature remembers the user the next time you enter the user's user name or email address.
You can invite up to five users by default. A Horizon administrator can change the maximum number
of users that you can invite.

4

Select an invitation method.
The following invitation methods are available by default. A Horizon administrator can disable the
email and IM invitation methods.
Option

Action

Email

Copies the collaboration invitation to the clipboard and opens a new email
message in the default email application. An email application must be installed to
use this invitation method.

IM

Copies the collaboration invitation to the clipboard and opens a new window in
Skype for Business. Press Ctrl+V to paste the link into the Skype for Business
window. Skype for Business must be installed and configured to use this invitation
method.

Copy Link

Copies the collaboration invitation to the clipboard. You must manually open
another application, such as Notepad, and press Ctrl+V to paste the invitation.

After you send an invitation, the VMware Horizon Collaboration icon also appears on the desktop and the
session collaboration user interface turns into a dashboard that shows the current state of the
collaboration session and enables you to take certain actions.
When a session collaborator accepts your invitation and joins the session, the session collaboration
feature notifies you and a red dot appears on the VMware Horizon Collaboration icon in the system tray.
What to do next

Manage the collaborative session in the VMware Horizon Collaboration dialog box. See Manage a
Collaborative Session.

Manage a Collaborative Session
After you send a session collaboration invitation, the Session Collaboration user interface turns into a
dashboard that shows the current state of the collaborative session and enables you to take certain
actions.
Prerequisites

Start a collaborative session. See Invite a User to Join a Remote Desktop Session.

VMware, Inc.
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Procedure

1

In the remote desktop, click the VMware Horizon Collaboration icon in the system tray, or double-click
the VMware Horizon Collaboration icon on the desktop.
The names of all session collaborators appear in the Name column and their status appears in the
Status column.

2

Use the VMware Horizon Session Collaboration dashboard to manage the collaboration session.
Option

Action

Revoke an invitation or remove a
collaborator

Click Remove in the Status column.

Hand off control to a session
collaborator

After the session collaborator joins the session, toggle the switch in the Control
column to On.
To resume control of the session, double-click or press any key. The session
collaborator can also give back control by toggling the switch in the Control
column to Off, or by clicking the Give Back Control button.

Add a collaborator

Click Add Collaborators.

End the collaborative session

Click End Collaboration. All active collaborators are disconnected.
You can also end the collaborative session by clicking the VMware Horizon
Session Collaboration icon on the desktop and clicking the Stop button.

Join a Collaborative Session
To join a collaborative session, you can click the link in a collaboration invitation. The link might be in an
email or instant message, or in a document that the session owner forwards to you. Alternatively, you can
log in to the server and double-click the icon for the collaborative session in the remote desktop and
application selector window.
This procedure describes how to join a collaborative session from a collaboration invitation.
You cannot use the following remote desktop features in a collaborative session.
n

USB redirection

n

Real-Time Audio-Video (RTAV)

n

Multimedia redirection

n

Client drive redirection

n

Smart card redirection

n

Virtual printing

n

Clipboard redirection

You cannot change the remote desktop resolution in a collaborative session.
Prerequisites

To join a collaborative session, you must have Horizon Client 4.7 for Windows, Mac, or Linux installed on
the client system, or you must use HTML Access 4.7 or later.

VMware, Inc.
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Procedure

1

Click the link in the collaboration invitation.
Horizon Client opens on the client system.

2

Enter your credentials to log in to Horizon Client.
After you are successfully authenticated, the collaborative session begins and you can see the
session owner's remote desktop. If the session owner transfers mouse and keyboard control to you,
you can use the remote desktop.

3

To return mouse and keyboard control to the session owner, click the VMware Horizon Session
Collaboration icon in the system tray and toggle the switch in the Control column to Off, or click the
Give Back Control button.

4

To leave the collaborative session, click Options > Disconnect.

VMware, Inc.
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4

You can use keyboards, displays, microphones, and other external devices with remote desktops and
published applications.
This chapter includes the following topics:
n

Keyboards and Monitors

n

Use USB Redirection to Connect USB Devices

n

Using the Real-Time Audio-Video Feature for Webcams and Microphones

n

Using Serial Port Redirection

n

Enable the Relative Mouse Feature for a Remote Desktop

n

Set Printing Preferences for a Virtual Printer Feature on a Remote Desktop

Keyboards and Monitors
You can use multiple monitors and all types of keyboards with a remote desktop. Certain settings ensure
the best possible user experience.

Best Practices for Using Multiple Monitors
Following are recommendations for successfully using multiple monitors with a remote desktop:
n

Define the primary monitor as the bottom-left-most monitor.

n

Enable Xinerama. If you do not enable Xinerama, the primary display might be identified incorrectly.

n

The menu bar will appear on the top-left-most monitor. For example, if you have two monitors side by
side and the top of the left monitor is lower than the top of the right monitor, the menu bar will appear
on the right monitor because the right monitor is still the top-left-most monitor.

n

You can use up to 4 monitors if you have enough video RAM.
To use more than 2 monitors to display your remote desktop on a Ubuntu client system, you must
configure the kernel.shmmax setting correctly. Use the following formula:
max horizontal resolution X max vertical resolution X max number of monitors X 4
For example, manually setting kernel.shmmax to 65536000 allows you to use four monitors with a
screen resolution of 2560x1600.
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n

Horizon Client uses the monitor configuration that is in use when Horizon Client starts. If you change
a monitor from landscape to portrait mode or if you plug an additional monitor in to the client system
while Horizon Client is running, you must restart Horizon Client in order to use the new monitor
configuration.

Horizon Client supports the following monitor configurations:
n

If you use 2 monitors, the monitors are not required to be in the same mode. For example, if you are
using a laptop connected to an external monitor, the external monitor can be in portrait mode or
landscape mode.

n

If you have a version of Horizon Client that is earlier than 4.0, and you use more than 2 monitors, the
monitors must be in the same mode and have the same screen resolution. That is, if you use 3
monitors, all 3 monitors must be in either portrait mode or landscape mode and must use the same
screen resolution.

n

Monitors can be placed side by side, stacked 2 by 2, or vertically stacked only if you are using 2
monitors.

n

If you specify that you want to use all monitors, and if you are using the VMware Blast or PCoIP
display protocol, you can specify a subset of adjacent monitors to use by right-clicking the desktop in
the desktop selector window, selecting Full Screen - All Monitors from the Display drop-down list,
and clicking to select the monitors you want to use.
Note If you have a Ubuntu client system, you must select the top-left-most monitor as one of the
monitors. For example, if you have 4 monitors stacked 2 X 2, you must select either the 2 monitors on
top or the 2 left-most monitors.

Screen Resolution
Consider the following guidelines when setting screen resolutions:
n

If you open a remote desktop on a secondary monitor and then change the screen resolution on that
monitor, the remote desktop moves to the primary monitor.

n

With PCoIP, if you use 2 monitors, you can adjust the resolution for each monitor separately, with a
resolution of up to 2560 x 1600 per display. If you use more than 2 monitors, the monitors must use
the same screen resolution.

n

With the VMware Blast display protocol or the PCoIP display protocol, a remote desktop screen
resolution of 4K (3840 x 2160) is supported. The number of 4K displays that are supported depends
on the hardware version of the desktop virtual machine and the Windows version.

Hardware Version

Windows Version

Number of 4K Displays
Supported

10 (ESXi 5.5.x compatible)

7, 8, 8.x, 10

1

11 (ESXi 6.0 compatible)

7

3

(3D rendering feature disabled and Windows Aero
disabled)
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Hardware Version

Windows Version

Number of 4K Displays
Supported

11

7

1

(3D rendering feature enabled)
11

8, 8.x, 10

1

13

8, 8.x, 10

4

Note When the remote desktop screen resolution is set to 3840 x 2160 (4K), items on the screen
might appear smaller, and you might not be able to use the Screen Resolution dialog box in the
remote desktop to make text and other items larger.
n

With RDP, if you have multiple monitors, you cannot adjust the resolution for each monitor separately.

Keyboard Limitations
For the most part, keyboards work as well with a remote desktop as they do with a physical computer.
Following is a list of the limitations you might encounter, depending on the type of peripherals and
software on your client system:
n

If you use the PCoIP display protocol and want the remote desktop to detect which keyboard map
your client system uses, such as, for example, a Japanese keyboard or a German keyboard, you
must set a GPO in the View agent. Use the Turn on PCOIP user default input language
synchronization policy, available as part of the View PCoIP Session Variables ADM template file.
For more information, see the Configuring Remote Desktop Features in Horizon 7 document.

n

Some multimedia keys on a multimedia keyboard might not work. For example, the Music key and My
Computer key might not work.

n

If you connect to a desktop using RDP and if you have the Fluxbox window manager, if a screen
saver is running in the remote desktop, after a period of inactivity, the keyboard might stop working.
Regardless of which window manager you use, VMware recommends turning off the screen saver in
a remote desktop and not specifying a sleep timer.

Use USB Redirection to Connect USB Devices
With the USB redirection feature, you can use locally attached USB devices, such as thumb flash drives,
in a remote desktop or published application.
When you use the USB redirection feature, most USB devices that are attached to the local client system
become available from menus in Horizon Client. You can use the menus to connect and disconnect the
devices.
You can connect USB devices to a remote desktop or published application either manually or
automatically.
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Prerequisites
n

To use USB devices with a remote desktop or published application, a Horizon administrator must
enable the USB feature.

n

The USB Redirection component must be installed in Horizon Client. If you did not include this
component in the installation, uninstall the client and run the installer again to include the USB
Redirection component.

n

Become familiar with USB Redirection Limitations

Procedure
n

Manually connect a USB device to a remote desktop.
a

Connect the USB device to your local client system.

b

From the Horizon Client menu bar, click Connect USB Device.

c

Select the USB device.

The device is manually redirected from the local system to the remote desktop.
n

Connect the USB device to a published application.
a

In the desktop and application selector window, open the remote application.
The name of the application is the name that your administrator has configured for the
application.

b

In the desktop and application selector window, right-click the application icon and select
Settings.

c

In the left pane, select USB Devices.

d

In the right pane, select the USB device and click Connect.

e

Select the application, and click OK.
Note The name of the application in the list comes from the application itself and might not
match the application name that your administrator configured to appear in the desktop and
application selector window.
You can now use the USB device with the remote application. After you close the application, the
USB device is not released right away.

f

When you are finished using the application, to release the USB device so that you can access it
from your local system, in the desktop and application selector window, open the Settings window
again, select USB Devices, and select Disconnect.
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n

Configure Horizon Client to connect USB devices automatically to the remote desktop when
Horizon Client starts.
This option is selected by default.
a

Before you plug in the USB device, start Horizon Client and connect to a remote desktop.

b

From the Horizon Client menu bar, click Connect USB Device.

c

Select Automatically Connect at Startup.

d

Plug in the USB device and restart Horizon Client.

USB devices that you connect to your local system after you start Horizon Client are redirected to the
remote desktop. USB devices that you connect to your local system after you start Horizon Client are
redirected to the remote desktop.
n

Configure Horizon Client to connect USB devices automatically to the remote desktop when you plug
them in to the local system.
Enable this option if you plan to connect devices that use MTP drivers, such as Android-based
Samsung smart phones and tablets. This option is selected by default.
a

Before you plug in the USB device, start Horizon Client and connect to a remote desktop.

b

From the Horizon Client menu bar, click Connect USB Device.

c

Select Automatically Connect when Inserted.

d

Plug in the USB device.

USB devices that you connect to your local system after you start Horizon Client are redirected to the
remote desktop.
If the USB device does not appear in the remote desktop or published application after several minutes,
disconnect and reconnect the device to the client computer.

USB Redirection Limitations
The USB redirection feature has certain limitations.
n

When you access a USB device from a menu in Horizon Client and use the device in a remote
desktop, you cannot access the device on the local computer.

n

USB devices that do not appear in the menu, but are available in a remote desktop, include human
interface devices such as keyboards and pointing devices. The remote desktop and the local
computer use these devices at the same time. Interaction with these devices can sometimes be slow
because of network latency.

n

Large USB disk drives can take several minutes to appear in the remote desktop.

n

Some USB devices require specific drivers. If a required driver is not already installed on a remote
desktop, you might be prompted to install it when you connect the USB device to the remote desktop.

VMware, Inc.

25

VMware Horizon Client for Linux User Guide

n

If you plan to attach USB devices that use MTP drivers, such as Android-based Samsung smart
phones and tablets, configure Horizon Client so that it automatically connects USB devices to the
remote desktop. Otherwise, if you try to manually redirect the USB device by using a menu item, the
device is not redirected unless you unplug the device and then plug it in again.

n

The redirection of USB audio devices depends on the state of the network and is not reliable. Some
devices require a high data throughput even when they are idle. Audio input and output devices work
well with the Real-Time Audio-Video feature. You do not need to use USB redirection for those
devices.

n

You cannot format a redirected USB drive in a published desktop unless you connect as an
administrator user.

Note Do not redirect USB devices such as USB Ethernet devices and touch screen devices to a remote
desktop or published application. If you redirect a USB Ethernet device, your client system loses network
connectivity. If you redirect a touch screen device, the remote desktop or published application receives
touch input but not keyboard input. If you have set the remote desktop or published application to
autoconnect USB devices, you can configure a policy to exclude specific devices. See "Configuring Filter
Policy Settings for USB Devices" in the Configuring Remote Desktop Features in Horizon 7 document.

Using the Real-Time Audio-Video Feature for Webcams
and Microphones
With the Real-Time Audio-Video feature, you can use the local client system's webcam or microphone in
a remote desktop or published application. Real-Time Audio-Video is compatible with standard
conferencing applications and browser-based video applications. It supports standard webcams, audio
USB devices, and analog audio input.
Note This feature is available only with the version of Horizon Client for Linux provided by third-party
vendors or with the Horizon Client software available from the VMware Product Downloads website.

When You Can Use a Webcam
If a Horizon administrator has configured the Real-Time Audio-Video feature, and if you use the VMware
Blast display protocol or the PCoIP display protocol, you can use a webcam that is built in or connected to
the local client computer in a remote desktop or published application. You can use the webcam in
conferencing applications such as Skype, Webex, or Google Hangouts.
During the setup of an application such as Skype, Webex, or Google Hangouts on a remote desktop, you
can select input and output devices from menus in the application. For virtual desktops, you can select
VMware Virtual Microphone and VMware Virtual Webcam. For published desktops and applications, you
can select Remote Audio Device and VMware Virtual Webcam.
For many applications, you do not need to select an input device.
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When the local client computer uses the webcam, the remote session cannot use it at the same time.
Also, when the remote session uses the webcam, the local client computer cannot use it at the same
time.
If more than one webcam is connected to the local client computer, you can configure a preferred
webcam to use in remote sessions.

Select a Default Microphone on a Linux Client System
If you have multiple microphones on your client system, only one of them is used on your remote desktop.
To specify which microphone is the default, you can use the Sound control on your client system.
With the Real-Time Audio-Video feature, audio input devices and audio output devices work without
requiring the use of USB redirection, and the amount of network bandwidth required is greatly reduced.
Analog audio input devices are also supported.
Prerequisites
n

Verify that you have a USB microphone or another type of microphone installed and operational on
your client system.

n

Verify that you are using the VMware Blast display protocol or the PCoIP display protocol for your
remote desktop.

Procedure

1

In the Ubuntu graphical user interface, select System > Preferences > Sound.
You can alternatively click the Sound icon on the right side of the toolbar at the top of the screen.

2

Click the Input tab in the Sound Preferences dialog box.

3

Select the preferred device and click Close.

Using Serial Port Redirection
With serial port redirection, you can redirect locally connected serial (/dev/ttyS) ports, such as built-in
RS232 ports and USB-to-serial adapters. Devices such as printers, bar code readers, and other serial
devices can be connected to these ports and used in RDS-hosted desktops.
If a Horizon administrator has configured the serial port redirection feature, and if you use the VMware
Blast display protocol, serial port redirection works in the RDS-hosted desktop without further
configuration. For example, /dev/ttyS0 on the local client system is redirected as COM1 on the RDShosted desktop. Serial port /dev/ttyS1 is redirected as COM2. If the /dev/ttyS port is already in use, it is
mapped to avoid conflicts. For example, if COM1 and COM2 exist on the RDS-hosted desktop, /dev/ttyS0
on the client system is mapped to COM3 by default.
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You must have any required device drivers installed on the local client system, but you do not need to
install the device drivers on the RDS-hosted desktop. For example, if you use a USB-to-serial adapter
that requires specific device drivers to work on your local client system, you must install those drivers, but
only on the client system.
Important If you are using a device that plugs in to a USB-to-serial adapter, do not connect the device
from the Connect USB Device menu in Horizon Client. Doing so routes the device through USB
redirection and bypasses the serial port redirection feature.

Tips for Using the Serial Port Redirection Feature
n

Click the serial port icon (

) in the system tray or notification area of the RDS-hosted desktop to
connect, disconnect, or customize the mapped /dev/ttyS ports.
When you click the serial port icon, the Serial COM Redirection for VMware Horizon context menu
appears. If an administrator has locked the configuration, the items in the context menu are dimmed.
The icon appears only if a Horizon administrator has configured the serial port redirection feature and
all requirements are met. For more information, see the "System Requirements for Serial Port
Redirection" topic in the VMware Horizon Client for Linux Installation and Setup Guide document.

n

In the context menu, the port items are listed as port mapped to port, for example, /dev/ttyS0
mapped to COM1. The first port, which is /dev/ttyS0 in this example, is the physical port or the USBto-serial adapter on the local client system. The second port, which is COM1 in this example, is the
port used in the RDS-hosted desktop.

n

To select the Port Properties command, right-click a /dev/ttyS port.
In the COM Properties dialog box, you can configure a port to connect automatically when a RDShosted desktop session is started, or you can ignore DSR (data-set-ready signal), which is required
for some modems and other devices.
You can also change the port number that the RDS-hosted desktop uses. For example, if
the /dev/ttyS0 port on the client system is mapped to COM3 in the RDS-hosted desktop, you can
change the port number to COM1. If COM1 exists in the RDS-hosted desktop, you might see COM1
(Overlapped). You can still use this overlapped port. The RDS-hosted desktop can receive serial
data through the port from the server and also from the client system.

n

Connect to a mapped COM port by selecting Connect to use the port in the RDS-hosted desktop.
When a redirected COM port is opened and in use on a RDS-hosted desktop, you cannot access the
port on the local computer. Conversely, when a /dev/ttyS port is in use on the local computer, you
cannot access the port on the RDS-hosted desktop.

n

You can then select the Disconnect command to disconnect and make the physical COM port
available for use on the client computer.
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Enable the Relative Mouse Feature for a Remote Desktop
If you use the VMware Blast display protocol or the PCoIP display protocol when using 3D applications in
a remote desktop, mouse performance improves when you enable the relative mouse feature.
In most circumstances, if you are using applications that do not require 3D rendering, Horizon Client
transmits information about mouse pointer movements by using absolute coordinates. Using absolute
coordinates, the client renders the mouse movements locally, which improves performance, especially if
you are outside the corporate network.
For work that requires using graphics-intensive applications, such as AutoCAD, or for playing 3D video
games, you can improve mouse performance by enabling the relative mouse feature, which uses relative,
rather than absolute, coordinates.
When the relative mouse feature is enabled, performance might be slow if you are outside the corporate
network, on a WAN.
Prerequisites

A Horizon administrator must turn on 3D rendering for the remote desktop.
Procedure

1

Start Horizon Client and log in to the server.

2

Right-click the remote desktop and select VMware Blast or PCoIP.

3

Connect to the remote desktop.

4

Select Connection > Enable Relative Mouse from the Horizon Client menu bar.
The option is a toggle. To disable the relative mouse feature, select Connection > Enable Relative
Mouse again.
Note If you use Horizon Client in windowed mode rather than full-screen mode and the relative
mouse feature is enabled, you might not be able to move the mouse pointer to the Horizon Client
menu options or move the pointer outside of the Horizon Client window. To resolve this situation,
press Ctrl+Alt.
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Set Printing Preferences for a Virtual Printer Feature on a
Remote Desktop
With the virtual printing feature, you can use local or network printers from a remote desktop without
having to install additional printer drivers in the remote desktop. For each printer available through this
feature, you can set preferences for data compression, print quality, double-sided printing, color, and
other settings.
Important The virtual printing feature is available only with Horizon Client 3.2 or a later release that is
available from the VMware Product Downloads Web site, or with the version of Horizon Client for Linux
that is provided by third-party vendors.
This feature also has the following requirements:
n

The remote desktop must have View Agent 6.0.2 or later, or Horizon Agent 7.0 or later, installed.

n

You must be using the VMware Blast or PCoIP display protocol.

For more information about VMware thin-client and zero-client partners, see the VMware Compatibility
Guide at http://www.vmware.com/resources/compatibility/search.php?deviceCategory=vdm. For client
software provided by third-party vendors, you must be using the VMware Blast, PCoIP, or FreeRDP
display protocol. This feature does not work with rdesktop.
After a printer is added on the local client computer, Horizon Client adds that printer to the list of available
printers in the remote desktop. No further configuration is required. If you have administrator privileges,
you can install printer drivers on the remote desktop without creating a conflict with the virtual printer
component.
Important This feature is not available for the following types of printers.
n

USB printers that use the USB redirection feature to connect to a virtual USB port in the remote
desktop.
You must disconnect the USB printer from the remote desktop to use the virtual printing feature with
it.

n

The Windows feature for printing to a file.
Selecting the Print to file check box in a Print dialog box does not work. Using a printer driver that
creates a file does work. For example, you can use a PDF writer to print to a PDF file.

This procedure applies to Windows 7 or Windows 8.x remote desktops. The procedure is similar, but not
exactly the same, for other types of Windows remote desktops.
Procedure

1

In the Windows 7 or Windows 8.x remote desktop, click Start > Devices and Printers.
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2

In the Devices and Printers window, right-click the default printer, select Printer Properties from the
context menu, and select the printer.
Virtual printers might appear as <printer_name>, <printer_name>(s<session_ID>), or
<printer_name>#:<number> in the remote desktop.

3

In the Printer Properties window, click the Device Setup tab and specify which settings to use.

4

On the General tab, click Preferences and specify which settings to use.

5

In the Printing Preferences dialog box, select the different tabs and specify which settings to use.
For the Page Adjustment advanced setting, VMware recommends that you retain the default
settings.

6

Click OK.
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You can solve most problems with Horizon Client by restarting or resetting remote desktops or published
applications, or by reinstalling Horizon Client.
This chapter includes the following topics:
n

Restart a Remote Desktop

n

Reset a Remote Desktop or Published Applications

n

Uninstall Horizon Client for Linux

n

Problems with Keyboard Input

n

What to Do If Horizon Client Quits Unexpectedly

n

Connecting to a Server in Workspace ONE Mode

Restart a Remote Desktop
If the remote desktop operating system stops responding, you might need to restart a remote desktop.
Restarting a remote desktop is similar to using the Windows operating system restart command. The
remote desktop operating system usually prompts you to save any unsaved data before it restarts.
You can restart a remote desktop only if a Horizon administrator has enabled the restart feature for the
remote desktop.
Prerequisites

Obtain login credentials, such as a user name and password, RSA SecurID user name and password,
RADIUS authentication user name and password, or smart card personal identification number (PIN).
Procedure
u

Use the Restart command.
Option

Action

From within the desktop

Select Connection > Restart Desktop from the menu bar.

From the desktop selection window

Select the remote desktop and select Connection > Restart Desktop from the
menu bar.

Horizon Client prompts you to confirm the restart action.
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The operating system in the remote desktop restarts and Horizon Client disconnects and logs off from the
remote desktop.
What to do next

Wait an appropriate amount of time for the system to restart before you attempt to reconnect to the
remote desktop.
If restarting the remote desktop does not solve the problem, you might need to reset the remote desktop.
See Reset a Remote Desktop or Published Applications.

Reset a Remote Desktop or Published Applications
You might need to reset a remote desktop if the desktop operating system stops responding and
restarting the remote desktop does not solve the problem. Resetting published applications quits all open
applications.
Resetting a remote desktop is the same as pressing the Reset button on a physical PC to force the PC to
restart. Any files that are open on the remote desktop are closed and are not saved.
Resetting published applications quits the applications without saving any unsaved data. All open
published applications are closed.
You can reset a remote desktop only if a Horizon administrator has enabled the reset feature for the
remote desktop.
Procedure
u

Use the Reset command.
Option

Action

Reset a remote desktop from within the
desktop

Select Connection > Reset from the menu bar.

Reset a remote desktop from the
desktop and application selection
window

Select the remote desktop and select Connection > Reset from the menu bar.

Reset published applications from the
desktop and application selection
window

Click the Settings button (gear icon) in the upper right corner of the window,
select Applications in the left pane, click Reset, and click Continue.

When you reset a remote desktop, the operating system in the remote desktop restarts and
Horizon Client disconnects and logs off from the remote desktop. When you reset published applications,
the published applications quit.
What to do next

Wait an appropriate amount of time for system to restart before attempting to reconnect to the remote
desktop or published application.
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Uninstall Horizon Client for Linux
You can sometimes resolve problems with Horizon Client by uninstalling and reinstalling the
Horizon Client application.
The method you use for uninstalling Horizon Client for Linux depends on the version and the method you
used for installing the client software.
Prerequisites

Verify that you have root access on the Linux client system.
Procedure
n

If you have Horizon Client 3.1 or earlier, or if you installed the client from the Ubuntu Software Center,
select Applications > Ubuntu Software Center, and in the Installed Software section, select
vmware-view-client and click Remove.

n

If you have Horizon Client 3.2 or later, which you installed from the VMware Product Downloads Web
site, open a Terminal window, change directories to the directory that contains the installer file, and
run the installer command with the -u option.
sudo env VMWARE_KEEP_CONFIG=yes \
./VMware-Horizon-Client-x.x.x-yyyyyyy.arch.bundle -u vmware-horizon-client

In the file name, x.x.x is the version number, yyyyyyy is the build number, and arch is either x86 or
x64. Using the VMWARE_KEEP_CONFIG=yes setting means retain the configuration settings when the
client is uninstalled. If this environment variable is not set, you are prompted to specify whether to
save the configuration settings.

Problems with Keyboard Input
When you type in a remote desktop or published application, none of the keystrokes seem to work.
Problem

When you are connected to a remote desktop or published application, no characters appear when you
type. Another symptom might be that a single key keeps repeating itself.
Cause

Some security software, such as Norton 360 Total Security, includes a feature that detects keystroke
logging software and blocks keystroke logging. This security feature is meant to protect the system
against spyware that steals passwords and credit card numbers. This security software might block
Horizon Client from sending keystrokes to the remote desktop or published application.
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Solution
u

On the client system, turn off the keystroke logging detection feature of your antivirus or security
software.

What to Do If Horizon Client Quits Unexpectedly
Horizon Client quits even if you do not close it.
Problem

Horizon Client quits unexpectedly. Depending on the server configuration, you might see a message such
as There is no secure connection to the View Connection Server. Sometimes a message
does not appear.
Cause

This problem occurs when the connection to the server is lost.
Solution
u

Restart Horizon Client. You can connect successfully when the server is running again. If you
continue to have connection problems, contact your system administrator.

Connecting to a Server in Workspace ONE Mode
You cannot connect to a server in Workspace ONE mode directly through Horizon Client.
Problem
n

When you try to connect to the server directly through Horizon Client, Horizon Connection Server
does not allow your connection request.

n

When you open a remote desktop or published application through a URI, Horizon Connection Server
does not allow your connection request.

n

If Block connections from clients that don't support Workspace ONE mode is enabled,
Horizon Client for Linux cannot connect to the server directly or from Workspace ONE.

Cause

Beginning with Horizon 7 version 7.2, a Horizon administrator can enable Workspace ONE mode on a
Connection Server instance. This behavior is normal when Workspace ONE mode is enabled on a
Connection Server instance.
Horizon Client for Linux does not support Workspace ONE mode.
Solution

Use Workspace ONE to connect to a Workspace ONE enabled server and access your remote desktops
and published applications.
Disable Block connections from clients that don't support Workspace ONE mode in Horizon
Connection Server.
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