Using VMware Horizon Client for Mac

VMware Horizon Client for Mac 4.3

vmware



Using VMware Horizon Client for Mac

You can find the most up-to-date technical documentation on the VMware Web site at:
https://docs.vmware.com/

The VMware Web site also provides the latest product updates.

If you have comments about this documentation, submit your feedback to:

docfeedback@vmware.com

Copyright © 2010-2016 VMware, Inc. Al rights reserved. Copyright and trademark information.

VMware, Inc.

3401 Hillview Ave.
Palo Alto, CA 94304
www.vmware.com

2 VMware, Inc.


https://docs.vmware.com/
mailto:docfeedback@vmware.com
http://pubs.vmware.com/copyright-trademark.html

Contents

Using VMware Horizon Client for Mac 5

1 Setup and Installation 7
System Requirements for Mac Clients 7
System Requirements for Real-Time Audio-Video 8
Smart Card Authentication Requirements 9
Requirements for URL Content Redirection 10
Supported Desktop Operating Systems 10
Preparing Connection Server for Horizon Client 11
Install Horizon Client on Mac 11
Add Horizon Client to Your Dock 12
Configuring Certificate Checking for End Users 12
Configure Advanced TLS/SSL Options 13
Configuring Log File Collection Values 14
Configure VMware Blast Options 14
Horizon Client Data Collected by VMware 15

2 Using URIs to Configure Horizon Client 19
Syntax for Creating vmware-view URIs 19

Examples of vmware-view URIs 22

3 Managing Remote Desktop and Application Connections 25
Connect to a Remote Desktop or Application 26
Open a Recent Remote Desktop or Application 28
Share Access to Local Folders and Drives 28
Connecting to a Server When Horizon Client Starts 30
Configure Horizon Client to Forget the Server User Name and Domain 31
Hide the VMware Horizon Client Window 31
Configure Horizon Client to Select a Smart Card Certificate 31
Configure Keyboard Shortcut Mappings 32
Considerations for Mapping Operating System Keyboard Shortcuts 33
Configure Mouse Shortcut Mappings 33
Configure Horizon Client Shortcuts 34
Setting the Certificate Checking Mode for Horizon Client 34
Searching for Desktops or Applications 35
Select a Favorite Remote Desktop or Application 36
Switch Desktops or Applications 37
Log Off or Disconnect 37
Autoconnect to a Remote Desktop 39
Configure Reconnect Behavior for Remote Applications 39
Removing a Server Shortcut from the Home Screen 40

VMware, Inc.



Using VMware Horizon Client for Mac

Reordering Shortcuts 40

4 Using a Microsoft Windows Desktop or Application on a Mac 41
Feature Support Matrix for Mac 41
Internationalization 44
Monitors and Screen Resolution 44
Using Exclusive Mode 45
Connect USB Devices 46
Configuring USB Redirection on a Mac Client 48
USB Redirection Properties 50
USB Device Families 52
Turn on Logging for USB Redirection 53
Using the Real-Time Audio-Video Feature for Webcams and Microphones 53
When You Can Use Your Webcam 54
Select a Default Microphone on a Mac Client System 54
Configuring Real-Time Audio-Video on a Mac Client 55
Configure a Preferred Webcam or Microphone on a Mac Client System 56
Copying and Pasting Text and Images 57
Configuring the Client Clipboard Memory Size 58
Using Remote Applications 58
Use a Local IME with Remote Applications 59
Saving Documents in a Remote Application 59
Clicking URL Links That Open Outside of Horizon Client 60
Printing from a Remote Desktop or Application 60
Enabling Virtual Printing in Horizon Client 60
Set Printing Preferences for the Virtual Printer Feature on a Remote Desktop 61
Using USB Printers 62
PColP Client-Side Image Cache 62

5 Troubleshooting Horizon Client 63
Reset a Remote Desktop or Application 63
Uninstalling Horizon Client 64

Index 65

4 VMware, Inc.



Using VMware Horizon Client for Mac

Using VMuware Horizon Client for Mac provides information about installing and using VMware Horizon®
Client™ software on a Mac to connect to a remote desktop or application in the datacenter.

This information is intended for administrators who need to set up a View deployment that includes Mac
client devices. The information is written for experienced system administrators who are familiar with
virtual machine technology and datacenter operations.
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Setup and Installation

Setting up a View deployment for Mac clients involves using certain Connection Server configuration
settings, meeting the client and server system requirements, and downloading and installing Horizon Client
for Mac from the VMware Web site.

Note In Horizon 7 and later, View Administrator is renamed Horizon Administrator. This document uses
the name View Administrator to refer to both View Administrator and Horizon Administrator.

This chapter includes the following topics:

m  “System Requirements for Mac Clients,” on page 7

m  “System Requirements for Real-Time Audio-Video,” on page 8
®  “Smart Card Authentication Requirements,” on page 9

m  “Requirements for URL Content Redirection,” on page 10

m  “Supported Desktop Operating Systems,” on page 10

m  “Preparing Connection Server for Horizon Client,” on page 11
m  “Install Horizon Client on Mac,” on page 11

m  “Add Horizon Client to Your Dock,” on page 12

m  “Configuring Certificate Checking for End Users,” on page 12
m  “Configure Advanced TLS/SSL Options,” on page 13

m  “Configuring Log File Collection Values,” on page 14

m  “Configure VMware Blast Options,” on page 14

m  “Horizon Client Data Collected by VMware,” on page 15

System Requirements for Mac Clients

The Mac on which you install Horizon Client, and the peripherals it uses, must meet certain system

requirements.

Model 64-bit Intel-based Mac

Memory At least 2GB of RAM

Operating systems ®m  Mac OS X Mavericks (10.9.x)

m Mac OS X Yosemite (10.10.x)

VMware, Inc. 7
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Connection Server,
Security Server, and
View Agent or
Horizon Agent

Display protocol for
View

Software Requirements
for RDP

Smart cards

m  Mac OS X El Capitan (10.11)
m  macOS Sierra (10.12)

Latest maintenance release of View 5.3.x and later releases

If client systems connect from outside the corporate firewall, VMware
recommends that you use a security server. With a security server, client
systems will not require a VPN connection.

Remote applications are available on Horizon 6.0 with View and later
servers.

m  PColP
m  RDP

®  VMware Blast (requires Horizon Agent 7.0 or later)

Remote Desktop Connection Client for Mac from Microsoft, versions 2.0
through 2.1.1. You can download this client from the Microsoft Web site.

Norte Horizon Client for Mac does not work with Microsoft Remote
Desktop 8.0 and later releases.

See “Smart Card Authentication Requirements,” on page 9.

System Requirements for Real-Time Audio-Video

Real-Time Audio-Video works with standard webcam, USB audio, and analog audio devices, and with
standard conferencing applications like Skype, WebEx, and Google Hangouts. To support Real-Time Audio-
Video, your View deployment must meet certain software and hardware requirements.

View remote desktop

Horizon Client computer
or client access device

Display protocol for
View

The desktops must have View Agent 5.2 or later, or Horizon Agent 7.0 or
later, installed. For View Agent 5.2 desktops, the desktops must also have the
corresponding Remote Experience Agent installed. For example, if View
Agent 5.2 is installed, you must also install the Remote Experience Agent
from View 5.2 Feature Pack 2. See the View Feature Pack Installation and
Administration document for View. If you have View Agent 6.0 or later, or
Horizon Agent 7.0 or later, no feature pack is required. To use Real-Time
Audio-Video with RDS desktops and remote applications, you must have
Horizon Agent 7.0.2 or later.

B The webcam and audio device drivers must be installed, and the
webcam and audio device must be operable, on the client computer. To
support Real-Time Audio-Video, you do not have to install the device
drivers on the desktop operating system where the agent is installed.

m  PColP

®  VMware Blast (requires Horizon Agent 7.0 or later)

Real-Time Audio-Video is not supported in RDP desktop sessions.
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Smart Card Authentication Requirements
Client systems that use a smart card for user authentication must meet certain requirements.
VMware tested the following smart cards:
m  U.S. Department of Defense Common Access Card (CAC)
m  U.S. Federal Government Personal Identity Verification (PIV), also called FIPS-201

Each client system that uses a smart card for user authentication must have the following software and
hardware:

m  Horizon Client
® A compatible smart card reader
m  Product-specific application drivers

You must also install product-specific application drivers on the remote desktops or Microsoft RDS host. For
Windows 7 remote desktops, the operating system installs the related driver when you insert a smart card
reader and PIV card. For Windows XP and Windows Vista remote desktops, you can install the related
driver by using Activldentify ActivClient.

Users who authenticate with smart cards must have a smart card and each smart card must contain a user
certificate. When you generate a certificate for a blank PIV card, enter the path to the server truststore file on
the Connection Server or security server host on the Crypto Provider tab in the PIV Data Generator tool. For
information about creating a server truststore file, see "Setting Up Smart Card Authentication" in the View
Administration document.

In addition to meeting these requirements for Horizon Client systems, other View components must meet
certain configuration requirements to support smart cards:

m  For information about configuring Connection Server to support smart card use, see "Setting Up Smart
Card Authentication" in the View Administration document.

Note Smart cards are supported only with View 5.3.2 and later servers and desktops.

You must add all applicable Certificate Authority (CA) certificates for all trusted user certificates to a
server truststore file on the Connection Server host or security server host. These certificates include
root certificates and must include intermediate certificates if the user's smart card certificate was issued
by an intermediate certificate authority.

m  For information about tasks you might need to perform in Active Directory to implement smart card
authentication, see "Setting Up Smart Card Authentication" in the View Administration document.

Enabling the Username Hint Field in Horizon Client

In some environments, smart card users can use a single smart card certificate to authenticate to multiple
user accounts. Users enter their user name in the Username hint field during smart card sign-in.

To make the Username hint field appear on the Horizon Client login dialog box, you must enable the smart
card user name hints feature for the Connection Server instance in View Administrator. The smart card user
name hints feature is supported only with Horizon 7 version 7.0.2 and later servers and agents. For
information about enabling the smart card user name hints feature, see "Setting Up Smart Card
Authentication" in the View Administration document.

VMware, Inc. 9
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If your environment uses an Access Point appliance rather than a security server for secure external access,
you must configure the Access Point appliance to support the smart card user name hints feature. The smart
card user name hints feature is supported only with Access Point 2.7.2 and later. For information about
enabling the smart card user name hints feature in Access Point, see the Deploying and Configuring Access
Point document.

Note Horizon Client still supports single-account smart card certificates when the smart card user name
hints feature is enabled.

Requirements for URL Content Redirection

With the URL Content Redirection feature, you can have URL content redirected from a remote desktop or
application (the agent) to your Mac system (the client). For example, you can enter a URL or click a link in
Internet Explorer on a remote desktop and have a browser on your client display the content.

Horizon Agent sends the URL to Horizon Client, which opens the default application for the protocol that is
specified in the URL. Any number of protocols, including HTTP, mailto, and callto, can be configured for
URL redirection.

The URL Content Redirection feature has the following requirements:

Remote desktop or RDS m  Horizon Agent 7.0.0 or later with the URL Content Redirection feature

host that provides enabled must be installed.
remote applications
® A Horizon administrator must configure group policy settings that

specify how Horizon Agent redirects URL content.

m  The supported browsers in which you can type or click a URL and have
the URL redirected to the client system are Internet Explorer 9, 10, and
11.

Display protocol for the B VMware Blast

remote session
m PColP

For more information about URL Content Redirection, including limitations and group policy settings, see
"Configuring URL Content Redirection" in the Setting Up Desktop and Application Pools in View document.

Note URL Content Redirection is a Tech Preview feature in Horizon Client for Mac and it supports only
agent-to-client redirection. Horizon Client for Windows 4.0 and later supports both agent-to-client and
client-to-agent redirection.

Supported Desktop Operating Systems

10

Administrators create virtual machines with a guest operating system and install agent software in the guest
operating system. End users can log in to these virtual machines from a client device.

For a list of the supported Windows guest operating systems, see the "Supported Operating Systems for
View Agent" topic in the View 5.x or 6.x installation documentation. See the "Supported Operating Systems
for Horizon Agent" topic in the Horizon 7 installation documentation.

Some Linux guest operating systems are also supported if you have View Agent 6.1.1 or later, or

Horizon Agent 7.0 or later. For information about system requirements, configuring Linux virtual machines
for use in Horizon 6 or Horizon 7, and a list of supported features, see Setting Up Horizon 6 for Linux
Desktops, which is part of the Horizon 6, version 6.1 documentation, or see Setting Up Horizon 7 for Linux
Desktops.
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Chapter 1 Setup and Installation

Preparing Connection Server for Horizon Client

Administrators must perform specific tasks to enable end users to connect to remote desktops and
applications.

Before end users can connect to Connection Server or a security server and access a remote desktop or
application, you must configure certain pool settings and security settings:

If you plan to use Access Point, configure Connection Server to work with Access Point. See Deploying
and Configuring Access Point. Access Point appliances fulfill the same role that was previously played by
only security servers.

If you are using a security server, verify that you are using the latest maintenance releases of
Connection Server 5.3.x and Security Server 5.3.x or later releases. For more information, see the View
Installation document.

If you plan to use a secure tunnel connection for client devices and if the secure connection is
configured with a DNS host name for Connection Server or a security server, verify that the client
device can resolve this DNS name.

To enable or disable the secure tunnel, in View Administrator, go to the Edit View Connection Server
Settings dialog box and use the check box called Use secure tunnel connection to desktop.

Verify that a desktop or application pool has been created and that the user account that you plan to use
is entitled to access the pool.

For Connection Server 5.3.x, see the topics about creating desktop pools in the View Administration
document. For Connection Server 6.0 and later, see the topics about creating desktop and application
pools in the Setting Up Desktop and Application Pools in View document.

ImporTANT If end users have a high-resolution display and will use the High Resolution Mode client
setting while viewing their remote desktops in full screen mode, you must allocate sufficient VRAM for
each Windows 7 or later remote desktop. The amount of vVRAM depends on the number of monitors
configured for end users and on the display resolution. To estimate the amount of vVRAM you need, see
the section "RAM Sizing for Specific Monitor Configurations" of the topic "Estimating Memory
Requirements for Virtual Desktops," in the View Architecture Planning document.

To use two-factor authentication with Horizon Client, such as RSA SecurID or RADIUS authentication,
you must enable this feature on Connection Server. For more information, see the topics about two-
factor authentication in the View Administration document.

To enable end users to save their passwords with Horizon Client, so that they do not always need to
supply credentials when connecting to a Connection Server instance, configure View LDAP for this
feature on the Connection Server host.

Users can save their passwords if View LDAP is configured to allow it, if the Horizon Client certificate
verification mode is set to Warn before connecting to untrusted servers or Never connect to untrusted
servers, and if Horizon Client can fully verify the server certificate that Connection Server presents. For
instructions, see "Saving Credentials in Mobile and Mac Horizon Clients" in the View Administration
document.

Install Horizon Client on Mac

End users open Horizon Client to connect to remote desktops and applications from a Mac physical
machine. You install Horizon Client on Mac client systems from a disk image file.

Prerequisites

VMware, Inc.

Verify that the client system uses a supported operating system. See “System Requirements for Mac
Clients,” on page 7.
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m  Verify that you can log in as an administrator on the client system.

m  If you plan to use the RDP display protocol to connect to a remote desktop, verify that the Mac client
system has Remote Desktop Connection Client for Mac from Microsoft, version 2.0 or later installed.

m  Verify that you have the URL for a download page that contains the Horizon Client installer. This URL
might be the VMware Downloads page at http://www.vmware.com/go/viewclients, or it might be the
URL for a Connection Server instance.

Procedure
1 From your Mac, browse to the URL for downloading the Horizon Client installer file.

The file name format is VMware-Horizon-Client-y.y. y-xxxxxx.dmg. xxxxxx is the build number and y.y.y
is the version number.

2 Double-click the .dmg file to open it and click Agree.
The contents of the disk image appear in a Horizon Client Finder window.
3 In the Finder window, drag the VMware Horizon Client icon to the Applications folder icon.

If you are not logged in as an administrator user, you are prompted for an administrator user name and
password.

What to do next

Start Horizon Client and verify that you can connect to a remote desktop or application. See “Connect to a
Remote Desktop or Application,” on page 26.

Add Horizon Client to Your Dock

You can add Horizon Client to your Dock just as you do with any other application.

Procedure

1  Inthe Applications folder, select VMware Horizon Client.

2 Drag the VMware Horizon Client icon to the Dock.

3 To configure the Dock icon to open Horizon Client at login or to show the icon in the Finder, right-click

the icon on the Dock, select Options, and select the appropriate command from the context menu.

When you quit Horizon Client, the application shortcut remains in the Dock.

Configuring Certificate Checking for End Users

Administrators can configure the certificate verification mode so that, for example, full verification is always
performed.

Certificate checking occurs for SSL connections between Connection Server and Horizon Client.
Administrators can configure the verification mode to use one of the following strategies:

m  End users are allowed to choose the verification mode. The rest of this list describes the three
verification modes.

m  (No verification) No certificate checks are performed.

m  (Warn) End users are warned if a self-signed certificate is being presented by the server. Users can
choose whether or not to allow this type of connection.

m  (Full security) Full verification is performed and connections that do not pass full verification are
rejected.
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For details about the types of verification checks performed, see “Setting the Certificate Checking Mode for
Horizon Client,” on page 34.

You can set the verification mode so that end users cannot change it. Set the "Security Mode" key in
the /Library/Preferences/com.vmware.horizon.plist file on Mac clients to one of the following values:

®  1implements Never connect to untrusted servers.
® 2 implements Warn before connecting to untrusted servers.

®  3implements Do not verify server identity certificates.

Configure Advanced TLS/SSL Options

You can select the security protocols and cryptographic algorithms that are used to encrypt communications
between Horizon Client and Horizon servers and between Horizon Client and the agent in the remote
desktop.

These security options are also used to encrypt the USB channel (communication between the USB service
daemon and the agent on the remote desktop).

By default, TLSv1.0, TLSv1.1, and TLSv1.2 are enabled. SSL v2.0 and 3.0 are not supported. The default
cipher control string is "laNULL:kKECDH+AESGCM:ECDH+AESGCM:RSA+AESGCM:KkECDH+AES:ECDH
+AES:RSA+AES".

Norte If TLSv1.0 and RC4 are disabled, USB redirection does not work when users are connected to
Windows XP remote desktops. Be aware of the security risk if you choose to make this feature work by
enabling TLSv1.0 and RC4.

If you configure a security protocol for Horizon Client that is not enabled on the Horizon server to which the
client connects, a TLS/SSL error occurs and the connection fails.

IMPORTANT At least one of the protocol versions that you enable in Horizon Client must also be enabled on
the remote desktop. Otherwise, USB devices cannot be redirected to the remote desktop.

For information about configuring the security protocols that are accepted by Connection Server instances,
see the View Security document.

Procedure

1  Select VMware Horizon Client > Preferences from the menu bar, click Security, and click Advanced.
To enable or disable a security protocol, select the check box next to the security protocol name.

To change the cipher control string, replace the default string.

(Optional) If you need to revert to the default settings, click Restore Defaults.

62 B N S N S

Click Confirm to save your changes.

Your changes take effect the next time you connect to the server.
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Configuring Log File Collection Values

Horizon Client generates log files in the ~/Library/Logs/VMware Horizon Client directory on the Mac client.
Administrators can configure the maximum number of log files and the maximum number of days to keep
log files by setting keys in the /Library/Preferences/com.vmware.horizon.plist file on a Mac client.

Table 1-1. plist Keys for Log File Collection

Key Description
MaxDebugLogs Maximum number of log files. The maximum value is 100.
MaxDaysToKeepLogs Maximum number of days to keep log files. This value has no limit.

Files that do not match these criteria are deleted when you start Horizon Client.

If the MaxDebugLogs or MaxDaysToKeepLogs keys are not set in the com.vmware.horizon.plist file, the
default number of log files is 5 and the default number of days to keep log files is 7.

Configure VMware Blast Options

You can configure H.264 decoding and network protocol options for remote desktop and application
sessions that use the VMware Blast display protocol.

Prerequisites

This feature requires Horizon Agent 7.0 or later.

Procedure
1  Select VMware Horizon Client > Preferences from the menu bar and click VMware Blast.

2 Configure the decoding and network protocol options.

Option Description

Allow H.264 decoding Select this option to allow H.264 decoding in Horizon Client. When this
option is selected (the default setting), Horizon Client uses H.264 decoding
if the agent supports H.264 encoding. If the agent does not support H.264
encoding, Horizon Client uses JPG/PNG decoding.

Deselect this option to use JPG/PNG decoding.

Allow UDP networking Select this option to allow UDP networking in Horizon Client. When this
option is selected (the default setting), Horizon Client uses UDP
networking if UDP connectivity is available. If UDP networking is blocked,
Horizon Client uses TCP networking.

Deselect this option to use TCP networking.

Note UDP is disabled by default on a Horizon remote desktop. For UDP
to work, it must be enabled on the desktop, the client, and the Blast Secure
Gateway (BSG).

3 Close the Preferences dialog box.

Your changes take effect the next time a user connects to a remote desktop or application and selects the
VMware Blast display protocol. Your changes do not affect existing VMware Blast sessions.

14 VMware, Inc.
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Horizon Client Data Collected by VMware

If your company participates in the customer experience improvement program, VMware collects data from
certain Horizon Client fields. Fields containing sensitive information are made anonymous.

VMware collects data on the clients to prioritize hardware and software compatibility. If your company's
administrator has opted to participate in the customer experience improvement program, VMware collects
anonymous data about your deployment in order to improve VMware's response to customer requirements.
No data that identifies your organization is collected. Horizon Client information is sent first to Connection
Server and then on to VMware, along with data from Connection Server instances, desktop pools, and
remote desktops.

Although the information is encrypted while in transit to Connection Server, the information on the client
system is logged unencrypted in a user-specific directory. The logs do not contain any personally identifiable
information.

The administrator who installs Connection Server can select whether to participate in the VMware customer
experience improvement program while running the Connection Server installation wizard, or an
administrator can set an option in View Administrator after the installation.

Table 1-2. Data Collected from Horizon Clients for the Customer Experience Improvement Program

Is This Field
Made
Anonymous
Description ? Example Value
Company that produced the No VMware
Horizon Client application
Product name No VMware Horizon Client
Client product version No (The format is x.x.x-yyyyyy, where x.x.x is the client version
number and yyyyyy is the build number.)
Client binary architecture No Examples include the following:
m  i386
m x86_64
® arm
Client build name No Examples include the following:
m  VMware-Horizon-Client-Win32-Windows
m  VMware-Horizon-Client-Linux
®  VMware-Horizon-Client-iOS
m  VMware-Horizon-Client-Mac
m  VMware-Horizon-Client-Android
®  VMware-Horizon-Client-WinStore
Host operating system No Examples include the following:

m  Windows 8.1

Windows 7, 64-bit Service Pack 1 (Build 7601 )
iPhone OS 5.1.1 (9B206)

Ubuntu 12.04.4 LTS

Mac OS X 10.8.5 (12F45)
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Table 1-2. Data Collected from Horizon Clients for the Customer Experience Improvement Program

(Continued)
Is This Field
Made
Anonymous
Description ? Example Value
Host operating system kernel No Examples include the following:
m Windows 6.1.7601 SP1
m  Darwin Kernel Version 11.0.0: Sun Apr 8 21:52:26 PDT
2012; root:xnu-1878.11.10~1/RELEASE_ARM_S51.8945X
Darwin 11.4.2
®m  Linux 2.6.32-44-generic #98-Ubuntu SMP Mon Sep 24
17:27:10 UTC 2012
m  unknown (for Windows Store)
Host operating system architecture No Examples include the following:
m  x86_64
m i386
m  armv71
m ARM
Host system model No Examples include the following:
m  Dell Inc. OptiPlex 960
m  iPad3,3
®  MacBookPro8,2
m  Dell Inc. Precision WorkStation T3400 (A04 03/21/2008)
Host system CPU No Examples include the following:
m  Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GH
m  Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GH
m  unknown (for iPad)
Number of cores in the host system's No For example: 4
processor
MB of memory on the host system No Examples include the following:
m 4096
m  unknown (for Windows Store)
Number of USB devices connected No 2 (USB device redirection is supported only for Linux,
Windows, and Mac clients.)
Maximum concurrent USB device No 2
connections
USB device vendor ID No Examples include the following:
m  Kingston
m NEC
m  Nokia
m  Wacom
USB device product ID No Examples include the following:

m  DataTraveler

m  Gamepad

®m  Storage Drive

m  Wireless Mouse

VMware, Inc.
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(Continued)
Is This Field
Made
Anonymous
Description ? Example Value
USB device family No Examples include the following:
m  Security
®  Human Interface Device
®  Imaging
USB device usage count No (Number of times the device was shared)

VMware, Inc.
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Using URIs to Configure
Horizon Client

Using uniform resource identifiers (URIs), you can create a Web page or an email with links that end users

click to start Horizon Client, connect to a server, and open a specific desktop or application with specific
configuration options.

You can simplify the process of connecting to a remote desktop or application by creating Web or email links

for end users. You create these links by constructing URIs that provide some or all the following

information, so that your end users do not need to supply it:

Connection Server address

Port number for Connection Server

Active Directory user name

Domain name

Desktop or application display name

Window size

Actions including reset, log out, and start session
Display protocol

Options for redirecting USB devices

To construct a URI, you use the vmware-view URI scheme with Horizon Client specific path and query parts.

Note You can use URIs to start Horizon Client only if the client software is already installed on client
computers.

This chapter includes the following topics:

“Syntax for Creating vmware-view URIs,” on page 19

“Examples of vmware-view URIs,” on page 22

Syntax for Creating vmware-view URIs

Syntax includes the vmware-view URI scheme, a path part to specify the desktop or application, and,

optionally, a query to specify desktop or application actions or configuration options.

URI Specification

Use the following syntax to create URISs to start Horizon Client:

vmware-view://[authority-part][/path-part] [?query-part]

VMware, Inc.
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The only required element is the URI scheme, vmware-view. For some versions of some client operating
systems, the scheme name is case-sensitive. Therefore, use vmware-view.

ImpoRTANT In all parts, non-ASCII characters must first be encoded according to UTF-8 [STD63], and then
each octet of the corresponding UTF-8 sequence must be percent-encoded to be represented as URI

characters.

For information about encoding for ASCII characters, see the URL encoding reference at

http://www.utf8-chartable.de/.

authority-part

path-part

query-part

Supported Queries

Specifies the server address and, optionally, a user name, a non-default port
number, or both. Underscores (_) are not supported in server names. Server
names must conform to DNS syntax.

To specify a user name, use the following syntax:
userl@server-address

You cannot specify a UPN address, which includes the domain. To specify
the domain, you can use the domainName query part in the URL

To specify a port number, use the following syntax:
server-address:port-number

Specifies the desktop or application. Use the desktop display name or
application display name. This name is the one specified in View
Administrator when the desktop or application pool was created. If the
display name has a space in it, use the %20 encoding mechanism to represent
the space.

Specifies the configuration options to use or the desktop or application
actions to perform. Queries are not case-sensitive. To use multiple queries,
use an ampersand (&) between the queries. If queries conflict with each
other, the last query in the list is used. Use the following syntax:

queryl=valuel[&query2=value2...]

This topic lists the queries that are supported for this type of Horizon Client. If you are creating URIs for

multiple types of clients, such as desktop clients and mobile clients, see the Using VMware Horizon Client
guide for each type of client system.

action

Table 2-1. Values That Can Be Used With the action Query

Value Description

browse Displays a list of available desktops and applications hosted on the
specified server. You are not required to specify a desktop or
application when using this action.
If you use the browse action and specify a desktop or application,

the desktop or application is highlighted in the list of available
items.

start-session Opens the specified desktop or application. If no action query is
provided and the desktop or application name is provided,
start-session is the default action.
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args

appProtocol
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Table 2-1. Values That Can Be Used With the action Query (Continued)

Value Description

reset Shuts down and restarts the specified desktop or remote
application. Unsaved data is lost. Resetting a remote desktop is the
equivalent of pressing the Reset button on a physical PC.

logoff Logs the user out of the guest operating system in the remote
desktop. If you specify an application, the action is ignored or the
end user sees the warning message "Invalid URI action."

Specifies command-line arguments to add to remote application launch. Use
the syntax args=value, where value is a string. Use percent encoding for the
following characters:

m  For a colon (:), use %3A

m  For aback slash (\), use %5C

m  For a space (), use %20

m  For a double quotation mark ("), use %22

For example, to specify the filename "My new file.txt" for the Notepad++
application, use %22My%20new%20file. txt%22.

For remote applications, valid values are PCOIP and BLAST. For example, to
specify PColP, use the syntax appProtocol=PCOIP.

Connects a USB device to the foreground virtual desktop when you plug in
the device. This query is implicitly set if you specify the unattended query. To
use this query, you must set the action query to start-session or else not
have an action query. Valid values are true and false. An example of the
syntax is connectUSBOnInsert=true.

Redirects all USB devices that are currently connected to the client system to
the desktop. This query is implicitly set if you specify the unattended query.
To use this query, you must set the action query to start-session or else not
have an action query. Valid values are true and false. An example of the
syntax is connectUSBOnStartup=true.

Sets the size of the window that displays a remote desktop. To use this query,
you must set the action query to start-session or else not have an action

query.
Table 2-2. Valid Values for the desktopLayout Query

Value Description

fullscreen Full screen on all connected external monitors. This value is
the default.

windowlLarge Large window.
windowSmall Small window.
WxH Custom resolution, where you specify the width by height,

in pixels. An example of the syntax is
desktopLayout=1280x800.

For remote desktops, valid values are RDP, PCOIP, and BLAST. For example, to
specify PColP, use the syntax desktopProtocol=PCOIP.
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domainName The NETBIOS domain name associated with the user who is connecting to

the remote desktop or application. For example, you might use mycompany
rather than mycompany . com.

filePath Specifies the path to the file on the local system that you want to open with

the remote application. You can use the full path or relative path, for
example, ~/username/test%20file. txt. Use percent encoding for the
following characters:

m  For a colon (:), use %3A
m  For aback slash (\), use %5C
m  For a space (), use %20

For example, to represent file path /Users/username/test file.txt,
use /User/username/test%20file. txt.

Examples of vmware-view URIs

22

You can create hypertext links or buttons with the vmware-view URI scheme and include these links in email
or on a Web page. Your end users can click these links to, for example, open a particular remote desktop
with the startup options you specify.

URI Syntax Examples

Each URI example is followed by a description of what the end user sees after clicking the URI link.

1

vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session

Horizon Client starts and connects to the view.mycompany.com server. The login box prompts the user for
a user name, domain name, and password. After a successful login, the client connects to the desktop
whose display name is displayed as Primary Desktop, and the user is logged in to the guest operating
system.

Note The default display protocol and window size are used. The default display protocol is PColP.
The default window size is full screen.

vmware-view://view.mycompany.com:7555/Primary%20Desktop

This URI has the same effect as the previous example, except that it uses the nondefault port of 7555 for
Connection Server. (The default port is 443.) Because a desktop identifier is provided, the desktop opens
even though the start-session action is not included in the URIL

vmware-view://fred@view.mycompany.com/Finance%20Desktop?desktopProtocol=PCOIP

Horizon Client starts and connects to the view.mycompany . com server. In the login box, the User name
text box is populated with the name fred. The user must supply the domain name and password. After
a successful login, the client connects to the desktop whose display name is displayed as Finance
Desktop, and the user is logged in to the guest operating system. The connection uses the PCoIP
display protocol.

vmware-view://view.mycompany.com/Calculator?action=start-session&appProtocol=BLAST

Horizon Client starts and connects to the view.mycompany.com server. In the login box, the user must
supply the user name, domain name, and password. After a successful login, the client connects to the
application whose display name is displayed as Calculator. The connection uses the VMware Blast
display protocol.

vmware-view://fred@view.mycompany.com/Finance%20Desktop?domainName=mycompany
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Horizon Client starts and connects to the view.mycompany.com server. In the login box, the User name
text box is populated with the name fred, and the Domain text box is populated with mycompany. The
user must supply only a password. After a successful login, the client connects to the desktop whose
display name is displayed as Finance Desktop, and the user is logged in to the guest operating system.

6 vmware-view://view.mycompany.com/

Horizon Client starts and the user is taken to the login prompt for connecting to the
view.mycompany.com server.

7 vmware-view://view.mycompany.com/Primary%20Desktop?action=reset

Horizon Client starts and connects to the view.mycompany.com server. The login box prompts the user for
a user name, domain name, and password. After a successful login, Horizon Client displays a dialog
box that prompts the user to confirm the reset operation for Primary Desktop. After the reset occurs,
depending on the type of client, the user might see a message that indicates whether the reset was
successful.

Norte This action is available only if a View administrator has enabled this feature for end users.

8 vmware-view://
Horizon Client starts and the user is taken to the page for entering the address of a server.
9  vmware-view://10.10.10.10/My%20Notepad++?args=%22My%20new%20file. txt%22

Launches My Notepad++ on server 10.10.10.10 and passes the argument My new file.txt in the
application launch command. The filename is enclosed in double quotes because it contains spaces.

10 vmware-view://10.10.10.10/Notepad++%2012?args=a.txt%20b.txt

Launches Notepad++ 12 on server 10.10.10.10 and passes the argument a. text b.txt in the application
launch command. Because the argument is not enclosed in quotes, a space separates the filenames and
the two files are opened separately in Notepad-++.

Note Applications can differ in the way they use command line arguments. For example, if you pass
the argument a. txt b.txt to Wordpad, Wordpad will open only one file, a. txt.

HTML Code Examples

You can use URIs to make hypertext links and buttons to include in emails or on Web pages. The following
examples show how to use the URI from the first URI example to code a hypertext link that says, Test Link,
and a button that says, TestButton.

<html>
<body>

<a href="vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session">Test
Link</a><br>

<form><input type="button" value="TestButton"™ onClick="window.location.href=
></form> <br>

'vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session

</body>
</html>
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Managing Remote Desktop and
Application Connections

Use Horizon Client to connect to Connection Server or a security server and log in to or off of a remote
desktop, and use remote applications. For troubleshooting purposes, you can also reset remote desktops and
applications.

Depending on how the administrator configures policies for remote desktops, end users might be able to
perform many operations on their desktops.

This chapter includes the following topics:

m  “Connect to a Remote Desktop or Application,” on page 26

B “Open a Recent Remote Desktop or Application,” on page 28

m  “Share Access to Local Folders and Drives,” on page 28

m  “Connecting to a Server When Horizon Client Starts,” on page 30

m  “Configure Horizon Client to Forget the Server User Name and Domain,” on page 31
m  “Hide the VMware Horizon Client Window,” on page 31

m  “Configure Horizon Client to Select a Smart Card Certificate,” on page 31
m  “Configure Keyboard Shortcut Mappings,” on page 32

m  “Configure Mouse Shortcut Mappings,” on page 33

m  “Configure Horizon Client Shortcuts,” on page 34

m  “Setting the Certificate Checking Mode for Horizon Client,” on page 34

m  “Searching for Desktops or Applications,” on page 35

m  “Select a Favorite Remote Desktop or Application,” on page 36

m  “Switch Desktops or Applications,” on page 37

m  “Log Off or Disconnect,” on page 37

®  “Autoconnect to a Remote Desktop,” on page 39

m  “Configure Reconnect Behavior for Remote Applications,” on page 39

m  “Removing a Server Shortcut from the Home Screen,” on page 40

m  “Reordering Shortcuts,” on page 40
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Connect to a Remote Desktop or Application

26

After you connect to a server, you can open the remote desktops and applications that you are authorized to

use.

Before you have end users access remote desktops and applications, test that you can connect to a remote
desktop or application from the client system.

To use remote applications, you must connect to Connection Server 6.0 or later.

Prerequisites

m  Obtain credentials to log in, such as a user name and password, RSA SecurID user name and passcode,
RADIUS authentication user name and passcode, or smart card personal identification number (PIN).

m  Obtain the NETBIOS domain name for logging in. For example, you might use mycompany rather than
mycompany . com.

m  Perform the administrative tasks described in “Preparing Connection Server for Horizon Client,” on
page 11.

m  If you are outside the corporate network and are not using a security server to access the remote
desktop, verify that your client device is set up to use a VPN connection and turn on that connection.
ImpPORTANT VMware recommends using a security server rather than a VPN.

m  Verify that you have the fully qualified domain name (FQDN) of the server that provides access to the
remote desktop or application. Underscores (_) are not supported in server names. You also need the
port number if the port is not 443.

m  If you plan to use the RDP display protocol to connect to a remote desktop, verify that the
AllowDirectRDP agent group policy setting is enabled.

®  If your administrator has allowed it, you can configure the certificate checking mode for the SSL
certificate that the server presents. See “Setting the Certificate Checking Mode for Horizon Client,” on
page 34.

m  If you are using smart card authentication, you can configure Horizon Client to automatically use a
local certificate or the certificate on your smart card. See “Configure Horizon Client to Select a Smart
Card Certificate,” on page 31.

®  If end users are allowed to use the Microsoft RDP display protocol, verify that the client system has
Remote Desktop Connection Client for Mac from Microsoft, version 2.0 or later. You can download this
client from the Microsoft Web site.

Procedure

1 If a VPN connection is required, turn on the VPN.

2 Inthe Applications folder, double-click VMware Horizon Client.

3 Click Continue to start remote desktop USB and printing services, or click Cancel to use Horizon Client

without remote desktop USB and printing services.

If you click Continue, you must provide system credentials. If you click Cancel, you can enable remote
desktop USB and printing services later.

Note The prompt to start remote desktop USB and printing services appears the first time you start
Horizon Client. It does not appear again, regardless of whether you click Cancel or Continue.
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4  Connect to a server.

Option Description

Connect to a new server Click the New Server icon on the Horizon Client Home screen, enter the
server name and port number (if required), and click Connect. An example
using a non-default port is view.company.com:1443.

Connect to an existing server Double-click the server shortcut on the Horizon Client Home screen.

5 If you are prompted for RSA SecurID credentials or RADIUS authentication credentials, type the user
name and passcode and click Login.

6  Enter your user name and password and select a domain.

7  (Optional) Select the Remember this password check box if your administrator has enabled this feature
and if the server certificate can be fully verified.

8  Click Login.
You might see a message that you must confirm before the login dialog box appears.
9  If the desktop security indicator turns red and a warning message appears, respond to the prompt.

Usually, this warning means that Connection Server did not send a certificate thumbprint to the client.
The thumbprint is a hash of the certificate public key and is used as an abbreviation of the public key.

10 (Optional) If multiple display protocols are configured for a remote desktop or application, select the
protocol to use.

VMware Blast provides better battery life and is the best protocol for high-end 3D and mobile device
users. The default display protocol is PCoIP.

Option Description
Select a display protocol for a Select the remote desktop name, press Control-click, and select the display
remote desktop protocol from the context menu.

Alternatively, you can select Settings from the context menu and select the
display protocol from the Connect Via drop-down menu in the Settings

dialog box.
Select a display protocol for a Select the remote application name, press Control-click, select Settings
remote application from the context menu, and select the display protocol from the Preferred

protocol drop-down menu in the Settings dialog box.

11 Double-click a remote desktop or application to connect.

If you are connecting to a session-based remote desktop, which is hosted on a Microsoft RDS host, and
if the desktop is already set to use a different display protocol, you cannot connect immediately. You are
prompted to either use the protocol that is set or have the system log you off the remote operating
system so that a connection can be made with the protocol you selected.

Norte If you are entitled to only one remote desktop on the server, Horizon Client automatically
connects you to that desktop.

After you are connected, the client window appears.

The Sharing dialog box might appear. From the Sharing dialog box, you can allow or deny access to files on
your local system. For more information, see “Share Access to Local Folders and Drives,” on page 28.
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If Horizon Client cannot connect to the remote desktop or application, perform the following tasks:

®  Determine whether Connection Server is configured not to use SSL. Horizon Client requires SSL
connections. Check whether the global setting in View Administrator for the Use SSL for client
connections check box is deselected. If so, you must either select the check box, so that SSL is used, or
set up your environment so that clients can connect to an HTTPS enabled load balancer or other
intermediate device that is configured to make an HTTP connection to Connection Server.

m  Verify that the security certificate for Connection Server is working properly. If it is not, in View
Administrator, you might also see that View Agent or Horizon Agent on desktops is unreachable.

m  Verify that the tags set on the Connection Server instance allow connections from this user. See the View
Administration document.

m  Verify that the user is entitled to access the desktop or application. See the Setting Up Desktop and
Application Pools in View document.

m  If you are using the RDP display protocol to connect to a remote desktop, verify that the client
computer allows remote desktop connections.

Open a Recent Remote Desktop or Application

You can open recent remote desktops and applications in Horizon Client.

Recent remote desktops and applications appear in the order in which they were opened. If you are not
already connected to the server when you open a recent remote desktop or application, the server login
screen appears and you must provide your credentials.

Prerequisites

To use this feature, you must have previously opened a remote desktop or application. If you plan to open a
recent desktop or application from the Dock, VMware Horizon Client must be in the Dock. See “Add
Horizon Client to Your Dock,” on page 12.

Procedure

m  To open a remote desktop or application from the Dock, Ctrl-click VMware Horizon Client in the Dock
and select the remote desktop or application from the menu.

m  To open a remote desktop or application from the File menu, start Horizon Client, select File > Open
Recent, and select the remote desktop or application from the menu.

Share Access to Local Folders and Drives

28

You can configure Horizon Client to share folders and drives on your local system with remote desktops
and applications. Drives can include mapped drives and USB storage devices. This feature is called client
drive redirection.

In a Windows remote desktop, shared folders and drives appear in the Devices and drives section in the
This PC folder, or in the Other section in the Computer folder, depending on the Windows operating
system version. In a remote application, such as Notepad, you can browse to and open a file in a shared
folder or drive. The folders and drives you select for sharing appear in the file system as network drives that
use the naming format name on MACHINE-NAME.

You do not need to be connected to a remote desktop or application to configure client drive redirection
settings. The settings apply to all your remote desktops and applications. That is, you cannot configure the
settings so that local client folders are shared with one remote desktop or application but not with other
remote desktops or applications.
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You can turn on the ability to open local files with remote applications directly from your local file system. If
you select a local file and press Control-click, the Open With menu lists the available remote applications.
You can also open a local file by dragging and dropping it to the remote application window or Dock icon. If
you set a remote application as the default application for files that have a certain file extension, all files on
your local file system that have that file extension are registered with the server to which you are logged in.
You can also turn on the ability to run remote applications from the Applications folder.

Note You cannot open a file with a remote application if the filename contains characters that are invalid in
the Windows file system. For example, you cannot open Notepad and open a file named test2<. txt.

Configuring the browser on the client system to use a proxy server can cause poor client drive redirection
performance if the secure tunnel is enabled on the Connection Server instance. For the best client drive
redirection performance, configure the browser not to use a proxy server or automatically detect LAN
settings.

Prerequisites

To share folders and drives with a remote desktop or application, you must enable the client drive
redirection feature. This task includes installing View Agent 6.1.1 or later, or Horizon Agent 7.0 or later, and
enabling the agent Client Drive Redirection option. It can also include setting policies to control client drive
redirection behavior. For more information, see the Setting Up Desktop and Application Pools in View
document.

Procedure

1  Open the Preferences dialog box with the Sharing panel displayed.

Option Description

From the desktop and application Select VMware Horizon Client > Preferences and click Sharing.
selection window

From the Sharing dialog box that Click the Preferences > Sharing link in the dialog box.
appears when you connect to a
desktop or application

From within a desktop OS Select VMware Horizon Client > Preferences from the menu bar and click
Sharing.

2 Configure the client drive redirection settings.

Option Action

Share a specific folder or drive with  Click the plus (+) button, browse to and select the folder or drive to share,
remote desktops and applications and click Add.
Note You cannot share a folder on a USB device if the device is already
connected to a remote desktop or application with the USB redirection

feature.
Stop sharing a specific folder or Select the folder or drive in the Folder list and click the minus (-) button.
drive
Allow remote desktops and Select the Allow access to home-directory check box.

applications access to files in your
home directory
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Option

Action

Share USB storage devices with
remote desktops and applications

Select the Allow access to removable storage check box. The client drive
redirection feature automatically shares all USB storage devices inserted in
your client system and all FireWire and Thunderbolt-connected external
drives. You do not need to select a specific device to share.

Note USB storage devices already connected to a remote desktop or
application with the USB redirection feature are not shared.

If this check box is deselected, you can use the USB redirection feature to
connect USB storage devices to remote desktops and applications.

Do not show the Sharing dialog box
when you connect to a remote
desktop or application

Select the Do not show dialog when connecting to a desktop or
application check box.

If this check box is deselected, the Sharing dialog box appears the first time
you connect to a desktop or application after you connect to a server. For
example, if you log in to a server and connect to a desktop, you see the
Sharing dialog box. If you then connect to another desktop or application,
you do not see the dialog box again. To see the dialog box again, you must
disconnect from the server and then log in again.

3 Configure settings for remote applications.

a  Click the Settings button (gear icon) in the upper right corner of the desktop and application
selection window and select Applications in the left pane.

b Select Open local files in hosted applications to turn on the ability to open local files with remote
applications from the local file system.

¢ Select Run hosted applications from your local Applications folder to turn on the ability to run
remote applications from the Applications folder on the client system.

What to do next

Verify that you can see the shared folders from within the remote desktop or application:

m  From within a Windows remote desktop, open File Explorer and look in the Devices and drives section
in the This PC folder, or open Windows Explorer and look in the Other section in the Computer folder.

m  From within a remote application, if applicable, select File > Open or File > Save As and navigate to the
folder or drive, which appears in the file system as a network drive that uses the naming format folder-

name on MACHINE-NAME.

Connecting to a Server When Horizon Client Starts

The Always connect at launch setting is enabled by default for the first server that you connect to with
Horizon Client. When this setting is enabled for a server, Horizon Client always connects to that server

when you start Horizon Client.

To disable this behavior for a server, select the server shortcut on the Horizon Client Home screen, press
Control-click on the Apple keyboard, and deselect the Always connect at launch setting. If you have other
server shortcuts on your Horizon Client Home screen, you can enable the Always connect at launch setting

for a different server.

You can enable the Always connect at launch setting for only one server at a time.

30
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Configure Horizon Client to Forget the Server User Name and Domain

By default, Horizon Client stores the user name and domain that you enter when you log in to a server to
connect to a remote desktop or application. For increased security, you can configure Horizon Client to
never remember the server user name and domain.

Procedure

1  Select VMware Horizon Client > Preferences from the menu bar.
2 Click General in the Preferences dialog box.

3 Deselect Remember username and domain.

4  Close the Preferences dialog box.

Your changes take effect when the dialog box is closed.

Hide the VMware Horizon Client Window

You can hide the VMware Horizon Client window after you open a remote desktop or application.

You can also set a preference that always hides the VMware Horizon Client window after a remote desktop
or application opens.

Procedure

®  To hide the VMware Horizon Client window after you open a remote desktop or application, click the
Close button in the corner of the VMware Horizon Client window.

The VMware Horizon Client icon remains in the Dock.

m  To set a preference that always hides the VMware Horizon Client window after a remote desktop or
application opens, perform these steps before you connect to a server.

a Select VMware Horizon Client > Preferences from the menu bar and click General in the
Preferences dialog box.

b  Select Hide client window after desktop/application launched.
¢ Close the Preferences dialog box.
Your changes take effect when the dialog box is closed.

®  To show the VMware Horizon Client window after it has been hidden, select Window > Open
Selection Window from the menu bar, or right-click the VMware Horizon Client icon in the Dock and
select Show All Windows.

Configure Horizon Client to Select a Smart Card Certificate

You can configure Horizon Client to select a local certificate or the certificate on a smart card when you
authenticate to a server by setting a preference. If this preference is not set (the default), you must manually
select a certificate.

Prerequisites

For this setting to take effect, smart card authentication must be configured on the server and only one
certificate must be available on your client system or smart card. If you have multiple certificates,
Horizon Client always prompts you to select a certificate, regardless of how this preference is set.

Procedure

1  Before you connect to a server, select VMware Horizon Client > Preferences from the menu bar.
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2 Click General in the Preferences dialog box.
3 Select Automatically select certificate.
4 Close the Preferences dialog box.

Your changes take effect when the dialog box is closed.

Configure Keyboard Shortcut Mappings

You can customize how remote desktops and applications interpret Apple keyboard shortcuts by
configuring keyboard shortcut mappings.

When you create a keyboard shortcut mapping, you map an Apple keyboard shortcut to a Windows
keyboard shortcut. A keyboard shortcut consists of one or more key modifiers, such as Control and Shift,
and a key code. A key code can be any key on your keyboard, except for a modifier key. When you press a
mapped keyboard shortcut on your Apple keyboard, the corresponding Windows keyboard shortcut or
action occurs in the remote desktop or application.

Prerequisites

If you plan to map an operating system keyboard shortcut, see “Considerations for Mapping Operating
System Keyboard Shortcuts,” on page 33.

Procedure

1  Select VMware Horizon Client > Preferences and click Keyboard & Mouse.
2 Select the Key Mappings tab.

3 Configure the keyboard shortcut mappings.

Option Action
Delete a keyboard shortcut Select the mapping to delete and click the minus (-) button.
mapping

Add a keyboard shortcut mapping a  Click the plus (+) button.

b Specify the Apple keyboard shortcut sequence by clicking one or more
keyboard modifiers and typing a key code in the text box. You can also
select a key from the drop-down menu. The From: field shows the
keyboard shortcut that you created.

¢ Specify the corresponding Windows keyboard shortcut sequence by
clicking one or more keyboard modifiers and typing a key code in the
text box. You can also select a key from the drop-down menu. The To:
field shows the keyboard shortcut that you created.

d Click OK to save your changes.

The keyboard shortcut mapping is enabled by default (the On check box
next to the keyboard shortcut mapping is selected).

Modify a keyboard shortcut Double-click the mapping and make your changes.
mapping m  To modify the Apple keyboard shortcut sequence, click one or more
keyboard modifiers and type a key code in the text box. You can also
select a key from the drop-down menu.
m  To modify the corresponding Windows keyboard shortcut sequence,
click one or more keyboard modifiers and type a key code in the text
box. You can also select a key from the drop-down menu.

Click OK to save your changes.

Disable a keyboard shortcut Deselect the On check box next to the keyboard shortcut mapping. When
mapping you disable a keyboard shortcut mapping, Horizon Client does not send
the Apple keyboard shortcut to the remote desktop or application.
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Option Action

Enable or disable language-specific  Select or deselect the Enable Language Specific Key Mappings check box.

key mappings The check box is selected by default.

Restore the default mappings Click Restore Defaults. Any changes that you made to the default
keyboard shortcut mappings are deleted and the default mappings are
restored.

4  Close the Preferences dialog box.

Your keyboard shortcut mapping changes take effect immediately. You do not need to restart open
remote desktops or applications to see the changes take effect.

Considerations for Mapping Operating System Keyboard Shortcuts

Mac and Windows both include default keyboard shortcuts. For example, Command-Tab and Command-
Space bar are common keyboard shortcuts on Mac systems and Ctrl+Esc and Alt+Enter are common
keyboard shortcuts on Windows systems. If you attempt to map one of these operating system keyboard
shortcuts in Horizon Client, the behavior of the shortcut on your Mac client system and in the remote
desktop or application can be unpredictable.

m  If you map a keyboard shortcut, how the shortcut behaves on your Mac client system depends on how
the operating system manages the shortcut. For example, the keyboard shortcut might trigger an action
in the operating system and Horizon Client might not respond to the shortcut. Alternatively, the
keyboard shortcut might trigger an action in both the operating system and Horizon Client.

m  Before you map a Mac keyboard shortcut in Horizon Client, you must disable the shortcut in System
Preferences on your Mac client system. Not all Mac keyboard shortcuts can be disabled.

m  If you map a Windows keyboard shortcut in Horizon Client, the mapped action occurs when you use
the shortcut in the remote desktop or application.

m  For remote applications, Windows shortcuts that include the Windows key are disabled by default and
do not appear on the Horizon Client Keyboard Preferences dialog box. If you create a mapping for one
of these disabled keyboard shortcuts, the shortcut appears in the Keyboard Preferences dialog box.

For a list of the default Mac keyboard shortcuts, go to the Apple support website (http://support.apple.com).
For a list of the default Windows shortcuts, go to the Microsoft Windows website
(http://windows.microsoft.com).

Configure Mouse Shortcut Mappings

You can configure a single-button Apple mouse to send a right-click and a middle-click to remote desktops
and applications. You can modify, enable, or disable the default mouse shortcut mappings. You cannot
create new mouse shortcut mappings or delete the default mouse shortcut mappings.

Procedure
1  Select VMware Horizon Client > Preferences and click Keyboard & Mouse.
2 Select the Mouse Shortcuts tab.

3 Modify the mouse shortcut mappings.

Option Action

Modify a mouse shortcut mapping Double-click the mapping and make your changes. Click OK to save your
changes.

Disable a mouse shortcut mapping Deselect the On check box next to the mouse shortcut mapping. When you
disable a mouse shortcut mapping, Horizon Client does not send the
mouse shortcut to the remote desktop or application.
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Option Action

Enable a mouse shortcut mapping Select the On check box next to the mouse shortcut mapping. When you
enable a mouse shortcut mapping, Horizon Client sends the mouse
shortcut to the remote desktop or application.

Restore the default settings Click Restore Defaults. Any changes that you made to the default mouse
shortcut mappings are deleted and the default mappings are restored.

4  Close the Preferences dialog box.

Your mouse shortcut mapping changes take effect immediately. You do not need to restart open remote
desktops or applications to see the changes take effect.

Configure Horizon Client Shortcuts

Horizon Client includes preconfigured shortcut mappings for common Windows actions, including Toggle
Full Screen, Quit, Hide Application, Cycle Through Windows, and Cycle Through Windows in Reverse. It
also includes a preconfigured shortcut mapping for Toggle Exclusive Mode. You can enable or disable the
default shortcuts. You cannot create new shortcuts or delete the default shortcuts.

Procedure
1  Select VMware Horizon Client > Preferences and click Keyboard & Mouse.
2 Select the Horizon Shortcuts tab.

3 Configure the default shortcuts.

Option Action

Enable a shortcut Select the On check box next to the shortcut. When you enable a shortcut,
Horizon Client does not send the shortcut to the remote desktop or
application.

Disable a shortcut Deselect the On check box next to the shortcut. When you disable a
shortcut, Horizon Client sends the shortcut to the remote desktop or
application.

Note The behavior of the shortcut on the remote desktop or application
can be unpredictable.

Restore the default settings Click Restore Defaults. Any changes that you made are deleted and the
default settings are restored.

4  Close the Preferences dialog box.

Your changes take effect immediately. You do not need to restart open remote desktops or applications
to see the changes take effect.

Setting the Certificate Checking Mode for Horizon Client

34

Administrators and sometimes end users can configure whether client connections are rejected if any or
some server certificate checks fail.

Certificate checking occurs for SSL connections between Connection Server and Horizon Client. Certificate
verification includes the following checks:

m  Is the certificate intended for a purpose other than verifying the identity of the sender and encrypting
server communications? That is, is it the correct type of certificate?

m  Has the certificate expired, or is it valid only in the future? That is, is the certificate valid according to
the computer clock?
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m  Does the common name on the certificate match the host name of the server that sends it? A mismatch
can occur if a load balancer redirects Horizon Client to a server that has a certificate that does not match
the host name entered in Horizon Client. Another reason a mismatch can occur is if you enter an IP
address rather than a host name in the client.

m s the certificate signed by an unknown or untrusted certificate authority (CA)? Self-signed certificates
are one type of untrusted CA.

To pass this check, the certificate's chain of trust must be rooted in the device's local certificate store.

Note For information about distributing a self-signed root certificate and installing it on Mac client
systems, see the Advanced Server Administration document for the Mac Server that you are using, which is
available from the Apple Web site.

In addition to presenting a server certificate, Connection Server also sends a certificate thumbprint to
Horizon Client. The thumbprint is a hash of the certificate public key and is used as an abbreviation of the
public key. If Connection Server does not send a thumbprint, you see a warning that the connection is
untrusted.

If your administrator has allowed it, you can set the certificate checking mode. Select VMware Horizon
Client > Preferences from the menu bar. You have three choices:

m  Never connect to untrusted servers. If any of the certificate checks fails, the client cannot connect to the
server. An error message lists the checks that failed.

m  Warn before connecting to untrusted servers. If a certificate check fails because the server uses a self-
signed certificate, you can click Continue to ignore the warning. For self-signed certificates, the
certificate name is not required to match the server name you entered in Horizon Client.

m Do not verify server identity certificates. This setting means that no certificate checking occurs.

If the certificate checking mode is set to Warn, you can still connect to a Connection Server instance that uses
a self-signed certificate.

If an administrator later installs a security certificate from a trusted certificate authority, so that all certificate
checks pass when you connect, this trusted connection is remembered for that specific server. In the future,
if that server ever presents a self-signed certificate again, the connection fails. After a particular server
presents a fully verifiable certificate, it must always do so.

Searching for Desktops or Applications

After you connect to a View server, the available desktops and applications on that server appear on the
desktop and application selection window. You can search for a particular desktop or application by typing
in the window.

When you begin to type, Horizon Client highlights the first matching desktop or application name. To
connect to a highlighted desktop or application, press the Enter key. If you continue to type after the first
match is found, Horizon Client continues to search for matching desktops and applications. If

Horizon Client finds multiple matching desktops or applications, you can press the Tab key to switch to the
next match. If you stop typing for two seconds and then begin to type again, Horizon Client assumes that
you are starting a new search.
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Select a Favorite Remote Desktop or Application

36

You can select remote desktops and applications as favorites. Favorites are identified by a star. The star helps
you quickly find your favorite desktops and applications. Your favorite selections are saved, even after you
log off from the server.

Prerequisites

Obtain the credentials you need to connect to the server, such as a user name and password or RSA SecurID
and passcode.

Procedure
1  On the Horizon Client Home screen, double-click the server icon.

2 If prompted, supply your RSA user name and passcode, your Active Directory user name and
password, or both.

3 Perform these steps to select or deselect a desktop or application as a favorite.

Option Description

Select a favorite Select the desktop or application shortcut, press Control-click, and select
Mark as Favorite from the context menu. A star appears in the upper right
corner of the desktop or application shortcut.

Deselect a favorite Select the desktop or application shortcut, press Control-click, and deselect
Mark as Favorite from the context menu. A star no longer appears in the
upper right corner of the desktop or application shortcut.

4  (Optional) To display only favorite desktops or applications, click the Favorites button (star icon) in the
upper right corner of the desktop and application selection window.

You can click the Favorites button again to display all the available desktops and applications.
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Switch Desktops or Applications

If you are connected to a remote desktop, you can switch to another desktop. You can also connect to remote
applications while you are connected to a remote desktop.

Procedure

® Select a remote desktop or application from the same server or a different server.

Option

Action

Choose a different desktop or
application on the same server

Perform one of the following actions:

To keep the current desktop and also connect to another remote
desktop, select Window > VMware Horizon Client from the menu bar
and double-click the shortcut for the other desktop. That desktop
opens in a new window so that you have multiple desktops open. You
can switch between desktops from the Window menu on the menu
bar.

To close the current desktop and connect to another desktop, select
Connection > Disconnect from the menu bar and double-click the
shortcut for the other desktop.

To open another application, double-click the shortcut for the other
application. That application opens in a new window. You can have
multiple applications open and you can switch between them by
clicking in an application window.

Choose a different desktop or
application on a different server

If you are entitled to multiple desktops or applications, so that the desktop
and application selection window is open, click the Disconnect from
Server button in the left side of the toolbar in the desktop and application
selection window and disconnect from the server. If you are entitled to
only one desktop or application, and the desktop and application selection
window is not open, you can select File > Disconnect from Server from
the menu bar and then connect to a different server.

Log Off or Disconnect

With some configurations, if you disconnect from a remote desktop without logging off, applications in the

desktop can remain open. You can also disconnect from a server and leave remote applications running.

Even if you do not have a remote desktop open, you can log off of the remote desktop operating system.
Using this feature has the same result as sending Ctrl+Alt+Del to the desktop and then clicking Log Off.

Note The Windows key combination Ctrl+Alt+Del is not supported in remote desktops. To use the
equivalent of pressing Ctrl+Alt+Del, select Connection > Send Ctrl-Alt-Del from the menu bar.

Alternatively, you can press Fn-Control-Option-Delete on an Apple keyboard.

VMware, Inc.
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Procedure
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Disconnect from a remote desktop without logging off.

Option Action

Disconnect and quit Horizon Client a  Click the Close button in the corner of the window or select File >
Close from the menu bar.
b Select VMware Horizon Client > Quit VMware Horizon Client from
the menu bar.

Disconnect and remain in Click the Disconnect button in the toolbar or select Connection >
Horizon Client Disconnect from the menu bar.

Note Your View administrator can configure your desktop to automatically log off when
disconnected. In that case, any open applications in your desktop are stopped.

Log off and disconnect from a remote desktop.

Option Action
From within the desktop OS Use the Windows Start menu to log off.
From the menu bar Select Connection > Log Off from the menu bar.

If you use this procedure, files that are open on the remote desktop will be
closed without being saved first.

Disconnect from a remote application.

Option Action
Disconnect from the server and Perform one of the following actions:
leave the application running m  Click the Disconnect from Server button in the left side of the toolbar

in the desktop and application selection window.
m  Select File > Disconnect from Server from the menu bar.

Close the application and a  Quit the application in the usual manner, for example, click the Close
disconnect from the server button in the corner of the application window.
b Click the Disconnect from Server button in the left side of the toolbar
in the desktop and application selection window or select File >
Disconnect from Server from the menu bar.

Log off when you do not have a remote desktop open.

If you use this procedure, files that are open on the remote desktop will be closed without being saved
first.

Option Action

From the Home screen a  Double-click the server shortcut and supply credentials.

These credentials might include RSA SecurID credentials and
credentials for logging in to the desktop.

b Select the desktop and select Connection > Log Off from the menu bar.

From the desktop and application Select the desktop and select Connection > Log Off from the menu bar.
selection window
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Autoconnect to a Remote Desktop

You can configure a server to automatically open a remote desktop when you connect to the server.

If you are entitled to only one remote desktop on a server, Horizon Client opens that desktop when you
connect to the server.

Note You cannot configure a server to automatically open a remote application.

Prerequisites

Obtain credentials to connect to the server, such as a user name and password, RSA SecurID user name and
passcode, RADIUS authentication user name and passcode, or smart card personal identification number
(PIN).

Procedure
1  On the Horizon Client Home screen, double-click the server icon.
2 If prompted, supply your credentials.

3 Click the Settings button (gear icon) in the upper right corner of the desktop and application selection
window.

4  Select a desktop pool in the left pane of the Settings dialog box.
5 Select Autoconnect to this desktop.

6  Close the Settings dialog box to save your changes.

The next time you connect to the server, Horizon Client automatically opens the remote desktop.

Configure Reconnect Behavior for Remote Applications

If a user disconnects from a server without closing a remote application, Horizon Client prompts the user to
reopen that application the next time the user connects to the server. You can change this behavior by
modifying the Reconnect Behavior setting in Horizon Client.

Prerequisites

Obtain the credentials you need to connect to the server, such as a user name and password or RSA SecurID
user name and passcode.

Procedure
1  On the Horizon Client Home screen, double-click the server icon.
2 If prompted, supply your credentials.

3 Click the Settings button (gear icon) in the upper right corner of the desktop and application selection
window.

4  Select Applications in the left pane of the Settings dialog box.
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5  Select an application reconnect behavior option.

These options determine how Horizon Client behaves when a user connects to the server and remote
applications are still running.

Option Description
Ask to reconnect to open Horizon Client shows the message You have one or more remote
applications applications running. Would you like to open them now? . Users can

respond by clicking Reconnect to Applications or Not Now. Users can
also select the Don't show this message again. check box to suppress the
message in the future. This setting is enabled by default.

Reconnect automatically to open Horizon Client immediately reopens any running applications.
applications

Do not ask to reconnect and do not  Horizon Client does not prompt users to reopen running applications, nor
automatically reconnect does it reopen running applications. This setting has the same effect as the
Don't show this message again. check box.

6  Click Continue to save your changes.

The new setting takes effect the next time a user connects to the server.

Removing a Server Shortcut from the Home Screen

After you connect to a server, a server shortcut is saved to the Horizon Client Home screen.

You can remove a server shortcut by selecting the shortcut and pressing the Delete key or by Control-
clicking or right-clicking the shortcut on the Home screen and selecting Delete.

You cannot remove remote desktop or application shortcuts that appear after you connect to a server.

Reordering Shortcuts

40

You can reorder server, remote desktop, and remote application shortcuts.

Each time you connect to a server, Horizon Client saves a server shortcut to the Home screen. You can
reorder these server shortcuts by selecting a shortcut and dragging it to a new position on the Home screen.

After you connect to a server, the available desktops and applications on that server appear in the desktop
and application selection window. Desktop shortcuts appear first, followed by application shortcuts.
Desktop shortcuts and application shortcuts are arranged alphabetically and cannot be rearranged. When
you are in Favorites view (you clicked the Favorites button in the upper right corner of the desktop and
application selection window), you can reorder desktop and application shortcuts by selecting a shortcut
and dragging it to a new position on the window.
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Horizon Client for Mac supports several features.

This chapter includes the following topics:

m  “Feature Support Matrix for Mac,” on page 41

®  “Internationalization,” on page 44

B “Monitors and Screen Resolution,” on page 44

m  “Using Exclusive Mode,” on page 45

m “Connect USB Devices,” on page 46

m  “Using the Real-Time Audio-Video Feature for Webcams and Microphones,” on page 53
m  “Copying and Pasting Text and Images,” on page 57

m  “Using Remote Applications,” on page 58

®  “Saving Documents in a Remote Application,” on page 59

m  “Clicking URL Links That Open Outside of Horizon Client,” on page 60
m  “Printing from a Remote Desktop or Application,” on page 60

m  “PColP Client-Side Image Cache,” on page 62

Feature Support Matrix for Mac
Some features are supported on one type of Horizon Client but not on another.

Table 4-1. Features Supported on Windows Desktops for Mac Clients

Windows
Server
2008/2012 R2 or
Windows Windows Windows Windows
10 Windows Windows 7 Vista XP Server 2016
Feature Desktop 8.x Desktop  Desktop Desktop Desktop Desktop
RSA SecurID or X X X Limited Limited X
RADIUS
Single sign-on X X X Limited Limited X
PColP display protocol X X X Limited Limited X
RDP display protocol X X X Limited Limited X
VMware Blast display X X X X
protocol
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Table 4-1. Features Supported on Windows Desktops for Mac Clients (Continued)

Windows
Server
2008/2012 R2 or
Windows Windows Windows Windows
10 Windows Windows 7  Vista XP Server 2016
Feature Desktop 8.x Desktop  Desktop Desktop Desktop Desktop
USB redirection X X X Limited Limited X
Client drive redirection X X X X
Real-Time Audio- X X X Limited Limited X
Video (RTAV)
Wyse MMR
Windows 7 MMR
Virtual printing X X X Limited Limited
Location-based X X X Limited Limited
printing
Smart cards X X X Limited Limited
Multiple monitors X X X Limited Limited

Windows 10 desktops require View Agent 6.2 or later or Horizon Agent 7.0 or later. Windows Server 2012
R2 desktops require View Agent 6.1 or later or Horizon Agent 7.0 or later. Windows Server 2016 desktops
require Horizon Agent 7.0.2 or later.

ImpPoORTANT View Agent 6.1 and later and Horizon Agent 7.0 and later releases do not support Windows XP
and Windows Vista desktops. View Agent 6.0.2 is the last View release that supports these guest operating
systems. Customers who have an extended support agreement with Microsoft for Windows XP and Vista,
and an extended support agreement with VMware for these guest operating systems, can deploy the View
Agent 6.0.2 version of their Windows XP and Vista desktops with Connection Server 6.1.

For descriptions of these features, see the View Planning document.

Feature Support for Session-Based Desktops on RDS Hosts

RDS hosts are server computers that have Windows Remote Desktop Services and View Agent or
Horizon Agent installed. Multiple users can have desktop sessions on an RDS host simultaneously. An RDS
host can be either a physical machine or a virtual machine.

Note The following table contains rows only for the features that are supported. Where the text specifies a
minimum version of View Agent, the text "and later" is meant to include Horizon Agent 7.0.x and later.

Table 4-2. Features Supported for RDS Hosts with View Agent 6.0.x or Later, or Horizon Agent 7.0.x or
Later, Installed

Windows Server 2008 R2 Windows Server 2012 Windows Server 2016 RDS

Feature RDS Host RDS Host Host

RSA SecurID or RADIUS X X Horizon Agent 7.0.2 and later
Smart card View Agent 6.1 and later View Agent 6.1 and later =~ Horizon Agent 7.0.2 and later
Single sign-on X X Horizon Agent 7.0.2 and later
PColP display protocol X X Horizon Agent 7.0.2 and later
VMware Blast display Horizon Agent 7.0 and later =~ Horizon Agent 7.0 and Horizon Agent 7.0.2 and later
protocol later
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Table 4-2. Features Supported for RDS Hosts with View Agent 6.0.x or Later, or Horizon Agent 7.0.x or
Later, Installed (Continued)

Windows Server 2008 R2 Windows Server 2012 Windows Server 2016 RDS

Feature RDS Host RDS Host Host
HTML Access View Agent 6.0.2 and later View Agent 6.0.2 and Horizon Agent 7.0.2 and later
(virtual machine only) later (virtual machine
only)
USB redirection (USB View Agent 6.1 and later =~ Horizon Agent 7.0.2 and later
storage devices only)
Client drive redirection View Agent 6.1.1 and later View Agent 6.1.1 and Horizon Agent 7.0.2 and later
later
Virtual printing (for desktop ~ View Agent 6.0.1 and later View Agent 6.0.1 and Horizon Agent 7.0.2 and later
clients) (virtual machine only) later (virtual machine (virtual machine only)
only)
Location-based printing View Agent 6.0.1 and later View Agent 6.0.1 and Horizon Agent 7.0.2 and later
(virtual machine only) later (virtual machine (virtual machine only)
only)
Multiple monitors (for X X Horizon Agent 7.0.2 and later
desktop clients)
Unity Touch (for mobile and X X Horizon Agent 7.0.2 and later
Chrome OS clients)
Real-Time Audio-Video Horizon Agent 7.0.2 and Horizon Agent 7.0.2and  Horizon Agent 7.0.3 and later
(RTAV) later later

For information about which editions of each guest operating system are supported, or which service packs,
see the "Supported Operating Systems for View Agent" topic in the View 5.x or 6.x installation
documentation. See the "Supported Operating Systems for Horizon Agent" topic in the Horizon 7
installation documentation.

Limitations for Specific Features

Specific features that are supported on Windows desktops for Horizon Client for Mac have certain
restrictions.

Table 4-3. Requirements for Specific Features

Feature Requirements

RDP connection with a Windows 8.1 or later desktop See the VMware KB article at
http://kb.vmware.com/kb/2059786.

Real-Time Audio-Video See “System Requirements for Real-Time Audio-Video,” on
page 8.

Virtual printing and location-based printing for Windows Horizon 6.0.1 with View and later servers.

Server 2008 R2 desktops, RDS desktops (on virtual machine
RDS hosts), and remote applications
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Table 4-3. Requirements for Specific Features (Continued)

Feature Requirements

Smart cards For session-based desktops on RDS hosts, View Agent 6.1
and later.

Client drive redirection View Agent 6.1.1 and later or Horizon Agent 7.0 and later.

Note You can also use Horizon Client to securely access remote Windows-based applications, in addition
to remote desktops. Selecting an application in Horizon Client opens a window for that application on the
local client device, and the application looks and behaves as if it were locally installed.

You can use remote applications only if you are connected to Connection Server 6.0 or later. For information
about which operating systems are supported for the RDS (Remote Desktop Sessions) host, which provides
remote applications and session-based desktops, see "Supported Operating Systems for Horizon Agent"
topic in the View 5.x or 6.x installation documentation. See the "Supported Operating Systems for

Horizon Agent" topic in the Horizon 7 installation documentation.

Feature Support for Linux Desktops

Some Linux guest operating systems are supported if you have View Agent 6.1.1 or later or Horizon Agent
7.0 or later. For a list of supported Linux operating systems and information about supported features, see
Setting Up Horizon 6 for Linux Desktops or Setting Up Horizon 7 for Linux Desktops.

Internationalization

The user interface and documentation are available in English, Japanese, French, German, Simplified
Chinese, Traditional Chinese, Korean, and Spanish.

Monitors and Screen Resolution

44

When you use the VMware Blast display protocol or the PColP display protocol, you can extend a remote
desktop to multiple monitors. If you have a Mac with Retina Display, you can see the remote desktop in full
resolution.

Using Multiple Monitors

With the VMware Blast display protocol or the PCoIP display protocol, a remote desktop screen resolution
of 4K (3840 x 2160) is supported. The number of 4K displays that are supported depends on the hardware
version of the desktop virtual machine and the Windows version.

Number of 4K Displays

Hardware Version Windows Version Supported
10 (ESXi 5.5.x compatible) 7, 8, 8.x, 10 1
11 (ESXi 6.0 compatible) 7 (3D rendering feature disabled and Windows Aero 3
disabled)
11 7 (3D rendering feature enabled) 1
11 8,8.x, 10 1

The remote desktop must have View Agent 6.2 or later, or Horizon Agent 7.0 or later, installed. For best
performance, the virtual machine should have at least 2 GB of RAM and 2 vCPUs. This feature might
require good network conditions, such as a bandwidth of 1000 Mbps with low network latency and a low
package loss rate.
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Using Full-Screen Mode With Multiple Monitors

When a remote desktop window is open, you can use the Window > Enter Full Screen menu item or the
expander arrows in the upper-right corner of the desktop window to extend the remote desktop across
multiple monitors. You can select the Window > Use Single Display in Full Screen menu item to make the
remote desktop fill only one monitor. With this option, the monitors do not have to be in the same mode. For
example, if you are using a laptop connected to an external monitor, the external monitor can be in portrait
mode or landscape mode.

You can select a full-screen option from the Settings dialog box after you connect to a server and before you
open a remote desktop. Click the Settings button (gear icon) in the upper right corner of the desktop and
application selection window, select the remote desktop, and select a full-screen option from the Full Screen
drop-down menu.

Using Remote Desktops With Split View

With Split View, which is supported in El Capitan (10.11) and later operating systems, you can fill your Mac
screen with two applications without manually moving and resizing windows. You can use Split View with
remote desktops in full-screen mode (Full Screen or Use Single Display in Full Screen option).

Using a High-Resolution Mac With Retina Display

When you use the VMware Blast display protocol or the PColIP display protocol, Horizon Client also
supports very high resolutions for those client systems with Retina Display. After you connect to a remote
desktop, you can select the Connection > Resolution > Full Resolution menu item. This menu item appears
only if the client system supports Retina Display.

If you use Full Resolution, the icons on the remote desktop are smaller but the display is sharper.

Using Exclusive Mode

Exclusive mode is similar to full-screen mode in that the remote desktop fills the screen. Unlike full-screen
mode, with exclusive mode the VMware Horizon Client menu bar and Dock do not appear when you move
your cursor to the edges of the screen.

To enter exclusive mode, open a remote desktop in windowed mode, press and hold down the Option key,
and select Window > Enter Exclusive Mode.

When a remote desktop is in windowed mode, you can also press Command-Control-Option-F to enter
exclusive mode. To exit exclusive mode, press Command-Control-Option-F again.

Norte If you do not press and hold down the Option key, the Enter Full Screen menu item appears instead
of the Enter Exclusive Mode menu item. You cannot select the Enter Excusive Mode menu item if the
remote desktop is in full-screen mode.

Using Exclusive Mode with Multiple Monitors

To use exclusive mode with two monitors, before you open the remote desktop, select Use All Displays
from the Settings dialog box, and then open the desktop and enter exclusive mode. To use exclusive mode
with a single monitor, before you open the remote desktop, select Use Single Display from the Settings
dialog box, and then connect to the desktop and enter exclusive mode.

To open the Settings dialog box, click the Settings button (gear icon) in the upper right corner of the desktop
and application window, select the remote desktop, and select an option from the Full Screen drop-down
menu.
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Connect USB Devices
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You can use locally attached USB devices, such as thumb flash drives, cameras, and printers, from a remote
desktop. This feature is called USB redirection.

When you use this feature, most USB devices that are attached to the local client system become available
from a menu in Horizon Client. You use the menu to connect and disconnect the devices.

With View Agent 6.1 or later, or Horizon Agent 7.0 or later, you can also redirect locally connected USB
thumb flash drives and hard disks for use in RDS desktops and applications. Other types of USB devices,
including other types of storage devices, such as security storage drives and USB CD-ROM, are not
supported in RDS desktops and applications. The server that hosts the RDS desktop or application must be
running Windows Server 2012 or later.

If you use the client drive redirection feature to share a USB storage device or a folder on a USB storage
device, you cannot use the USB redirection feature to redirect the device to a remote desktop or application
because the device is already shared.

Using USB devices with remote desktops has the following limitations:

®  When you access a USB device from a menu in Horizon Client and use the device in a remote desktop,
you cannot access the device on the local computer.

m  USB devices that do not appear in the menu, but are available in a remote desktop, include human
interface devices such as keyboards and pointing devices. The remote desktop and the local computer
use these devices at the same time. Interaction with these devices can sometimes be slow because of
network latency.

m  Large USB disk drives can take several minutes to appear in the desktop.

m  Some USB devices require specific drivers. If a required driver is not already installed on a remote
desktop, you might be prompted to install it when you connect the USB device to the remote desktop.

m  If you plan to attach USB devices that use MTP drivers, such as Android-based Samsung smart phones
and tablets, configure Horizon Client so that it automatically connects USB devices to your remote
desktop. Otherwise, if you try to manually redirect the USB device by using a menu item, the device is
not redirected unless you unplug the device and then plug it in again.

m  Webcams are not supported for USB redirection.

m  The redirection of USB audio devices depends on the state of the network and is not reliable. Some
devices require a high data throughput even when they are idle.

You can connect USB devices to a remote desktop either manually or automatically.

Note Do not redirect USB Ethernet connections to the remote desktop. Your remote desktop can connect to
your network if your local system is connected. If you have set your remote desktop to autoconnect USB
devices, you can add an exception to exclude your Ethernet connection. See “Configuring USB Redirection
on a Mac Client,” on page 48 .

Prerequisites

m  To use USB devices with a remote desktop, a View administrator must have enabled the USB feature for
the remote desktop.

This task includes installing the USB Redirection component of the agent, and can include setting
policies regarding USB redirection. For more information, see the View Administration document if you
are using Connection Server and Agent 5.3.x. See Setting Up Desktop and Application Pools in View if you
are using Connection Server and Agent 6.0 or later.
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m  The first time you attempt to connect a USB device, you must provide the Administrator password.
Horizon Client prompts you for the password.

Some components required for USB redirection that Horizon Client installs must be configured, and
configuration of these components requires Administrator privileges.

Procedure

®  Manually connect the USB device to a remote desktop.

a

d

The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

Connect the USB device to your local client system.

From the VMware Horizon Client menu bar, click Connection > USB > Connect to a desktop to list
USB devices.

Connect to a remote desktop to list the connected USB devices and select a USB device.

The device is manually redirected from the local system to the remote desktop.

m  Connect the USB device to a remote hosted application.

a
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The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

Plug in the USB device.
Open the remote application.

Click the Settings button (gear icon) in the upper right corner of the desktop and application
selection window.

Select Applications in the left pane of the Settings dialog box.
Click USB at the top of the right pane of the Settings dialog box.
The available USB devices appear in the left pane.

Select a USB device and click Connect Device.

If a USB device is already connected to a remote desktop or application, you must disconnect the
device from the desktop or application before you can select it.

Select a remote application and click Continue.

You can select any running application on the RDS host. After you select a remote application, you
can use the USB device with the remote application.

After you finish using the remote application, open the Settings dialog box again, select USB, and
select Disconnect to release the USB device from the remote application.

You can now use the USB device with your local client system, a remote desktop, or another remote
application.
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m  Configure Horizon Client to connect USB devices automatically to the remote desktop when you plug
them in to the local system.

Use the autoconnect feature if you plan to connect devices that use MTP drivers, such as Android-based
Samsung smart phones and tablets.

a  Before you plug in the USB device, start Horizon Client and connect to a remote desktop.

b The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

¢ From the VMware Horizon Client menu bar, click Connection > USB > Automatically connect
when inserted.

d  Plug in the USB device.

USB devices that you connect to your local system after you start Horizon Client are redirected to the
remote desktop.

m  Configure Horizon Client to connect USB devices automatically to the remote desktop when
Horizon Client starts.

a  The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

b  From the VMware Horizon Client menu bar, click Connection > USB > Automatically connect at
startup.

¢ Plugin the USB device and restart Horizon Client.
USB devices that are connected to the local system when you start Horizon Client are redirected to the
remote desktop.
The USB device appears in the desktop. A USB device might take up to 20 seconds to appear in the desktop.
The first time you connect the device to the desktop you might be prompted to install drivers.

If the USB device does not appear in the desktop after several minutes, disconnect and reconnect the device
to the client computer.

What to do next

If you have problems with USB redirection, see the topic about troubleshooting USB redirection problems in
the Setting Up Desktop and Application Pools in View document.

Configuring USB Redirection on a Mac Client

Administrators can configure the client system to specify which USB devices can be redirected to a remote
desktop.

You can configure USB policies for both View Agent or Horizon Agent, on the remote desktop, and
Horizon Client, on the local system, to achieve the following goals:

B Restrict the types of USB devices that Horizon Client makes available for redirection.

m  Make View Agent or Horizon Agent prevent certain USB devices from being forwarded from a client
computer.

m  Specify whether Horizon Client should split composite USB devices into separate components for
redirection.

Composite USB devices consist of a combination of two or more devices, such as a video input device
and a storage device.
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Configuration settings on the client might be merged with or overridden by corresponding policies set for
View Agent or Horizon Agent on the remote desktop. For information about how USB settings on the client
work in conjunction with View Agent or Horizon Agent USB policies, see the topics about using policies to
control USB redirection, in the Setting Up Desktop and Application Pools in View document.

Syntax for Configuring USB Redirection

You can configure filtering and splitting rules to exclude or include USB devices from being redirected to a
remote desktop. On a Mac client, you configure USB functionality by using Terminal

(/Applications/Utilities/Terminal.app) and running a command as root.

VMware, Inc.

To list the rules:

# sudo defaults read domain

For example:

# sudo defaults read com.vmware.viewusb

To remove a rule:

# sudo defaults delete domain property

For example:

# sudo defaults delete com.vmware.viewusb ExcludeVidPid
To set or replace a filter rule:

# sudo defaults write domain property value
For example:

# sudo defaults write com.vmware.viewusb ExcludeVidPid vid-1234_pid-5678

IMPORTANT Some configuration parameters require the VID (vendor ID) and PID (product ID) for a
USB device. To find the VID and PID, you can search on the Internet for the product name combined
with vid and pid. Alternatively, you can look in the USB Log file after you plug in the USB device to the
local system when Horizon Client is running. For more information, see “Turn on Logging for USB
Redirection,” on page 53.

To set or replace a splitting rule for a composite device:
# sudo defaults write domain property value
For example:

# sudo defaults write com.vmware.viewusb AllowAutoDeviceSplitting true

# sudo defaults write com.vmware.viewusb SplitExcludeVidPid vid-03f0_Pid-2al2

# sudo defaults write com.vmware.viewusb SplitVidPid "'vid-0911_Pid-149a(exintf:03)"'"

# sudo defaults write com.vmware.viewusb IncludeVidPid vid-0911_Pid-149a

Composite USB devices consist of a combination of two or more devices, such as a video input device
and a storage device. The first line in this example turns on automatic splitting of composite devices.
The second line excludes the specified composite USB device (Vid-03f0_Pid-2al2) from splitting.

The third line tells Horizon Client to treat the components of a different composite device
(Vid-0911_Pid-149a) as separate devices but to exclude the following component from being redirected:
the component whose interface number is 03. This component is kept local.
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Because this composite device includes a component that is ordinarily excluded by default, such as a
mouse or keyboard, the fourth line is necessary so that the other components of the composite device
Vid-0911_Pid-149a can be redirected to the remote desktop.

The first three properties are splitting properties. The last property is a filtering property. Filtering
properties are processed before splitting properties.

Example: Excluding a USB Ethernet Device

One example of a USB device you might want to exclude from redirection is a USB Ethernet device. Suppose
that your Mac is using a USB Ethernet device to connect the network for the Mac client system to a remote
desktop. If you redirect the USB Ethernet device, your local client system will lose its connection to the

network and the remote desktop.

If you want to permanently hide this device from the USB connection menu, or if you have set your remote

desktop to autoconnect USB devices, you can add an exception to exclude your Ethernet connection.

sudo defaults write com.vmware.viewusb ExcludeVidPid vid-xxxx_pid-yyyy

In this example, xxxx is the vendor ID and yyyy is the product ID of the USB Ethernet adapter.

USB Redirection Properties

When creating filtering rules, you can use the USB redirection properties.

Table 4-4. Configuration Properties for USB Redirection

Policy Name and Property

Description

Allow Auto Device Splitting
Property:
AllowAutoDeviceSplitting

Allow the automatic splitting of composite USB devices.

The default value is undefined, which equates to false.

Exclude Vid/Pid Device From Split

Excludes a composite USB device specified by vendor and product IDs from

Property: splitting. The format of the setting is vid-xxx1_pid-yyyl[;vid-xxx2_pid-yyy2]...
SplitExcludeVidPid You must specify ID numbers in hexadecimal. You can use the wildcard character
(*) in place of individual digits in an ID.
For example: vid-0781_pid-55%*
The default value is undefined.
Split Vid/Pid Device Treats the components of a composite USB device specified by vendor and product
Property: IDs as separate devices. The format of the setting is
Splitvidprid vid-xxxx_pid-yyyy([exintf:zz[;exintf:ww ID[;...]

You can use the exintf keyword to exclude components from redirection by
specifying their interface number. You must specify ID numbers in hexadecimal,
and interface numbers in decimal including any leading zero. You can use the
wildcard character (*) in place of individual digits in an ID.

For example: vid-0781_pid-554c(exintf:01;exintf:02)

Norte If the composite device includes components that are automatically
excluded, such as mouse and keyboard components, then View does not
automatically include the components that you have not explicitly excluded. You
must specify a filter policy such as Include Vid/Pid Device to include those
components.

The default value is undefined.

Allow Audio Input Devices
Property:
AllowAudioIn

Allows audio input devices to be redirected.

The default value is undefined, which equates to true.

Allow Audio Output Devices
Property:
AllowAudioOut

Allows audio output devices to be redirected.

The default value is undefined, which equates to false.
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Table 4-4. Configuration Properties for USB Redirection (Continued)

Policy Name and Property

Description

Allow HID Allows input devices other than keyboards or mice to be redirected.

Property: The default value is undefined, which equates to true.

AllowHID

Allow HIDBootable Allows input devices other than keyboards or mice that are available at boot time
Property: (also known as hid-bootable devices) to be redirected.

AllowHIDBootable The default value is undefined, which equates to true.

Allow Device Descriptor Failsafe
Property:
AllowDevDescFailsafe

Allows devices to be redirected even if the Horizon Client fails to get the
config/device descriptors.

To allow a device even if it fails the config/desc, include it in the Include filters, such
IncludeVidPid or IncludePath.

The default value is undefined, which equates to false.

Allow Keyboard and Mouse Devices

Allows keyboards with integrated pointing devices (such as a mouse, trackball, or

Property: touch pad) to be redirected.

AllowKeyboardMouse The default value is undefined, which equates to false.
Allow Smart Cards Allows smart-card devices to be redirected.

Property: The default value is undefined, which equates to false.
AllowSmartcard

Allow Video Devices
Property:
AllowVideo

Allows video devices to be redirected.

The default value is undefined, which equates to true.

Disable Remote Configuration Download

Disables the use of View Agent or Horizon Agent settings when performing USB

Property: device filtering.

DisableRemoteConfig The default value is undefined, which equates to false.

Exclude All Devices Excludes all USB devices from being redirected. If set to true, you can use other
Property: policy settings to allow specific devices or families of devices to be redirected. If set
ExcludeAllDevices to false, you can use other policy settings to prevent specific devices or families of

devices from being redirected.

If you set the value of Exclude All Devices to true on View Agent or
Horizon Agent, and this setting is passed to Horizon Client, the View Agent or
Horizon Agent setting overrides the Horizon Client setting.

The default value is undefined, which equates to false.

Exclude Device Family

Excludes families of devices from being redirected. The format of the setting is

Property: family_name_1[; family_name_2]...
ExcludeFamily For example: bluetooth;smart-card
The default value is undefined.
Norte If you have enabled automatic device splitting, View examines the device
family of each interface of a composite USB device to decide which interfaces
should be excluded. If you have disabled automatic device splitting, View examines
the device family of the whole composite USB device.
Exclude Vid/Pid Device Excludes devices with specified vendor and product IDs from being redirected. The
Property: format of the setting is vid-xxx1_pid-yyy2[;vid-xxx2_pid-yyy2]...
ExcludeVidPid You must specify ID numbers in hexadecimal. You can use the wildcard character
(*) in place of individual digits in an ID.
For example: vid-0781_pid—****;vid-0561_pid-554c
The default value is undefined.
Exclude Path Exclude devices at specified hub or port paths from being redirected. The format of
Property: the setting is bus—x1[/y1]..._port-zI1[;bus—x2[/y2]..._port-z2]...
ExcludePath You must specify bus and port numbers in hexadecimal. You cannot use the

wildcard character in paths.
For example: bus-1/2/3_port-02;bus-1/1/1/4_port-ff
The default value is undefined.
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Table 4-4. Configuration Properties for USB Redirection (Continued)

Policy Name and Property

Description

Include Device Family

Includes families of devices that can be redirected. The format of the setting is

Property: family_name_1[; family_name_2]...
IncludeFamily For example: storage
The default value is undefined.
Include Path Include devices at a specified hub or port paths that can be redirected. The format of
Property: the setting is bus—x1[/y1]..._port—z1[;bus-x2[/y2]..._port-z2]...
IncludePath You must specify bus and port numbers in hexadecimal. You cannot use the
wildcard character in paths.
For example: bus-1/2_port-02;bus-1/7/1/4_port-0f
The default value is undefined.
Include Vid/Pid Device Includes devices with specified vendor and product IDs that can be redirected. The
Property: format of the setting is vid-xxx1_pid-yyy2[;vid-xxx2_pid-yyy2]...
IncludeVidPid You must specify ID numbers in hexadecimal. You can use the wildcard character

(*) in place of individual digits in an ID.
For example: vid-0561_pid-554c
The default value is undefined.

USB Device Families

You can specify a family when you are creating USB filtering rules for Horizon Client, or View Agent or

Horizon Agent.

Note Some devices do not report a device family.

Table 4-5. USB Device Families

Device Family

Name Description

audio Any audio-input or audio-output device.

audio-in Audio-input devices such as microphones.

audio-out Audio-output devices such as loudspeakers and headphones.

bluetooth Bluetooth-connected devices.

comm Communications devices such as modems and wired networking adapters.
hid Human interface devices excluding keyboards and pointing devices.

hid-bootable

Human interface devices that are available at boot time excluding keyboards and pointing devices.

imaging Imaging devices such as scanners.

keyboard Keyboard device.

mouse Pointing device such as a mouse.

other Family not specified.

pda Personal digital assistants.

physical Force feedback devices such as force feedback joysticks.
printer Printing devices.

security Security devices such as fingerprint readers.

smart-card

Smart-card devices.

storage

Mass storage devices such as flash drives and external hard disk drives.

unknown

Family not known.
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Table 4-5. USB Device Families (Continued)

Device Family

Name Description

vendor Devices with vendor-specific functions.
video Video-input devices.

wireless Wireless networking adapters.

wusb Wireless USB devices.

Turn on Logging for USB Redirection

You can use USB logs to troubleshoot and to determine the product ID and vendor ID of various devices you
plug in to the client system.

You can enable trace logging either just for the current session or across reboots. To enable logging for the
current session, you use a shell command. To enable logging across reboots, add the shell command to the
appropriate profile file.

Prerequisites

If you plan to configure trace logging to persist across system reboots, you must have Administrator or root
permissions on the client system. This prerequisite does not apply if you plan to enable logging for the
current session only.

Procedure
m  To enable logging for the current session only, use the launchctl command.
a  Quit Horizon Client so that the USB service daemon is stopped.
b Open ashell (/Applications/Utilities/Terminal.app) as the same user who starts Horizon Client.
¢ Use the following command:
launchctl setenv VMWARE_VIEW_USBD_LOG_OPTIONS "-o log:trace"
d  Restart Horizon Client.

m  To enable logging across reboots, add the launchctl command to the appropriate shell rc or profile file
for your choice of shell, such as ~/.bash_profile for the default Mac shell.

Following is an example of the launchctl command to add:

setenv VMWARE_VIEW_USBD_LOG_OPTIONS "-o log:trace"

Using the Real-Time Audio-Video Feature for Webcams and
Microphones

With the Real-Time Audio-Video feature, you can use your local computer's webcam or microphone on your
remote desktop. Real-Time Audio-Video is compatible with standard conferencing applications and
browser-based video applications, and supports standard webcams, audio USB devices, and analog audio
input.

For information about setting up the Real-Time Audio-Video feature and configuring the frame rate and
image resolution in a remote desktop, see the VMuware Horizon View Feature Pack Installation and
Administration document (for View 5.3.x desktops) or the Setting Up Desktop and Application Pools in View
document (for Horizon 6.0 with View and later desktops). For information about configuring these settings
on client systems, see the VMware knowledge base article Setting Frame Rates and Resolution for Real-Time
Audio-Video on Horizon View Clients, at http://kb.vmware.com/kb/2053644.
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To download a test application that verifies the correct installation and operation of the Real-Time Audio-
Video functionality, go to http://labs.vmware.com/flings/real-time-audio-video-test-application. This test
application is available as a VMware fling, and therefore no technical support is available for it.

When You Can Use Your Webcam

If a View administrator has configured the Real-Time Audio-Video feature, and if you use the VMware Blast
display protocol or the PColP display protocol, a webcam that is built-in or connected to your local
computer can be used on your desktop. You can use the webcam in conferencing applications such as Skype,
Webex, or Google Hangouts.

During the setup of an application such as Skype, Webex, or Google Hangouts on your remote desktop, you
can choose input and output devices from menus in the application. For virtual machine desktops, you can
choose VMware Virtual Microphone and VMware Virtual Webcam. For RDS desktops, you can choose
Remote Audio Device and VMware Virtual Webcam.

With many applications, however, this feature will just work, and selecting an input device will not be
necessary.

If the webcam is currently being used by your local computer, it can be used by the remote desktop
simultaneously. Also, if the webcam is being used by the remote desktop, it can be used by your local
computer at the same time.

NortE If you are using a USB webcam, do not connect it from the Connection > USB menu in
Horizon Client. To do so routes the device through USB redirection and the performance will be unusable
for video chat.

If you have more than one webcam connected to your local computer, you can configure a preferred
webcam to use on your remote desktop.

Select a Default Microphone on a Mac Client System

If you have multiple microphones on your client system, only one microphone is used on your remote
desktop. You can use System Preferences on your client system to specify which microphone is the default
microphone on the remote desktop.

With the Real-Time Audio-Video feature, audio input devices and audio output devices work without
requiring the use of USB redirection, and the amount of network bandwidth required is greatly reduced.
Analog audio input devices are also supported.

This procedure describes how to choose a microphone from the user interface of the client system.
Administrators can also configure a preferred microphone by using the Mac defaults system. See “Configure
a Preferred Webcam or Microphone on a Mac Client System,” on page 56.

ImporTANT If you are using a USB microphone, do not connect it from the Connection > USB menu in
Horizon Client. To do so routes the device through USB redirection and the device cannot use the Real-Time
Audio-Video feature.

Prerequisites

m  Verify that you have a USB microphone or another type of microphone installed and operational on
your client system.

m  Verify that you are using the VMware Blast display protocol or the PColP display protocol for your
remote desktop.

Procedure

1 Onyour client system, select Apple menu > System Preferences and click Sound.

VMware, Inc.


http://labs.vmware.com/flings/real-time-audio-video-test-application

2 Open the Input pane of Sound preferences.

3 Select the microphone that you prefer to use.
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The next time that you connect to a remote desktop and start a call, the desktop uses the default microphone

that you selected on the client system.

Configuring Real-Time Audio-Video on a Mac Client

You can configure Real-Time Audio-Video settings at the command line by using the Mac defaults system.

With the defaults system, you can read, write, and delete Mac user defaults by using Terminal

(/Applications/Utilities/Terminal.app).

Mac defaults belong to domains. Domains typically correspond to individual applications. The domain for

the Real-Time Audio-Video feature is com.vmware.rtav.

Syntax for Configuring Real-Time Audio-Video

You can use the following commands to configure the Real-Time Audio-Video feature.

Table 4-6. Command Syntax for Real-Time Audio-Video Configuration

Command Description

defaults write com.vmware.rtav scrWCamId "webcam- Sets the preferred webcam to use on remote desktops. When this

userid" value is not set, the webcam is selected automatically by system
enumeration. You can specify any webcam connected to (or built
into) the client system.

defaults write com.vmware.rtav srcAudioInId "audio-  Sets the preferred microphone (audio-in device) to use on remote

device-userid"

desktops. When this value is not set, remote desktops use the
default recording device set on the client system. You can specify
any microphone connected to (or built into) the client system.

defaults write com.vmware.rtav srcWCamFrameWidth Sets the image width. The value defaults to a hardcoded value of

pixels 320 pixels. You can change the image width to any pixel value.

defaults write com.vmware.rtav srcWCamFrameHeight Sets the image height. The value defaults to a hardcoded value of

pixels 240 pixels. You can change the image height to any pixel value.

defaults write com.vmware.rtav srcWCamFrameRate fps  Sets the frame rate. The value defaults to 15 fps. You can change
the frame rate to any value.

defaults write com.vmware.rtav LoglLevel "level" Sets the logging level for the Real-Time Audio-Video log file
(~/Library/Logs/VMware/vmware-RTAV-pid.log). You can set
the logging level to trace or debug.

defaults write com.vmware.rtav IsDisabled walue Determines whether Real-Time Audio-Video is enabled or
disabled. Real-Time Audio-Video is enabled by default. (This
value is not in effect.) To disable Real-Time Audio-Video on the
client, set the value to true.

defaults read com.vmware.rtav Displays Real-Time Audio-Video configuration settings.

defaults delete com.vmware.rtav sefting Deletes a Real-Time Audio-Video configuration setting, for

example: defaults delete com.vmware.rtav
srcWCamFrameWidth

Note You can adjust frame rates from 1 fps up to a maximum of 25 fps and resolution up to a maximum of

1920x1080. A high resolution at a fast frame rate might not be supported on all devices or in all

environments.
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Configure a Preferred Webcam or Microphone on a Mac Client System

With the Real-Time Audio-Video feature, if you have multiple webcams or microphones on your client
system, only one webcam and one microphone can be used on your remote desktop. You specify which
webcam and microphone are preferred at the command line by using the Mac defaults system.

With the Real-Time Audio-Video feature, webcams, audio input devices, and audio output devices work
without requiring USB redirection, and the amount of network bandwidth required is greatly reduced.
Analog audio input devices are also supported.

In most environments, there is no need to configure a preferred microphone or webcam. If you do not set a
preferred microphone, remote desktops use the default audio device set in the client system's System
Preferences. See “Select a Default Microphone on a Mac Client System,” on page 54. If you do not configure
a preferred webcam, the remote desktop selects the webcam by enumeration.

Prerequisites

®m  If you are configuring a preferred USB webcam, verify that the webcam is installed and operational on
your client system.

®m  If you are configuring a preferred USB microphone or other type of microphone, verify that the
microphone is installed and operational on your client system.

m  Verify that you are using the VMware Blast display protocol or the PColIP display protocol for your
remote desktop.

Procedure

1 Onyour Mac client system, start a webcam or microphone application to trigger an enumeration of
camera devices or audio devices to the Real-Time Audio-Video log file.

a  Attach the webcam or audio device.
b  Inthe Applications folder, double-click VMware Horizon Client to start Horizon Client.

¢ Start a call and then stop the call.

2 Find log entries for the webcam or microphone in the Real-Time Audio-Video log file.

a Inatext editor, open the Real-Time Audio-Video log file.

The Real-Time Audio-Video log file is named ~/Library/Logs/VMware/vmware-RTAV-pid.log, where
pid is the process ID of the current session.

b Search the Real-Time Audio-Video log file for entries that identify the attached webcams or
microphones.

The following example shows how webcam entries might appear in the Real-Time Audio-Video log file:

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void VideoInputBase::LogDevEnum() -
1 Device(s) found

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void VideoInputBase::LogDevEnum() -
Name=FaceTime HD Camera (Built-in) UserId=FaceTime HD Camera (Built-
in)#0xfa20000005ac8509  SystemId=0xfa20000005ac8509

The following example shows how microphone entries might appear in the Real-Time Audio-Video log
file:

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: int

AVCaptureEnumerateAudioDevices (MMDev: :Devicelist&) -

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum()

— 2 Device(s) found
2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum()
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— Index=255 Name=Built-in Microphone UserId=Built-in Microphone#AppleHDAEngineInput:1B,
0,1,0:1 SystemId=AppleHDAEngineInput:1B,0,1,0:1

2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum()
— Index=255 Name=Built-in Input UserId=Built-in Input#AppleHDAEngineInput:1B,0,1,1:2
SystemId=AppleHDAEngineInput:1B,0,1,1:2

Find the webcam or microphone that you prefer in the Real-Time Audio-Video log file and make a note
of its user ID.

The user ID appears after the string Userld=in the log file. For example, the user ID of the internal face
time camera is FaceTime HD Camera (Built-in) and the user ID of the internal microphone is Built-in
Microphone.

In Terminal (/Applications/Utilities/Terminal.app), use the defaults write command to set the
preferred webcam or microphone.

Option Action

Set the preferred webcam Type
defaults write com.vmware.rtav srcWCamId "webcam-userid",
where webcam-userid is the user ID of the preferred webcam, which you
obtained from the Real-Time Audio-Video log file. For example:
defaults write com.vmware.rtav srcWCamId "HD Webcam C525”

Set the preferred microphone Type
defaults write com.vmware.rtav srcAudioInld "audio-device-
userid", where audio-device-userid is the user ID of the preferred
microphone, which you obtained from the Real-Time Audio-Video log file.
For example:
defaults write com.vmware.rtav srcAudioInId "Built-in
Microphone"

(Optional) Use the defaults read command to verify your changes to the Real-Time Audio-Video
feature.

For example: defaults read com.vmware.rtav

The command lists all of the Real-Time Audio-Video settings.

The next time you connect to a remote desktop and start a new call, the desktop uses the preferred webcam
or microphone that you configured, if it is available. If the preferred webcam or microphone is not available,
the remote desktop can use another available webcam or microphone.

Copying and Pasting Text and Images

By default, you can copy and paste text from your client system to a remote desktop or application. If a View

administrator enables the feature, you can also copy and paste text from a remote desktop or application to
your client system or between two remote desktops or applications. Supported file formats include text,
images, and RTF (Rich Text Format). Some restrictions apply.

If you use the VMware Blast display protocol or the PColP display protocol, a View administrator can set
this feature so that copy and paste operations are allowed only from your client system to a remote desktop

or application, or only from a remote desktop or application to your client system, or both, or neither.

View administrators configure the ability to copy and paste by configuring group policy settings that pertain
to Horizon Agent. Depending on the Horizon server and agent version, administrators might also be able to
use group policies to restrict clipboard formats during copy and paste operations or use Smart Policies to
control copy and paste behavior in remote desktops. For more information, see the Sefting Up Desktop and
Application Pools in View document.
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In Horizon 7 version 7.0 and earlier and Horizon Client 4.0 and earlier, the clipboard can accommodate 1
MB of data for copy and paste operations. In Horizon 7 version 7.0.1 and later and Horizon Client 4.1 and
later, the clipboard memory size is configurable for both the server and the client. When a PColIP or VMware
Blast session is established, the server sends its clipboard memory size to the client. The effective clipboard
memory size is the lesser of the server and client clipboard memory size values.

If you are copying formatted text, some of the data is text and some of the data is formatting information. If
you copy a large amount of formatted text or text and an image, when you attempt to paste the text and
image, you might see some or all of the plain text but no formatting or image. The reason is that the three
types of data are sometimes stored separately. For example, depending on the type of document you are
copying from, images might be stored as images or as RTF data.

If the text and RTF data together use less than maximum clipboard size, the formatted text is pasted. Often
the RTF data cannot be truncated, so that if the text and formatting use more than the maximum clipboard
size amount, the RTF data is discarded, and plain text is pasted.

If you are unable to paste all of the formatted text and images you selected in one operation, you might need
to copy and paste smaller amounts in each operation.

You cannot copy and paste files between a remote desktop and the file system on your client computer.

Configuring the Client Clipboard Memory Size

You can configure the client clipboard memory size by creating a file named config in the %HomeDir
%/Library/Preferences/VMware Horizon View/ directory on your Mac client system.

To set the client clipboard memory size, add the following parameter to the config file.
mksvchan.clipboardSize=value

value is the client clipboard memory size in kilobytes. You can specify a minimum value of 512 kilobytes and
a maximum value of 16384 kilobytes. If you specify 0 or do not specify a value, the default client clipboard
memory size is 8192 kilobytes (8 MB).

A large clipboard memory size can negatively affect performance, depending on your network. VMware
recommends that you do not set the clipboard memory size to a value greater than 16 MB.

Using Remote Applications
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You can use many Mac functions with remote applications.

B When you run a remote application, its icon appears in the Dock. You can maximize a minimized
remote application by clicking its icon in the Dock.

®  You can keep, open, and quit a remote application from its context menu in the Dock. If you select Keep
in Dock, the remote application icon remains in the Dock, even after you close all application windows.

B You can open a remote application by clicking its icon in the Dock.

®  You can open local files in remote applications and run remote applications from the Applications
folder on your client system. To enable these features, see “Share Access to Local Folders and Drives,”
on page 28.

m  Flashing Windows taskbar items are forwarded to Horizon Client. For example, if the remote
application is an IM client and you receive a new message, a flashing red dot appears on the IM client
icon in the Dock.

®  You can start voice dictation, minimize, and zoom a remote application from the menu bar.

®  You can use the Exposé feature to see open remote applications, and you can press Command-Tab to
switch between open remote applications.
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®  You can use standard Mac keyboard shortcuts to interact with remote applications. For example, you
can press Command-W to close an individual application window and Command-S to save the current
file. You can also use standard Mac keyboard shortcuts to copy, cut, and paste text between your Mac
applications and remote applications. You can customize keyboard shortcut mappings. See “Configure
Keyboard Shortcut Mappings,” on page 32.

m  If aremote application creates a Windows System Tray item, that item appears in the notification area
on the menu bar on your Mac client system. You can interact with this item from the notification area on
your Mac in the same way that you interact with it from the System Tray on a Windows system.

Note When you reclick a redirected System Tray item in the notification area on your Mac, the context
menu does not disappear.

Use a Local IME with Remote Applications

When using non-English keyboards and locales, you can use an IME (input method editor) installed in your
local system to send non-English characters to a remote hosted application.

You can also use the Input menu in the menu bar on your Mac or keyboard shortcuts to switch to a different
IME. No IME is required to be installed in the remote RDS host.

Note On aMac, an IME is referred to as an input source.

When this feature is turned on, the local IME is used. If an IME is installed and configured on the RDS host
where the remote application is installed, that remote IME is ignored.

Prerequisites
m  Verify that one or more IMEs are installed in the client system.

m  Verify that View Agent 6.1.1 or later, or Horizon Agent 7.0 or later, is installed on the RDS host.

Procedure

1  In the desktop and application selection window of Horizon Client, Control-click a remote application
and select Settings.

2 Inthe Remote Applications pane that appears, select the Extend the local IME to hosted applications
check box.

3 Use the local IME as you would with any locally installed applications.

The Input menu appears in the menu bar on your Mac client system. When you are using a remote
application, you can switch to a different language or IME by using the Input menu or keyboard shortcuts.
Key combinations that perform certain actions, such as Command-C to copy and Command-V to paste, will
still work correctly.

Saving Documents in a Remote Application

With certain remote applications, such as Microsoft Word or WordPad, you can create and save documents.
Where these documents are saved depends on your company's network environment. For example, your
documents might be saved to a home share mounted on your local computer.

Administrators can use an ADMX template file to set a group policy that specifies where documents are
saved. This policy is called "Set Remote Desktop Services User Home Directory.” For more information, see
the "RDS Profiles Settings" topic in the Setting Up Desktop and Application Pools in View document.
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Clicking URL Links That Open Outside of Horizon Client

An administrator can configure URL links that you click inside a remote desktop or application to open in
the default browser on your client system. A link might be to a Web page, a phone number, an email
address, or other type of link. This feature is called URL Content Redirection.

Each company configures its own URL redirection policies. If you have questions about how the URL Client
Redirection feature behaves at your company, contact your system administrator.

Norte URL Content Redirection is a Tech Preview feature in Horizon Client for Mac 4.2.

Printing from a Remote Desktop or Application

From a remote desktop, you can print to a virtual printer or to a USB printer that is attached to your client
computer. Virtual printing and USB printing work together without conflict.

You can use the virtual printing feature with the following types of remote desktops and applications:
®  Remote desktops that run Windows Server operating systems
m  Session-based desktops (on virtual machine RDS hosts)

®  Remote hosted applications

Enabling Virtual Printing in Horizon Client

When you use the VMware Blast display protocol or the PColP display protocol, you can use printers
configured for your local computer from a remote desktop or application. You do not need to install printer
drivers on the remote desktop to use the virtual printing feature.

You can enable virtual printing the first time you start Horizon Client. Click Continue when Horizon Client
prompts you to start remote desktop USB and printing services and type your system credentials.

If you do not enable virtual printing the first time you start Horizon Client, you can use the Connection
menu to enable virtual printing.

m  To enable virtual printing before you connect to a remote desktop or application, select Connection >
Start Printing Services from the VMware Horizon Client menu. Click Continue and type your system
credentials.

m  To enable virtual printing after you connect to a desktop, select Connection > Start Printing Services
from the VMware Horizon Client menu. Click Continue, type your system credentials, and reconnect
to the desktop or application. If you cancel the reconnection, you can select Connection > Enable
Printing and Horizon Client prompts you to reconnect again.

When the virtual printing feature is enabled, the Connection menu displays Printing Enabled.

Norte If you install Horizon Client on a Mac on which VMware Fusion was previously started, printing
services are already enabled when you start Horizon Client. This behavior occurs because VMware Fusion
and Horizon Client use some of the same files to implement virtual printing.

60 VMware, Inc.



Chapter 4 Using a Microsoft Windows Desktop or Application on a Mac

Set Printing Preferences for the Virtual Printer Feature on a Remote Desktop

The virtual printing feature lets end users use local or network printers from a remote desktop without
requiring that additional print drivers be installed in the remote desktop. For each printer available through
this feature, you can set preferences for data compression, print quality, double-sided printing, color, and so
on.

After a printer is added on the local computer, Horizon Client adds that printer to the list of available
printers on the remote desktop. No further configuration is required. Users who have administrator
privileges can still install printer drivers on the remote desktop without creating a conflict with the virtual
printer component.

ImporTANT This feature is not available for the following types of printers:

m  USB printers that are using the USB redirection feature to connect to a virtual USB port in the remote
desktop

You must disconnect the USB printer from the remote desktop in order to use the virtual printing
feature with it.

m  The Windows feature for printing to a file

Selecting the Print to file check box in a Print dialog box does not work. Using a printer driver that
creates a file does work. For example, you can use a PDF writer to print to a PDF file.

This procedure is written for a remote desktop that has a Windows 7 or Windows 8.x (Desktop) operating
system. The procedure is similar but not exactly the same for Windows Server 2008 and Windows Server
2012.

Prerequisites

Verify that the Virtual Printing component of the agent is installed on the remote desktop. In the remote
desktop file system, verify that the following folder exists: C:\Program Files\Common Files\ThinPrint.

To use virtual printing, the View administrator must have enabled the virtual printing feature for the remote
desktop. This task includes enabling the Virtual Printing setup option in the agent installer, and can include
setting policies regarding virtual printing behavior. For more information, see the View Administration
document if you are using Connection Server and View Agent 5.x or an earlier version. See Setting Up
Desktop and Application Pools in View if you are using Horizon 6 or later.

Procedure
1  Inthe Windows 7 or Windows 8.x remote desktop, click Start > Devices and Printers.

2 In the Devices and Printers window, right-click the default printer, select Printer Properties from the
context menu, and select the printer.

Virtual printers appear as <printer_name> in single-user virtual machine desktops and as
<printer_name>(s<session_ID>) in session-based desktops on RDS hosts if View Agent 6.2 or later, or
Horizon Agent 7.0 or later, is installed. If View Agent 6.1 or earlier is installed in the remote desktop,
virtual printers appear as <printer_name>#:<number>.

3 In the Printer Properties window, click the Device Setup tab and specify which settings to use.
4 On the General tab, click Preferences and specify which settings to use.
5 In the Printing Preferences dialog box, select the different tabs and specify which settings to use.
For the Page Adjustment advanced setting, VMware recommends that you retain the default settings.

6 Click OK.
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Using USB Printers

In an View environment, virtual printers and redirected USB printers can work together without conflict.

A USB printer is a printer that is attached to a USB port on the local client system. To send print jobs to a
USB printer, you can either use the USB redirection feature or use the virtual printing feature. USB printing
can sometimes be faster than virtual printing, depending on network conditions.

®  You can use the USB redirection feature to attach a USB printer to a virtual USB port in the remote
desktop as long as the required drivers are also installed on the remote desktop.

If you use this redirection feature the printer is no longer logically attached to the physical USB port on
the client and this is why the USB printer does not appear in the list of local printers on the local client
machine. This also means that you can print to the USB printer from the remote desktop but not from
the local client machine.

In the remote desktop, redirected USB printers appear as <printer_name>.
For information about how to connect a USB printer, see “Connect USB Devices,” on page 46.

m  On some clients, you can alternatively use the virtual printing feature to send print jobs to a USB
printer. If you use the virtual printing feature you can print to the USB printer from both the remote
desktop and the local client, and you do not need to install print drivers on the remote desktop.

PColP Client-Side Image Cache
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PColIP client-side image caching stores image content on the client to avoid retransmission. This feature
reduces bandwidth usage.

The PColP image cache captures spatial, as well as temporal, redundancy. For example, when you scroll
down through a PDF document, new content appears from the bottom of the window and the oldest content
disappears from the top of the window. All the other content remains constant and moves upward. The
PColP image cache is capable of detecting this spatial and temporal redundancy.

Because during scrolling, the display information sent to the client device is primarily a sequence of cache
indices, using the image cache saves a significant amount of bandwidth. This efficient scrolling has benefits
both on the LAN and over the WAN.

®  On the LAN, where bandwidth is relatively unconstrained, using client-side image caching delivers
significant bandwidth savings.

m  Over the WAN, to stay within the available bandwidth constraints, scrolling performance would be
degraded without client-side caching. Over the WAN, client-side caching saves bandwidth and ensure a
smooth, highly responsive scrolling experience.

With client-side caching, the client stores portions of the display that were previously transmitted. The cache
size is 250 MB.
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You can solve most problems with Horizon Client by resetting the desktop or by reinstalling the
VMware Horizon Client application.

This chapter includes the following topics:
m  “Reset a Remote Desktop or Application,” on page 63

®  “Uninstalling Horizon Client,” on page 64

Reset a Remote Desktop or Application

You might need to reset a desktop or application if the application or desktop operating system stops
responding. Resetting a remote desktop shuts down and restarts the desktop. Resetting your remote
applications quits the applications. Unsaved data is lost.

Resetting a remote desktop is the equivalent of pressing the Reset button on a physical PC to force the PC to
restart. Any files that are open on the remote desktop will be closed without being saved first.

Resetting applications is the equivalent of quitting all remote applications without saving any unsaved data.
All open applications are closed, even if the applications come from different RDS server farms.

You can reset a remote desktop only if your administrator has enabled this feature.

Procedure

& Use the Reset command.

Option Action

Reset a remote desktop from within  Select Connection > Reset from the menu bar.
the desktop

Reset a remote desktop from the Select the remote desktop and select Connection > Reset from the menu
desktop and application selection bar.
window

Reset remote applications from the  Click the Settings button (gear icon) in the upper right corner of the
desktop and application selection window, select Applications in the left pane, click Reset, and click
window Continue.

For a remote desktop, the operating system in the remote desktop is rebooted. The client disconnects from
the desktop. For remote applications, the applications are quit.

What to do next

Wait an appropriate amount of time for system startup before attempting to connect to the remote desktop.
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Uninstalling Horizon Client

You can sometimes resolve problems with Horizon Client by uninstalling and reinstalling the
Horizon Client application.

You uninstall Horizon Client by using the same method that you usually use to uninstall any other
application.

Drag the VMware Horizon Client application from the Applications folder to the Trash and empty the
trash.

After uninstalling is complete, you can reinstall the application.

See “Install Horizon Client on Mac,” on page 11.

64 VMware, Inc.



Index

A

agent, installation requirements 10
always connect at launch setting 30
autoconnect to a remote desktop 39
autoconnect USB devices 46

C
caching, client-side image 62
certificates, ignoring problems 12, 34
client image cache 62
client drive redirection 28
clipboard memory size 58
connect
to a desktop 26
to Connection Server 26

USB devices 46
Connection Server
connect to 26

shortcuts for 40
copying text and images 57

customer experience program, desktop pool

data 15

D

desktop
connect to 26

display options 26
display protocol 26
log off from 37
reset 63
switch 37

device families 52

devices
connecting USB 46

USB 48, 53
disconnecting from a remote desktop 37
display options, desktop 26
display protocol, desktop 26
Dock 12
domain 26

E

Exclusive Mode 45

VMware, Inc.

F
favorites 36

feature support matrix, for Mac 41
folder sharing 28

forget user name and domain 31
forwarding USB devices 48

H
hardware requirements
Mac 7

smart card authentication 9
hiding the Horizon Client window 31

Horizon Client
disconnect from a desktop 37

installing on Mac 11
setup for Mac clients 7
system requirements for Mac 7
troubleshooting 63
Horizon Client shortcuts 34

image cache, client 62
images, copying 57
IME (input method editor) 59

K
keyboard shortcuts 32

L

log files 14

log in, Connection Server 26
log off 37

logging, for USB devices 53

Mac
installing Horizon Client 11

installing Horizon Clienton 7
microphone 54
mouse shortcut mappings 33
multiple monitors 44

(o)

operating system keyboard shortcuts 33

operating systems, supported on the agent 10

65



Using VMware Horizon Client for Mac

options USB redirection 48, 53
display protocol 26 USB device families 52
screen layout 26 USB devices 46

USB printers 60, 62

P

pasting text and images 57 Vv

PColP clientimage cache 62 verification modes for certificate checking 12

preferences, desktop 26 virtual printers 60

prerequisites for client devices 11 virtual printing 60

print from a desktop 60 virtual printing feature 61

printers, setting up 61 VMware Blast 14

R w

Real-Time Audio-Video, system requirements 8 webcam 53. 54. 56

recent desktops and applications 28
reconnect to a remote application 39

redirection
properties for USB devices 50

USB 48, 53
remote applications 58
reordering shortcuts 40
reset desktop 63
Retina Display 44

S

saving documents in a remote application 59
screen layout 26

searching for remote desktops 35

security servers 11

server connections 25

server certificate verification 12

server shortcuts 40

sharing files and folders from the client
system 28

shortcut for Connection Server 40

smart card authentication, requirements 9
smart card certificates 31

SSL certificates, verifying 12

SSL options 13

switch desktops 37

system requirements, for Mac 7

T
text, copying 57
ThinPrint setup 61

U

uninstalling Horizon Client 64

URI examples 22

URI syntax for Horizon Clients 19
URIs (uniform resource identifiers) 19
URL Content Redirection 10, 60

66 VMware, Inc.



	Using VMware Horizon Client for Mac
	Contents
	Using VMware Horizon Client for Mac
	Setup and Installation
	System Requirements for Mac Clients
	System Requirements for Real-Time Audio-Video
	Smart Card Authentication Requirements
	Requirements for URL Content Redirection
	Supported Desktop Operating Systems
	Preparing Connection Server for Horizon Client
	Install Horizon Client on Mac
	Add Horizon Client to Your Dock
	Configuring Certificate Checking for End Users
	Configure Advanced TLS/SSL Options
	Configuring Log File Collection Values
	Configure VMware Blast Options
	Horizon Client Data Collected by VMware

	Using URIs to Configure Horizon Client
	Syntax for Creating vmware-view URIs
	Examples of vmware-view URIs

	Managing Remote Desktop and Application Connections
	Connect to a Remote Desktop or Application
	Open a Recent Remote Desktop or Application
	Share Access to Local Folders and Drives
	Connecting to a Server When Horizon Client Starts
	Configure Horizon Client to Forget the Server User Name and Domain
	Hide the VMware Horizon Client Window
	Configure Horizon Client to Select a Smart Card Certificate
	Configure Keyboard Shortcut Mappings
	Considerations for Mapping Operating System Keyboard Shortcuts

	Configure Mouse Shortcut Mappings
	Configure Horizon Client Shortcuts
	Setting the Certificate Checking Mode for Horizon Client
	Searching for Desktops or Applications
	Select a Favorite Remote Desktop or Application
	Switch Desktops or Applications
	Log Off or Disconnect
	Autoconnect to a Remote Desktop
	Configure Reconnect Behavior for Remote Applications
	Removing a Server Shortcut from the Home Screen
	Reordering Shortcuts

	Using a Microsoft Windows Desktop or Application on a Mac
	Feature Support Matrix for Mac
	Internationalization
	Monitors and Screen Resolution
	Using Exclusive Mode
	Connect USB Devices
	Configuring USB Redirection on a Mac Client
	USB Redirection Properties
	USB Device Families
	Turn on Logging for USB Redirection

	Using the Real-Time Audio-Video Feature for Webcams and Microphones
	When You Can Use Your Webcam
	Select a Default Microphone on a Mac Client System
	Configuring Real-Time Audio-Video on a Mac Client
	Configure a Preferred Webcam or Microphone on a Mac Client System

	Copying and Pasting Text and Images
	Configuring the Client Clipboard Memory Size

	Using Remote Applications
	Use a Local IME with Remote Applications

	Saving Documents in a Remote Application
	Clicking URL Links That Open Outside of Horizon Client
	Printing from a Remote Desktop or Application
	Enabling Virtual Printing in Horizon Client
	Set Printing Preferences for the Virtual Printer Feature on a Remote Desktop
	Using USB Printers

	PCoIP Client-Side Image Cache

	Troubleshooting Horizon Client
	Reset a Remote Desktop or Application
	Uninstalling Horizon Client

	Index


