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VMware Horizon Client for Mac
Installation and Setup Guide
This document, VMware Horizon Client for Mac Installation and Setup Guide, provides information about
®
installing, configuring, and using VMware Horizon Client™ software on a Mac.
This information is intended for administrators who need to set up a Horizon deployment that includes
Mac client devices. The information is written for experienced system administrators who are familiar with
virtual machine technology and data center operations.
If you are an end user, see the VMware Horizon Client for Mac User Guide document on VMware Docs,
or view the Horizon Client online help.
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Setup and Installation

1

Setting up a Horizon deployment for Mac clients involves using certain Connection Server configuration
settings, meeting the client and server system requirements, and downloading and installing
Horizon Client for Mac from the VMware website.
This chapter includes the following topics:
n

System Requirements for Mac Clients

n

System Requirements for Real-Time Audio-Video

n

Smart Card Authentication Requirements

n

Touch ID Authentication Requirements

n

Requirements for Using URL Content Redirection

n

Requirements for Using Skype for Business with Horizon Client

n

Requirements for the Session Collaboration Feature

n

Supported Desktop Operating Systems

n

Preparing Connection Server for Horizon Client

n

Install Horizon Client on Mac

n

Upgrade Horizon Client Online

n

Add Horizon Client to the Dock

n

Setting the Certificate Checking Mode in Horizon Client

n

Configure Advanced TLS Options

n

Configuring Log File Collection Values

n

Configure VMware Blast Options

n

Horizon Client Data Collected by VMware

VMware, Inc.
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System Requirements for Mac Clients
The Mac on which you install Horizon Client, and the peripherals it uses, must meet certain system
requirements.
Mac models

Any 64-bit Intel-based Mac

Memory

At least 2 GB of RAM

Operating systems

n

Mac OS X El Capitan (10.11)

n

macOS Sierra (10.12)

n

macOS High Sierra (10.13)

Smart card
authentication

See Smart Card Authentication Requirements.

Touch ID authentication

See Touch ID Authentication Requirements.

Connection Server,
security server, and
View Agent or
Horizon Agent

Latest maintenance release of Horizon 6 version 6.x and later releases.

Display protocols

If client systems connect from outside the corporate firewall, use a security
server or a Unified Access Gateway appliance so that client systems do not
require a VPN connection.
n

PCoIP

n

VMware Blast (requires Horizon Agent 7.0 or later)

System Requirements for Real-Time Audio-Video
Real-Time Audio-Video works with standard webcam, USB audio, and analog audio devices. The feature
also works with standard conferencing applications, such as Skype, WebEx, and Google Hangouts. To
support Real-Time Audio-Video, your Horizon deployment must meet certain software and hardware
requirements.
Virtual desktops

Virtual desktops must have View Agent 6.0, or Horizon Agent 7.0 or later,
installed.

Published desktops
and applications

To use the Real-Time Audio-Video feature with published desktops and
applications, Horizon Agent 7.0.2 or later must be installed on the RDS
host.

Horizon Client
computer or client
access device

VMware, Inc.
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The webcam and audio device drivers must be installed, and the webcam
and audio device must be operable, on the client computer. You do not
need to install the device drivers on the machine where the agent is
installed.
Display protocols

n

PCoIP

n

VMware Blast (requires Horizon Agent 7.0 or later)

Smart Card Authentication Requirements
Client devices that use a smart card for user authentication must meet certain requirements.

Client Hardware and Software Requirements
Each client machine that uses a smart card for user authentication must have the following hardware and
software.
n

Horizon Client

n

A compatible smart card reader

n

Product-specific application drivers

Users who use smart cards to authenticate must have a smart card and each smart card must contain a
user certificate. The following smart cards are supported.
n

U.S. Department of Defense Common Access Card (CAC)

n

U.S. Federal Government Personal Identity Verification (PIV) card (also called FIPS-201 smart cards)

The following client drivers are supported for PIV cards.
n

PKard for Mac v1.7 and v1.7.1

n

Charismathics (CCSI_5.0.3_PIV)

n

Centrify Express

Agent Software Requirements
A Horizon administrator must install product-specific application drivers on the agent machine.
For Windows 7 virtual desktops, the operating system installs the related driver when you insert a smart
card reader and PIV card. For Windows XP and Windows Vista virtual desktops, you can install the
related driver by using ActivIdentify ActivClient.
The following agent drivers are supported for PIV cards:
n

Charismathics (CSTC PIV 5.2.2)

n

Microsoft minidriver

VMware, Inc.
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Enabling the Username Hint Field in Horizon Client
In some environments, smart card users can use a single smart card certificate to authenticate to multiple
user accounts. Users enter their user name in the Username hint text box when they use a smart card to
authenticate.
To make the Username hint text box appear on the Horizon Client login dialog box, you must enable the
smart card user name hints feature for the Connection Server instance in Horizon Administrator. The
smart card user name hints feature is supported only with Horizon 7 version 7.0.2 and later servers and
agents. For information about enabling the smart card user name hints feature, see the Horizon 7
Administration document.
If your environment uses a Unified Access Gateway appliance rather than a security server for secure
external access, you must configure the Unified Access Gateway appliance to support the smart card
user name hints feature. The smart card user name hints feature is supported only with
Unified Access Gateway 2.7.2 and later. For information about enabling the smart card user name hints
feature in Unified Access Gateway, see the Deploying and Configuring Unified Access Gateway
document.
Note Horizon Client supports single-account smart card certificates, even when the smart card user
name hints feature is enabled.

Additional Smart Card Authentication Requirements
In addition to meeting the smart card requirements for Horizon Client systems, other Horizon components
must meet certain configuration requirements to support smart cards.
Connection Server and
security server hosts

A Horizon administrator must add all applicable Certificate Authority (CA)
certificates for all trusted user certificates to a server truststore file on the
Connection Server host or security server host. These certificates include
root certificates and must include intermediate certificates if the user's
smart card certificate was issued by an intermediate certificate authority.
When you generate a certificate for a blank PIV card, enter the path to the
server truststore file on the Connection Server or security server host on
the Crypto Provider tab in the PIV Data Generator tool.
For information about configuring Connection Server to support smart card
use, see the Horizon 7 Administration document.

Active Directory

VMware, Inc.

For information about tasks that an administrator might need to perform in
Active Directory to implement smart card authentication, see the Horizon 7
Administration document.
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Touch ID Authentication Requirements
To use Touch ID for user authentication in Horizon Client, you must meet certain requirements.
Mac models

Any Mac model that supports Touch ID, for example, MacBook Pro.

Operating system
requirements

Add at least one fingerprint in the Touch ID setting.

Connection Server
requirements

n
n

Horizon 6 version 6.2 or a later release.
Enable biometric authentication in Connection Server. For information,
see the Horizon 7 Administration document.

Horizon Client
requirements

n

The Connection Server instance must present a valid root-signed
certificate to Horizon Client.

n

Set the certificate checking mode to Never connect to untrusted
servers or Warn before connecting to untrusted servers. For
information about setting the certificate checking mode, see Setting the
Certificate Checking Mode in Horizon Client.

n

Enable Touch ID when you connect to the server. After you successfully
log in, your Active Directory credentials are stored securely on the Mac
client system. The Touch ID option is shown the first time you log in and
does not appear after Touch ID is enabled.

You can use Touch ID with smart card authentication and as part of two-factor authentication with RSA
SecurID and RADIUS authentication. If you use Touch ID with smart card authentication, Horizon Client
connects to the server after you enter your PIN and the Touch ID login screen does not appear.

Requirements for Using URL Content Redirection
With the URL Content Redirection feature, URL content can be redirected from the client machine to a
remote desktop or published application (client-to-agent redirection), or from a remote desktop or
published application to the client machine (agent-to-client redirection).
For example, an end user can click a link in the native Microsoft Word application on the client and the
link opens in the remote Internet Explorer application, or an end user can click a link in the remote
Internet Explorer application and the link opens in a native browser on the client machine. Any number of
protocols can be configured for redirection, including HTTP, mailto, and callto.
Note The callto protocol is not supported for URL content redirection with the Chrome browser.
Web browsers

You can type or click a URL in the following browsers and have that URL
redirected.
n

VMware, Inc.

Internet Explorer 9, 10, and 11

11

VMware Horizon Client for Mac Installation and Setup Guide

n

64-bit or 32-bit Chrome 60.0.3112.101, Official Build (requires Horizon
7 version 7.4 or later)

URL Content Redirection does not work for links clicked from inside
Windows 10 universal apps, including the Microsoft Edge Browser.
Client system

To use URL Content Redirection with the Chrome browser, you must
enable the VMware Horizon URL Content Redirection Helper extension for
Chrome. This extension is installed, but is not enabled, when you connect
to a Connection Server instance on which URL Content Redirection rules
are configured. To enable the extension, restart Chrome after you connect
to the Connection Server instance and click Enable Extension when
Chrome prompts you to enable the extension.
The first time a URL is redirected from the Chrome browser, you are
prompted to open the URL in Horizon Client. You must click Open VMware
Horizon Client for URL content redirection to occur. If you select the
Remember my choice for VMware Horizon Client links check box, this
prompt does not appear again.

Remote desktop or
published application

A Horizon administrator must enable URL Content Redirection when
Horizon Agent is installed. For information, see the Setting Up Virtual
Desktops in Horizon 7 or Setting Up Published Desktops and Applications
in Horizon 7 documents.
To use URL Content Redirection with the Chrome browser, a Horizon
administrator must install and enable the VMware Horizon URL Content
Redirection Helper extension on the Windows agent machine. For
information, see the Configuring Remote Desktop Features in Horizon 7
document for Horizon 7 version 7.4 or later.

A Horizon administrator must also configure settings that specify how Horizon Client redirects URL
content from the client to a remote desktop or published application, or how Horizon Agent redirects URL
content from a remote desktop or published application to the client. For complete information, see the
"Configuring URL Content Redirection" topic in the Configuring Remote Desktop Features in Horizon 7
document.

Requirements for Using Skype for Business with
Horizon Client
An end user can run Skype for Business inside a virtual desktop without negatively affecting the virtual
infrastructure and overloading the network. During Skype audio and video calls, all media processing
takes place on the client machine instead of in the virtual desktop.
To use this feature, the VMware Horizon Virtualization Pack for Skype for Business software must be
installed on the client machine. This software is installed by default when Horizon Client for Mac is
installed.

VMware, Inc.
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A Horizon administrator must also install the VMware Virtualization Pack for Skype for Business feature
on the virtual desktop when Horizon Agent is installed. For information about installing Horizon Agent, see
the Setting Up Virtual Desktops in Horizon 7 document.
For complete requirements, see "Configure Skype for Business" in the Configuring Remote Desktop
Features in Horizon 7 document.

Requirements for the Session Collaboration Feature
With the Session Collaboration feature, users can invite other users to join an existing Windows remote
desktop session. To support the Session Collaboration feature, your Horizon deployment must meet
certain requirements.
Session collaborators

Windows remote
desktops

To join a collaborative session, a user must have Horizon Client 4.7 or later
for Windows, Mac, or Linux installed on the client system, or must use
HTML Access 4.7 or later.
n

Horizon Agent 7.4 or later must be installed in the virtual desktop, or on
the RDS host for published desktops.

n

The Session Collaboration feature must be enabled at the desktop pool
or farm level. For information about enabling the Session Collaboration
feature for desktop pools, see the Setting Up Virtual Desktops in
Horizon 7 document. For information about enabling the Session
Collaboration feature for a farm, see the Setting Up Published
Desktops and Applications in Horizon 7 document.

You can use Horizon Agent group policy settings to configure the Session
Collaboration feature. For information, see the Configuring Remote
Desktop Features in Horizon 7 document.
The Session Collaboration feature does not support Linux remote desktop
sessions or published application sessions.
Connection Server

The Session Collaboration feature requires that the Connection Server
instance uses an Enterprise license.

Display protocols

VMware Blast

Supported Desktop Operating Systems
A Horizon administrator creates virtual machines that have a guest operating system and installs agent
software in the guest operating system. End users can log in to these virtual machines from a client
device.
For a list of the supported Windows guest operating systems, see the Horizon 7 Installation document.

VMware, Inc.
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If you have View Agent 6.1.1 or later, or Horizon Agent 7.0 or later, some Linux guest operating systems
are also supported. For information about system requirements, configuring Linux virtual machines, and a
list of supported features, see the Setting Up Horizon 6 for Linux Desktops or Setting Up Horizon 7 for
Linux Desktops document.

Preparing Connection Server for Horizon Client
Before end users can connect to a server and access a remote desktop or published application, a
Horizon administrator must configure certain Connection Server settings.

Unified Access Gateway and Security Servers
n

If your Horizon deployment includes a Unified Access Gateway appliance, configure Connection
Server to work with Unified Access Gateway. See the Deploying and Configuring Unified Access
Gateway document. Unified Access Gateway appliances perform the same role as security servers.

n

If your Horizon deployment includes a security server, verify that you are using the latest maintenance
releases of Connection Server 6.x and Security Server 6.x or later releases. For more information,
see the installation document for your Horizon version.

Secure Tunnel Connection
If you plan to use a secure tunnel connection for client devices, and if the secure connection is configured
with a DNS host name for a Connection Server instance or a security server, verify that the client device
can resolve this DNS name.

Desktop and Application Pools
n

Verify that a desktop or application pool has been created and that the user account that you plan to
use is entitled to access the pool. For more information, see the Setting Up Virtual Desktops in
Horizon 7 and Setting Up Published Desktops and Applications in Horizon 7 documents.

n

If end users have a high-resolution display and use the High Resolution Mode client setting while
viewing their remote desktops in full screen mode, verify that sufficient vRAM is allocated for each
Windows 7 or later remote desktop. The amount of vRAM depends on the number of monitors
configured for end users and on the display resolution. To estimate the amount of vRAM, see the
Horizon 7 Architecture Planning document.

User Authentication
n

To use two-factor authentication, such as RSA SecurID or RADIUS authentication, with
Horizon Client, you must enable the two-factor authentication feature in Connection Server. For more
information, see the topics about two-factor authentication in the Horizon 7 Administration document.

VMware, Inc.
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n

To hide security information in Horizon Client, including server URL information and the Domain
drop-down menu, enable the Hide server information in client user interface and Hide domain
list in client user interface settings for the Connection Server instance. These global settings are
available in Horizon 7 version 7.1 and later. For information about configuring global settings, see the
Horizon 7 Administration document.
To authenticate when the Domain drop-down menu is hidden, users must provide domain information
by entering their user name in the format domain\username or username@domain in the User name
text box.
Important If you enable the Hide server information in client user interface and Hide domain
list in client user interface settings and select two-factor authentication (RSA SecureID or RADIUS)
for the Connection Server instance, do not enforce Windows user name matching. Enforcing
Windows user name matching prevents users from entering domain information in the user name text
box and login always fails. For more information, see the topics about two-factor authentication in the
Horizon 7 Administration document.

n

To enable end users to save their passwords with Horizon Client, so that they do not have to supply
credentials when they connect to a Connection Server instance, configure Horizon LDAP for this
feature in Connection Server.
Users can save their passwords if Horizon LDAP is configured to allow it, if the Horizon Client
certificate verification mode is set to Warn before connecting to untrusted servers or Never
connect to untrusted servers, and if Horizon Client can fully verify the server certificate that
Connection Server presents. For more information, see the Horizon 7 Administration document.

Install Horizon Client on Mac
You install Horizon Client on Mac client systems from a disk image file.
Prerequisites
n

Verify that the client system uses a supported operating system. See System Requirements for Mac
Clients.

n

Verify that you can log in as an administrator on the client system.

n

Verify that you have the URL for a download page that contains the Horizon Client installer. This URL
might be the VMware Downloads page at http://www.vmware.com/go/viewclients, or it might be the
URL for a Connection Server instance.

Procedure

1

On the Mac client system, browse to the URL for downloading the Horizon Client installer file.
The filename format is VMware-Horizon-Client-y.y.y-xxxxxx.dmg, where xxxxxx is the build
number and y.y.y is the version number.

2

Double-click the .dmg file and click Agree.
The contents of the disk image appear in a Horizon Client Finder window.

VMware, Inc.
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3

In the Finder window, drag the VMware Horizon Client icon to the Applications folder icon.
If you are not logged in as an administrator user, the Mac client system prompts you for an
administrator user name and password.

What to do next

Start Horizon Client and verify that you can connect to a remote desktop or published application. See
Connect to a Remote Desktop or Published Application.

Upgrade Horizon Client Online
You can configure Horizon Client to look for and install updates each time it starts. You can also look for
and install updates manually.
If Horizon Client detects a new version, you can download and install the new version, have
Horizon Client remind you to install the new version the next time it starts, or skip the new version. If you
skip a new version when looking for updates manually, the automatic update process also skips that
version.
Procedure
n

To configure Horizon Client to look for and install updates each time it starts, select VMware Horizon
Client > Preferences and select the Automatically check for updates check box.
The Automatically check for updates check box is selected by default.

n

To look manually for and install an update, select VMware Horizon Client > Check for Updates.

Add Horizon Client to the Dock
You can add Horizon Client to the Dock on the Mac client system.
Procedure

1

In the Applications folder, select VMware Horizon Client.

2

Drag the VMware Horizon Client icon to the Dock.

3

To configure the Dock icon to open Horizon Client at login or to show the icon in the Finder, right-click
the icon on the Dock, select Options, and select the appropriate command from the context menu.

When you quit Horizon Client, the application shortcut remains in the Dock.

Setting the Certificate Checking Mode in Horizon Client
Server certificate checking occurs for connections between Horizon Client and a server. A certificate is a
digital form of identification, similar to a passport or a driver's license.
End users can configure a setting in Horizon Client to determine whether Horizon Client connections are
rejected if server certificate checking fails.

VMware, Inc.
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You can configure the default certificate checking mode and prevent end users from changing it in
Horizon Client. For more information, see Configuring the Certificate Checking Mode for End Users.
Server certificate checking includes the following checks:
n

Is the certificate intended for a purpose other than verifying the identity of the sender and encrypting
server communications? That is, is it the correct type of certificate?

n

Has the certificate expired, or is it valid only in the future? That is, is the certificate valid according to
the computer clock?

n

Does the common name on the certificate match the host name of the server that sends it? A
mismatch can occur if a load balancer redirects Horizon Client to a server that has a certificate that
does not match the host name entered in Horizon Client. Another reason a mismatch can occur is if
you enter an IP address rather than a host name in the client.

n

Is the certificate signed by an unknown or untrusted certificate authority (CA)? Self-signed certificates
are one type of untrusted CA.
To pass this check, the certificate's chain of trust must be rooted in the device's local certificate store.

For information about distributing a self-signed root certificate and installing it on Mac client systems, see
the Advanced Server Administration document for the Mac Server that you are using, which is available
from the Apple website.
In addition to presenting a server certificate, the server also sends a certificate thumbprint to
Horizon Client. The thumbprint is a hash of the certificate public key and is used as an abbreviation of the
public key. If the server does not send a thumbprint, you see a warning that the connection is untrusted.
To set the certificate checking mode, start Horizon Client and select VMware Horizon Client >
Preferences from the menu bar. You have three choices:
n

Never connect to untrusted servers. This setting means that you cannot connect to the server if
any of the certificate checks fail. An error message lists the checks that failed.

n

Warn before connecting to untrusted servers. This setting means that you can click Continue to
ignore the warning if a certificate check fails because the server uses a self-signed certificate. For
self-signed certificates, the certificate name is not required to match the server name that you entered
in Horizon Client.

n

Do not verify server identity certificates. This setting means that no certificate checking occurs.

If an administrator later installs a security certificate from a trusted certificate authority and all certificate
checks pass when you connect, this trusted connection is remembered for that specific server. In the
future, if that server ever presents a self-signed certificate again, the connection fails. After a particular
server presents a fully verifiable certificate, it must always do so.

Configuring the Certificate Checking Mode for End Users
You can configure the certificate checking mode for end users. For example, you can configure that full
verification is always performed. Certificate checking occurs for TLS connections between a server and
Horizon Client.

VMware, Inc.
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You can configure one of the following certificate verification strategies for end users.
n

End users are allowed to select the certificate checking mode in Horizon Client.

n

(No verification) No certificate checks are performed.

n

(Warn) If the server presents a self-signed certificate, end users are warned. Users can determine
whether to allow this type of connection.

n

(Full security) Full verification is performed and connections that do not pass full verification are
rejected.

For information about the types of certificate checks that can be performed, see Setting the Certificate
Checking Mode in Horizon Client.
To configure the certificate checking mode so that end users cannot change it, set the Security Mode
key in the /Library/Preferences/com.vmware.horizon.plist file on the Mac client to one of the
following values.
n

1 implements Never connect to untrusted servers.

n

2 implements Warn before connecting to untrusted servers.

n

3 implements Do not verify server identity certificates.

Configure Advanced TLS Options
You can select the security protocols and cryptographic algorithms that Horizon uses to encrypt
communications between Horizon Client and servers, and between Horizon Client and Horizon Agent.
Horizon also uses the security options to encrypt the USB channel (communication between the USB
plugin and Horizon Agent).
By default, TLSv1.0, TLSv1.1, and TLSv1.2 are enabled. SSL v2.0 and 3.0 are not supported. The default
cipher control string is "!aNULL:kECDH+AESGCM:ECDH+AESGCM:RSA+AESGCM:kECDH
+AES:ECDH+AES:RSA+AES".
Note If TLSv1.0 and RC4 are disabled, USB redirection does not work when users are connected to
Windows XP remote desktops. If you make this feature work by enabling TLSv1.0 and RC4, a security
risk exists.
If you configure a security protocol for Horizon Client that is not enabled on the server to which the client
system connects, a TLS error occurs and the connection fails.
Important At least one of the protocol versions that you enable in Horizon Client must also be enabled
in the remote desktop for USB devices to be redirected to the remote desktop.
For information about configuring the security protocols that Connection Server can accept, see the
Horizon 7 Security document.

VMware, Inc.

18

VMware Horizon Client for Mac Installation and Setup Guide

Procedure

1

Select VMware Horizon Client > Preferences from the menu bar, click Security, and click
Advanced.

2

To enable or disable a security protocol, select the check box next to the security protocol name.

3

To change the cipher control string, replace the default string.

4

(Optional) To revert to the default settings, click Restore Defaults.

5

To save your changes, click Confirm.

Your changes take effect the next time you connect to the server.

Configuring Log File Collection Values
Horizon Client generates log files in the ~/Library/Logs/VMware Horizon Client directory on the
Mac client. An administrator can configure the maximum number of log files, and the maximum number of
days to keep log files, by setting keys in the /Library/Preferences/com.vmware.horizon.plist file
on the Mac client.
Table 1‑1. PLIST Keys for Log File Collection
Key

Description

MaxDebugLogs

Maximum number of log files. The maximum value is 100.

MaxDaysToKeepLogs

Maximum number of days to keep log files. This value has no limit.

Files that do not match these criteria are deleted when you start Horizon Client.
If the MaxDebugLogs or MaxDaysToKeepLogs keys are not set in the com.vmware.horizon.plist file,
the default number of log files is five and the default number of days to keep log files is seven.

Configure VMware Blast Options
You can configure H.264 decoding for remote desktop and published application sessions that use the
VMware Blast display protocol.
You can configure H.264 decoding before or after you connect to a server.
Note In previous Horizon Client versions, you had to select a network condition option to provide the
best user experience with VMware Blast. In this release, Horizon Client senses current network conditions
and chooses one or more transports to provide the best user experience automatically.
Prerequisites

To use H.264 decoding, Horizon Agent 7.0 or later must be installed.
Procedure

1

Select VMware Horizon Client > Preferences from the menu bar and click VMware Blast.
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2

To allow H.264 decoding in Horizon Client, select the Allow H.264 decoding check box.
When this option is selected (the default setting), Horizon Client uses H.264 decoding if the agent
supports H.264 software or hardware encoding. If the agent does not support H.264 software or
hardware encoding, Horizon Client uses JPG/PNG decoding. When this option is deselected,
Horizon Client uses JPG/PNG decoding.

3

Close the Preferences dialog box.

Changes take effect the next time a user connects to a remote desktop or published application and
selects the VMware Blast display protocol. Your changes do not affect existing VMware Blast sessions.

Horizon Client Data Collected by VMware
If your company participates in the customer experience improvement program, VMware collects data
from certain Horizon Client text boxes. Text boxes that contain sensitive information are anonymous.
VMware collects data on client systems to prioritize hardware and software compatibility. If your
company's Horizon administrator has opted to participate in the customer experience improvement
program, VMware collects anonymous data about your deployment to respond better to customer
requirements. VMware does not collect data that identifies your organization. Horizon Client information is
sent first to the Connection Server instance and then to VMware, with data from Connection Server,
desktop pools, and remote desktops.
Although the information is encrypted when it is in transit to the Connection Server instance, the
information on the client system is logged unencrypted in a user-specific directory. The logs do not
contain any personally identifiable information.
The Horizon administrator that installs Connection Server can select whether to participate in the VMware
customer experience improvement program when installing Connection Server, or can set an option in
Horizon Administrator after the installation.
Table 1‑2. Data Collected from Horizon Clients for the Customer Experience Improvement
Program
Is This Field
Made
Anonymous?

Example Value

Company that produced the Horizon Client
application

No

VMware

Product name

No

VMware Horizon Client

Client product version

No

(The format is x.x.x-yyyyyy, where x.x.x is the client version
number and yyyyyy is the build number.)

Client binary architecture

No

Examples include the following:

Description

VMware, Inc.
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i386

n

x86_64

n

arm
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Table 1‑2. Data Collected from Horizon Clients for the Customer Experience Improvement
Program (Continued)

Description

Is This Field
Made
Anonymous?

Example Value

Client build name

No

Examples include the following:
n

Host operating system

Host operating system kernel

Host operating system architecture

Host system model

Host system CPU

No

No

No

No

No

VMware-Horizon-Client-Win32-Windows

n

VMware-Horizon-Client-Linux

n

VMware-Horizon-Client-iOS

n

VMware-Horizon-Client-Mac

n

VMware-Horizon-Client-Android

n

VMware-Horizon-Client-WinStore

Examples include the following:
n

Windows 8.1

n

Windows 7, 64-bit Service Pack 1 (Build 7601 )

n

iPhone OS 5.1.1 (9B206)

n

Ubuntu 12.04.4 LTS

n

Mac OS X 10.8.5 (12F45)

Examples include the following:
n

Windows 6.1.7601 SP1

n

Darwin Kernel Version 11.0.0: Sun Apr 8 21:52:26 PDT
2012; root:xnu-1878.11.10~1/RELEASE_ARM_S5L8945X

n

Darwin 11.4.2

n

Linux 2.6.32-44-generic #98-Ubuntu SMP Mon Sep 24
17:27:10 UTC 2012

n

unknown (for Windows Store)

Examples include the following:
n

x86_64

n

i386

n

armv71

n

ARM

Examples include the following:
n

Dell Inc. OptiPlex 960

n

iPad3,3

n

MacBookPro8,2

n

Dell Inc. Precision Workstation T3400 (A04 03/21/2008)

Examples include the following:
n

Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GH

n

Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GH

n

unknown (for iPad)

Number of cores in the host system's
processor

No

For example: 4

MB of memory on the host system

No

Examples include the following:

VMware, Inc.

n

4096

n

unknown (for Windows Store)
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Table 1‑2. Data Collected from Horizon Clients for the Customer Experience Improvement
Program (Continued)

Description

Is This Field
Made
Anonymous?

Number of USB devices connected

No

2 (USB device redirection is supported only for Linux, Windows,
and Mac clients.)

Maximum concurrent USB device
connections

No

2

USB device vendor ID

No

Examples include the following:

USB device product ID

USB device family

USB device use count

VMware, Inc.

No

No

No

Example Value

n

Kingston

n

NEC

n

Nokia

n

Wacom

Examples include the following:
n

DataTraveler

n

Gamepad

n

Storage Drive

n

Wireless Mouse

Examples include the following:
n

Security

n

Human Interface Device

n

Imaging

(Number of times the device was shared)
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Using URIs to Configure
Horizon Client

2

You can use uniform resource identifiers (URIs) to create Web page or email links that end users can click
to start Horizon Client, connect to a server, or open a remote desktop or published application.
You create these links by constructing URIs that provide some or all the following information, so that your
end users do not need to supply it.
n

Server address

n

Port number for the server

n

Active Directory user name

n

Domain name

n

Remote desktop or published application display name

n

Window size

n

Actions including reset, log out, and start session

n

Display protocol

n

Options for redirecting USB devices

To construct a URI, you use the vmware-view URI scheme with Horizon Client specific path and query
parts.
To use URIs to start Horizon Client, Horizon Client must already be installed on client computers.
This chapter includes the following topics:
n

Syntax for Creating vmware-view URIs

n

Examples of vmware-view URIs

Syntax for Creating vmware-view URIs
URI syntax includes the vmware-view URI scheme, a path part to specify the remote desktop or
published application, and, optionally, a query to specify remote desktop or published application actions
or configuration options.
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URI Specification
Use the following syntax to create URIs to start Horizon Client.
vmware-view://[authority-part][/path-part][?query-part]

The only required element is the URI scheme, vmware-view. Because the scheme name is casesensitive for some versions of some client operating systems, type vmware-view.
Important In all parts, non-ASCII characters must first be encoded according to UTF-8 [STD63], and
then each octet of the corresponding UTF-8 sequence must be percent-encoded to be represented as
URI characters.
For information about encoding for ASCII characters, see the URL encoding reference at
http://www.utf8-chartable.de/.
authority-part

Server address and, optionally, a user name, a non-default port number, or
both. Underscores (_) are not supported in server names. Server names
must conform to DNS syntax.
To specify a user name, use the following syntax.
user1@server-address

You cannot specify a UPN address, which includes the domain. To specify
the domain, you can use the domainName query part in the URI.
To specify a port number, use the following syntax.
server-address:port-number

path-part

Remote desktop or published application. Use the remote desktop display
name or published application display name. This value is the name that is
specified in Horizon Administrator when the desktop or application pool was
created. If the display name contains a space, use the %20 encoding
mechanism to represent the space.

query-part

Configuration options to use, or the remote desktop or published
application actions to perform. Queries are not case-sensitive. To use
multiple queries, use an ampersand (&) between the queries. If the queries
conflict, Horizon Client uses the last query in the list. Use the following
syntax.
query1=value1[&query2=value2...]
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Supported Queries
The following queries are supported for this type of Horizon Client. If you are creating URIs for multiple
types of clients, such as desktop clients and mobile clients, see the installation and setup guide for each
type of client system for the list of supported queries.
action

Table 2‑1. Values That Can Be Used with the action Query
Value

Description

browse

Displays a list of available remote desktops and published applications
hosted on the specified server. You are not required to specify a remote
desktop or published application when using this action.
If you use the browse action and specify a remote desktop or published
application, the remote desktop or published application is highlighted
in the list of available items.

args

start-session

Opens the specified remote desktop or published application. If no
action query is provided and the remote desktop or published
application name is provided, start-session is the default action.

reset

Shuts down and restarts the specified remote desktop or published
application. Unsaved data is lost. Resetting a remote desktop is the
same as pressing the Reset button on a physical PC.

restart

Shuts down and restarts the specified remote desktop. Restarting a
remote desktop is the same as the Windows operating system restart
command. The operating system usually prompts the user to save any
unsaved data before it restarts.

logoff

Logs the user out of the guest operating system in the remote desktop.
If you specify a published application, the action is ignored or the end
user sees the warning message "Invalid URI action."

Specifies command-line arguments to add when the published application
starts. Use the syntax args=value, where value is a string. Use percent
encoding for the following characters:
n

For a colon (:), use %3A

n

For a back slash (\), use %5C

n

For a space ( ), use %20

n

For a double quotation mark ("), use %22

For example, to specify the filename "My new file.txt" for the Notepad
++ application, use %22My%20new%20file.txt%22.
appProtocol

For published applications, valid values are PCOIP and BLAST. For
example, to specify PCoIP, use the syntax appProtocol=PCOIP.
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connectUSBOnInsert

Connects a USB device to the foreground remote desktop when you plug in
the device. This query is implicitly set if you specify the unattended query
for a remote desktop. To use this query, you must set the action query to
start-session or else not have an action query. Valid values are true
and false. An example of the syntax is connectUSBOnInsert=true.

connectUSBOnStartup

Redirects all USB devices that are currently connected to the client system
to the remote desktop. This query is implicitly set if you specify the
unattended query for a remote desktop. To use this query, you must set
the action query to start-session or else not have an action query.
Valid values are true and false. An example of the syntax is
connectUSBOnStartup=true.

desktopLayout

Sets the size of the window that displays a remote desktop. To use this
query, you must set the action query to start-session or else not have
an action query.
Table 2‑2. Valid Values for the desktopLayout Query

desktopProtocol

Value

Description

fullscreen

Full screen on all connected external monitors. This value is the
default.

windowLarge

Large window.

windowSmall

Small window.

WxH

Custom resolution, where you specify the width by height, in
pixels. An example of the syntax is desktopLayout=1280x800.

For remote desktops, valid values are PCOIP and BLAST. For example, to
specify PCoIP, use the syntax desktopProtocol=PCOIP.

domainName

The NETBIOS domain name associated with the user who is connecting to
the remote desktop or published application. For example, you might use
mycompany rather than mycompany.com.

filePath

Specifies the path to the file on the local system that you want to open with
the published application. You can specify the full path or a relative path, for
example, ~/username/test%20file.txt. Use percent encoding for the
following characters:
n

For a colon (:), use %3A

n

For a back slash (\), use %5C

n

For a space ( ), use %20

For example, to represent file path /Users/username/test file.txt,
use /User/username/test%20file.txt.
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Examples of vmware-view URIs
You can use the vmware-view URI scheme to create hypertext links or buttons and include these links in
email or on a Web page. For example, an end user can click a URI link to start a remote desktop with the
startup options that you specify.

URI Syntax Examples
Each URI example is followed by a description of what the end user sees after clicking the URI link.
1

vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session

Horizon Client starts and connects to the view.mycompany.com server. The login dialog box prompts
the user for a user name, domain name, and password. After a successful login, the client connects
to the remote desktop that has the display name Primary Desktop, and the user is logged in to the
guest operating system.
Note In this example, the default display protocol and window size are used. The default display
protocol is PCoIP and the default window size is full screen.
2

vmware-view://view.mycompany.com:7555/Primary%20Desktop

This URI has the same effect as the previous example, except that it uses the nondefault port of 7555
for the Connection Server instance. (The default port is 443.) Because a remote desktop identifier is
provided, the remote desktop opens, even though the start-session action is not included in the
URI.
3

vmware-view://fred@view.mycompany.com/Finance%20Desktop?desktopProtocol=PCOIP

Horizon Client starts and connects to the view.mycompany.com server. In the login dialog box, the
User name text box is populated with fred. The user must supply the domain name and password.
After a successful login, the client connects to the remote desktop that has the display name Finance
Desktop, and the user is logged in to the guest operating system. The connection uses the PCoIP
display protocol.
4

vmware-view://view.mycompany.com/Calculator?action=start-session&appProtocol=BLAST

Horizon Client starts and connects to the view.mycompany.com server. In the login dialog box, the
user must supply the user name, domain name, and password. After a successful login, the client
connects to the published application that has the display name Calculator. The connection uses
the VMware Blast display protocol.
5

vmware-view://fred@view.mycompany.com/Finance%20Desktop?domainName=mycompany

VMware, Inc.

27

VMware Horizon Client for Mac Installation and Setup Guide

Horizon Client starts and connects to the view.mycompany.com server. In the login dialog box, the
User name text box is populated with fred, and the Domain text box is populated with mycompany.
The user must supply only a password. After a successful login, the client connects to the remote
desktop that has the display name Finance Desktop, and the user is logged in to the guest
operating system.
6

vmware-view://view.mycompany.com/

Horizon Client starts and the user is taken to the login prompt for connecting to the
view.mycompany.com server.
7

vmware-view://view.mycompany.com/Primary%20Desktop?action=reset

Horizon Client starts and connects to the view.mycompany.com server. The login dialog box prompts
the user for a user name, domain name, and password. After a successful login, Horizon Client
shows a dialog box that prompts the user to confirm the reset operation for Primary Desktop.
Note This action is available only if a Horizon administrator has enabled the reset feature for the
remote desktop.
8

vmware-view://view.mycompany.com/Primary%20Desktop?action=restart

Horizon Client starts and connects to the view.mycompany.com server. The login dialog box prompts
the user for a user name, domain name, and password. After a successful login, Horizon Client
shows a dialog box that prompts the user to confirm the restart operation for Primary Desktop.
Note This action is available only if a Horizon administrator has enabled the restart feature for the
remote desktop.
9

vmware-view://

Horizon Client starts and the user is taken to the page for entering the address of a server.
10

vmware-view://10.10.10.10/My%20Notepad++?args=%22My%20new%20file.txt%22

Starts My Notepad++ on server 10.10.10.10 and passes the argument My new file.txt in the
published application start command. The filename is enclosed in double quotes because it contains
spaces.
11

vmware-view://10.10.10.10/Notepad++%2012?args=a.txt%20b.txt
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Starts Notepad++ 12 on server 10.10.10.10 and passes the argument a.text b.txt in the
published application start command. Because the argument is not enclosed in quotes, a space
separates the filenames and the two files are opened separately in Notepad++.
Note Published applications can differ in the way that they use command-line arguments. For
example, if you pass the argument a.txt b.txt to WordPad, WordPad opens only one file, a.txt.

HTML Code Examples
You can use URIs to make hypertext links and buttons to include in emails or on Web pages. The
following examples show how to use the URI from the first URI example to code the hypertext link labeled
Test Link and a button labeled TestButton.
<html>
<body>
<a href="vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session">Test Link</a><br>
<form><input type="button" value="TestButton" onClick="window.location.href=
'vmware-view://view.mycompany.com/Primary%20Desktop?action=start-session'"></form> <br>
</body>
</html>
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Managing Remote Desktop and
Published Application
Connections

3

End users can use Horizon Client to connect to a server, log in to or off of remote desktops, and use
published applications. For troubleshooting purposes, end users can also restart and reset remote
desktops and reset published applications.
Depending on how you configure policies, end users might be able to perform many operations on their
remote desktops and published applications.
This chapter includes the following topics:
n

Configure Horizon Client to Select a Smart Card Certificate

n

Connect to a Remote Desktop or Published Application

n

Share Access to Local Folders and Drives with Client Drive Redirection

n

Clicking URL Links That Open Outside of Horizon Client

n

Open a Recent Remote Desktop or Published Application

n

Using a Touch Bar with Server, Desktop, and Application Connections

n

Connecting to a Server When Horizon Client Starts

n

Configure Horizon Client to Forget the Server User Name and Domain

n

Hide the VMware Horizon Client Window

n

Create Keyboard Shortcut Mappings

n

Modify the Horizon Client Mouse Shortcut Mappings

n

Modify the Horizon Client Shortcuts for Windows Actions

n

Searching for Remote Desktops and Published Applications

n

Select a Favorite Remote Desktop or Published Application

n

Switch Remote Desktops or Published Applications

n

Log Off or Disconnect

n

Autoconnect to a Remote Desktop

n

Configure Reconnect Behavior for Published Applications

n

Removing a Server Shortcut from the Home Window
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n

Reordering Shortcuts

n

Dragging Shortcuts and URIs

n

Disconnecting from a Server

Configure Horizon Client to Select a Smart Card
Certificate
You can configure a Horizon Client setting to select a local certificate, or the certificate on a smart card,
when you connect to a server. If you do not configure this setting, you must manually select a certificate.
Prerequisites

For your setting to take effect, a Horizon administrator must configure smart card authentication on the
server and only one certificate must be available on your client system or smart card.
If you have multiple certificates, Horizon Client always prompts you to select a certificate, regardless of
how you configure this setting.
Procedure

1

In the Applications folder, double-click VMware Horizon Client.

2

Select VMware Horizon Client > Preferences from the menu bar.

3

Click General in the Preferences dialog box.

4

Select Automatically select certificate.

5

Close the Preferences dialog box.
Your changes take effect when the dialog box is closed.

Connect to a Remote Desktop or Published Application
To connect to a remote desktop or published application, you must provide the name of a server and
supply credentials for your user account.
Before you have end users access remote desktops and published applications, test that you can connect
to a remote desktop or published application from the client system.
Prerequisites
n

Obtain login credentials, such as a user name and password, RSA SecurID user name and
passcode, RADIUS authentication user name and passcode, or smart card personal identification
number (PIN).

n

Obtain the NETBIOS domain name for logging in. For example, you might use mycompany rather than
mycompany.com.

n

Perform the administrative tasks described in Preparing Connection Server for Horizon Client.
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n

If you are outside the corporate network and require a VPN connection to access remote desktops
and published applications, verify that the client device is set up to use a VPN connection and turn on
that connection.

n

Verify that you have the fully qualified domain name (FQDN) of the server that provides access to the
remote desktop or published application. Underscores (_) are not supported in server names. If the
port is not 443, you also need the port number.

n

Configure the certificate checking mode for the certificate that the server presents. See Setting the
Certificate Checking Mode in Horizon Client.

n

If you are using smart card authentication, configure Horizon Client to use a local certificate or the
certificate on your smart card automatically. See Configure Horizon Client to Select a Smart Card
Certificate.

n

If you plan to use Touch ID to authenticate, add at least one fingerprint in the Touch setting on your
Mac. Touch ID authentication is available only if biometric authentication is enabled on the server. For
complete Touch ID authentication requirements, see Touch ID Authentication Requirements.

Procedure

1

If a VPN connection is required, turn on the VPN.

2

In the Applications folder, double-click VMware Horizon Client.

3

Click Continue to start remote desktop USB and printing services, or click Cancel to use
Horizon Client without remote desktop USB and printing services.
If you click Continue, you must provide system credentials. If you click Cancel, you can enable
remote desktop USB and printing services later.
Note The prompt to start remote desktop USB and printing services appears the first time you start
Horizon Client. It does not appear again, regardless of whether you click Cancel or Continue.

4

5

Connect to a server.
Option

Description

Connect to a new server

Click the New Server icon on the Horizon Client Home window, enter the server
name and port number (if necessary), and click Connect. An example of using a
non-default port is view.company.com:1443.

Connect to an existing server

Double-click the server shortcut on the Horizon Client Home window.

If you are prompted for RSA SecurID credentials or RADIUS authentication credentials, enter the
user name and passcode and click Login.
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6

If you are prompted for a user name and password, supply Active Directory credentials.
a

Type the user name and password of a user who is entitled to use at least one desktop or
application pool.

b

Select a domain.
If the Domain drop-down menu is hidden, you must type the user name as username@domain or
domain\username.

c

(Optional) Select the Remember this password check box if this feature is enabled and if the
server certificate can be fully verified.

d

(Optional) Select the Enable Touch ID check box to enable Touch ID authentication.
If Touch ID is enabled and you are logging in for the first time, your Active Directory credentials
are stored securely on your Mac for future use.

e

Click Login.
You might see a message that you must confirm before the login dialog box appears.

7

If the desktop security indicator turns red and a warning message appears, respond to the prompt.
Usually, this warning means that the server did not send a certificate thumbprint to the client. The
thumbprint is a hash of the certificate public key and is used as an abbreviation of the public key.

8

If you are prompted for Touch ID authentication, place your finger on the Touch ID sensor.

9

(Optional) If multiple display protocols are configured for a remote desktop, select the protocol to use.
VMware Blast provides better battery life and is the best protocol for high-end 3D and mobile device
users.
Option

Description

Select a display protocol for a remote
desktop

Select the remote desktop name, press Control-click, and select the display
protocol from the context menu.
Alternatively, you can select Settings from the context menu and select the
display protocol from the Connect Via drop-down menu in the Settings dialog
box.

Select a display protocol for a
published application

Select the published application name, press Control-click, select Settings from
the context menu, and select the display protocol from the Preferred protocol
drop-down menu in the Settings dialog box.

10 Double-click a remote desktop or published application to connect to it.
If you are connecting to a published desktop, and if the published desktop is already set to use a
different display protocol, you are prompted to either use the protocol that is set or have the system
log you off the remote operating system so that a connection can be made with the protocol that you
selected.
Note If you are entitled to only one remote desktop on the server, Horizon Client connects
automatically to that remote desktop.
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If a Horizon administrator has enabled the client drive redirection feature, the Sharing dialog box might
appear. From the Sharing dialog box, you can allow or deny access to files on your local system. For
more information, see Share Access to Local Folders and Drives with Client Drive Redirection.
After you connect to a server for the first time, Horizon Client connects to that server automatically the
next time you start Horizon Client. To disable this feature, see Connecting to a Server When Horizon
Client Starts.
If Horizon Client cannot connect to the remote desktop or published application, perform the following
tasks:
n

Verify that the certificate for the server is working properly. If it is not, in Horizon Administrator, you
might also see that View Agent or Horizon Agent on remote desktops is unreachable.

n

Verify that the tags set on the Connection Server instance allow connections from this user. See the
Horizon 7 Administration document.

n

Verify that the user is entitled to access the remote desktop or published application. For information
about entitling users, see the Setting Up Virtual Desktops in Horizon 7 or Setting Up Published
Desktops and Applications in Horizon 7 document.

Share Access to Local Folders and Drives with Client
Drive Redirection
With the client drive redirection feature, you can share folders and drives on the local client system with
remote desktops and published applications.
Shared drives can include mapped drives and USB storage devices.
In a Windows remote desktop, shared folders and drives appear in the This PC folder or in the Computer
folder, depending on the Windows operating system version. In a published application, such as Notepad,
you can browse to and open a file in a shared folder or drive.
You can turn on the ability to open local files in published applications directly from your local file system.
If you select a local file and press Control-click, the Open With menu lists the available published
applications. You can also open a local file by dragging it into the published application window or Dock
icon.
If you set a published application as the default application for files that have a certain file extension, all
files on your local file system that have that file extension are registered with the server. You can also turn
on the ability to run published applications from the Applications folder.
Note If a filename contains characters that are invalid in the Windows file system, you cannot open the
file in a published application. For example, you cannot open a file named test2<.txt in Notepad.
The client drive redirection settings apply to all remote desktops and published applications.
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Prerequisites

To share folders and drives with a remote desktop or published application, a Horizon administrator must
enable the client drive redirection feature. This task involves installing View Agent 6.1.1 or later, or
Horizon Agent 7.0 or later, and enabling the agent Client Drive Redirection option. It can also include
setting policies to control the client drive redirection behavior. For more information, see the Configuring
Remote Desktop Features in Horizon 7 document.
If the secure tunnel is enabled on the Connection Server instance, configuring the browser on the client
system to use a proxy server can cause poor client drive redirection performance. For the best client drive
redirection performance, configure the browser not to use a proxy server or automatically detect LAN
settings.
Procedure

1

2

Open the Preferences dialog box and display the Sharing panel.
Option

Description

From the desktop and application
selection window

Select VMware Horizon Client > Preferences and click Sharing.

From the Sharing dialog box that
appears when you connect to a remote
desktop or published application

Click the Preferences > Sharing link in the dialog box.

From within a remote desktop
operating system

Select VMware Horizon Client > Preferences from the menu bar and click
Sharing.

Configure the client drive redirection settings.
Option

Action

Share a specific folder or drive with
remote desktops and published
applications

Click the plus (+) button, browse to and select the folder or drive to share, and
click Add.

Stop sharing a specific folder or drive

Select the folder or drive in the Folder list and click the minus (-) button.

Give remote desktops and published
applications access to files in your
home directory

Select the Allow access to home-directory check box.
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Option

Action

Share USB storage devices with
remote desktops and published
applications

Select the Allow access to removable storage check box. The client drive
redirection feature shares all USB storage devices inserted in your client system
and all FireWire and Thunderbolt-connected external drives automatically.
Selecting a specific device to share is not necessary.
Note USB storage devices already connected to a remote desktop or published
application with the USB redirection feature are not shared.
If this check box is deselected, you can use the USB redirection feature to
connect USB storage devices to remote desktops and published applications.

Do not show the Sharing dialog box
when you connect to a remote desktop
or published application

3

Select the Do not show dialog when connecting to a desktop or application
check box.
If this check box is deselected, the Sharing dialog box appears the first time you
connect to a remote desktop or published application. For example, if you log in to
a server and connect to a remote desktop, you see the Sharing dialog box. If you
then connect to another remote desktop or published application, you do not see
the dialog box. To see the dialog box again, you must disconnect from the server
and log in again.

Configure settings for published applications.
a

Click the Settings button (gear icon) in the upper right corner of the desktop and application
selector window and select Applications in the left pane.

b

To turn on the ability to open local files with published applications from the local file system,
select Open local files in hosted applications.

c

To turn on the ability to run published applications from the Applications folder on the client
system, select Run hosted applications from your local Applications folder.

What to do next

Verify that you can see the shared folders from within the remote desktop or published application.
n

In a Windows remote desktop, open File Explorer and look in the This PC folder, or open Windows
Explorer and look in the Computer folder, depending on the Windows operating system version.

n

In a published application, select File > Open or File > Save As and navigate to the folder or drive.

The folders and drives that you selected for sharing might use one or more of the following naming
conventions:
n

name on MACHINE-NAME. For example, jsmith on JSMITH-W03.

n

N on MACHINE-NAME. For example, Z on JSMITH-W03.

n

name (N:). For example, jsmith (Z:).

A redirected folder can have two entrances, such as Z on JSMITH-W03 and jsmith (Z:), and both
entrances can appear at the same time. If all the volume labels (from A: through Z:) are already in use,
the redirected folder has only one entrance, such as Z on JSMITH-W03.
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Clicking URL Links That Open Outside of Horizon Client
A Horizon administrator can configure URL links that you click inside a remote desktop or published
application to open in the default browser on the local client system. The URL link might be to a Web
page, a phone number, an email address, or another type of link. This feature is called URL Content
Redirection.
A Horizon administrator can also configure URL links that you click inside a browser or application on the
local client system to open in a remote desktop or published application. If Horizon Client is not already
open you click the URL link, it starts and prompts you to log in.
A Horizon administrator might set up the URL Content Redirection feature for security purposes. For
example, if you are at work and click a link that points to a URL outside your company network, the link
might be more safely opened in a published application. An administrator can configure which published
application opens the link.

Responding to URL Content Redirection Prompts
The first time you start Horizon Client and connect to a server on which the URL Content Redirection
feature is configured, Horizon Client prompts you to open the VMware Horizon URL Filter application
when you click a link for redirection. Click Open to allow the URL to be redirected.
Depending on how the URL Content Redirection feature is configured, Horizon Client might display an
alert message that asks you to change your default Web browser to VMware Horizon URL Filter. If you
see this prompt, click the Use "VMware Horizon URL Filter" button to allow VMware Horizon URL Filter
to become the default browser. This prompt appears only once, unless you change your default browser
after clicking Use "VMware Horizon URL Filter".
Horizon Client might also display an alert message that asks you to select an application when you click a
URL. If you see this prompt, you can click Choose Application to search for an application on the local
client system, or click Search App Store to search for and install a new application. If you click Cancel,
the URL is not opened.

Using URL Content Redirection with Chrome
If the Chrome browser prompts you to enable the VMware Horizon URL Content Redirection Helper
extension, click Enable Extension to use the URL Content Redirection feature with the Chrome browser.
If you click Remove from Chrome, the extension is removed and URLs clicked in Chrome are not
redirected. You can still install the extension manually from the Chrome Web Store.
The first time a URL is redirected from the Chrome browser on the client system, you are prompted to
open the URL in Horizon Client. If you select the Remember my choice for VMware Horizon Client
links check box (recommended) and then click Open VMware Horizon Client, this prompt does not
appear again.
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Open a Recent Remote Desktop or Published Application
You can open recent remote desktops and published applications in Horizon Client.
Recent remote desktops and published applications appear in the order in which they were opened. If you
are not already connected to the server when you open a recent remote desktop or published application,
the server login screen appears and you must provide your credentials.
Prerequisites

To use this feature, you must have previously opened a remote desktop or published application. If you
plan to open a recent desktop or published application from the Dock, VMware Horizon Client must be in
the Dock. See Add Horizon Client to the Dock.
Procedure
n

To open a remote desktop or published application from the Dock, Ctrl-click VMware Horizon Client
in the Dock and select the remote desktop or published application from the menu.

n

To open a remote desktop or published application from the File menu, start Horizon Client, select
File > Open Recent, and select the remote desktop or published application from the menu.

Using a Touch Bar with Server, Desktop, and Application
Connections
If the Mac has a Touch Bar, you can use the Touch Bar to add a server, disconnect from a server, or
connect to a recent remote desktop or published application. This feature requires macOS Sierra (10.12)
or later.
Before you connect to a server, you can touch the plus (+) icon to add a server. After you connect to a
server, you can touch the Disconnect icon to disconnect from the server.
If you previously connected to a remote desktop or published application, its name appears on the Touch
Bar before you connect to a server. You can touch the remote desktop or application name to log in to the
server and start the remote desktop or published application.
You can add, remove, and reorder the items in the Horizon Client app Touch Bar by selecting VMware
Horizon Client > Customize Touch Bar.
For information about using the Touch Bar after you connect to a remote desktop or published application,
see Using a Touch Bar with Remote Desktops and Published Applications.

Connecting to a Server When Horizon Client Starts
After you connect to a server for the first time, Horizon Client connects automatically to that server the
next time you start Horizon Client.
To disable this feature, select the server shortcut on the Horizon Client Home window, press Control-click,
and deselect the Always connect at launch setting.
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If there are other server shortcuts on the Horizon Client Home window, you can enable the Always
connect at launch setting for a different server. You can enable the Always connect at launch setting
for only one server at a time.

Configure Horizon Client to Forget the Server User Name
and Domain
By default, Horizon Client stores the user name and domain that you enter when you log in to a server.
For increased security, you can configure Horizon Client so that it never remembers the server user name
and domain.
Procedure

1

Select VMware Horizon Client > Preferences from the menu bar.

2

Click General in the Preferences dialog box.

3

Deselect Remember username and domain.

4

Close the Preferences dialog box.
Your changes take effect when the dialog box is closed.

Hide the VMware Horizon Client Window
You can hide the VMware Horizon Client window after you open a remote desktop or published
application.
Procedure
n

To hide the VMware Horizon Client window after you open a remote desktop or published application,
click the Close button in the corner of the VMware Horizon Client window.
The VMware Horizon Client icon remains in the Dock.

n

To configure a setting that always hides the VMware Horizon Client window after you open a remote
desktop or published application, perform these steps before you connect to a server.
a

Select VMware Horizon Client > Preferences from the menu bar and click General in the
Preferences dialog box.

b

Select Hide client window after desktop/application launched.

c

Close the Preferences dialog box.
Your changes take effect when the dialog box is closed.

n

To show the VMware Horizon Client window after it has been hidden, select Window > Open
Selection Window from the menu bar, or right-click the VMware Horizon Client icon in the Dock and
select Show All Windows.
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Create Keyboard Shortcut Mappings
You can customize how remote desktops and published applications interpret Apple keyboard shortcuts
by creating keyboard shortcut mappings.
When you create a keyboard shortcut mapping, you map an Apple keyboard shortcut to a Windows
keyboard shortcut. A keyboard shortcut consists of one or more key modifiers, such as Control and Shift,
and a key code. A key code can be any key on your keyboard, except for a modifier key. When you press
a mapped keyboard shortcut on your Apple keyboard, the corresponding Windows keyboard shortcut or
action occurs in the remote desktop or application.
If you attempt to map an operating system keyboard shortcut, the results can be unpredictable. For more
information, see Considerations for Mapping Operating System Keyboard Shortcuts.
Procedure

1

Select VMware Horizon Client > Preferences and click Keyboard & Mouse.

2

Select the Key Mappings tab.

3

Configure the keyboard shortcut mappings.
Option

Action

Delete a keyboard shortcut mapping

Select the mapping to delete and click the minus (-) button.

Add a keyboard shortcut mapping

a

Click the plus (+) button.

b

Specify the Apple keyboard shortcut sequence by clicking one or more
keyboard modifiers and typing a key code in the text box. You can also select
a key from the drop-down menu. The From: field shows the keyboard
shortcut that you created.

c

Specify the corresponding Windows keyboard shortcut sequence by clicking
one or more keyboard modifiers and typing a key code in the text box. You
can also select a key from the drop-down menu. The To: field shows the
keyboard shortcut that you created.

d

To save your changes, click OK.

The keyboard shortcut mapping is enabled by default (the On check box next to
the keyboard shortcut mapping is selected).
Modify a keyboard shortcut mapping

Double-click the mapping and make your changes.
n

To modify the Apple keyboard shortcut sequence, click one or more keyboard
modifiers and type a key code in the text box. You can also select a key from
the drop-down menu.

n

To modify the corresponding Windows keyboard shortcut sequence, click one
or more keyboard modifiers and type a key code in the text box. You can also
select a key from the drop-down menu.

To save your changes, click OK.
Disable a keyboard shortcut mapping
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4

Option

Action

Enable or disable language-specific
key mappings

Select or deselect the Enable Language Specific Key Mappings check box.
The check box is selected by default.

Restore the default mappings

Click Restore Defaults. Any changes that you made to the default keyboard
shortcut mappings are deleted and the default mappings are restored.

Close the Preferences dialog box.
Your keyboard shortcut mapping changes take effect immediately. You do not need to restart open
remote desktops or published applications to make the changes take effect.

Considerations for Mapping Operating System Keyboard
Shortcuts
Mac and Windows both include default keyboard shortcuts. For example, Command-Tab and CommandSpace bar are common keyboard shortcuts on Mac systems and Ctrl+Esc and Alt+Enter are common
keyboard shortcuts on Windows systems. If you attempt to map one of these operating system keyboard
shortcuts in Horizon Client, the behavior of the shortcut on the Mac client system and in the remote
desktop or published application can be unpredictable.
n

If you map a keyboard shortcut, how the shortcut behaves on the Mac client system depends on how
the operating system manages the shortcut. For example, the keyboard shortcut might trigger an
action in the operating system and Horizon Client might not respond to the shortcut. Alternatively, the
keyboard shortcut might trigger an action in both the operating system and Horizon Client.

n

Before you map a Mac keyboard shortcut in Horizon Client, you must disable the shortcut in System
Preferences on the Mac client system. Not all Mac keyboard shortcuts can be disabled.

n

If you map a Windows keyboard shortcut in Horizon Client, the mapped action occurs when you use
the shortcut in the remote desktop or published application.

n

For published applications, Windows shortcuts that include the Windows key are disabled by default
and do not appear on the Horizon Client Keyboard Preferences dialog box. If you create a mapping
for one of these disabled keyboard shortcuts, the shortcut appears in the Keyboard Preferences
dialog box.

For a list of the default Mac keyboard shortcuts, go to the Apple support website
(http://support.apple.com). For a list of the default Windows shortcuts, go to the Microsoft Windows
website (http://windows.microsoft.com).

Modify the Horizon Client Mouse Shortcut Mappings
You can configure a single-button Apple mouse to send a right-click and a middle-click to remote
desktops and published applications. You can modify, enable, or disable the default mouse shortcut
mappings. You cannot create mouse shortcut mappings, or delete the default mouse shortcut mappings.
Procedure

1

Select VMware Horizon Client > Preferences and click Keyboard & Mouse.
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2

Select the Mouse Shortcuts tab.

3

Modify the mouse shortcut mappings.

4

Option

Action

Modify a mouse shortcut mapping

Double-click the mapping and make your changes. To save your changes, click
OK .

Disable a mouse shortcut mapping

Deselect the On check box next to the mouse shortcut mapping. When you
disable a mouse shortcut mapping, Horizon Client does not send the mouse
shortcut to the remote desktop or published application.

Enable a mouse shortcut mapping

Select the On check box next to the mouse shortcut mapping. When you enable a
mouse shortcut mapping, Horizon Client sends the mouse shortcut to the remote
desktop or published application.

Restore the default settings

Click Restore Defaults. Any changes that you made to the default mouse
shortcut mappings are deleted and the default mappings are restored.

Close the Preferences dialog box.
Your mouse shortcut mapping changes take effect immediately. You do not need to restart open
remote desktops or published applications to make the changes take effect.

Modify the Horizon Client Shortcuts for Windows Actions
Horizon Client includes preconfigured shortcut mappings for common Windows actions, including Toggle
Full Screen, Quit, Hide Application, Cycle Through Windows, and Cycle Through Windows in Reverse. It
also includes a preconfigured shortcut mapping for Toggle Exclusive Mode. You can enable or disable the
default shortcuts. You cannot create shortcuts or delete the default shortcuts.
Procedure

1

Select VMware Horizon Client > Preferences and click Keyboard & Mouse.

2

Select the Horizon Shortcuts tab.

3

Modify the default shortcuts.
Option

Action

Enable a shortcut

Select the On check box next to the shortcut. When you enable a shortcut,
Horizon Client does not send the shortcut to the remote desktop or published
application.

Disable a shortcut

Deselect the On check box next to the shortcut. When you disable a shortcut,
Horizon Client sends the shortcut to the remote desktop or published application.
Note The behavior of the shortcut on the remote desktop or published
application can be unpredictable.

Restore the default settings
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4

Close the Preferences dialog box.
Your changes take effect immediately. You do not need to restart open remote desktops or published
applications to make the changes take effect.

Searching for Remote Desktops and Published
Applications
After you connect to a server, the available remote desktops and published applications on that server
appear in the desktop and application selection window. You can search for a particular remote desktop
or published application by typing in the window.
When you begin to type, Horizon Client highlights the first matching remote desktop or published
application name. To connect to a highlighted remote desktop or published application, press the Enter
key. If you continue to type after the first match is found, Horizon Client continues to search for matching
remote desktops and published applications. If Horizon Client finds multiple matching remote desktops or
published applications, you can press the Tab key to switch to the next match. If you stop typing for two
seconds and then begin to type again, Horizon Client assumes that you are starting a new search.

Select a Favorite Remote Desktop or Published
Application
You can select favorite remote desktops and published applications. Shortcuts for favorite items are
identified by a star and appear on the Favorites tab. Favorite items are saved after you log off from the
server.
Prerequisites

Obtain the credentials for connecting to the server, such as a user name and password or RSA SecurID
and passcode.
Procedure

1

On the Horizon Client Home window, double-click the server icon.

2

If prompted, supply your RSA user name and passcode, your Active Directory user name and
password, or both.

3

To select or deselect a favorite remote desktop or published application, perform these steps.
Option

Action

Select a favorite

Select the remote desktop or published application shortcut, press Control-click,
and select Mark as Favorite from the context menu. A star appears in the upperright corner of the remote desktop or published application shortcut.

Deselect a favorite

Select the remote desktop or published application shortcut, press Control-click,
and deselect Mark as Favorite from the context menu. A star no longer appears
in the upper-right corner of the remote desktop or published application shortcut.
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4

(Optional) To display only favorite remote desktops or published applications, click the Favorites
button (star icon) in the upper-right corner of the desktop and application selection window.
You can click the Favorites button again to display all the available remote desktops and published
applications.

Switch Remote Desktops or Published Applications
If you are connected to a remote desktop, you can switch to another remote desktop. You can also
connect to a published application while you are connected to a remote desktop.
Procedure
u

Select a remote desktop or published application from the same server or from a different server.
Option

Action

Choose a different remote desktop or
published application on the same
server

Perform one of the following actions:

Choose a different remote desktop or
published application on a different
server

n

To keep the current remote desktop and also connect to another remote
desktop, select Window > VMware Horizon Client from the menu bar and
double-click the shortcut for the other remote desktop. That remote desktop
opens in a new window so that you have multiple remote desktops open. You
can switch between remote desktops from the Window menu on the menu
bar.

n

To close the current remote desktop and connect to another remote desktop,
select Connection > Disconnect from the menu bar and double-click the
shortcut for the other remote desktop.

n

To open another published application, double-click the shortcut for the other
published application. That published application opens in a new window. You
now have multiple published applications open, and you can switch between
them by clicking in an application window.

If you are entitled to multiple remote desktops or published applications, so that
the desktop and application selection window is open, click the Disconnect from
Server button in the left side of the toolbar in the desktop and application
selection window and disconnect from the server. If you are entitled to only one
remote desktop or published application, and the desktop and application
selection window is not open, you can select File > Disconnect from Server
from the menu bar and then connect to a different server.

Log Off or Disconnect
If you disconnect from a remote desktop without logging off, applications in the remote desktop might
remain open. You can also disconnect from a server and leave published applications running.
You can log off from a remote desktop even if you do not have the remote desktop open. This feature has
the same result as sending Ctrl+Alt+Del to the remote desktop and then clicking Log Off.
Note The Windows key combination Ctrl+Alt+Del is not supported in remote desktops. Instead, select
Connection > Send Ctrl-Alt-Del from the menu bar. Alternatively, press Fn-Control-Option-Delete on an
Apple keyboard.
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Procedure
n

Disconnect from a remote desktop without logging off.
Option

Action

Disconnect and quit Horizon Client

a

Click the Close button in the corner of the window, or select File > Close
from the menu bar.

b

Select VMware Horizon Client > Quit VMware Horizon Client from the
menu bar.

Disconnect and remain in
Horizon Client

Click the Disconnect button in the toolbar, or select Connection > Disconnect
from the menu bar.

Note A Horizon administrator can configure a remote desktop to log off when it is disconnected. In
this case, any open applications in the remote desktop are closed.
n

Log off and disconnect from a remote desktop.
Option

Action

From within the remote desktop

Use the Windows Start menu to log off.

From the menu bar

Select Connection > Log Off from the menu bar.
If you use this procedure, files that are open on the remote desktop are closed
without being saved first.

n

Disconnect from a published application.
Option

Action

Disconnect from the server and leave
the published application running

Perform one of the following actions:

Close the published application and
disconnect from the server

n

Click the Disconnect from Server button in the left side of the toolbar in the
desktop and application selection window.

n

Select File > Disconnect from Server from the menu bar.

a

Quit the published application in the usual manner, for example, click the
Close button in the corner of the application window.

b

Click the Disconnect from Server button in the left side of the toolbar in the
desktop and application selection window, or select File > Disconnect from
Server from the menu bar.

n

Log off when you do not have a remote desktop open.
If you use this procedure, files that are open on the remote desktop are closed without first being
saved.
Option

Action

From the Home window

a

Double-click the server shortcut and supply credentials.

b

Select the remote desktop and select Connection > Log Off from the menu
bar.

From the desktop and application
selection window
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Autoconnect to a Remote Desktop
You can configure a server to open a particular remote desktop when you connect to that server. You
cannot configure a server to open a published application.
If you are entitled to only one remote desktop on the server, Horizon Client always opens that remote
desktop when you connect to the server.
Prerequisites

Obtain credentials for connecting to the server, such as a user name and password, RSA SecurID user
name and passcode, RADIUS authentication user name and passcode, or smart card personal
identification number (PIN).
Procedure

1

On the Horizon Client Home window, double-click the server icon.

2

If prompted, supply your credentials.

3

Click the Settings button (gear icon) in the upper right corner of the desktop and application selection
window.

4

Select the remote desktop in the left pane of the Settings dialog box.

5

Select Autoconnect to this desktop.

6

To save your changes, close the Settings dialog box.

Configure Reconnect Behavior for Published Applications
If you disconnect from a server without closing a published application, Horizon Client prompts you to
reopen that published application the next time you connect to the server. You can change this behavior
by modifying the Reconnect Behavior setting in Horizon Client.
Prerequisites

Obtain credentials for connecting to the server, such as a user name and password, RSA SecurID user
name and passcode, RADIUS authentication user name and passcode, or smart card personal
identification number (PIN).
Procedure

1

On the Horizon Client Home window, double-click the server icon.

2

If prompted, supply your credentials.

3

Click the Settings button (gear icon) in the upper right corner of the desktop and application selection
window.

4

Select Applications in the left pane of the Settings dialog box.
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Select an application reconnect behavior option.
These options determine how Horizon Client behaves when a user connects to the server and
published applications are still running.
Option

Description

Ask to reconnect to open applications

Horizon Client shows the message You have one or more remote applications
running. Would you like to open them now? You can respond by clicking
Reconnect to Applications or Not Now. You can also select the Don't show
this message again check box to suppress the message in the future. This
setting is enabled by default.

Reconnect automatically to open
applications

Horizon Client immediately reopens any running published applications.

Do not ask to reconnect and do not
automatically reconnect

Horizon Client does not prompt you to reopen running published applications, nor
does it reopen running published applications. This setting has the same effect as
the Don't show this message again check box.

The new setting takes effect the next time you connect to the server.

Removing a Server Shortcut from the Home Window
After you connect to a server, Horizon Client saves a server shortcut to the Home window.
You can remove a server shortcut by selecting the shortcut and pressing the Delete key. Alternatively, you
can Control-click or right-click the shortcut on the Horizon Client Home window and select Delete.
You cannot remove remote desktop or published application shortcuts that appear after you connect to a
server.

Reordering Shortcuts
You can reorder server, remote desktop, and published application shortcuts.
Each time you connect to a server, Horizon Client saves a server shortcut to the Home window. You can
reorder these server shortcuts by selecting a shortcut and dragging it to a new position on the Home
window.
After you connect to a server, the available remote desktops and published applications on that server
appear in the desktop and application selection window. Remote desktop shortcuts appear first, followed
by published application shortcuts. Remote desktop shortcuts and published application shortcuts are
arranged alphabetically and cannot be rearranged.
When you are in the Favorites view (you clicked the Favorites button in the upper-right corner of the
desktop and application selection window), you can reorder remote desktop and published application
shortcuts by selecting a shortcut and dragging it to a new position on the window.

Dragging Shortcuts and URIs
You can drag server, remote desktop, and published application shortcuts and Uniform Resource
Identifiers (URIs).
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You can drag a server shortcut from the Horizon Client Home window into another app, such as Notes.
The server shortcut appears as a URI in the other app, for example, vmware-view://server-address.
You can also drag a server address or URI from another app into the Home window.
After you connect to a server, you can drag a remote desktop or published application shortcut from the
Horizon Client desktop and application selection window into another app, such as Notes. The shortcut
appears as a URI in the other app, for example, vmware-view://server-name/item-name.
If you drag a server, remote desktop, or published application shortcut from Horizon Client into a folder on
the Mac, Horizon Client creates a shortcut file in the folder. You can double-click this shortcut file to start
Horizon Client and connect to the server, remote desktop, or published application.
For information about URI syntax, see Syntax for Creating vmware-view URIs.

Disconnecting from a Server
After you have finished using a remote desktop or published application, you can disconnect from the
server.
To disconnect from a server, click the Disconnect from Server icon in the upper-left corner of the
Horizon Client menu bar.
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Horizon Client for Mac provides a familiar, personalized desktop and application environment. End users
can access USB and other devices connected to their local computer, send documents to any printer that
their local computer can detect, authenticate with smart cards, and use multiple display monitors.
This chapter includes the following topics:
n
Feature Support Matrix for Mac Clients
n

Internationalization

n

Monitors and Screen Resolution

n

Use USB Redirection to Connect USB Devices

n

Using the Real-Time Audio-Video Feature for Webcams and Microphones

n

Using the Session Collaboration Feature

n

Copying and Pasting

n

Dragging Text and Images

n

Using Published Applications

n

Saving Documents in a Published Application

n

Using a Touch Bar with Remote Desktops and Published Applications

n

Printing from a Remote Desktop or Published Application

n

PCoIP Client-Side Image Cache

Feature Support Matrix for Mac Clients
When planning which display protocol and features to make available to your end users, use the following
information to determine which guest operating systems support the feature.
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Table 4‑1. Features Supported for Windows Virtual Desktops

Windows
10 Desktop

Windows 8.x
Desktop

Windows 7
Desktop

Windows Vista
Desktop

Windows
XP Desktop

Windows
Server
2008/2012 R2 or
Windows
Server 2016
Desktop

RSA SecurID or
RADIUS

X

X

X

Limited

Limited

X

Single sign-on

X

X

X

Limited

Limited

X

PCoIP display protocol

X

X

X

Limited

Limited

X

VMware Blast display
protocol

X

X

X

USB redirection

X

X

X

Client drive redirection

X

X

X

Real-Time Audio-Video
(RTAV)

X

X

X

Limited

Limited

X

Virtual printing

X

X

X

Limited

Limited

X

Location-based printing

X

X

X

Limited

Limited

X

Smart cards

X

X

X

Limited

Limited

X

Multiple monitors

X

X

X

Limited

Limited

X

Feature

RDP display protocol
X

Limited

Limited

X
X

Wyse MMR
Windows 7 MMR

Windows 10 remote desktops require View Agent 6.2 or later or Horizon Agent 7.0 or later. Windows
Server 2012 R2 remote desktops require View Agent 6.1 or later or Horizon Agent 7.0 or later. Windows
Server 2016 remote desktops require Horizon Agent 7.0.2 or later.
Important View Agent 6.1 and later and Horizon Agent 7.0 and later releases do not support Windows
XP and Windows Vista remote desktops. View Agent 6.0.2 is the last release that supports these guest
operating systems. Customers who have an extended support agreement with Microsoft for Windows XP
and Vista, and an extended support agreement with VMware for these guest operating systems, can
deploy the View Agent 6.0.2 version of their Windows XP and Vista remote desktops with Connection
Server 6.1.
For descriptions of these features, see the Horizon 7 Architecture Planning document.
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Feature Support for Published Desktops on RDS Hosts
RDS hosts are server computers that have Windows Remote Desktop Services and View Agent or
Horizon Agent installed. Multiple users can have remote desktop sessions on an RDS host
simultaneously. An RDS host can be either a physical machine or a virtual machine.
Note The following table contains rows only for the features that are supported. Where the text specifies
a minimum version of View Agent, the text "and later" is meant to include Horizon Agent 7.0.x and later.
Table 4‑2. Features Supported for RDS Hosts with View Agent 6.0.x or Later, or
Horizon Agent 7.0.x or Later, Installed
Feature

Windows Server 2008 R2
RDS Host

Windows Server 2012
RDS Host

Windows Server 2016 RDS
Host

RSA SecurID or RADIUS

X

X

Horizon Agent 7.0.2 and later

Smart card

View Agent 6.1 and later

View Agent 6.1 and later

Horizon Agent 7.0.2 and later

Single sign-on

X

X

Horizon Agent 7.0.2 and later

PCoIP display protocol

X

X

Horizon Agent 7.0.2 and later

VMware Blast display
protocol

Horizon Agent 7.0 and later

Horizon Agent 7.0 and later

Horizon Agent 7.0.2 and later

HTML Access

View Agent 6.0.2 and later
(virtual machine only)

View Agent 6.0.2 and later
(virtual machine only)

Horizon Agent 7.0.2 and later

View Agent 6.1 and later

Horizon Agent 7.0.2 and later

USB redirection
Client drive redirection

View Agent 6.1.1 and later

View Agent 6.1.1 and later

Horizon Agent 7.0.2 and later

Virtual printing

View Agent 6.0.1 and later
(virtual machine only)

View Agent 6.0.1 and later
(virtual machine only)

Horizon Agent 7.0.2 and later
(virtual machine only)

Location-based printing

View Agent 6.0.1 and later
(virtual machine only)

View Agent 6.0.1 and later
(virtual machine only)

Horizon Agent 7.0.2 and later
(virtual machine only)

Multiple monitors

X

X

Horizon Agent 7.0.2 and later

Unity Touch

X

X

Horizon Agent 7.0.2 and later

Real-Time Audio-Video
(RTAV)

Horizon Agent 7.0.2 and later

Horizon Agent 7.0.2 and
later

Horizon Agent 7.0.3 and later

For information about which editions of each guest operating system are supported, see the Horizon 7
Installation document.

Limitations for Specific Features
Specific features that are supported on Windows desktops for Horizon Client for Mac have certain
restrictions.
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Table 4‑3. Requirements for Specific Features
Feature

Requirements

Real-Time Audio-Video

See System Requirements for Real-Time Audio-Video.

Virtual printing and location-based printing for Windows Server
2008 R2 desktops, published desktops (on virtual machine
RDS hosts), and published applications

Horizon 6 version 6.0.1 and later servers.

Smart cards

For published desktops, View Agent 6.1 and later.

Client drive redirection

View Agent 6.1.1 and later or Horizon Agent 7.0 and later.

Feature Support for Linux Desktops
If you have View Agent 6.1.1 or later, or Horizon Agent 7.0 or later, some Linux guest operating systems
are supported. For a list of supported Linux operating systems and information about supported features,
see the Setting Up Horizon 6 for Linux Desktops or Setting Up Horizon 7 for Linux Desktops document.

Internationalization
The user interface and documentation are available in English, Japanese, French, German, Simplified
Chinese, Traditional Chinese, Korean, and Spanish.

Monitors and Screen Resolution
When you use the VMware Blast display protocol or the PCoIP display protocol, you can extend a remote
desktop to multiple monitors. If you have a Mac with Retina Display, you can see the remote desktop in
full resolution.
With the VMware Blast display protocol or the PCoIP display protocol, a remote desktop screen resolution
of 4K (3840 x 2160) is supported. The number of 4K displays that are supported depends on the
hardware version of the desktop virtual machine and the Windows version.
Hardware Version

Windows Version

Number of 4K Displays Supported

10 (ESXi 5.5.x compatible)

7, 8, 8.x, 10

1

11 (ESXi 6.0 compatible)

7

3

(3D rendering feature disabled and Windows Aero disabled)
11

7

1

(3D rendering feature enabled)
11

8, 8.x, 10

1

The remote desktop must have View Agent 6.2 or later, or Horizon Agent 7.0 or later, installed. For the
best performance, the virtual machine should have at least 2 GB of RAM and 2 vCPUs. This feature
might require good network conditions, such as a bandwidth of 1000 Mbps with low network latency and a
low package loss rate.
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Using Full-Screen Mode with Multiple Monitors
When a remote desktop window is open, you can use the Window > Enter Full Screen menu item or the
expander arrows in the upper-right corner of the remote desktop window to extend the remote desktop
across multiple monitors. You can select the Window > Use Single Display in Full Screen menu item to
make the remote desktop fill only one monitor.
The monitors do not have to be in the same mode. For example, if you are using a laptop that is
connected to an external monitor, the external monitor can be in portrait mode or landscape mode.
You can select a full-screen option from the Settings dialog box after you connect to a server and before
you open a remote desktop. Click the Settings button (gear icon) in the upper-right corner of the desktop
and application selection window, select the remote desktop, and select a full-screen option from the Full
Screen drop-down menu.
You can use the selective multiple-monitor feature to display a remote desktop window on a subset of
your monitors. For more information, see Select Specific Monitors in a Multiple-Monitor Setup.

Using Remote Desktops with Split View
With Split View, which is supported in El Capitan (10.11) and later, you can fill your Mac screen with two
applications without manually moving and resizing windows. You can use Split View with remote desktops
in full-screen mode (Full Screen or Use Single Display in Full Screen option).

Using a High-Resolution Mac with Retina Display
If you use the VMware Blast display protocol or the PCoIP display protocol, Horizon Client supports high
resolutions for client systems that support Retina Display. After you connect to a remote desktop, you can
select the Connection > Resolution > Full Resolution menu item to enable a high-resolution mode.
This menu item appears only if the client system supports Retina Display.
In high-resolution mode, the DPI Synchronization feature ensures that the remote desktop's DPI setting
matches the client system's DPI setting. For more information, see Using DPI Synchronization.

Using DPI Synchronization
The DPI Synchronization feature ensures that the DPI setting in a remote desktop or published
application matches the client system's DPI setting. When you start a new remote session, Horizon Agent
sets the DPI value in the remote session to match the DPI value of the client system.
The DPI Synchronization feature is enabled when the following requirements are met.
n

The client system supports Retina Display.

n

Full-resolution mode (Connection > Resolution > Full Resolution) is selected in the remote
desktop.

n

If you use multiple monitors, the Retina Display is the primary window in system preferences. You
cannot have more than one display in full-screen mode.
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The DPI Synchronization feature cannot change the DPI setting of an active remote session. If you
connect to an active remote session in full-resolution mode, Horizon Client scales the resolution to be
similar to when DPI Synchronization is enabled, but icons are not as clear. If you switch from normal to
full-resolution mode in an active remote session, Horizon Client prompts you to log off from the remote
session for the resolution change to take effect.
If you use a non-Retina Display computer when you start a remote session, and then use a Retina
Display computer to connect to the same session, the remote session cannot change to the new DPI
setting until after you log off.
A Horizon administrator can disable the DPI Synchronization feature on a remote desktop by disabling
the DPI Synchronization agent group policy setting. You must log out and log in to the remote desktop
again to make the configuration change take effect. For information about the DPI Synchronization
group policy setting, see the Configuring Remote Desktop Features in Horizon 7 document.
For virtual desktops, the DPI Synchronization feature is supported on the following guest operating
systems.
n

32-bit or 64-bit Windows 7

n

32-bit or 64-bit Windows 8.x

n

32-bit or 64-bit Windows 10

n

Windows Server 2008 R2 configured as a desktop

n

Windows Server 2012 R2 configured as a desktop

n

Windows Server 2016 configured as a desktop

For published desktops, the DPI Synchronization feature is supported on the following RDS hosts.
n

Windows Server 2012 R2

n

Windows Server 2016

The DPI synchronization feature does not work with published applications.
The DPI Synchronization feature requires Horizon Agent 7.0.2 or later and Horizon Client 4.7 or later. The
DPI Synchronization feature is not available if you use Horizon Client 4.7 with Horizon Agent 7.0 or 7.0.1,
or an earlier (pre-4.7) version of Horizon Client with Horizon Agent 7.0.2 or later.

Select Specific Monitors in a Multiple-Monitor Setup
With the selective multiple-monitor feature, you can select the monitors on which to display a remote
desktop window. For example, if you have three monitors, you can specify that the remote desktop
window appears on only two of those monitors. This feature is not supported for published applications.
You can select up to four adjacent monitors.
Procedure

1

Start Horizon Client and log in to a server.

2

In the desktop and application selector window, right-click the remote desktop and select Settings.
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3

From the Connect Via drop-down menu, select PCoIP or VMware Blast.

4

Select Use Selective Displays from the Full Screen drop-down menu.
Thumbnails of the monitors that are currently connected to the client system appear under Display
Arrangement. The display topology matches the display settings on the client system.

5

To select or deselect a monitor on which to display the remote desktop window, click a thumbnail.
When you select a monitor, its thumbnail changes color. If you violate a display selection rule, a
warning message appears.

6

Connect to the remote desktop.
Your changes are applied immediately when you connect to the remote desktop. The remote desktop
enters full-screen mode on the displays that you selected.

Using Exclusive Mode
Exclusive mode is similar to full-screen mode in that the remote desktop fills the screen. With exclusive
mode, unlike full-screen mode, the VMware Horizon Client menu bar and Dock do not appear when you
move your pointer to the edges of the screen.
To enter exclusive mode, open a remote desktop in windowed mode, press and hold down the Option
key, and select Window > Enter Exclusive Mode.
When a remote desktop is in windowed mode, you can also press Command-Control-Option-F to enter
exclusive mode. To exit exclusive mode, press Command-Control-Option-F again.
Note If you do not press and hold down the Option key, the Enter Full Screen menu item appears
instead of the Enter Exclusive Mode menu item. If the remote desktop is in full-screen mode, you cannot
select the Enter Excusive Mode menu item.
To use exclusive mode with two monitors, before you open the remote desktop, select Use All Displays
from the Settings dialog box, and then open the desktop and enter exclusive mode. To use exclusive
mode with a single monitor, before you open the remote desktop, select Use Single Display from the
Settings dialog box, and then connect to the remote desktop and enter exclusive mode.
To open the Settings dialog box, click the Settings button (gear icon) in the upper right corner of the
desktop and application selection window, select the remote desktop, and select an option from the Full
Screen drop-down menu.

Use USB Redirection to Connect USB Devices
With the USB redirection feature, you can use locally attached USB devices, such as thumb flash drives,
in a remote desktop or published application.
When you use the USB redirection feature, most USB devices that are attached to the local client system
become available from menus in Horizon Client. You use these menus to connect and disconnect the
devices.
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With View Agent 6.1 and later, or Horizon Agent 7.0 and later, you can redirect locally connected USB
thumb flash drives and hard disks for use in published desktops and applications. Beginning with
Horizon Agent 7.0.2, published desktops and applications can also support more generic USB devices,
including TOPAZ Signature Pad, Olympus Dictation Foot pedal, and Wacom signature pad. Other types of
USB devices, including security storage drives and USB CD-ROM drives, are not supported in published
desktops and applications.
If you use the client drive redirection feature to share a USB storage device or a folder on a USB storage
device, you cannot use the USB redirection feature to redirect the device to a remote desktop or
published application because the device is already shared.
You can connect USB devices to a remote desktop or published application either manually or
automatically.
Prerequisites
n

To use USB devices with a remote desktop or published application, a Horizon administrator must
enable the USB redirection feature.
This task includes installing the USB Redirection component of Horizon Agent, and can include
setting policies regarding USB redirection. For more information, see the Configuring Remote
Desktop Features in Horizon 7 document.

n

The first time you attempt to connect a USB device, you must provide the Administrator password.
Horizon Client prompts you for the password.
Some components required for USB redirection that Horizon Client installs must be configured, and
configuration of these components requires Administrator privileges.

n

Become familiar with USB Redirection Limitations.

Procedure
n

Manually connect the USB device to a remote desktop.
a

The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

b

Connect the USB device to the local client system.

c

From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB >
Connect to a desktop to list USB devices.

d

Connect to a remote desktop to list the connected USB devices and select a USB device.

The device is manually redirected from the local system to the remote desktop.
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n

Connect the USB device to a published application.
a

The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

b

Plug in the USB device.

c

Open the published application.

d

Click the Settings button (gear icon) in the upper right corner of the desktop and application
selection window.

e

Select Applications in the left pane of the Settings dialog box.

f

Click USB at the top of the right pane of the Settings dialog box.
The available USB devices appear in the left pane.

g

Select a USB device and click Connect Device.
If a USB device is already connected to a remote desktop or application, you must disconnect the
device from the desktop or application before you can select it.

h

Select a published application and click Continue.
You can select any running published application. After you select a published application, you
can use the USB device with the published application.

i

After you finish using the published application, open the Settings dialog box again, select USB,
and select Disconnect to release the USB device from the published application.
You can now use the USB device with your local client system, a remote desktop, or another
published application.

n

Configure Horizon Client to connect USB devices automatically to a remote desktop when you plug
them in to the local system.
Use the autoconnect feature if you plan to connect devices that use MTP drivers, such as Androidbased Samsung smart phones and tablets.
a

Before you plug in the USB device, start Horizon Client and connect to the remote desktop.

b

The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

c

From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB >
Automatically connect when inserted.

d

Plug in the USB device.

USB devices that you connect to your local system after you start Horizon Client are redirected to the
remote desktop.
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n

Configure Horizon Client to connect USB devices automatically to a remote desktop when
Horizon Client starts.
a

The first time you use the USB feature, from the VMware Horizon Client menu bar in the remote
desktop, click Connection > USB > Start remote USB services and provide the Administrator
password when prompted.

b

From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB >
Automatically connect at startup.

c

Plug in the USB device and restart Horizon Client.

USB devices that are connected to the local client system when you start Horizon Client are
redirected to the remote desktop.
The USB device appears in the remote desktop or published application. A USB device might take up to
20 seconds to appear in the remote desktop or published application. The first time you connect the
device to a remote desktop you might be prompted to install drivers.
If the USB device does not appear in the remote desktop or published application after several minutes,
disconnect and reconnect the device to the client computer.
What to do next

If you have problems with USB redirection, see the topic about troubleshooting USB redirection problems
in the Configuring Remote Desktop Features in Horizon 7 document.

USB Redirection Limitations
The USB redirection feature has certain limitations.
n

When you access a USB device from a menu in Horizon Client and use the device in a remote
desktop, you cannot access the device on the local computer.

n

USB devices that do not appear in the menu, but are available in a remote desktop, include human
interface devices such as keyboards and pointing devices. The remote desktop and the local
computer use these devices at the same time. Interaction with these devices can sometimes be slow
because of network latency.

n

Large USB disk drives can take several minutes to appear in the remote desktop.

n

Some USB devices require specific drivers. If a required driver is not already installed on a remote
desktop, you might be prompted to install it when you connect the USB device to the remote desktop.

n

If you plan to attach USB devices that use MTP drivers, such as Android-based Samsung smart
phones and tablets, configure Horizon Client so that it automatically connects USB devices to the
remote desktop. Otherwise, if you try to manually redirect the USB device by using a menu item, the
device is not redirected unless you unplug the device and then plug it in again.

n

Webcams are not supported for USB redirection.
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n

The redirection of USB audio devices depends on the state of the network and is not reliable. Some
devices require a high data throughput even when they are idle. Audio input and output devices work
well with the Real-Time Audio-Video feature. You do not need to use USB redirection for those
devices.

n

You cannot format a redirected USB drive in a published desktop unless you connect as an
administrator user.

Note Do not redirect USB Ethernet devices to a remote desktop. The remote desktop can connect to the
network if the local system is connected. If you have set the remote desktop to autoconnect USB devices,
you can add an exception to exclude the Ethernet connection. See Configuring USB Redirection on a
Mac Client .

Configuring USB Redirection on a Mac Client
You can configure which USB devices are redirected to a remote desktop.
You can configure USB policies for View Agent or Horizon Agent on the remote desktop, and for
Horizon Client on the Mac client system, to achieve the following goals.
n

Restrict the types of USB devices that Horizon Client makes available for redirection.

n

Make View Agent or Horizon Agent prevent certain USB devices from being forwarded from a client
computer.

n

Specify whether Horizon Client splits composite USB devices into separate components for
redirection.
Composite USB devices consist of a combination of two or more devices, such as a video input
device and a storage device.

Configuration settings on the client might be merged with or overridden by corresponding policies set for
View Agent or Horizon Agent on the remote desktop. For information about how USB settings on the
client work together with View Agent or Horizon Agent USB policies, see the topics about using policies to
control USB redirection in the Configuring Remote Desktop Features in Horizon 7 document.

Using Rules from a Previous Horizon Client Release
In previous Horizon Client releases, you had to use sudo to configure USB filtering and splitting rules. You
can use the following procedure to move rules that use sudo to new rules that do not use sudo.
1

On the Mac client, open Terminal (/Applications/Utilities/Terminal.app) and run the
following command:
sudo defaults export com.vmware.viewusb /tmp/usb.plist

2

Open a Terminal window (press command+N) and run the following command:
defaults import com.vmware.viewusb /tmp/usb.plist
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3

In the first Terminal window, run the following command:
sudo rm -rf /tmp/usb.plist

4

Close both Terminal windows.

You can now use defaults write com.vmware.viewusb property value to update the rules.

Syntax for Configuring USB Redirection
You can configure filtering and splitting rules to include USB devices, or to exclude USB devices from
being redirected. On a Mac client, you configure USB functionality by using Terminal
(/Applications/Utilities/Terminal.app) and running a command as root.
n

To list the rules:
# defaults read domain

For example:
# defaults read com.vmware.viewusb
n

To remove a rule:
# defaults delete domain property

For example:
# defaults delete com.vmware.viewusb ExcludeVidPid
n

To set or replace a filter rule:
# defaults write domain property value

For example:
# defaults write com.vmware.viewusb ExcludeVidPid vid-1234_pid-5678

Important Some configuration parameters require the VID (vendor ID) and PID (product ID) for a
USB device. To find the VID and PID, you can search on the Internet for the product name combined
with vid and pid. Alternatively, you can look in the USB Log file after you plug in the USB device to
the Mac client when Horizon Client is running. For more information, see Turn on Logging for USB
Redirection.
n

To set or replace a splitting rule for a composite device:
# defaults write domain property value

VMware, Inc.

60

VMware Horizon Client for Mac Installation and Setup Guide

For example:
#
#
#
#

defaults
defaults
defaults
defaults

write
write
write
write

com.vmware.viewusb
com.vmware.viewusb
com.vmware.viewusb
com.vmware.viewusb

AllowAutoDeviceSplitting true
SplitExcludeVidPid vid-03f0_Pid-2a12
SplitVidPid "'vid-0911_Pid-149a(exintf:03)'"
IncludeVidPid vid-0911_Pid-149a

Composite USB devices consist of a combination of two or more devices, such as a video input
device and a storage device. The first line in this example turns on automatic splitting of composite
devices. The second line excludes the specified composite USB device (Vid-03f0_Pid-2a12) from
splitting.
The third line instructs Horizon Client to treat the components of a different composite device
(Vid-0911_Pid-149a) as separate devices, but to exclude the component that has interface number
03 from being redirected. This component is kept local.
Because this composite device includes a component that is ordinarily excluded by default, such as a
mouse or keyboard, the fourth line is necessary so that the other components of the composite
device Vid-0911_Pid-149a can be redirected to the remote desktop.
The first three properties are splitting properties. The last property is a filtering property. Filtering
properties are processed before splitting properties.

Example: Excluding a USB Ethernet Device
You might want to exclude a USB Ethernet device from redirection. For example, if the Mac client uses a
USB Ethernet device to connect the network for the Mac client to a remote desktop, and you redirect that
USB Ethernet device, the Mac client loses its connection to both the network and the remote desktop.
To hide a device from the USB connection menu permanently, or if you have set the remote desktop to
autoconnect USB devices, you can add an exception to exclude the Ethernet connection as follows.
defaults write com.vmware.viewusb ExcludeVidPid vid-xxxx_pid-yyyy

In this example, xxxx is the vendor ID and yyyy is the product ID of the USB Ethernet adapter.

USB Redirection Properties
When creating filtering rules, you can use the USB redirection properties.
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Table 4‑4. Configuration Properties for USB Redirection
Policy Name and Property

Description

Allow Auto Device Splitting

Allow the automatic splitting of composite USB devices.

Property:

The default value is undefined, which equates to false.

AllowAutoDeviceSplitting
Exclude Vid/Pid Device From Split
Property:
SplitExcludeVidPid

Excludes a composite USB device specified by vendor and product IDs from
splitting. The format of the setting is as follows:
vid-xxx1_pid-yyy1[;vid-xxx2_pid-yyy2]...
You must specify ID numbers in hexadecimal. You can use the wildcard character
(*) in place of individual digits in an ID.
For example: vid-0781_pid-55**
The default value is undefined.

Split Vid/Pid Device
Property:
SplitVidPid

Treats the components of a composite USB device specified by vendor and
product IDs as separate devices. The format of the setting is as follows:
vid-xxxx_pid-yyyy([exintf:zz[;exintf:ww]])[;...]
You can use the exintf keyword to exclude components from redirection by
specifying their interface number. You must specify ID numbers in hexadecimal,
and interface numbers in decimal including any leading zero. You can use the
wildcard character (*) in place of individual digits in an ID.
For example: vid-0781_pid-554c(exintf:01;exintf:02)
Note If the composite device includes components that are automatically
excluded, such as mouse and keyboard components, then Horizon does not
include the components that you have not explicitly excluded automatically. You
must specify a filter policy such as Include Vid/Pid Device to include those
components.
The default value is undefined.

Allow Audio Input Devices

Allows audio input devices to be redirected.

Property:

The default value is undefined, which equates to true.

AllowAudioIn
Allow Audio Output Devices

Allows audio output devices to be redirected.

Property:

The default value is undefined, which equates to false.

AllowAudioOut
Allow HID

Allows input devices other than keyboards or mice to be redirected.

Property:

The default value is undefined, which equates to true.

AllowHID
Allow HIDBootable
Property:

Allows input devices other than keyboards or mice that are available at startup
time (also known as hid-bootable devices) to be redirected.

AllowHIDBootable

The default value is undefined, which equates to true.

Allow Device Descriptor Failsafe

Allows devices to be redirected even if the Horizon Client fails to get the
config/device descriptors.

Property:
AllowDevDescFailsafe

To allow a device even if it fails the config/desc, include it in the Include filters,
such IncludeVidPid or IncludePath.
The default value is undefined, which equates to false.
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Table 4‑4. Configuration Properties for USB Redirection (Continued)
Policy Name and Property

Description

Allow Keyboard and Mouse Devices
Property:

Allows keyboards with integrated pointing devices (such as a mouse, trackball, or
touch pad) to be redirected.

AllowKeyboardMouse

The default value is undefined, which equates to false.

Allow Smart Cards

Allows smart-card devices to be redirected.

Property:

The default value is undefined, which equates to false.

AllowSmartcard
Allow Video Devices

Allows video devices to be redirected.

Property:

The default value is undefined, which equates to true.

AllowVideo
Disable Remote Configuration Download

Disables the use of View Agent or Horizon Agent settings when performing USB

Property:

device filtering.

DisableRemoteConfig

The default value is undefined, which equates to false.

Exclude All Devices

Excludes all USB devices from being redirected. If set to true, you can use other

Property:

policy settings to allow specific devices or families of devices to be redirected. If
set to false, you can use other policy settings to prevent specific devices or

ExcludeAllDevices

families of devices from being redirected.
If you set the value of Exclude All Devices to true on View Agent or
Horizon Agent, and this setting is passed to Horizon Client, the View Agent or
Horizon Agent setting overrides the Horizon Client setting.
The default value is undefined, which equates to false.

Exclude Device Family
Property:

Excludes families of devices from being redirected. The format of the setting is
family_name_1[;family_name_2]...

ExcludeFamily

For example: bluetooth;smart-card
The default value is undefined.
Note If you have enabled automatic device splitting, Horizon examines the device
family of each interface of a composite USB device to decide which interfaces to
exclude. If you have disabled automatic device splitting, Horizon examines the
device family of the whole composite USB device.

Exclude Vid/Pid Device
Property:
ExcludeVidPid

Excludes devices with specified vendor and product IDs from being redirected.
The format of the setting is vid-xxx1_pid-yyy2[;vid-xxx2_pid-yyy2]...
You must specify ID numbers in hexadecimal. You can use the wildcard character
(*) in place of individual digits in an ID.
For example: vid-0781_pid-****;vid-0561_pid-554c
The default value is undefined.

Exclude Path
Property:
ExcludePath

Exclude devices at specified hub or port paths from being redirected. The format of
the setting is bus-x1[/y1]..._port-z1[;bus-x2[/y2]..._port-z2]...
You must specify bus and port numbers in hexadecimal. You cannot use the
wildcard character in paths.
For example: bus-1/2/3_port-02;bus-1/1/1/4_port-ff
The default value is undefined.
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Table 4‑4. Configuration Properties for USB Redirection (Continued)
Policy Name and Property

Description

Include Device Family
Property:

Includes families of devices that can be redirected. The format of the setting is
family_name_1[;family_name_2]...

IncludeFamily

For example: storage
The default value is undefined.

Include Path

Include devices at a specified hub or port paths that can be redirected. The format
of the setting is bus-x1[/y1]..._port-z1[;bus-x2[/y2]..._port-z2]...

Property:

You must specify bus and port numbers in hexadecimal. You cannot use the
wildcard character in paths.

IncludePath

For example: bus-1/2_port-02;bus-1/7/1/4_port-0f
The default value is undefined.
Include Vid/Pid Device

Includes devices with specified vendor and product IDs that can be redirected. The

Property:

format of the setting is vid-xxx1_pid-yyy2[;vid-xxx2_pid-yyy2]...

IncludeVidPid

You must specify ID numbers in hexadecimal. You can use the wildcard character
(*) in place of individual digits in an ID.
For example: vid-0561_pid-554c
The default value is undefined.

USB Device Families
You can specify a USB device family when you create USB filtering rules for Horizon Client or for View
Agent or Horizon Agent.
Note Some devices do not report a device family.
Table 4‑5. USB Device Families
Device Family
Name

Description

audio

Any audio-input or audio-output device.

audio-in

Audio-input devices such as microphones.

audio-out

Audio-output devices such as loudspeakers and headphones.

bluetooth

Bluetooth-connected devices.

comm

Communications devices such as modems and wired networking adapters.

hid

Human interface devices excluding keyboards and pointing devices.

hid-bootable

Human interface devices that are available at startup time, excluding keyboards and pointing devices.

imaging

Imaging devices such as scanners.

keyboard

Keyboard device.

mouse

Pointing device such as a mouse.

other

Family not specified.

pda

Personal digital assistants.

physical

Force feedback devices such as force feedback joysticks.
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Table 4‑5. USB Device Families (Continued)
Device Family
Name

Description

printer

Printing devices.

security

Security devices such as fingerprint readers.

smart-card

Smart-card devices.

storage

Mass storage devices such as flash drives and external hard disk drives.

unknown

Family not known.

vendor

Devices with vendor-specific functions.

video

Video-input devices.

wireless

Wireless networking adapters.

wusb

Wireless USB devices.

Turn on Logging for USB Redirection
You can use USB logs to troubleshoot and to determine the product ID and vendor ID of various devices
that you plug in to the Mac client.
Procedure

1

On the Mac client, use a text editor to open the config file in the ~/Library/Preferences/VMware
Fusion/ directory.

2

To set the log level for USB redirection, add the view-usbd.logLevel parameter to the config file.
For example:
#[or info, debug, error]. Info level by default.
view-usbd.logLevel=trace

Using the Real-Time Audio-Video Feature for Webcams
and Microphones
With the Real-Time Audio-Video feature, you can use the local client system's webcam or microphone in
a remote desktop or published application. Real-Time Audio-Video is compatible with standard
conferencing applications and browser-based video applications. It supports standard webcams, audio
USB devices, and analog audio input.
For information about setting up the Real-Time Audio-Video feature and configuring the frame rate and
image resolution on the agent machine, see the Configuring Remote Desktop Features in Horizon 7
document. For information about configuring these settings on client systems, see the VMware
knowledge base article Setting Frame Rates and Resolution for Real-Time Audio-Video on Horizon View
Clients, at http://kb.vmware.com/kb/2053644.
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To download a test application that verifies the correct installation and operation of the Real-Time AudioVideo functionality, go to http://labs.vmware.com/flings/real-time-audio-video-test-application. Because
this test application is available as a VMware fling, technical support is not available.

When You Can Use a Webcam
If a Horizon administrator has configured the Real-Time Audio-Video feature, and if you use the VMware
Blast display protocol or the PCoIP display protocol, you can use a webcam that is built in or connected to
the local client computer in a remote desktop or published application. You can use the webcam in
conferencing applications such as Skype, Webex, or Google Hangouts.
During the setup of an application such as Skype, Webex, or Google Hangouts on a remote desktop, you
can select input and output devices from menus in the application. For virtual desktops, you can select
VMware Virtual Microphone and VMware Virtual Webcam. For published desktops and applications, you
can select Remote Audio Device and VMware Virtual Webcam.
For many applications, you do not need to select an input device.
When the local client computer uses the webcam, the remote session can use it at the same time. Also, if
the remote session uses the webcam, the local client computer can use it at the same time.
Note If you use a USB webcam, do not connect it from the Connection > USB menu in Horizon Client.
Doing so routes the device through USB redirection and the performance is not usable for video chat.
If more than one webcam is connected to the local client computer, you can configure a preferred
webcam to use in remote sessions.

Select a Default Microphone on the Mac Client
If you have multiple microphones on the Mac client, the remote desktop uses only one microphone. You
can use the System Preferences on the Mac client to specify the default microphone in the remote
desktop.
With the Real-Time Audio-Video feature, audio input devices and audio output devices work without using
USB redirection and the required network bandwidth is greatly reduced. Analog audio input devices are
also supported.
This procedure describes how to select a microphone from the user interface of the Mac client. You can
also configure a preferred microphone by using the Mac defaults system. See Configure a Preferred
Webcam or Microphone on a Mac Client.
Important When you use a USB microphone, do not connect it from the Connection > USB menu in
Horizon Client. Doing so routes the device through USB redirection and the device cannot use the RealTime Audio-Video feature.
Prerequisites
n

Verify that you have a USB microphone, or another type of microphone, installed and operational on
the Mac client.
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n

Use the VMware Blast display protocol or the PCoIP display protocol for the remote desktop.

Procedure

1

On the Mac client, select Apple menu > System Preferences and click Sound.

2

Open the Input pane of Sound preferences.

3

Select the microphone that you prefer to use.

The next time that you connect to a remote desktop and start a call, the remote desktop uses the default
microphone that you selected on the Mac client.

Configuring Real-Time Audio-Video on a Mac Client
You can configure Real-Time Audio-Video settings at the command line by using the Mac defaults
system. With the defaults system, you can read, write, and delete Mac user defaults by using Terminal
(/Applications/Utilities/Terminal.app).
Mac defaults belong to domains, and domains typically correspond to individual applications. The domain
for the Real-Time Audio-Video feature is com.vmware.rtav.

Syntax for Configuring Real-Time Audio-Video
You can use the following commands to configure the Real-Time Audio-Video feature.
Table 4‑6. Command Syntax for Real-Time Audio-Video Configuration
Command

Description

defaults write com.vmware.rtav scrWCamId "webcam-

Sets the preferred webcam to use on remote desktops. When
this value is not set, the webcam is selected by system
enumeration automatically. You can specify any webcam
connected to (or built into) the client system.

userid"

defaults write com.vmware.rtav srcAudioInId
"audio-device-userid"

defaults write com.vmware.rtav srcWCamFrameWidth
pixels

defaults write com.vmware.rtav srcWCamFrameHeight
pixels

defaults write com.vmware.rtav srcWCamFrameRate
fps
defaults write com.vmware.rtav LogLevel "level"

Sets the preferred microphone (audio-in device) to use on
remote desktops. When this value is not set, remote desktops
use the default recording device set on the client system. You
can specify any microphone connected to (or built into) the client
system.
Sets the image width. The value defaults to a hardcoded value
of 320 pixels. You can change the image width to any pixel
value.
Sets the image height. The value defaults to a hardcoded value
of 240 pixels. You can change the image height to any pixel
value.
Sets the frame rate. The value defaults to 15 fps. You can
change the frame rate to any value.
Sets the logging level for the Real-Time Audio-Video log file
(~/Library/Logs/VMware/vmware-RTAV-pid.log). You can
set the logging level to trace or debug.
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Table 4‑6. Command Syntax for Real-Time Audio-Video Configuration (Continued)
Command

Description

defaults write com.vmware.rtav IsDisabled value

Determines whether Real-Time Audio-Video is enabled or
disabled. Real-Time Audio-Video is enabled by default. (This
value is not in effect.) To disable Real-Time Audio-Video on the
client, set the value to true.

defaults read com.vmware.rtav

Displays Real-Time Audio-Video configuration settings.

defaults delete com.vmware.rtav setting

Deletes a Real-Time Audio-Video configuration setting, for
example: defaults delete com.vmware.rtav
srcWCamFrameWidth

Note You can adjust frame rates from 1 fps up to a maximum of 25 fps and resolution up to a maximum
of 1920x1080. A high resolution at a fast frame rate might not be supported on all devices or in all
environments.

Configure a Preferred Webcam or Microphone on a Mac Client
If you have multiple webcams or microphones on the Mac client, you can use only one webcam and one
microphone in a remote desktop with the Real-Time Audio-Video feature. You specify the preferred
webcam and microphone at the command line by using the Mac defaults system.
With the Real-Time Audio-Video feature, webcams, audio input devices, and audio output devices do not
require USB redirection to work and the required network bandwidth is reduced. Analog audio input
devices are also supported.
In most environments, you do not need to configure a preferred microphone or webcam. If you do not set
a preferred microphone, remote desktops use the default audio device set in the client system's System
Preferences. See Select a Default Microphone on the Mac Client. If you do not configure a preferred
webcam, the remote desktop selects the webcam by enumeration.
Prerequisites
n

If you are configuring a preferred USB webcam, verify that the webcam is installed and operational on
the client system.

n

If you are configuring a preferred USB microphone or another type of microphone, verify that the
microphone is installed and operational on the Mac client.

n

Use the VMware Blast display protocol or the PCoIP display protocol for the remote desktop.

Procedure

1

On the Mac client, start a webcam or microphone application to trigger an enumeration of camera
devices or audio devices to the Real-Time Audio-Video log file.
a

Attach the webcam or audio device.

b

In the Applications folder, double-click VMware Horizon Client to start Horizon Client.

c

Start a call and then stop the call.
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2

Find log entries for the webcam or microphone in the Real-Time Audio-Video log file.
a

In a text editor, open the Real-Time Audio-Video log file.
The Real-Time Audio-Video log file is named ~/Library/Logs/VMware/vmware-RTAV-pid.log,
where pid is the process ID of the current session.

b

Search the Real-Time Audio-Video log file for entries that identify the attached webcams or
microphones.

The following example shows how webcam entries might appear in the Real-Time Audio-Video log
file:
2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void VideoInputBase::LogDevEnum() - 1
Device(s) found
2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void VideoInputBase::LogDevEnum() Name=FaceTime HD Camera (Built-in)
UserId=FaceTime HD Camera (Built-in)#0xfa20000005ac8509
SystemId=0xfa20000005ac8509

The following example shows how microphone entries might appear in the Real-Time Audio-Video log
file:
2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: int
AVCaptureEnumerateAudioDevices(MMDev::DeviceList&) 2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum() - 2
Device(s) found
2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum() Index=255
Name=Built-in Microphone
UserId=Built-in Microphone#AppleHDAEngineInput:1B,0,1,0:1
SystemId=AppleHDAEngineInput:1B,0,1,0:1
2013-12-16T12:18:17.404Z| vthread-3| I120: RTAV: static void AudioCaptureBase::LogDevEnum() Index=255
Name=Built-in Input
UserId=Built-in Input#AppleHDAEngineInput:1B,0,1,1:2
SystemId=AppleHDAEngineInput:1B,0,1,1:2

3

Find the webcam or microphone that you prefer in the Real-Time Audio-Video log file and make a
note of its user ID.
The user ID appears after the string UserId= in the log file. For example, the user ID of the internal
face time camera is FaceTime HD Camera (Built-in) and the user ID of the internal microphone is
Built-in Microphone.
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4

In Terminal (/Applications/Utilities/Terminal.app), use the defaults write command to
set the preferred webcam or microphone.
Option

Action

Set the preferred webcam

Type defaults write com.vmware.rtav srcWCamId "webcam-userid",
where webcam-userid is the user ID of the preferred webcam, which you obtained
from the Real-Time Audio-Video log file. For example:
defaults write com.vmware.rtav srcWCamId "HD Webcam C525”

Set the preferred microphone

Type
defaults write com.vmware.rtav srcAudioInId "audio-deviceuserid", where audio-device-userid is the user ID of the preferred microphone,
which you obtained from the Real-Time Audio-Video log file. For example:
defaults write com.vmware.rtav srcAudioInId "Built-in
Microphone"

5

(Optional) Use the defaults read command to verify your changes to the Real-Time Audio-Video
feature.
For example: defaults read com.vmware.rtav
The command lists all the Real-Time Audio-Video settings.

The next time you connect to a remote desktop and start a new call, the remote desktop uses the
preferred webcam or microphone that you configured, if it is available. If the preferred webcam or
microphone is not available, the remote desktop can use another available webcam or microphone.

Using the Session Collaboration Feature
You can use the Session Collaboration feature to invite other users to join an existing remote desktop
session.

Invite a User to Join a Remote Desktop Session
When the Session Collaboration feature is enabled for a remote desktop, you can invite other users to
join an existing remote desktop session.
By default, you can send Session Collaboration invitations by email, in an instant message (IM), or by
copying a link to the clipboard and forwarding the link to users. To use the email invitation method, an
email application must be installed. To use the IM invitation method, Skype for Business must be installed
and configured. You can invite only users that belong to a domain that the server allows for
authentication. You can invite up to five users by default.
The Session Collaboration feature has the following limitations.
n

If you have multiple monitors, only the primary monitor is shown to session collaborators.

n

You must select the VMware Blast display protocol when you create a remote desktop session. The
Session Collaboration feature does not support PCoIP or RDP sessions.
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n

H.264 hardware encoding is not supported. If the session owner is using hardware encoding and a
collaborator joins the session, both fall back to software encoding.

n

Anonymous collaboration is not supported. Session collaborators must be identifiable through
Horizon-supported authentication mechanisms.

n

Session collaborators must have Horizon Client 4.7 or later for Windows, Mac, or Linux installed, or
they must use HTML Access 4.7 or later. If a session collaborator has an unsupported version of
Horizon Client, an error message appears when the user clicks a collaboration link.

n

You cannot use the Session Collaboration feature to share Linux remote desktop sessions or
published application sessions.

Prerequisites

To invite users to join a remote desktop session, a Horizon administrator must enable the Session
Collaboration feature.
This task includes enabling the Session Collaboration feature at the desktop pool or farm level. It can also
include using group policies to configure Session Collaboration features, such as the available invitation
methods. For complete requirements, see Requirements for the Session Collaboration Feature.
For information about enabling the Session Collaboration feature for desktop pools, see the Setting Up
Virtual Desktops in Horizon 7 document. For information about enabling the Session Collaboration feature
for a farm, see the Setting Up Published Desktops and Applications in Horizon 7 document. For
information about using group policy settings to configure the Session Collaboration feature, see the
Configuring Remote Desktop Features in Horizon 7 document.
Procedure

1

Connect to a remote desktop for which the session collaboration feature is enabled.
You must use the VMware Blast display protocol.

2

In the system tray in the remote desktop, click the VMware Horizon Collaboration icon, for example,
.
The collaboration icon looks different depending on the Windows operating system version.

3

When the VMware Horizon Collaboration dialog box opens, enter the user name (for example,
testuser or domain\testuser) or the email address of the user that you want to join the remote
desktop session.
The first time you enter the user name or email address of a particular user, you must click Look up
"user", enter a comma (,), or press the Enter key to validate the user. The session collaboration
feature remembers the user the next time you enter the user's user name or email address.
You can invite up to five users by default. A Horizon administrator can change the maximum number
of users that you can invite.
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4

Select an invitation method.
The following invitation methods are available by default. A Horizon administrator can disable the
email and IM invitation methods.
Option

Action

Email

Copies the collaboration invitation to the clipboard and opens a new email
message in the default email application. An email application must be installed to
use this invitation method.

IM

Copies the collaboration invitation to the clipboard and opens a new window in
Skype for Business. Press Ctrl+V to paste the link into the Skype for Business
window. Skype for Business must be installed and configured to use this invitation
method.

Copy Link

Copies the collaboration invitation to the clipboard. You must manually open
another application, such as Notepad, and press Ctrl+V to paste the invitation.

After you send an invitation, the VMware Horizon Collaboration icon also appears on the desktop and the
session collaboration user interface turns into a dashboard that shows the current state of the
collaboration session and enables you to take certain actions.
When a session collaborator accepts your invitation and joins the session, the session collaboration
feature notifies you and a red dot appears on the VMware Horizon Collaboration icon in the system tray.
What to do next

Manage the collaborative session in the VMware Horizon Collaboration dialog box. See Manage a
Collaborative Session.

Manage a Collaborative Session
After you send a session collaboration invitation, the Session Collaboration user interface turns into a
dashboard that shows the current state of the collaborative session and enables you to take certain
actions.
Prerequisites

Start a collaborative session. See Invite a User to Join a Remote Desktop Session.
Procedure

1

In the remote desktop, click the VMware Horizon Collaboration icon in the system tray, or double-click
the VMware Horizon Collaboration icon on the desktop.
The names of all session collaborators appear in the Name column and their status appears in the
Status column.
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2

Use the VMware Horizon Session Collaboration dashboard to manage the collaboration session.
Option

Action

Revoke an invitation or remove a
collaborator

Click Remove in the Status column.

Hand off control to a session
collaborator

After the session collaborator joins the session, toggle the switch in the Control
column to On.
To resume control of the session, double-click or press any key. The session
collaborator can also give back control by toggling the switch in the Control
column to Off, or by clicking the Give Back Control button.

Add a collaborator

Click Add Collaborators.

End the collaborative session

Click End Collaboration. All active collaborators are disconnected.
You can also end the collaborative session by clicking the VMware Horizon
Session Collaboration icon on the desktop and clicking the Stop button.

Join a Collaborative Session
To join a collaborative session, you can click the link in a collaboration invitation. The link might be in an
email or instant message, or in a document that the session owner forwards to you. Alternatively, you can
log in to the server and double-click the icon for the collaborative session in the remote desktop and
application selector window.
This procedure describes how to join a collaborative session from a collaboration invitation.
Note In a Cloud Pod Architecture environment, you cannot join a collaborative session by logging in to
the server unless you log in to the session owner's pod.
You cannot use the following remote desktop features in a collaborative session.
n

USB redirection

n

Real-Time Audio-Video (RTAV)

n

Multimedia redirection

n

Client drive redirection

n

Smart card redirection

n

Virtual printing

n

Microsoft Lync redirection

n

File redirection and Keep in Dock functionality

n

Clipboard redirection

You cannot change the remote desktop resolution in a collaborative session.
Prerequisites

To join a collaborative session, you must have Horizon Client 4.7 for Windows, Mac, or Linux installed on
the client system, or you must use HTML Access 4.7 or later.
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Procedure

1

Click the link in the collaboration invitation.
Horizon Client opens on the client system.

2

Enter your credentials to log in to Horizon Client.
After you are successfully authenticated, the collaborative session begins and you can see the
session owner's remote desktop. If the session owner transfers mouse and keyboard control to you,
you can use the remote desktop.

3

To return mouse and keyboard control to the session owner, click the VMware Horizon Session
Collaboration icon in the system tray and toggle the switch in the Control column to Off, or click the
Give Back Control button.

4

To leave the collaborative session, click Options > Disconnect.

Copying and Pasting
By default, you can copy and paste from the local client system to a remote desktop or published
application. You can also copy and paste from a remote desktop or published application to the client
system, or between two remote desktops or published applications, if a Horizon administrator enables
these features.
Supported file formats include text, images, and RTF (Rich Text Format).
A Horizon administrator configures the ability to copy and paste by setting agent group policies.
Depending on the Horizon server and agent version, a Horizon administrator might also be able to use
group policies to restrict clipboard formats during copy and paste operations, or use Smart Policies to
control the copy and paste behavior in remote desktops. For more information, see the Configuring
Remote Desktop Features in Horizon 7 document.
The copy and paste feature has the following limitations.
n

You cannot copy and paste files between a remote desktop and the file system on the local client
computer.

n

If you are copying formatted text, some of the data is text and some of the data is formatting
information. If you copy a large amount of formatted text or text and an image, when you attempt to
paste the text and image, you might see some or all the plain text but no formatting or image. The
reason is that the three types of data is sometimes stored separately. For example, depending on the
type of document you are copying from, images might be stored as images or as RTF data.

n

If the text and RTF data together use less than maximum clipboard size, the formatted text is pasted.
Often the RTF data cannot be truncated, so that if the text and formatting use more than the
maximum clipboard size amount, the RTF data is discarded, and plain text is pasted.

n

If you are unable to paste all the formatted text and images you selected in one operation, you might
need to copy and paste smaller amounts in each operation.
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Configuring the Client Clipboard Memory Size
You can configure the client clipboard memory size by creating a file named config in the %HomeDir
%/Library/Preferences/VMware Horizon View/ directory on the Mac client.
To set the client clipboard memory size, add the following parameter to the config file.
mksvchan.clipboardSize=value

value is the client clipboard memory size in kilobytes. You can specify a minimum value of 512 kilobytes
and a maximum value of 16384 kilobytes. If you specify 0, or do not specify a value, the default client
clipboard memory size is 8192 kilobytes (8 MB).
A large clipboard memory size can negatively affect performance, depending on your network. Do not set
the clipboard memory size to a value greater than 16 MB.

Dragging Text and Images
You can drag text and images from the Mac client to an open application in a remote desktop.
For example, you can drag text from Firefox on the Mac client and drop it into the WordPad application in
a remote desktop. Both plain text and Rich Text Format (RTF) text are supported.
Horizon administrators can configure the drag behavior by setting group policies that pertain to
Horizon Agent, including changing the clipboard size. The default clipboard size is 1 MB. The clipboard
can accommodate up to 16 MB of data. Depending on the Connection Server and agent version,
administrators might also use group policies to restrict clipboard formats during drag operations, or use
Smart Policies. For information, see the Configuring Remote Desktop Features in Horizon 7 document.
This feature has the following limitations.
n

You cannot drag text and images to a published application.

n

You cannot drag text and images from a remote desktop to the client device.

Using Published Applications
You can use many Mac functions with published applications.
n

When you run a published application, its icon appears in the Dock. You can maximize a minimized
published application by clicking its icon in the Dock.

n

You can keep, open, and quit a published application from its context menu in the Dock. If you select
Keep in Dock, the published application icon remains in the Dock, even after you close all application
windows.

n

You can open a published application by clicking its icon in the Dock.

n

You can open local files in published applications and run published applications from the
Applications folder on the client system. To enable these features, see Share Access to Local Folders
and Drives with Client Drive Redirection.
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n

Flashing Windows taskbar items are forwarded to Horizon Client. For example, if the published
application is an IM client and you receive a new message, a flashing red dot appears on the IM client
icon in the Dock.

n

You can start voice dictation, minimize, and zoom a published application from the menu bar.

n

You can use the Exposé feature to see open published applications, and you can press CommandTab to switch between open published applications.

n

You can use standard Mac keyboard shortcuts to interact with published applications. For example,
you can press Command-W to close an individual application window and Command-S to save the
current file. You can also use standard Mac keyboard shortcuts to copy, cut, and paste text between
applications on the Mac and published applications. You can customize keyboard shortcut mappings.
See Create Keyboard Shortcut Mappings.

n

If a published application creates a Windows System Tray item, that item appears in the notification
area on the menu bar on the Mac client system. You can interact with this item from the notification
area on the Mac in the same way that you interact with it from the System Tray on a Windows
system.
Note When you reclick a redirected System Tray item in the notification area on the Mac, the context
menu does not disappear.

Use a Local IME with Published Applications
If you use non-English keyboards and locales, you can use an IME (input method editor) that is installed
in the local client system to send non-English characters to a published application.
You can use the Input menu in the menu bar on the Mac or keyboard shortcuts to switch to a different
IME. You do not need to install an IME on the server that hosts the published application.
Note On a Mac, an IME is called an input source.
When this feature is enabled, the local IME is used. If an IME is installed and configured on the server
that hosts the published application, that remote IME is ignored.
Prerequisites
n

Verify that one or more IMEs are installed in the client system.

n

Verify that View Agent 6.1.1 or later, or Horizon Agent 7.0 or later, is installed on the RDS host.

Procedure

1

In theHorizon Client desktop and application selection window, Control-click a published application
and select Settings.

2

In the Remote Applications pane, select the Extend the local IME to hosted applications check
box.

3

Use the local IME as you might use it with locally installed applications.
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The Input menu appears in the menu bar on the Mac client. When you use a published application, you
can switch to a different language or IME by using the Input menu or keyboard shortcuts. Key
combinations that perform certain actions, such as Command-C to copy and Command-V to paste, work
correctly.

Saving Documents in a Published Application
With certain published applications, such as Microsoft Word or WordPad, you can create and save
documents. Where these documents are saved depends on your company's network environment. For
example, your documents might be saved to a home share mounted on your local computer.
A Horizon administrator can use the RDS Profiles group policy setting called Set Remote Desktop
Services User Home Directory to specify where documents are saved. For more information, see the
Configuring Remote Desktop Features in Horizon 7 document.

Using a Touch Bar with Remote Desktops and Published
Applications
You can use a Touch Bar to interact with remote desktops and published applications. This feature
requires macOS Sierra (10.12) or later.
After you connect to a remote desktop, you can use icons on the Touch Bar to perform the following
tasks.
n

Disconnect, log out, restart or reset, and send Ctrl+Alt+Delete to the remote desktop.

n

Enter or exit full-screen mode.

n

Bring the desktop and application selection window to the foreground.

n

View a list of all the currently open remote desktops and published applications.

n

Switch to another open remote desktop or published application.

You can add, remove, and reorder the items in the Horizon Client app Touch Bar by selecting VMware
Horizon Client > Customize Touch Bar.
Note The log out, reset, and restart features are available only if a Horizon administrator has enabled
them. If the remote desktop is in exclusive mode, you cannot use the Touch Bar to enter or exit full-screen
mode or bring the desktop and application selection window to the foreground.
After you connect to a published application, the following icons appear on the Touch Bar.

From left to right, you can use these icons to perform the following tasks:
n

Display a list of function keys.

n

View the list of open windows for the current published application. You can click a window title to
switch to that window.
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n

Zoom (toggles between maximize and restore).

n

Hide all windows of the current published application.

n

Minimize the current published application window.

n

Bring the application selection window to the foreground.

n

View a list of all currently open remote desktops and published applications. You can click the remote
desktop or published application to bring it to the foreground.

Printing from a Remote Desktop or Published Application
You can print to a virtual printer or a USB printer that is attached to the local client computer from a
remote desktop or published application. Virtual printing and USB printing work together without conflict.
For information about the types of remote desktops that support virtual printing, see Feature Support
Matrix for Mac Clients.

Enabling Virtual Printing in Horizon Client
When you use the VMware Blast display protocol or the PCoIP display protocol, you can use printers
configured for the Mac client from a remote desktop or published application. You do not need to install
printer drivers on a remote desktop to use the virtual printing feature.
You typically enable virtual printing the first time you start Horizon Client. Click Continue when
Horizon Client prompts you to start remote desktop USB and printing services and type your system
credentials.
If you do not enable virtual printing the first time you start Horizon Client, you can use the Connection
menu to enable virtual printing.
n

To enable virtual printing before you connect to a remote desktop or published application, select
VMware Horizon Client > Connection > Start Printing Services. Click Continue and type your
system credentials.

n

To enable virtual printing after you connect to a remote desktop or published application, select
VMware Horizon Client > Connection > Start Printing Services. Click Continue, type your system
credentials, and reconnect to the remote desktop or published application. If you cancel the
reconnection, you can select Connection > Enable Printing and Horizon Client prompts you to
reconnect again.

When the virtual printing feature is enabled, the Connection menu displays Printing Enabled.
Note If you install Horizon Client on a Mac on which VMware Fusion was previously started, printing
services are already enabled when you start Horizon Client. This behavior occurs because VMware
Fusion and Horizon Client use some of the same files to implement virtual printing.
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Set Printing Preferences for a Virtual Printer Feature on a Remote
Desktop
With the virtual printing feature, you can use local or network printers from a remote desktop without
having to install additional printer drivers in the remote desktop. For each printer available through this
feature, you can set preferences for data compression, print quality, double-sided printing, color, and
other settings.
After a printer is added on the local client computer, Horizon Client adds that printer to the list of available
printers in the remote desktop. No further configuration is required. If you have administrator privileges,
you can install printer drivers on the remote desktop without creating a conflict with the virtual printer
component.
Important This feature is not available for the following types of printers.
n

USB printers that use the USB redirection feature to connect to a virtual USB port in the remote
desktop.
You must disconnect the USB printer from the remote desktop to use the virtual printing feature with
it.

n

The Windows feature for printing to a file.
Selecting the Print to file check box in a Print dialog box does not work. Using a printer driver that
creates a file does work. For example, you can use a PDF writer to print to a PDF file.

This procedure applies to Windows 7 or Windows 8.x remote desktops. The procedure is similar, but not
exactly the same, for other types of Windows remote desktops.
Prerequisites

Verify that the Virtual Printing component of the agent is installed on the remote desktop. In the remote
desktop file system, verify that the C:\Program Files\Common Files\ThinPrint folder exists.
To use virtual printing, a Horizon administrator must enable the virtual printing feature for the remote
desktop. This task involves enabling the Virtual Printing setup option in the agent installer, and can
include setting policies that control virtual printing behavior. For more information, see the Setting Up
Virtual Desktops in Horizon 7 or Setting Up Published Desktops and Applications in Horizon 7 document.
Procedure

1

In the Windows 7 or Windows 8.x remote desktop, click Start > Devices and Printers.

2

In the Devices and Printers window, right-click the default printer, select Printer Properties from the
context menu, and select the printer.
Virtual printers appear as <printer_name> in single-user virtual machine desktops and as
<printer_name>(s<session_ID>) in published desktops on RDS hosts if View Agent 6.2 or later, or
Horizon Agent 7.0 or later, is installed. If View Agent 6.1 or earlier is installed in the remote desktop,
virtual printers appear as <printer_name>#:<number>.
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3

In the Printer Properties window, click the Device Setup tab and specify which settings to use.

4

On the General tab, click Preferences and specify which settings to use.

5

In the Printing Preferences dialog box, select the different tabs and specify which settings to use.
For the Page Adjustment advanced setting, VMware recommends that you retain the default
settings.

6

Click OK.

Using USB Printers
A USB printer is a printer that is attached to a USB port on the local client system. To send print jobs to a
USB printer, you can use the USB redirection feature or the virtual printing feature. Depending on network
conditions, USB printing can sometimes be faster than virtual printing.
Virtual printers and redirected USB printers can work together without conflict.
n

You can use the USB redirection feature to attach a USB printer to a virtual USB port in the remote
desktop, but only if the required drivers are also installed on the remote desktop.
If you use the USB redirection feature, the printer is no longer logically attached to the physical USB
port on the client, and it does not appear in the list of local printers on the local client machine. You
can print to the USB printer from the remote desktop, but you cannot print to the USB printer from the
local client machine. In the remote desktop, redirected USB printers appear as <printer_name>.
For information about how to connect a USB printer, see Use USB Redirection to Connect USB
Devices.

n

On some client systems, you can alternatively use the virtual printing feature to send print jobs to a
USB printer. If you use the virtual printing feature, you can print to the USB printer from both the
remote desktop and the local client system, and you do not need to install printer drivers in the
remote desktop.

PCoIP Client-Side Image Cache
PCoIP client-side image caching stores image content on the client to avoid retransmitting data. This
feature reduces bandwidth use.
The PCoIP image cache captures spatial and temporal redundancy. For example, when you scroll
through a PDF document, new content appears from the bottom of the window and the oldest content
disappears from the top of the window. The remaining content is constant and moves upward. The PCoIP
image cache can detect this spatial and temporal redundancy.
During scrolling, because the display information sent to the client is primarily a sequence of cache
indexes, using the image cache saves a significant amount of bandwidth. This efficient scrolling has
benefits both on the LAN and over the WAN.
n

On the LAN, where the bandwidth is relatively unconstrained, using client-side image caching delivers
significant bandwidth savings.
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n

Over the WAN, to stay within the available bandwidth constraints, scrolling performance is degraded
without client-side caching. Over the WAN, client-side caching saves bandwidth and ensures a
smooth, highly responsive scrolling experience.

With client-side caching, the client stores portions of the display that were previously transmitted. The
cache size is 250 MB.
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5

You can solve most problems with Horizon Client by restarting or resetting remote desktops or published
applications, or by reinstalling Horizon Client.
This chapter includes the following topics:
n

Restart a Remote Desktop

n

Reset a Remote Desktop or Published Applications

n

Uninstalling Horizon Client

n

Connecting to a Server in Workspace ONE Mode

Restart a Remote Desktop
If the remote desktop operating system stops responding, you might need to restart a remote desktop.
Restarting a remote desktop is similar to using the Windows operating system restart command. The
remote desktop operating system usually prompts you to save any unsaved data before it restarts.
You can restart a remote desktop only if a Horizon administrator has enabled the restart feature for the
remote desktop.
For information about enabling the desktop restart feature, see the Setting Up Virtual Desktops in Horizon
7 or Setting Up Published Desktops and Applications in Horizon 7 document.
Prerequisites

Obtain login credentials, such as a user name and password, RSA SecurID user name and password,
RADIUS authentication user name and password, or smart card personal identification number (PIN).
Procedure
u

In the desktop and application selection window, select the remote desktop shortcut, press Controlclick, and select Restart from the context menu.

The operating system in the remote desktop restarts and Horizon Client disconnects and logs off from the
remote desktop.
What to do next

Wait an appropriate amount of time for the system to restart before you attempt to reconnect to the
remote desktop.
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If restarting the remote desktop does not solve the problem, you might need to reset the remote desktop.
See Reset a Remote Desktop or Published Applications.

Reset a Remote Desktop or Published Applications
You might need to reset a remote desktop if the desktop operating system stops responding and
restarting the remote desktop does not solve the problem. Resetting published applications quits all open
applications.
Resetting a remote desktop is the same as pressing the Reset button on a physical PC to force the PC to
restart. Any files that are open on the remote desktop are closed and are not saved.
Resetting published applications quits the applications without saving any unsaved data. All open
published applications are closed, even applications that come from different RDS server farms.
You can reset a remote desktop only if a Horizon administrator has enabled the reset feature for the
remote desktop.
For information about enabling the desktop reset feature, see the Setting Up Virtual Desktops in Horizon
7 or Setting Up Published Desktops and Applications in Horizon 7 document.
Procedure
u

Use the Reset command.
Option

Action

Reset a remote desktop from the
desktop and application selection
window

Select the remote desktop name, press Control-click, and select Reset from the
context menu.

Reset published applications from the
desktop and application selection
window

Click the Settings button (gear icon) in the upper right corner of the window,
select Applications in the left pane, click Reset, and click Continue.

When you reset a remote desktop, the operating system in the remote desktop restarts and
Horizon Client disconnects and logs off from the remote desktop. When you reset published applications,
the published applications quit.
What to do next

Wait an appropriate amount of time for system to restart before attempting to reconnect to the remote
desktop or published application.

Uninstalling Horizon Client
Sometimes you can resolve problems with Horizon Client by uninstalling and reinstalling Horizon Client.
To uninstall Horizon Client, use the same method that you use to uninstall any application.
Drag the VMware Horizon Client application from the Applications folder to the Trash and empty the
trash.
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After Horizon Client is uninstalled, you can reinstall it.
See Install Horizon Client on Mac.

Connecting to a Server in Workspace ONE Mode
You cannot connect to a server directly through Horizon Client, or your remote desktop and published
application entitlements are not visible in Horizon Client.
Problem
n

When you try to connect to the server directly through Horizon Client, Horizon Client redirects you to
the Workspace ONE portal.

n

When you open a remote desktop or published application through a URI or shortcut, or when you
open a local file through file association, the request redirects you to the Workspace ONE portal for
authentication.

n

After you open a remote desktop or published application through Workspace ONE and
Horizon Client starts, you cannot see or open other entitled remote desktops or published
applications in Horizon Client.

Cause

Beginning with Horizon 7 version 7.2, a Horizon administrator can enable Workspace ONE mode on a
Connection Server instance. This behavior is normal when Workspace ONE mode is enabled on a
Connection Server instance.
Solution

Use Workspace ONE to connect to a Workspace ONE enabled server and access your remote desktops
and published applications.
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