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VMware Horizon Client for Mac User
Guide
This document, VMware Horizon Client for Mac User Guide, explains how to use VMware Horizon
Client™ for Mac to connect to and use remote desktops and published applications.

®

Horizon Client communicates with a server, which acts as a broker between the client device and remote
desktops and published applications. You enter credentials into Horizon Client, the server authenticates
your credentials, and then the server finds the remote desktops and published applications that you are
entitled to use.
For information about the software installed on your remote desktops, contact your system administrator.
This document assumes that Horizon Client for Mac is already installed and configured on your Mac. For
information about installing and configuring Horizon Client for Mac, see the VMware Horizon Client for
Mac Installation and Setup Guide document.
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How Do I Log In?

1

Before you can log in and connect to a remote desktop or published application, a system administrator at
your company must set up your user account. If your system administrator has not set up your user
account, you cannot use Horizon Client or HTML Access.
If Horizon Client prompts you for a server name and domain name, your system administrator must tell
you the server name to type and the domain to select. At some companies, Horizon Client connects to
the correct server and selects the correct domain automatically.
If you do not know your user name or password or how to reset your password, contact the system
administrator at your company.
When you are ready to log in and get started, see Connect to a Remote Desktop or Published
Application.
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Connecting to Remote Desktops
and Published Applications

2

Horizon Client makes it easy to work on remote desktops and published applications from your local client
device, giving you on-the-go access from any location.
This chapter includes the following topics:
n

Set the Certificate Checking Mode

n

Configure Horizon Client to Select a Smart Card Certificate

n

Connect to a Remote Desktop or Published Application

n

Connecting to a Server When Horizon Client Starts

n

Hide the VMware Horizon Client Window

n

Add Horizon Client to the Dock

n

Autoconnect to a Remote Desktop

n

Searching for Remote Desktops and Published Applications

n

Switch Remote Desktops or Published Applications

n

Open a Recent Remote Desktop or Published Application

n

Using a Touch Bar with Server, Desktop, and Application Connections

n

Configure Horizon Client to Forget the Server User Name and Domain

n

Log Off or Disconnect

n

Disconnecting from a Server

Set the Certificate Checking Mode
Your system administrator might ask you to set the certificate checking mode in Horizon Client to make
sure that you can successfully connect to a server. At some companies, an administrator might set the
certificate checking mode and prevent you from changing it in Horizon Client.
Server certificate checking occurs for connections between Horizon Client and a server. A certificate is a
digital form of identification, similar to a passport or a driver's license.
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Procedure

1

In the Applications folder, double-click VMware Horizon Client.

2

Select VMware Horizon Client > Preferences from the menu bar.

3

Select the certificate checking mode.

4

Option

Description

Never connect to untrusted servers

This setting means that you cannot connect to the server if any of the certificate
checks fail. An error message lists the checks that failed.

Warn before connecting to untrusted
servers

This setting means that you can click Continue to ignore the warning if a
certificate check fails because the server uses a self-signed certificate. For selfsigned certificates, the certificate name is not required to match the server name
that you entered in Horizon Client.

Do not verify server identity
certificates

This setting means that no certificate checking occurs.

To save your changes, click OK.

What to do next

If you receive a certificate error after setting the certificate checking mode, contact your system
administrator.

Configure Horizon Client to Select a Smart Card
Certificate
You can configure a Horizon Client setting to select a local certificate, or the certificate on a smart card,
when you connect to a server. If you do not configure this setting, you must manually select a certificate.
Prerequisites

For your setting to take effect, a Horizon administrator must configure smart card authentication on the
server and only one certificate must be available on your client system or smart card.
If you have multiple certificates, Horizon Client always prompts you to select a certificate, regardless of
how you configure this setting.
Procedure

1

In the Applications folder, double-click VMware Horizon Client.

2

Select VMware Horizon Client > Preferences from the menu bar.

3

Click General in the Preferences dialog box.

4

Select Automatically select certificate.

5

Close the Preferences dialog box.
Your changes take effect when the dialog box is closed.
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Connect to a Remote Desktop or Published Application
To connect to a remote desktop or published application, you must provide the name of a server and
supply credentials for your user account.
Prerequisites

Obtain the following information from your system administrator:
n

Instructions about whether to turn on a VPN (virtual private network) connection.

n

Server name to use for connecting to the server.

n

If the port is not 443, the port number to use for connecting to the server.

n

Credentials for logging in, such as an Active Directory user name and password, RSA SecurID user
name and passcode, RADIUS authentication user name and passcode, or smart card personal
identification number (PIN).

n

Domain name for logging in.

n

Instructions about whether you can use Touch ID authentication.

If your administrator instructs you to configure the certificate checking mode, see Set the Certificate
Checking Mode.
If you use smart card authentication, you can configure Horizon Client to use a local certificate
automatically, or to use the certificate on your smart card. See Configure Horizon Client to Select a Smart
Card Certificate.
Procedure

1

If a VPN connection is required, turn on the VPN.

2

In the Applications folder, double-click VMware Horizon Client.

3

Click Continue to start remote desktop USB and printing services, or click Cancel to use
Horizon Client without remote desktop USB and printing services.
If you click Continue, you must provide system credentials. If you click Cancel, you can enable
remote desktop USB and printing services later.
Note The prompt to start remote desktop USB and printing services appears the first time you start
Horizon Client. It does not appear again, regardless of whether you click Cancel or Continue.

4

Connect to a server.
Option

Description

Connect to a new server

Click the New Server icon on the Horizon Client Home window, enter the server
name and port number (if necessary) as instructed by your system administrator,
and click Connect. An example of using a non-default port is view.company.com:
1443.

Connect to an existing server

Double-click the server shortcut on the Horizon Client Home window.
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5

If you are prompted for RSA SecurID credentials or RADIUS authentication credentials, enter the
user name and passcode and click Login.

6

If you are prompted for a user name and password, supply Active Directory credentials.
a

Type the user name and password as instructed by your system administrator.

b

Select a domain as instructed by your system administrator.
If the Domain drop-down menu is hidden, you must type the user name as username@domain or
domain\username.

c

(Optional) Select the Remember this password check box if this feature is enabled and if the
server certificate can be fully verified.

d

(Optional) Select the Enable Touch ID check box to enable Touch ID authentication.
If Touch ID is enabled and you are logging in for the first time, your Active Directory credentials
are stored securely on your Mac for future use.

e

Click Login.
You might see a message that you must confirm before the login dialog box appears.

7

If the desktop security indicator turns red and a warning message appears, respond to the prompt.

8

If you are prompted for Touch ID authentication, place your finger on the Touch ID sensor.

9

(Optional) If multiple display protocols are configured for a remote desktop, select the protocol to use.
VMware Blast provides better battery life and is the best protocol for high-end 3D and mobile device
users.
Option

Description

Select a display protocol for a remote
desktop

Select the remote desktop name, press Control-click, and select the display
protocol from the context menu.
Alternatively, you can select Settings from the context menu and select the
display protocol from the Connect Via drop-down menu in the Settings dialog
box.

Select a display protocol for a
published application

Select the published application name, press Control-click, select Settings from
the context menu, and select the display protocol from the Preferred protocol
drop-down menu in the Settings dialog box.

10 Double-click a remote desktop or published application to connect to it.
If you are connecting to a published desktop, and if the published desktop is already set to use a
different display protocol, you are prompted to either use the protocol that is set or have the system
log you off the remote operating system so that a connection can be made with the protocol that you
selected.
Note If you are entitled to only one remote desktop on the server, Horizon Client connects
automatically to that remote desktop.

VMware, Inc.
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If a Horizon administrator has enabled the client drive redirection feature, the Sharing dialog box might
appear. From the Sharing dialog box, you can allow or deny access to files on your local system. For
more information, see Share Access to Local Folders and Drives with Client Drive Redirection.
After you connect to a server for the first time, Horizon Client connects to that server automatically the
next time you start Horizon Client. To disable this feature, see Connecting to a Server When Horizon
Client Starts.

Connecting to a Server When Horizon Client Starts
After you connect to a server for the first time, Horizon Client connects automatically to that server the
next time you start Horizon Client.
To disable this feature, select the server shortcut on the Horizon Client Home window, press Control-click,
and deselect the Always connect at launch setting.
If there are other server shortcuts on the Horizon Client Home window, you can enable the Always
connect at launch setting for a different server. You can enable the Always connect at launch setting
for only one server at a time.

Hide the VMware Horizon Client Window
You can hide the VMware Horizon Client window after you open a remote desktop or published
application.
Procedure
n

To hide the VMware Horizon Client window after you open a remote desktop or published application,
click the Close button in the corner of the VMware Horizon Client window.
The VMware Horizon Client icon remains in the Dock.

n

To configure a setting that always hides the VMware Horizon Client window after you open a remote
desktop or published application, perform these steps before you connect to a server.
a

Select VMware Horizon Client > Preferences from the menu bar and click General in the
Preferences dialog box.

b

Select Hide client window after desktop/application launched.

c

Close the Preferences dialog box.
Your changes take effect when the dialog box is closed.

n

To show the VMware Horizon Client window after it has been hidden, select Window > Open
Selection Window from the menu bar, or right-click the VMware Horizon Client icon in the Dock and
select Show All Windows.

Add Horizon Client to the Dock
You can add Horizon Client to the Dock on the Mac client system.

VMware, Inc.
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Procedure

1

In the Applications folder, select VMware Horizon Client.

2

Drag the VMware Horizon Client icon to the Dock.

3

To configure the Dock icon to open Horizon Client at login or to show the icon in the Finder, right-click
the icon on the Dock, select Options, and select the appropriate command from the context menu.

When you quit Horizon Client, the application shortcut remains in the Dock.

Autoconnect to a Remote Desktop
You can configure a server to open a particular remote desktop when you connect to that server. You
cannot configure a server to open a published application.
If you are entitled to only one remote desktop on the server, Horizon Client always opens that remote
desktop when you connect to the server.
Prerequisites

Obtain credentials for connecting to the server, such as a user name and password, RSA SecurID user
name and passcode, RADIUS authentication user name and passcode, or smart card personal
identification number (PIN).
Procedure

1

On the Horizon Client Home window, double-click the server icon.

2

If prompted, supply your credentials.

3

Click the Settings button (gear icon) in the upper right corner of the desktop and application selection
window.

4

Select the remote desktop in the left pane of the Settings dialog box.

5

Select Autoconnect to this desktop.

6

To save your changes, close the Settings dialog box.

Searching for Remote Desktops and Published
Applications
After you connect to a server, the available remote desktops and published applications on that server
appear in the desktop and application selection window. You can search for a particular remote desktop
or published application by typing in the window.
When you begin to type, Horizon Client highlights the first matching remote desktop or published
application name. To connect to a highlighted remote desktop or published application, press the Enter
key. If you continue to type after the first match is found, Horizon Client continues to search for matching
remote desktops and published applications. If Horizon Client finds multiple matching remote desktops or
published applications, you can press the Tab key to switch to the next match. If you stop typing for two
seconds and then begin to type again, Horizon Client assumes that you are starting a new search.

VMware, Inc.
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Switch Remote Desktops or Published Applications
If you are connected to a remote desktop, you can switch to another remote desktop. You can also
connect to a published application while you are connected to a remote desktop.
Procedure
u

Select a remote desktop or published application from the same server or from a different server.
Option

Action

Choose a different remote desktop or
published application on the same
server

Perform one of the following actions:

Choose a different remote desktop or
published application on a different
server

n

To keep the current remote desktop and also connect to another remote
desktop, select Window > VMware Horizon Client from the menu bar and
double-click the shortcut for the other remote desktop. That remote desktop
opens in a new window so that you have multiple remote desktops open. You
can switch between remote desktops from the Window menu on the menu
bar.

n

To close the current remote desktop and connect to another remote desktop,
select Connection > Disconnect from the menu bar and double-click the
shortcut for the other remote desktop.

n

To open another published application, double-click the shortcut for the other
published application. That published application opens in a new window. You
now have multiple published applications open, and you can switch between
them by clicking in an application window.

If you are entitled to multiple remote desktops or published applications, so that
the desktop and application selection window is open, click the Disconnect from
Server button in the left side of the toolbar in the desktop and application
selection window and disconnect from the server. If you are entitled to only one
remote desktop or published application, and the desktop and application
selection window is not open, you can select File > Disconnect from Server
from the menu bar and then connect to a different server.

Open a Recent Remote Desktop or Published Application
You can open recent remote desktops and published applications in Horizon Client.
Recent remote desktops and published applications appear in the order in which they were opened. If you
are not already connected to the server when you open a recent remote desktop or published application,
the server login screen appears and you must provide your credentials.
Prerequisites

To use this feature, you must have previously opened a remote desktop or published application. If you
plan to open a recent desktop or published application from the Dock, VMware Horizon Client must be in
the Dock. See Add Horizon Client to the Dock.
Procedure
n

To open a remote desktop or published application from the Dock, Ctrl-click VMware Horizon Client
in the Dock and select the remote desktop or published application from the menu.
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n

To open a remote desktop or published application from the File menu, start Horizon Client, select
File > Open Recent, and select the remote desktop or published application from the menu.

Using a Touch Bar with Server, Desktop, and Application
Connections
If the Mac has a Touch Bar, you can use the Touch Bar to add a server, disconnect from a server, or
connect to a recent remote desktop or published application. This feature requires macOS Sierra (10.12)
or later.
Before you connect to a server, you can touch the plus (+) icon to add a server. After you connect to a
server, you can touch the Disconnect icon to disconnect from the server.
If you previously connected to a remote desktop or published application, its name appears on the Touch
Bar before you connect to a server. You can touch the remote desktop or application name to log in to the
server and start the remote desktop or published application.
You can add, remove, and reorder the items in the Horizon Client app Touch Bar by selecting VMware
Horizon Client > Customize Touch Bar.
For information about using the Touch Bar after you connect to a remote desktop or published application,
see Using a Touch Bar with Remote Desktops and Published Applications.

Configure Horizon Client to Forget the Server User Name
and Domain
By default, Horizon Client stores the user name and domain that you enter when you log in to a server.
For increased security, you can configure Horizon Client so that it never remembers the server user name
and domain.
Procedure

1

Select VMware Horizon Client > Preferences from the menu bar.

2

Click General in the Preferences dialog box.

3

Deselect Remember username and domain.

4

Close the Preferences dialog box.
Your changes take effect when the dialog box is closed.

Log Off or Disconnect
If you disconnect from a remote desktop without logging off, applications in the remote desktop might
remain open. You can also disconnect from a server and leave published applications running.

VMware, Inc.
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You can log off from a remote desktop even if you do not have the remote desktop open. This feature has
the same result as sending Ctrl+Alt+Del to the remote desktop and then clicking Log Off.
Note The Windows key combination Ctrl+Alt+Del is not supported in remote desktops. Instead, select
Connection > Send Ctrl-Alt-Del from the menu bar. Alternatively, press Fn-Control-Option-Delete on an
Apple keyboard.
Procedure
n

Disconnect from a remote desktop without logging off.
Option

Action

Disconnect and quit Horizon Client

a

Click the Close button in the corner of the window, or select File > Close
from the menu bar.

b

Select VMware Horizon Client > Quit VMware Horizon Client from the
menu bar.

Disconnect and remain in
Horizon Client

Click the Disconnect button in the toolbar, or select Connection > Disconnect
from the menu bar.

Note A Horizon administrator can configure a remote desktop to log off when it is disconnected. In
this case, any open applications in the remote desktop are closed.
n

Log off and disconnect from a remote desktop.
Option

Action

From within the remote desktop

Use the Windows Start menu to log off.

From the menu bar

Select Connection > Log Off from the menu bar.
If you use this procedure, files that are open on the remote desktop are closed
without being saved first.

n

Disconnect from a published application.
Option

Action

Disconnect from the server and leave
the published application running

Perform one of the following actions:

Close the published application and
disconnect from the server

VMware, Inc.
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Click the Disconnect from Server button in the left side of the toolbar in the
desktop and application selection window.

n

Select File > Disconnect from Server from the menu bar.

a

Quit the published application in the usual manner, for example, click the
Close button in the corner of the application window.

b

Click the Disconnect from Server button in the left side of the toolbar in the
desktop and application selection window, or select File > Disconnect from
Server from the menu bar.
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n

Log off when you do not have a remote desktop open.
If you use this procedure, files that are open on the remote desktop are closed without first being
saved.
Option

Action

From the Home window

a

Double-click the server shortcut and supply credentials.

b

Select the remote desktop and select Connection > Log Off from the menu
bar.

From the desktop and application
selection window

Select the remote desktop and select Connection > Log Off from the menu bar.

Disconnecting from a Server
After you have finished using a remote desktop or published application, you can disconnect from the
server.
To disconnect from a server, click the Disconnect from Server icon in the upper-left corner of the
Horizon Client menu bar.

VMware, Inc.
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Using Remote Desktops and
Published Applications

3

Horizon Client includes additional features to help you use remote desktops and published applications
on your local client device.
This chapter includes the following topics:
n

Share Access to Local Folders and Drives with Client Drive Redirection

n

Clicking URL Links That Open Outside of Horizon Client

n

Using a Touch Bar with Remote Desktops and Published Applications

n

Copying and Pasting

n

Dragging Text and Images

n

Using Published Applications

n

Using the Session Collaboration Feature

n

Modify the Horizon Client Shortcuts for Windows Actions

Share Access to Local Folders and Drives with Client
Drive Redirection
With the client drive redirection feature, you can share folders and drives on the local client system with
remote desktops and published applications.
Shared drives can include mapped drives and USB storage devices.
In a Windows remote desktop, shared folders and drives appear in the This PC folder or in the Computer
folder, depending on the Windows operating system version. In a published application, such as Notepad,
you can browse to and open a file in a shared folder or drive.
You can turn on the ability to open local files in published applications directly from your local file system.
If you select a local file and press Control-click, the Open With menu lists the available published
applications. You can also open a local file by dragging it into the published application window or Dock
icon.

VMware, Inc.
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If you set a published application as the default application for files that have a certain file extension, all
files on your local file system that have that file extension are registered with the server. You can also turn
on the ability to run published applications from the Applications folder.
Note If a filename contains characters that are invalid in the Windows file system, you cannot open the
file in a published application. For example, you cannot open a file named test2<.txt in Notepad.
The client drive redirection settings apply to all remote desktops and published applications.
Prerequisites

To share folders and drives with a remote desktop or published application, a Horizon administrator must
enable the client drive redirection feature.
Procedure

1

2

Open the Preferences dialog box and display the Sharing panel.
Option

Description

From the desktop and application
selection window

Select VMware Horizon Client > Preferences and click Sharing.

From the Sharing dialog box that
appears when you connect to a remote
desktop or published application

Click the Preferences > Sharing link in the dialog box.

From within a remote desktop
operating system

Select VMware Horizon Client > Preferences from the menu bar and click
Sharing.

Configure the client drive redirection settings.
Option

Action

Share a specific folder or drive with
remote desktops and published
applications

Click the plus (+) button, browse to and select the folder or drive to share, and
click Add.
Note If a USB device is already connected to a remote desktop or published
application with the USB redirection feature, you cannot share a folder on the
USB device.

Stop sharing a specific folder or drive

Select the folder or drive in the Folder list and click the minus (-) button.

Give remote desktops and published
applications access to files in your
home directory

Select the Allow access to home-directory check box.

VMware, Inc.
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Option

Action

Share USB storage devices with
remote desktops and published
applications

Select the Allow access to removable storage check box. The client drive
redirection feature shares all USB storage devices inserted in your client system
and all FireWire and Thunderbolt-connected external drives automatically.
Selecting a specific device to share is not necessary.
Note USB storage devices already connected to a remote desktop or published
application with the USB redirection feature are not shared.
If this check box is deselected, you can use the USB redirection feature to
connect USB storage devices to remote desktops and published applications.

Do not show the Sharing dialog box
when you connect to a remote desktop
or published application

3

Select the Do not show dialog when connecting to a desktop or application
check box.
If this check box is deselected, the Sharing dialog box appears the first time you
connect to a remote desktop or published application. For example, if you log in to
a server and connect to a remote desktop, you see the Sharing dialog box. If you
then connect to another remote desktop or published application, you do not see
the dialog box. To see the dialog box again, you must disconnect from the server
and log in again.

Configure settings for published applications.
a

Click the Settings button (gear icon) in the upper right corner of the desktop and application
selector window and select Applications in the left pane.

b

To turn on the ability to open local files with published applications from the local file system,
select Open local files in hosted applications.

c

To turn on the ability to run published applications from the Applications folder on the client
system, select Run hosted applications from your local Applications folder.

What to do next

Verify that you can see the shared folders from within the remote desktop or published application.
n

In a Windows remote desktop, open File Explorer and look in the This PC folder, or open Windows
Explorer and look in the Computer folder, depending on the Windows operating system version.

n

In a published application, select File > Open or File > Save As and navigate to the folder or drive.

The folders and drives that you selected for sharing might use one (or more) of the following naming
conventions.
Naming Convention

Example

folder-name on desktop-name

jsmith on JSMITH-W03

folder-name (drive-number:)

jsmith (Z:)

folder-name on desktoptop-name (drive-number:)

jsmith on JSMITH-W03 (Z:)

For some Horizon Agent versions, a redirected folder can have two entrances, such as under Devices
and drives and Network locations in Windows 10, and both entrances can appear at the same time. If
all the volume labels (from A: through Z:) are already in use, the redirected folder has only one entrance.

VMware, Inc.
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Clicking URL Links That Open Outside of Horizon Client
A Horizon administrator can configure URL links that you click inside a remote desktop or published
application to open in the default browser on the local client system. The URL link might be to a Web
page, a phone number, an email address, or another type of link. This feature is called URL Content
Redirection.
A Horizon administrator can also configure URL links that you click inside a browser or application on the
local client system to open in a remote desktop or published application. If Horizon Client is not already
open you click the URL link, it starts and prompts you to log in.
A Horizon administrator might set up the URL Content Redirection feature for security purposes. For
example, if you are at work and click a link that points to a URL outside your company network, the link
might be more safely opened in a published application. An administrator can configure which published
application opens the link.
Each company configures its own URL Content Redirection policies. If you have questions about how the
URL Content Redirection feature behaves at your company, contact your system administrator.

Responding to URL Content Redirection Prompts
The first time you start Horizon Client and connect to a server on which the URL Content Redirection
feature is configured, Horizon Client prompts you to open the VMware Horizon URL Filter application
when you click a link for redirection. Click Open to allow the URL to be redirected.
Depending on how the URL Content Redirection feature is configured, Horizon Client might display an
alert message that asks you to change your default Web browser to VMware Horizon URL Filter. If you
see this prompt, click the Use "VMware Horizon URL Filter" button to allow VMware Horizon URL Filter
to become the default browser. This prompt appears only once, unless you change your default browser
after clicking Use "VMware Horizon URL Filter".
Horizon Client might also display an alert message that asks you to select an application when you click a
URL. If you see this prompt, you can click Choose Application to search for an application on the local
client system, or click Search App Store to search for and install a new application. If you click Cancel,
the URL is not opened.

Using URL Content Redirection with Chrome
If the Chrome browser prompts you to enable the VMware Horizon URL Content Redirection Helper
extension, click Enable Extension to use the URL Content Redirection feature with the Chrome browser.
If you click Remove from Chrome, the extension is removed and URLs clicked in Chrome are not
redirected. You can still install the extension manually from the Chrome Web Store.
The first time a URL is redirected from the Chrome browser on the client system, you are prompted to
open the URL in Horizon Client. If you select the Remember my choice for VMware Horizon Client
links check box (recommended) and then click Open VMware Horizon Client, this prompt does not
appear again.
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Using a Touch Bar with Remote Desktops and Published
Applications
You can use a Touch Bar to interact with remote desktops and published applications. This feature
requires macOS Sierra (10.12) or later.
After you connect to a remote desktop, you can use icons on the Touch Bar to perform the following
tasks.
n

Disconnect, log out, restart or reset, and send Ctrl+Alt+Delete to the remote desktop.

n

Enter or exit full-screen mode.

n

Bring the desktop and application selection window to the foreground.

n

View a list of all the currently open remote desktops and published applications.

n

Switch to another open remote desktop or published application.

You can add, remove, and reorder the items in the Horizon Client app Touch Bar by selecting VMware
Horizon Client > Customize Touch Bar.
Note The log out, reset, and restart features are available only if a Horizon administrator has enabled
them. If the remote desktop is in exclusive mode, you cannot use the Touch Bar to enter or exit full-screen
mode or bring the desktop and application selection window to the foreground.
After you connect to a published application, the following icons appear on the Touch Bar.

From left to right, you can use these icons to perform the following tasks:
n

Display a list of function keys.

n

View the list of open windows for the current published application. You can click a window title to
switch to that window.

n

Zoom (toggles between maximize and restore).

n

Hide all windows of the current published application.

n

Minimize the current published application window.

n

Bring the application selection window to the foreground.

n

View a list of all currently open remote desktops and published applications. You can click the remote
desktop or published application to bring it to the foreground.
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Copying and Pasting
By default, you can copy and paste from the local client system to a remote desktop or published
application. You can also copy and paste from a remote desktop or published application to the client
system, or between two remote desktops or published applications, if a Horizon administrator enables
these features.
Supported file formats include text, images, and RTF (Rich Text Format).
The copy and paste feature has the following limitations.
n

You cannot copy and paste files between a remote desktop and the file system on the local client
computer.

n

If you are copying formatted text, some of the data is text and some of the data is formatting
information. If you copy a large amount of formatted text or text and an image, when you attempt to
paste the text and image, you might see some or all the plain text but no formatting or image. The
reason is that the three types of data is sometimes stored separately. For example, depending on the
type of document you are copying from, images might be stored as images or as RTF data.

n

If the text and RTF data together use less than maximum clipboard size, the formatted text is pasted.
Often the RTF data cannot be truncated, so that if the text and formatting use more than the
maximum clipboard size amount, the RTF data is discarded, and plain text is pasted.

n

If you are unable to paste all the formatted text and images you selected in one operation, you might
need to copy and paste smaller amounts in each operation.

Dragging Text and Images
You can drag text and images from the Mac client to an open application in a remote desktop.
For example, you can drag text from Firefox on the Mac client and drop it into the WordPad application in
a remote desktop. Both plain text and Rich Text Format (RTF) text are supported.
A Horizon administrator can configure how much data, and the type of data, that you can drag. A Horizon
administrator can also disable this feature.
This feature has the following limitations.
n

You cannot drag text and images to a published application.

n

You cannot drag text and images from a remote desktop to the client device.

Using Published Applications
You can use many Mac functions with published applications.
n

When you run a published application, its icon appears in the Dock. You can maximize a minimized
published application by clicking its icon in the Dock.
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n

You can keep, open, and quit a published application from its context menu in the Dock. If you select
Keep in Dock, the published application icon remains in the Dock, even after you close all application
windows.

n

You can open a published application by clicking its icon in the Dock.

n

You can open local files in published applications and run published applications from the
Applications folder on the client system. To enable these features, see Share Access to Local Folders
and Drives with Client Drive Redirection.

n

Flashing Windows taskbar items are forwarded to Horizon Client. For example, if the published
application is an IM client and you receive a new message, a flashing red dot appears on the IM client
icon in the Dock.

n

You can start voice dictation, minimize, and zoom a published application from the menu bar.

n

You can use the Exposé feature to see open published applications, and you can press CommandTab to switch between open published applications.

n

You can use standard Mac keyboard shortcuts to interact with published applications. For example,
you can press Command-W to close an individual application window and Command-S to save the
current file. You can also use standard Mac keyboard shortcuts to copy, cut, and paste text between
applications on the Mac and published applications. You can customize keyboard shortcut mappings.
See Create Keyboard Shortcut Mappings.

n

If a published application creates a Windows System Tray item, that item appears in the notification
area on the menu bar on the Mac client system. You can interact with this item from the notification
area on the Mac in the same way that you interact with it from the System Tray on a Windows
system.
Note When you reclick a redirected System Tray item in the notification area on the Mac, the context
menu does not disappear.

Saving Documents in a Published Application
With certain published applications, such as Microsoft Word or WordPad, you can create and save
documents. Where these documents are saved depends on your company's network environment. For
example, your documents might be saved to a home share mounted on your local computer.
Contact your system administrator to find out where documents created in published applications are
saved in your environment.

Use a Local IME with Published Applications
If you use non-English keyboards and locales, you can use an IME (input method editor) that is installed
in the local client system to send non-English characters to a published application.

VMware, Inc.

23

VMware Horizon Client for Mac User Guide

You can use the Input menu in the menu bar on the Mac or keyboard shortcuts to switch to a different
IME. You do not need to install an IME on the server that hosts the published application.
Note On a Mac, an IME is called an input source.
When this feature is enabled, the local IME is used. If an IME is installed and configured on the server
that hosts the published application, that remote IME is ignored.
Prerequisites
n

Verify that one or more IMEs are installed in the client system.

Procedure

1

In theHorizon Client desktop and application selection window, Control-click a published application
and select Settings.

2

In the Remote Applications pane, select the Extend the local IME to hosted applications check
box.

3

Use the local IME as you might use it with locally installed applications.

The Input menu appears in the menu bar on the Mac client. When you use a published application, you
can switch to a different language or IME by using the Input menu or keyboard shortcuts. Key
combinations that perform certain actions, such as Command-C to copy and Command-V to paste, work
correctly.

Configure Reconnect Behavior for Published Applications
If you disconnect from a server without closing a published application, Horizon Client prompts you to
reopen that published application the next time you connect to the server. You can change this behavior
by modifying the Reconnect Behavior setting in Horizon Client.
Prerequisites

Obtain credentials for connecting to the server, such as a user name and password, RSA SecurID user
name and passcode, RADIUS authentication user name and passcode, or smart card personal
identification number (PIN).
Procedure

1

On the Horizon Client Home window, double-click the server icon.

2

If prompted, supply your credentials.

3

Click the Settings button (gear icon) in the upper right corner of the desktop and application selection
window.

4

Select Applications in the left pane of the Settings dialog box.

VMware, Inc.

24

VMware Horizon Client for Mac User Guide

5

Select an application reconnect behavior option.
These options determine how Horizon Client behaves when a user connects to the server and
published applications are still running.
Option

Description

Ask to reconnect to open applications

Horizon Client shows the message You have one or more remote applications
running. Would you like to open them now? You can respond by clicking
Reconnect to Applications or Not Now. You can also select the Don't show
this message again check box to suppress the message in the future. This
setting is enabled by default.

Reconnect automatically to open
applications

Horizon Client immediately reopens any running published applications.

Do not ask to reconnect and do not
automatically reconnect

Horizon Client does not prompt you to reopen running published applications, nor
does it reopen running published applications. This setting has the same effect as
the Don't show this message again check box.

The new setting takes effect the next time you connect to the server.

Using the Session Collaboration Feature
You can use the Session Collaboration feature to invite other users to join an existing remote desktop
session.

Invite a User to Join a Remote Desktop Session
When the Session Collaboration feature is enabled for a remote desktop, you can invite other users to
join an existing remote desktop session.
By default, you can send Session Collaboration invitations by email, in an instant message (IM), or by
copying a link to the clipboard and forwarding the link to users. To use the email invitation method, an
email application must be installed. To use the IM invitation method, Skype for Business must be installed
and configured. You can invite only users that belong to a domain that the server allows for
authentication. You can invite up to five users by default.
A Horizon administrator can disable the email and IM invitation methods, change the maximum number of
collaborators, and disable the Session Collaboration feature. For information about how the Session
Collaboration feature behaves at your company, contact your system administrator.
The Session Collaboration feature has the following limitations.
n

If you have multiple monitors, only the primary monitor is shown to session collaborators.

n

You must select the VMware Blast display protocol when you create a remote desktop session. The
Session Collaboration feature does not support PCoIP or RDP sessions.

n

Anonymous collaboration is not supported. Session collaborators must be identifiable through
Horizon-supported authentication mechanisms.
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n

Session collaborators must have Horizon Client 4.7 or later for Windows, Mac, or Linux installed, or
they must use HTML Access 4.7 or later. If a session collaborator has an unsupported version of
Horizon Client, an error message appears when the user clicks a collaboration link.

n

You cannot use the Session Collaboration feature to share Linux remote desktop sessions or
published application sessions.

Prerequisites

To invite users to join a remote desktop session, a Horizon administrator must enable the Session
Collaboration feature.
Procedure

1

Connect to a remote desktop for which the session collaboration feature is enabled.
You must use the VMware Blast display protocol.

2

In the system tray in the remote desktop, click the VMware Horizon Collaboration icon, for example,
.
The collaboration icon looks different depending on the Windows operating system version.

3

When the VMware Horizon Collaboration dialog box opens, enter the user name (for example,
testuser or domain\testuser) or the email address of the user that you want to join the remote
desktop session.
The first time you enter the user name or email address of a particular user, you must click Look up
"user", enter a comma (,), or press the Enter key to validate the user. The session collaboration
feature remembers the user the next time you enter the user's user name or email address.
You can invite up to five users by default. A Horizon administrator can change the maximum number
of users that you can invite.

4

Select an invitation method.
The following invitation methods are available by default. A Horizon administrator can disable the
email and IM invitation methods.
Option

Action

Email

Copies the collaboration invitation to the clipboard and opens a new email
message in the default email application. An email application must be installed to
use this invitation method.

IM

Copies the collaboration invitation to the clipboard and opens a new window in
Skype for Business. Press Ctrl+V to paste the link into the Skype for Business
window. Skype for Business must be installed and configured to use this invitation
method.

Copy Link

Copies the collaboration invitation to the clipboard. You must manually open
another application, such as Notepad, and press Ctrl+V to paste the invitation.
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After you send an invitation, the VMware Horizon Collaboration icon also appears on the desktop and the
session collaboration user interface turns into a dashboard that shows the current state of the
collaboration session and enables you to take certain actions.
When a session collaborator accepts your invitation and joins the session, the session collaboration
feature notifies you and a red dot appears on the VMware Horizon Collaboration icon in the system tray.
What to do next

Manage the collaborative session in the VMware Horizon Collaboration dialog box. See Manage a
Collaborative Session.

Manage a Collaborative Session
After you send a session collaboration invitation, the Session Collaboration user interface turns into a
dashboard that shows the current state of the collaborative session and enables you to take certain
actions.
Prerequisites

Start a collaborative session. See Invite a User to Join a Remote Desktop Session.
Procedure

1

In the remote desktop, click the VMware Horizon Collaboration icon in the system tray, or double-click
the VMware Horizon Collaboration icon on the desktop.
The names of all session collaborators appear in the Name column and their status appears in the
Status column.

2

Use the VMware Horizon Session Collaboration dashboard to manage the collaboration session.
Option

Action

Revoke an invitation or remove a
collaborator

Click Remove in the Status column.

Hand off control to a session
collaborator

After the session collaborator joins the session, toggle the switch in the Control
column to On.
To resume control of the session, double-click or press any key. The session
collaborator can also give back control by toggling the switch in the Control
column to Off, or by clicking the Give Back Control button.

Add a collaborator

Click Add Collaborators.

End the collaborative session

Click End Collaboration. All active collaborators are disconnected.
You can also end the collaborative session by clicking the VMware Horizon
Session Collaboration icon on the desktop and clicking the Stop button.
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Join a Collaborative Session
To join a collaborative session, you can click the link in a collaboration invitation. The link might be in an
email or instant message, or in a document that the session owner forwards to you. Alternatively, you can
log in to the server and double-click the icon for the collaborative session in the remote desktop and
application selector window.
This procedure describes how to join a collaborative session from a collaboration invitation.
You cannot use the following remote desktop features in a collaborative session.
n

USB redirection

n

Real-Time Audio-Video (RTAV)

n

Multimedia redirection

n

Client drive redirection

n

Smart card redirection

n

Virtual printing

n

Microsoft Lync redirection

n

File redirection and Keep in Dock functionality

n

Clipboard redirection

You cannot change the remote desktop resolution in a collaborative session.
Prerequisites

To join a collaborative session, you must have Horizon Client 4.7 for Windows, Mac, or Linux installed on
the client system, or you must use HTML Access 4.7 or later.
Procedure

1

Click the link in the collaboration invitation.
Horizon Client opens on the client system.

2

Enter your credentials to log in to Horizon Client.
After you are successfully authenticated, the collaborative session begins and you can see the
session owner's remote desktop. If the session owner transfers mouse and keyboard control to you,
you can use the remote desktop.

3

To return mouse and keyboard control to the session owner, click the VMware Horizon Session
Collaboration icon in the system tray and toggle the switch in the Control column to Off, or click the
Give Back Control button.

4

To leave the collaborative session, click Options > Disconnect.
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Modify the Horizon Client Shortcuts for Windows Actions
Horizon Client includes preconfigured shortcut mappings for common Windows actions, including Toggle
Full Screen, Quit, Hide Application, Cycle Through Windows, and Cycle Through Windows in Reverse. It
also includes a preconfigured shortcut mapping for Toggle Exclusive Mode. You can enable or disable the
default shortcuts. You cannot create shortcuts or delete the default shortcuts.
Procedure

1

Select VMware Horizon Client > Preferences and click Keyboard & Mouse.

2

Select the Horizon Shortcuts tab.

3

Modify the default shortcuts.
Option

Action

Enable a shortcut

Select the On check box next to the shortcut. When you enable a shortcut,
Horizon Client does not send the shortcut to the remote desktop or published
application.

Disable a shortcut

Deselect the On check box next to the shortcut. When you disable a shortcut,
Horizon Client sends the shortcut to the remote desktop or published application.
Note The behavior of the shortcut on the remote desktop or published
application can be unpredictable.

Restore the default settings

4

Click Restore Defaults. Any changes that you made are deleted and the default
settings are restored.

Close the Preferences dialog box.
Your changes take effect immediately. You do not need to restart open remote desktops or published
applications to make the changes take effect.
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4

You can reorder and drag and drop server, remote desktop, and published application shortcuts. You can
also select favorite remote desktop and published application shortcuts and remove server shortcuts from
the Horizon Client Home window.
This chapter includes the following topics:
n

Reordering Shortcuts

n

Dragging Shortcuts and URIs

n

Select a Favorite Remote Desktop or Published Application

n

Removing a Server Shortcut from the Home Window

Reordering Shortcuts
You can reorder server, remote desktop, and published application shortcuts.
Each time you connect to a server, Horizon Client saves a server shortcut to the Home window. You can
reorder these server shortcuts by selecting a shortcut and dragging it to a new position on the Home
window.
After you connect to a server, the available remote desktops and published applications on that server
appear in the desktop and application selection window. Remote desktop shortcuts appear first, followed
by published application shortcuts. Remote desktop shortcuts and published application shortcuts are
arranged alphabetically and cannot be rearranged.
When you are in the Favorites view (you clicked the Favorites button in the upper-right corner of the
desktop and application selection window), you can reorder remote desktop and published application
shortcuts by selecting a shortcut and dragging it to a new position on the window.

Dragging Shortcuts and URIs
You can drag server, remote desktop, and published application shortcuts and Uniform Resource
Identifiers (URIs).
You can drag a server shortcut from the Horizon Client Home window into another app, such as Notes.
The server shortcut appears as a URI in the other app, for example, vmware-view://server-address.
You can also drag a server address or URI from another app into the Home window.
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After you connect to a server, you can drag a remote desktop or published application shortcut from the
Horizon Client desktop and application selection window into another app, such as Notes. The shortcut
appears as a URI in the other app, for example, vmware-view://server-name/item-name.
If you drag a server, remote desktop, or published application shortcut from Horizon Client into a folder on
the Mac, Horizon Client creates a shortcut file in the folder. You can double-click this shortcut file to start
Horizon Client and connect to the server, remote desktop, or published application.

Select a Favorite Remote Desktop or Published
Application
You can select favorite remote desktops and published applications. Shortcuts for favorite items are
identified by a star and appear on the Favorites tab. Favorite items are saved after you log off from the
server.
Prerequisites

Obtain the credentials for connecting to the server, such as a user name and password or RSA SecurID
and passcode.
Procedure

1

On the Horizon Client Home window, double-click the server icon.

2

If prompted, supply your RSA user name and passcode, your Active Directory user name and
password, or both.

3

To select or deselect a favorite remote desktop or published application, perform these steps.

4

Option

Action

Select a favorite

Select the remote desktop or published application shortcut, press Control-click,
and select Mark as Favorite from the context menu. A star appears in the upperright corner of the remote desktop or published application shortcut.

Deselect a favorite

Select the remote desktop or published application shortcut, press Control-click,
and deselect Mark as Favorite from the context menu. A star no longer appears
in the upper-right corner of the remote desktop or published application shortcut.

(Optional) To display only favorite remote desktops or published applications, click the Favorites
button (star icon) in the upper-right corner of the desktop and application selection window.
You can click the Favorites button again to display all the available remote desktops and published
applications.

Removing a Server Shortcut from the Home Window
After you connect to a server, Horizon Client saves a server shortcut to the Home window.
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You can remove a server shortcut by selecting the shortcut and pressing the Delete key. Alternatively, you
can Control-click or right-click the shortcut on the Horizon Client Home window and select Delete.
You cannot remove remote desktop or published application shortcuts that appear after you connect to a
server.
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5

You can use keyboards, displays, microphones, and other external devices with remote desktops and
published applications.
This chapter includes the following topics:
n

Printing from a Remote Desktop or Published Application

n

Use USB Redirection to Connect USB Devices

n

Create Keyboard Shortcut Mappings

n

Modify the Horizon Client Mouse Shortcut Mappings

n

Monitors and Screen Resolution

Printing from a Remote Desktop or Published Application
You can print to a virtual printer or a USB printer that is attached to the local client computer from a
remote desktop or published application. Virtual printing and USB printing work together without conflict.

Enabling Virtual Printing in Horizon Client
When you use the VMware Blast display protocol or the PCoIP display protocol, you can use printers
configured for the Mac client from a remote desktop or published application. You do not need to install
printer drivers on a remote desktop to use the virtual printing feature.
You typically enable virtual printing the first time you start Horizon Client. Click Continue when
Horizon Client prompts you to start remote desktop USB and printing services and type your system
credentials.
If you do not enable virtual printing the first time you start Horizon Client, you can use the Connection
menu to enable virtual printing.
n

To enable virtual printing before you connect to a remote desktop or published application, select
VMware Horizon Client > Connection > Start Printing Services. Click Continue and type your
system credentials.
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n

To enable virtual printing after you connect to a remote desktop or published application, select
VMware Horizon Client > Connection > Start Printing Services. Click Continue, type your system
credentials, and reconnect to the remote desktop or published application. If you cancel the
reconnection, you can select Connection > Enable Printing and Horizon Client prompts you to
reconnect again.

When the virtual printing feature is enabled, the Connection menu displays Printing Enabled.
Note If you install Horizon Client on a Mac on which VMware Fusion was previously started, printing
services are already enabled when you start Horizon Client. This behavior occurs because VMware
Fusion and Horizon Client use some of the same files to implement virtual printing.

Set Printing Preferences for a Virtual Printer Feature on a Remote
Desktop
With the virtual printing feature, you can use local or network printers from a remote desktop without
having to install additional printer drivers in the remote desktop. For each printer available through this
feature, you can set preferences for data compression, print quality, double-sided printing, color, and
other settings.
After a printer is added on the local client computer, Horizon Client adds that printer to the list of available
printers in the remote desktop. No further configuration is required. If you have administrator privileges,
you can install printer drivers on the remote desktop without creating a conflict with the virtual printer
component.
Important This feature is not available for the following types of printers.
n

USB printers that use the USB redirection feature to connect to a virtual USB port in the remote
desktop.
You must disconnect the USB printer from the remote desktop to use the virtual printing feature with
it.

n

The Windows feature for printing to a file.
Selecting the Print to file check box in a Print dialog box does not work. Using a printer driver that
creates a file does work. For example, you can use a PDF writer to print to a PDF file.

This procedure applies to Windows 7 or Windows 8.x remote desktops. The procedure is similar, but not
exactly the same, for other types of Windows remote desktops.
Procedure

1

In the Windows 7 or Windows 8.x remote desktop, click Start > Devices and Printers.

2

In the Devices and Printers window, right-click the default printer, select Printer Properties from the
context menu, and select the printer.
Virtual printers might appear as <printer_name>, <printer_name>(s<session_ID>), or
<printer_name>#:<number> in the remote desktop.
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3

In the Printer Properties window, click the Device Setup tab and specify which settings to use.

4

On the General tab, click Preferences and specify which settings to use.

5

In the Printing Preferences dialog box, select the different tabs and specify which settings to use.
For the Page Adjustment advanced setting, VMware recommends that you retain the default
settings.

6

Click OK.

Using USB Printers
A USB printer is a printer that is attached to a USB port on the local client system. To send print jobs to a
USB printer, you can use the USB redirection feature or the virtual printing feature. Depending on network
conditions, USB printing can sometimes be faster than virtual printing.
Virtual printers and redirected USB printers can work together without conflict.
n

You can use the USB redirection feature to attach a USB printer to a virtual USB port in the remote
desktop, but only if the required drivers are also installed on the remote desktop.
If you use the USB redirection feature, the printer is no longer logically attached to the physical USB
port on the client, and it does not appear in the list of local printers on the local client machine. You
can print to the USB printer from the remote desktop, but you cannot print to the USB printer from the
local client machine. In the remote desktop, redirected USB printers appear as <printer_name>.
For information about how to connect a USB printer, see Use USB Redirection to Connect USB
Devices.

n

On some client systems, you can alternatively use the virtual printing feature to send print jobs to a
USB printer. If you use the virtual printing feature, you can print to the USB printer from both the
remote desktop and the local client system, and you do not need to install printer drivers in the
remote desktop.

Use USB Redirection to Connect USB Devices
With the USB redirection feature, you can use locally attached USB devices, such as thumb flash drives,
in a remote desktop or published application.
When you use the USB redirection feature, most USB devices that are attached to the local client system
become available from menus in Horizon Client. You use these menus to connect and disconnect the
devices.
The types of USB devices that you can redirect depend on how a Horizon administrator has configured
the remote desktop or published application.
If you use the client drive redirection feature to share a USB storage device or a folder on a USB storage
device, you cannot use the USB redirection feature to redirect the device to a remote desktop or
published application because the device is already shared.
You can connect USB devices to a remote desktop or published application either manually or
automatically.
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Prerequisites
n

To use USB devices with a remote desktop or published application, a Horizon administrator must
enable the USB redirection feature.

n

The first time you attempt to connect a USB device, you must provide the Administrator password.
Horizon Client prompts you for the password.
Some components required for USB redirection that Horizon Client installs must be configured, and
configuration of these components requires Administrator privileges.

n

Become familiar with USB Redirection Limitations.

Procedure
n

Manually connect the USB device to a remote desktop.
a

The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

b

Connect the USB device to the local client system.

c

From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB >
Connect to a desktop to list USB devices.

d

Connect to a remote desktop to list the connected USB devices and select a USB device.

The device is manually redirected from the local system to the remote desktop.
n

Connect the USB device to a published application.
a

The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

b

Plug in the USB device.

c

Open the published application.

d

Click the Settings button (gear icon) in the upper right corner of the desktop and application
selection window.

e

Select Applications in the left pane of the Settings dialog box.

f

Click USB at the top of the right pane of the Settings dialog box.
The available USB devices appear in the left pane.

g

Select a USB device and click Connect Device.
If a USB device is already connected to a remote desktop or application, you must disconnect the
device from the desktop or application before you can select it.
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h

Select a published application and click Continue.
You can select any running published application. After you select a published application, you
can use the USB device with the published application.

i

After you finish using the published application, open the Settings dialog box again, select USB,
and select Disconnect to release the USB device from the published application.
You can now use the USB device with your local client system, a remote desktop, or another
published application.

n

Configure Horizon Client to connect USB devices automatically to a remote desktop when you plug
them in to the local system.
Use the autoconnect feature if you plan to connect devices that use MTP drivers, such as Androidbased Samsung smart phones and tablets.
a

Before you plug in the USB device, start Horizon Client and connect to the remote desktop.

b

The first time you use the USB feature, from the VMware Horizon Client menu bar, click
Connection > USB > Start remote USB services and provide the Administrator password when
prompted.

c

From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB >
Automatically connect when inserted.

d

Plug in the USB device.

USB devices that you connect to your local system after you start Horizon Client are redirected to the
remote desktop.
n

Configure Horizon Client to connect USB devices automatically to a remote desktop when
Horizon Client starts.
a

The first time you use the USB feature, from the VMware Horizon Client menu bar in the remote
desktop, click Connection > USB > Start remote USB services and provide the Administrator
password when prompted.

b

From the VMware Horizon Client menu bar in the remote desktop, click Connection > USB >
Automatically connect at startup.

c

Plug in the USB device and restart Horizon Client.

USB devices that are connected to the local client system when you start Horizon Client are
redirected to the remote desktop.
The USB device appears in the remote desktop or published application. A USB device might take up to
20 seconds to appear in the remote desktop or published application. The first time you connect the
device to a remote desktop you might be prompted to install drivers.
If the USB device does not appear in the remote desktop or published application after several minutes,
disconnect and reconnect the device to the client computer.
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What to do next

If you have problems with USB redirection, see the topic about troubleshooting USB redirection problems
in the Configuring Remote Desktop Features in Horizon 7 document.

USB Redirection Limitations
The USB redirection feature has certain limitations.
n

When you access a USB device from a menu in Horizon Client and use the device in a remote
desktop, you cannot access the device on the local computer.

n

USB devices that do not appear in the menu, but are available in a remote desktop, include human
interface devices such as keyboards and pointing devices. The remote desktop and the local
computer use these devices at the same time. Interaction with these devices can sometimes be slow
because of network latency.

n

Large USB disk drives can take several minutes to appear in the remote desktop.

n

Some USB devices require specific drivers. If a required driver is not already installed on a remote
desktop, you might be prompted to install it when you connect the USB device to the remote desktop.

n

If you plan to attach USB devices that use MTP drivers, such as Android-based Samsung smart
phones and tablets, configure Horizon Client so that it automatically connects USB devices to the
remote desktop. Otherwise, if you try to manually redirect the USB device by using a menu item, the
device is not redirected unless you unplug the device and then plug it in again.

n

Webcams are not supported for USB redirection.

n

The redirection of USB audio devices depends on the state of the network and is not reliable. Some
devices require a high data throughput even when they are idle. Audio input and output devices work
well with the Real-Time Audio-Video feature. You do not need to use USB redirection for those
devices.

n

You cannot format a redirected USB drive in a published desktop unless you connect as an
administrator user.

Note Do not redirect USB Ethernet devices to a remote desktop. If the local system is connected, the
remote desktop can connect to the network. If you set the remote desktop to autoconnect USB devices,
you can add an exception to exclude the Ethernet connection. For information about configuring USB
redirection, see the VMware Horizon Client for Mac Installation and Setup Guide document.

Create Keyboard Shortcut Mappings
You can customize how remote desktops and published applications interpret Apple keyboard shortcuts
by creating keyboard shortcut mappings.
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When you create a keyboard shortcut mapping, you map an Apple keyboard shortcut to a Windows
keyboard shortcut. A keyboard shortcut consists of one or more key modifiers, such as Control and Shift,
and a key code. A key code can be any key on your keyboard, except for a modifier key. When you press
a mapped keyboard shortcut on your Apple keyboard, the corresponding Windows keyboard shortcut or
action occurs in the remote desktop or application.
If you attempt to map an operating system keyboard shortcut, the results can be unpredictable. For more
information, see Considerations for Mapping Operating System Keyboard Shortcuts.
Procedure

1

Select VMware Horizon Client > Preferences and click Keyboard & Mouse.

2

Select the Key Mappings tab.

3

Configure the keyboard shortcut mappings.
Option

Action

Delete a keyboard shortcut mapping

Select the mapping to delete and click the minus (-) button.

Add a keyboard shortcut mapping

a

Click the plus (+) button.

b

Specify the Apple keyboard shortcut sequence by clicking one or more
keyboard modifiers and typing a key code in the text box. You can also select
a key from the drop-down menu. The From: field shows the keyboard
shortcut that you created.

c

Specify the corresponding Windows keyboard shortcut sequence by clicking
one or more keyboard modifiers and typing a key code in the text box. You
can also select a key from the drop-down menu. The To: field shows the
keyboard shortcut that you created.

d

To save your changes, click OK.

The keyboard shortcut mapping is enabled by default (the On check box next to
the keyboard shortcut mapping is selected).
Modify a keyboard shortcut mapping

Double-click the mapping and make your changes.
n

To modify the Apple keyboard shortcut sequence, click one or more keyboard
modifiers and type a key code in the text box. You can also select a key from
the drop-down menu.

n

To modify the corresponding Windows keyboard shortcut sequence, click one
or more keyboard modifiers and type a key code in the text box. You can also
select a key from the drop-down menu.

To save your changes, click OK.

4

Disable a keyboard shortcut mapping

Deselect the On check box next to the keyboard shortcut mapping. When you
disable a keyboard shortcut mapping, Horizon Client does not send the Apple
keyboard shortcut to the remote desktop or application.

Enable or disable language-specific
key mappings

Select or deselect the Enable Language Specific Key Mappings check box.
The check box is selected by default.

Restore the default mappings

Click Restore Defaults. Any changes that you made to the default keyboard
shortcut mappings are deleted and the default mappings are restored.

Close the Preferences dialog box.
Your keyboard shortcut mapping changes take effect immediately. You do not need to restart open
remote desktops or published applications to make the changes take effect.

VMware, Inc.

39

VMware Horizon Client for Mac User Guide

Considerations for Mapping Operating System Keyboard
Shortcuts
Mac and Windows both include default keyboard shortcuts. For example, Command-Tab and CommandSpace bar are common keyboard shortcuts on Mac systems and Ctrl+Esc and Alt+Enter are common
keyboard shortcuts on Windows systems. If you attempt to map one of these operating system keyboard
shortcuts in Horizon Client, the behavior of the shortcut on the Mac client system and in the remote
desktop or published application can be unpredictable.
n

If you map a keyboard shortcut, how the shortcut behaves on the Mac client system depends on how
the operating system manages the shortcut. For example, the keyboard shortcut might trigger an
action in the operating system and Horizon Client might not respond to the shortcut. Alternatively, the
keyboard shortcut might trigger an action in both the operating system and Horizon Client.

n

Before you map a Mac keyboard shortcut in Horizon Client, you must disable the shortcut in System
Preferences on the Mac client system. Not all Mac keyboard shortcuts can be disabled.

n

If you map a Windows keyboard shortcut in Horizon Client, the mapped action occurs when you use
the shortcut in the remote desktop or published application.

n

For published applications, Windows shortcuts that include the Windows key are disabled by default
and do not appear on the Horizon Client Keyboard Preferences dialog box. If you create a mapping
for one of these disabled keyboard shortcuts, the shortcut appears in the Keyboard Preferences
dialog box.

For a list of the default Mac keyboard shortcuts, go to the Apple support website
(http://support.apple.com). For a list of the default Windows shortcuts, go to the Microsoft Windows
website (http://windows.microsoft.com).

Modify the Horizon Client Mouse Shortcut Mappings
You can configure a single-button Apple mouse to send a right-click and a middle-click to remote
desktops and published applications. You can modify, enable, or disable the default mouse shortcut
mappings. You cannot create mouse shortcut mappings, or delete the default mouse shortcut mappings.
Procedure

1

Select VMware Horizon Client > Preferences and click Keyboard & Mouse.

2

Select the Mouse Shortcuts tab.

3

Modify the mouse shortcut mappings.
Option

Action

Modify a mouse shortcut mapping

Double-click the mapping and make your changes. To save your changes, click
OK .

Disable a mouse shortcut mapping

Deselect the On check box next to the mouse shortcut mapping. When you
disable a mouse shortcut mapping, Horizon Client does not send the mouse
shortcut to the remote desktop or published application.
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4

Option

Action

Enable a mouse shortcut mapping

Select the On check box next to the mouse shortcut mapping. When you enable a
mouse shortcut mapping, Horizon Client sends the mouse shortcut to the remote
desktop or published application.

Restore the default settings

Click Restore Defaults. Any changes that you made to the default mouse
shortcut mappings are deleted and the default mappings are restored.

Close the Preferences dialog box.
Your mouse shortcut mapping changes take effect immediately. You do not need to restart open
remote desktops or published applications to make the changes take effect.

Monitors and Screen Resolution
When you use the VMware Blast display protocol or the PCoIP display protocol, you can extend a remote
desktop to multiple monitors. If you have a Mac with Retina Display, you can see the remote desktop in
full resolution.
With the VMware Blast display protocol or the PCoIP display protocol, a remote desktop screen resolution
of 4K (3840 x 2160) is supported. The number of 4K displays that are supported depends on the
hardware version of the desktop virtual machine and the Windows version.
Hardware Version

Windows Version

Number of 4K Displays Supported

10 (ESXi 5.5.x compatible)

7, 8, 8.x, 10

1

11 (ESXi 6.0 compatible)

7

3

(3D rendering feature disabled and Windows Aero disabled)
11

7

1

(3D rendering feature enabled)
11

8, 8.x, 10

1

13

8, 8.x, 10

4

Using Full-Screen Mode with Multiple Monitors
When a remote desktop window is open, you can use the Window > Enter Full Screen menu item or the
expander arrows in the upper-right corner of the remote desktop window to extend the remote desktop
across multiple monitors. You can select the Window > Use Single Display in Full Screen menu item to
make the remote desktop fill only one monitor.
The monitors do not have to be in the same mode. For example, if you are using a laptop that is
connected to an external monitor, the external monitor can be in portrait mode or landscape mode.
You can select a full-screen option from the Settings dialog box after you connect to a server and before
you open a remote desktop. Click the Settings button (gear icon) in the upper-right corner of the desktop
and application selection window, select the remote desktop, and select a full-screen option from the Full
Screen drop-down menu.
You can use the selective multiple-monitor feature to display a remote desktop window on a subset of
your monitors. For more information, see Select Specific Monitors in a Multiple-Monitor Setup.
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Using Remote Desktops with Split View
With Split View, which is supported in El Capitan (10.11) and later, you can fill your Mac screen with two
applications without manually moving and resizing windows. You can use Split View with remote desktops
in full-screen mode (Full Screen or Use Single Display in Full Screen option).

Using a High-Resolution Mac with Retina Display
If you use the VMware Blast display protocol or the PCoIP display protocol, Horizon Client supports high
resolutions for client systems that support Retina Display. After you connect to a remote desktop, you can
select the Connection > Resolution > Full Resolution menu item to enable a high-resolution mode.
This menu item appears only if the client system supports Retina Display.
In high-resolution mode, the DPI Synchronization feature ensures that the remote desktop's DPI setting
matches the client system's DPI setting. For more information, see Using DPI Synchronization.

Using DPI Synchronization
The DPI Synchronization feature ensures that the DPI setting in a remote desktop or published
application matches the client system's DPI setting. When you start a new remote session, Horizon Agent
sets the DPI value in the remote session to match the DPI value of the client system.
The DPI Synchronization feature is enabled when the following requirements are met.
n

The client system supports Retina Display.

n

Full-resolution mode (Connection > Resolution > Full Resolution) is selected in the remote
desktop.

n

If you use multiple monitors, the Retina Display is the primary window in system preferences. You
cannot have more than one display in full-screen mode.

The DPI Synchronization feature cannot change the DPI setting of an active remote session. If you
connect to an active remote session in full-resolution mode, Horizon Client scales the resolution to be
similar to when DPI Synchronization is enabled, but icons are not as clear. If you switch from normal to
full-resolution mode in an active remote session, Horizon Client prompts you to log off from the remote
session for the resolution change to take effect.
If you use a non-Retina Display computer when you start a remote session, and then use a Retina
Display computer to connect to the same session, the remote session cannot change to the new DPI
setting until after you log off.
A Horizon administrator can disable the DPI synchronization feature on a remote desktop.
Not all remote desktops support the DPI Synchronization feature. For more information, see the VMware
Horizon Client for Mac Installation and Setup Guide.
The DPI synchronization feature does not work with published applications.
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Select Specific Monitors in a Multiple-Monitor Setup
With the selective multiple-monitor feature, you can select the monitors on which to display a remote
desktop window. For example, if you have three monitors, you can specify that the remote desktop
window appears on only two of those monitors. This feature is not supported for published applications.
You can select up to four adjacent monitors.
Prerequisites

You must have multiple monitors.
Procedure

1

Start Horizon Client and log in to a server.

2

In the desktop and application selector window, right-click the remote desktop and select Settings.

3

From the Connect Via drop-down menu, select PCoIP or VMware Blast.

4

Select Use Selective Displays from the Full Screen drop-down menu.
Thumbnails of the monitors that are currently connected to the client system appear under Display
Arrangement. The display topology matches the display settings on the client system.

5

To select or deselect a monitor on which to display the remote desktop window, click a thumbnail.
When you select a monitor, its thumbnail changes color. If you violate a display selection rule, a
warning message appears.

6

Connect to the remote desktop.
Your changes are applied immediately when you connect to the remote desktop. The remote desktop
enters full-screen mode on the displays that you selected.

Using Exclusive Mode
Exclusive mode is similar to full-screen mode in that the remote desktop fills the screen. With exclusive
mode, unlike full-screen mode, the VMware Horizon Client menu bar and Dock do not appear when you
move your pointer to the edges of the screen.
To enter exclusive mode, open a remote desktop in windowed mode, press and hold down the Option
key, and select Window > Enter Exclusive Mode.
When a remote desktop is in windowed mode, you can also press Command-Control-Option-F to enter
exclusive mode. To exit exclusive mode, press Command-Control-Option-F again.
Note If you do not press and hold down the Option key, the Enter Full Screen menu item appears
instead of the Enter Exclusive Mode menu item. If the remote desktop is in full-screen mode, you cannot
select the Enter Excusive Mode menu item.
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To use exclusive mode with two monitors, before you open the remote desktop, select Use All Displays
from the Settings dialog box, and then open the desktop and enter exclusive mode. To use exclusive
mode with a single monitor, before you open the remote desktop, select Use Single Display from the
Settings dialog box, and then connect to the remote desktop and enter exclusive mode.
To open the Settings dialog box, click the Settings button (gear icon) in the upper right corner of the
desktop and application selection window, select the remote desktop, and select an option from the Full
Screen drop-down menu.
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6

You can configure Horizon Client to look for and install updates each time it starts. You can also look for
and install updates manually.
If Horizon Client detects a new version, you can download and install the new version, have
Horizon Client remind you to install the new version the next time it starts, or skip the new version. If you
skip a new version when looking for updates manually, the automatic update process also skips that
version.
Procedure
n

To configure Horizon Client to look for and install updates each time it starts, select VMware Horizon
Client > Preferences and select the Automatically check for updates check box.
The Automatically check for updates check box is selected by default.

n

To look manually for and install an update, select VMware Horizon Client > Check for Updates.
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7

You can solve most problems with Horizon Client by restarting or resetting remote desktops or published
applications, or by reinstalling Horizon Client.
This chapter includes the following topics:
n

Restart a Remote Desktop

n

Reset a Remote Desktop or Published Applications

n

Uninstalling Horizon Client

n

Connecting to a Server in Workspace ONE Mode

Restart a Remote Desktop
If the remote desktop operating system stops responding, you might need to restart a remote desktop.
Restarting a remote desktop is similar to using the Windows operating system restart command. The
remote desktop operating system usually prompts you to save any unsaved data before it restarts.
You can restart a remote desktop only if a Horizon administrator has enabled the restart feature for the
remote desktop.
Prerequisites

Obtain login credentials, such as a user name and password, RSA SecurID user name and password,
RADIUS authentication user name and password, or smart card personal identification number (PIN).
Procedure
u

In the desktop and application selection window, select the remote desktop shortcut, press Controlclick, and select Restart from the context menu.

The operating system in the remote desktop restarts and Horizon Client disconnects and logs off from the
remote desktop.
What to do next

Wait an appropriate amount of time for the system to restart before you attempt to reconnect to the
remote desktop.
If restarting the remote desktop does not solve the problem, you might need to reset the remote desktop.
See Reset a Remote Desktop or Published Applications.
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Reset a Remote Desktop or Published Applications
You might need to reset a remote desktop if the desktop operating system stops responding and
restarting the remote desktop does not solve the problem. Resetting published applications quits all open
applications.
Resetting a remote desktop is the same as pressing the Reset button on a physical PC to force the PC to
restart. Any files that are open on the remote desktop are closed and are not saved.
Resetting published applications quits the applications without saving any unsaved data. All open
published applications are closed.
You can reset a remote desktop only if a Horizon administrator has enabled the reset feature for the
remote desktop.
Procedure
u

Use the Reset command.
Option

Action

Reset a remote desktop from the
desktop and application selection
window

Select the remote desktop name, press Control-click, and select Reset from the
context menu.

Reset published applications from the
desktop and application selection
window

Click the Settings button (gear icon) in the upper right corner of the window,
select Applications in the left pane, click Reset, and click Continue.

When you reset a remote desktop, the operating system in the remote desktop restarts and
Horizon Client disconnects and logs off from the remote desktop. When you reset published applications,
the published applications quit.
What to do next

Wait an appropriate amount of time for system to restart before attempting to reconnect to the remote
desktop or published application.

Uninstalling Horizon Client
Sometimes you can resolve problems with Horizon Client by uninstalling and reinstalling Horizon Client.
To uninstall Horizon Client, use the same method that you use to uninstall any application.
Drag the VMware Horizon Client application from the Applications folder to the Trash and empty the
trash.
After Horizon Client is uninstalled, you can reinstall it.

Connecting to a Server in Workspace ONE Mode
You cannot connect to a server directly through Horizon Client, or your remote desktop and published
application entitlements are not visible in Horizon Client.
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Problem
n

When you try to connect to the server directly through Horizon Client, Horizon Client redirects you to
the Workspace ONE portal.

n

When you open a remote desktop or published application through a URI or shortcut, or when you
open a local file through file association, the request redirects you to the Workspace ONE portal for
authentication.

n

After you open a remote desktop or published application through Workspace ONE and
Horizon Client starts, you cannot see or open other entitled remote desktops or published
applications in Horizon Client.

Cause

Beginning with Horizon 7 version 7.2, a Horizon administrator can enable Workspace ONE mode on a
Connection Server instance. This behavior is normal when Workspace ONE mode is enabled on a
Connection Server instance.
Solution

Use Workspace ONE to connect to a Workspace ONE enabled server and access your remote desktops
and published applications.
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