You can install Horizon Client for Windows on PCs or laptops that use a supported Microsoft Windows operating system.

The PC or laptop on which you install Horizon Client, and the peripherals it uses, must meet certain system requirements.

Model

All x86 or x86-64 Windows devices

Memory

At least 1GB of RAM

Operating systems

The following operating systems are supported:

OS

Version

SP

Edition

Windows 10

32- or 64-bit

N/A

Home, Pro, Enterprise, IoT (Internet of Things) Enterprise, and LTSB (Long Term Servicing Branch)

Windows 8 or 8.1

32- or 64-bit

None or Update 2

Pro , Enterprise, and Industry Embedded

Windows 7

32- or 64-bit

SP1

Home, Enterprise, Professional, and Ultimate

Windows Server 2008 R2

64-bit

Latest Update

Standard

Windows Server 2012 R2

64-bit

Latest Update

Standard

Note:

Windows Server 2008 R2 and Windows Server 2012 R2 are supported for the purposes of running Horizon Client in nested mode. This mode is sometimes used for zero clients or thin clients, where, when the end user logs in to the zero client, Horizon Client automatically starts and logs the user into a remote desktop. From this remote desktop, the user launches hosted applications. In this setup, the remote desktop is either a single-user VDI desktop or a desktop provided by a Microsoft RDS host. In either case, to provide hosted applications, the Horizon Client software must be installed in the remote desktop. This setup is called nested because the client connects to a desktop that also has the client installed.

When the user runs Horizon Client in nested mode, remote desktop experience features such as device redirection and Real-Time Audio-Video are not available.

Connection Server, Security Server, and View Agent or Horizon Agent

Latest maintenance release of View 5.3.x and later releases

If client systems connect from outside the corporate firewall, VMware recommends that you use a security server or Access Point appliance so that client systems will not require a VPN connection.

Remote (hosted) applications are available only on Horizon 6.0 (or later) View servers.

Note:

Clients can also connect to the Access Point appliance, which is available with Horizon 6, version 6.2, or a later release.

Display protocol for View

VMware Blast, PCoIP, and RDP

Hardware Requirements for PCoIP and VMware Blast

  • x86-based processor with SSE2 extensions, with a 800MHz or higher processor speed.

  • Available RAM above system requirements to support various monitor setups. Use the following formula as a general guide:

    20MB + (24 * (# monitors) * (monitor width) * (monitor height))
    

    As a rough guide, you can use the following calculations:

    1 monitor: 1600 x 1200: 64MB
    2 monitors: 1600 x 1200: 128MB
    3 monitors: 1600 x 1200: 256MB
    

Hardware Requirements for RDP

  • x86-based processor with SSE2 extensions, with a 800MHz or higher processor speed.

  • 128MB RAM.

Software Requirements for RDP

  • For Windows 7, use RDP 7.1 or 8.0. Windows 7 includes RDP 7. Windows 7 SP1 includes RDP 7.1.

  • For Windows 8, use RDP 8.0. For Windows 8.1, use RDP 8.1.

  • For Windows 10, use RDP 10.0.

  • (Supported with View Agent 6.0.2 and earlier only) For Windows XP desktop virtual machines, you must install the RDP patches listed in Microsoft Knowledge Base (KB) articles 323497 and 884020. If you do not install the RDP patches, a Windows Sockets failed error message might appear on the client.

  • The agent installer configures the local firewall rule for inbound RDP connections to match the current RDP port of the host operating system, which is typically 3389. If you change the RDP port number, you must change the associated firewall rules.

You can download Remote Desktop Client versions from the Microsoft Download Center.