When the screen freezes, first, try resetting the remote desktop operating system.
Problem
Horizon Client does not work or repeatedly exits unexpectedly or the remote desktop freezes.
Cause
Assuming that View servers are configured properly and that firewalls surrounding them have the correct ports open, other issues usually relate to Horizon Client on the mobile device or to the guest operating system on the remote desktop.
Solution
What to do next
If the problem is with the operating system inside the remote desktop, see Reset a Remote Desktop or Application.