Various problems can arise with USB redirection in Horizon 8.

Problem

USB has its limitations. For more information, see Limitations Regarding USB Device Types. Scanner redirection, Real-Time Audio-Video, serial port redirection, and client drive redirection help to bypass these limitations for most use cases. VMware recommends using an alternate technology, when available, as USB redirection for audio, scanners, and so on, can be unreliable due to network latency.

USB redirection in Horizon Client fails to make local devices available on the remote desktop or application, or some devices do not appear to be available for redirection in Horizon Client.

Cause

USB redirection can fail to function correctly or as expected for the following reasons:
  • Verify the virtual operating system is supported. See Requirements and Considerations for Horizon Agent in the Horizon Installation and Upgrade document.
    Note: For server operating systems deployed as RDSH servers, there are limitations with supported devices. Storage drives and a limited set of lightweight device types are supported. For example, CDROM devices are not supported.
  • The device is a composite USB device and one of the devices it includes is blocked by default. For example, a dictation device that includes a mouse is blocked by default because mouse devices are blocked by default. To work around this problem, see Configuring Device Splitting Policy Settings for Composite USB Devices.
  • By default, Horizon Client for Windows does not allow you to select keyboard, mouse, smartcard, and audio-out devices for redirection. See Configuring Filter Policy Settings for USB Devices.
  • USB redirection is not supported for boot devices. If you run Horizon Client on a Windows system that boots from a USB device, and you redirect this device to the remote desktop, the local operating system might become unresponsive or unusable.
  • Network latency can cause slow device interaction or cause applications to appear frozen because they are designed to interact with local devices. Very large USB disk drives might take several minutes to appear in Windows Explorer and might be suited to client drive redirection.
  • USB flash cards formatted with the FAT32 file system are slow to load. See the Knowledge Base article Redirecting a USB flash drive might take several minutes.
  • A process or service on the local system opened the device before you connected to the remote desktop or application.
  • A redirected USB device stops working if you reconnect a desktop or application session even if the desktop or application shows that the device is available.
  • USB redirection is deactivated in the console.
  • Missing or deactivated USB redirection drivers on the guest.

Solution

  • If available, use VMware Blast or PCoIP instead of RDP as the protocol.
  • If a redirected device remains unavailable or stops working after a temporary disconnection, remove the device, plug it in again, and retry the redirection.
  • In the console, go to Policies > Global Policies, and verify that USB access is set to Allow under View Policies.
  • Examine the log on the guest for entries of class ws_vhub, and the log on the client for entries of class vmware-view-usbd.
    Entries with these classes are written to the logs if a user is not an administrator, or if the USB redirection drivers are not installed or are not working. For the location of these log files, see Using Log Files for Troubleshooting and to Determine USB Device IDs.
  • Open the Device Manager on the guest, expand Universal Serial Bus controllers, and reinstall the VMware View Virtual USB Host Controller and VMware View Virtual USB Hub drivers if these drivers are missing or re-activate them if they are deactivated.