The Connection Server installer has certain restrictions that can block the Connection Server installation process when you upgrade Connection Servers in parallel. These restrictions also apply to individual Connection Server upgrades and fresh installations of replica servers.

Problem

When you run the Connection Server installers while performing an upgrade or installation of Connection Servers, the Connection Server installer can display error messages and block the installation process.

Cause

Connection Server installation or upgrade errors can occur when the schema master node is not available or is removed from the LDAP cluster. The schema master node is deleted when a Connection Server instance is removed using the vdmadmin -S command without a clean uninstallation of LDAP instances.

Solution

  1. If the installation error occurs due to the unavailability of the schema master node, bring up all nodes in the LDAP cluster specified in the error message.
    If bringing up all nodes in the LDAP cluster does not resolve the issue, then the error can occur because the schema master node is removed from the cluster. Proceed to step 2 to troubleshoot the error.
  2. If the schema master node is removed from the LDAP cluster, you must make another node the schema master node on the cluster. The steps to make another node the schema master node on the cluster are based on whether any or none of the nodes are upgraded to the new version of VMware Horizon 8 or whether you are trying to install a new Connection Server replica.
    • If any node is upgraded to the new version of VMware Horizon 8 on the cluster, then you can use the vdmadmin -X command to make the current node the schema master node.

      If you are trying to install a new replica instance, run the vdmadmin -X command on another Connection Server instance in the cluster that has network connectivity with the replica node.

      • To make the current node the schema master node on the cluster for a local LDAP instance, enter the following command:
        vdmadmin -X -seizeSchemaMaster
      • To make the current node the schema master node on the cluster for a global LDAP instance in a Cloud Pod Architecture environment, enter the following command:
        vdmadmin -X -seizeSchemaMaster -global

      For more information about the vdmadmin -X command, see "Detecting and Resolving LDAP Entry and Schema Collisions Using the -X Option" in the Horizon Administration document.

    • If none of the nodes are upgraded to the new version of VMware Horizon 8 on the cluster, then use the dsmgmt command to make the current node the schema master node.
      • To make the current node the schema master node on the cluster for a local LDAP instance, enter the following command:
        dsmgmt "roles" "connections" "connect to server localhost:389" "quit" "transfer schema master" "quit" "quit"
      • To make the current node the schema master node on the cluster for a global LDAP instance in a Cloud Pod Architecture environment, enter the following command:
        dsmgmt "roles" "connections" "connect to server localhost:22389" "quit" "transfer schema master" "quit" "quit"
    If making the current node the schema master node does not resolve the issue, then the error can occur because the LDAP instance was locked during a failure to transfer the schema master role. Proceed to step 3 to troubleshoot the error.
  3. Remove the locks from the LDAP instance.
    • To remove the locks from a local LDAP instance, enter the following command:
      vdmadmin -X -deleteSchemaMasterLocks
    • To remove the locks from a global LDAP instance in a Cloud Pod Architecture environment, enter the following command:
      vdmadmin -X -deleteSchemaMasterLocks -global