VMware Integrated OpenStack with Kubernetes 4.1 supports Kubernetes version 1.8.1. You can upgrade clusters created using VMware Integrated OpenStack with Kubernetes 4.1 to be compatible with Kubernetes version 1.9.8.

The cluster upgrade is optional. For example, you do not need to upgrade a cluster to perform scale or delete operations using VMware Integrated OpenStack with Kubernetes 5.0.

Note:

VMware Integrated OpenStack with Kubernetes 4.1 clusters that have been upgraded to be compatible with Kubernetes 1.9.8 do not support new features in VMware Integrated OpenStack with Kubernetes 5.0.

Prerequisites

  • Verify that VMware Integrated OpenStack with Kubernetes has been upgraded to 5.0.

  • Verify that the cluster has more than one worker node.

Procedure

  1. Log in to the VMware Integrated OpenStack with Kubernetes VM.
  2. Run the CLI command.
    vkube cluster upgrade <ID>

    Where ID is the cluster ID.

Results

After upgrading, the cluster appears with Kubernetes version 1.9.8.