In a large VMware Live Site Recovery environment, you might encounter timeout errors when powering on virtual machines on a shared recovery site.

Problem

When you power on virtual machines on a shared recovery site, you see the error message Error:Operation timed out:900 seconds.

Cause

This problem can occur if a single vCenter Server instance manages a large number of virtual machines on the shared recovery site, for example 1000 or more.

Solution

  1. Increase the remoteManager.defaultTimeout timeout value on the VMware Live Site Recovery Server on the recovery site.
    For example, increase the timeout from the default of 300 seconds to 1200 seconds. For information about how to increase the remoteManager.defaultTimeout setting, see Change Remote Manager Settings in the VMware Live Site Recovery Administration.

    Do not increase the timeout period excessively. Setting the timeout to an unrealistically long period can hide other problems, for example problems related to communication between VMware Live Site Recovery Server and vCenter Server or other services that VMware Live Site Recovery requires.

  2. Open the vmware-dr.xml file in a text editor.
    The vmware-dr.xml file is located in the /opt/vmware/srm/conf/ directory.
  3. Set the timeout for reading from the vSphere Client.
    Set the timeout to 900 seconds (15 minutes) by adding a line to the <vmacore><http> element.
    <vmacore>
      <http>
        <defaultClientReadTimeoutSeconds>900</defaultClientReadTimeoutSeconds>
      </http>
    </vmacore>
  4. Restart the VMware Live Site Recovery Server service.

What to do next

If you still experience timeouts after increasing the RemoteManager timeout value, experiment with progressively longer timeout settings.