Reconfiguring VMware Live Site Recovery fails after you upgrade a vCenter Server 6.5.x or 6.7.x instance with an external Platform Services Controller to an embedded vCenter Server 7.x node.

Problem

When you attempt to reconfigure VMware Live Site Recovery after an upgrade of a vCenter Server 6.5.x or 6.7.x instance with an external Platform Services Controller to a vCenter Server with an embedded 7.x node, the operation fails with an error.
ERROR
Operation Failed
A general system error occurred: 22ConfigurationException Failed to configure DR server with the Infrastructure Node services. Reason: Fault cause: lookup.fault.EntryExistsFault

Exit code: 61

Cause

When you upgrade a vCenter Server 6.5.x or 6.7.x instance with an external Platform Services Controller to a vCenter Server 7.x instance with an embedded node the vCenter Single Sign-On site name id changes.

Solution

  1. Record the serviceId from the Error 61 message.
  2. Log in with vCenter Server credentials to https://<vCenter_Server_address>/lookupservice/mob/ on the protected site.
  3. Navigate to RetrieveServiceContent > Invoke Method > ServiceRegistration > Delete method to delete serviceId: <serviceId>.
  4. Log in to the VMware Live Site Recovery Appliance Management on the protected site as admin.
  5. Click Summary, click Reconfigure, and follow the prompts.
  6. Record the serviceId from the Error 61 message.
  7. Log in with vCenter Server credentials to https://<vCenter_Server_address>/lookupservice/mob/ on the recovery site.
  8. Navigate to RetrieveServiceContent > Invoke Method > ServiceRegistration > Delete method to delete serviceId: <serviceId>.
  9. Log in to the VMware Live Site Recovery Appliance Management as admin.
  10. In the VMware Live Site Recovery Appliance Management Interface, click Services.
  11. Select the srm-server service, click Stop, then click OK.
  12. SSH to the upgraded embedded vCenter Server, run the following command and take note of the vCenter Single Sign-On site name.
    /usr/lib/vmware-vmafd/bin/vmafd-cli get-site-name --server-name localhost
  13. SSH to VMware Live Site Recovery, run the following comment and take node of the db_id.
    echo "select * from pds_solutionuser;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
    Note: Password is the password for the embedded vPostgres database that you set during the installation of VMware Live Site Recovery.
  14. Run the following command.
    echo "update pds_solutionuser set siteid = 'default-first-site' where db_id =<db_id> ;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
  15. Log in to the VMware Live Site Recovery Appliance Management on the recovery site as admin and reconfigure VMware Live Site Recovery.
  16. Log in to VMware Live Site Recovery on the protected site.
  17. On the Site Recovery home tab, select a site pair, and click View Details.
  18. Select Site Pair > Summary, and click Reconnect.
    1. If you encounter an error, restart both VMware Live Site Recovery instances and vCenter Server instances and repeat the reconnect operation.
      Unable to connect to Site Recovery Manager Server at https://<SRM FQDN/IP>:443/drserver/vcdr/vmomi/sdk. 
      Reason: java.net.SocketTimeoutException: 30,000 milliseconds timeout on connection http-outgoing-431 [ACTIVE]