You might receive an error during the recovery process if the VMware Live Site Recovery solution user does not have permissions to perform an IP customization or in-guest OS callout operations.

Problem

If the VMware Live Site Recovery solution user does not have appropriate permissions to the guest OS of the recovered VM, you might receive one of the following error messages during the recovery process.
GuestPermissionDenied
CannotAccessFile

Cause

The problem appears if the VMware Live Site Recovery solution user is mapped to a guest OS user that does not have access to a file in the guest OS or permissions to run commands.

Solution

  1. If you use VMware Live Site Recovery to configure the guest user mappings, ensure that the guest OS user who runs the VMware Tools service has access to a file or has permissions to run commands.
    For information about how to activate or deactivate the automatic configuration of the guest user mappings, see Change Recovery Settings.
  2. (Optional) If you manually configure the guest user mappings, map the local VMware Live Site Recovery solution user on the recovery site to the guest OS user with appropriate permissions.
  3. Rerun the recovery plan.