When you attempt to cancel a Recovery Plan the status might remain as Not Completed.
Problem
When you attempt to cancel a recovery plan, the status is Not Completed.
Cause
When you run a recovery plan, an attempt is made to synchronize virtual machines. It is possible to cancel the recovery plan, but attempts to cancel the recovery plan run do not complete until the synchronization either completes or expires. The default expiration is 60 minutes.
Solution
You can use the following options to complete cancellation of the recovery plan.
- Pause vSphere Replication, causing synchronization to fail. After recovery enters an error state, use the vSphere Client to restart vSphere Replication in the vSphere Replication tab. After replication is restarted, you can run the the recovery plan again, if desired.
- Wait for synchronization to complete or time out. This might take considerable time, but does eventually finish. After synchronization finishes or expires, cancellation of the recovery plan continues.