Before you deploy Mirage, verify that the operating system requirements for each Mirage component that you install are satisfied.

Table 1. Operating System Requirements for Mirage Components

Component

Requirements

Mirage

client

  • Windows XP Professional with SP3, 32-bit

  • Windows Vista Business or Enterprise, 32-bit and 64-bit

  • Windows 7 Professional or Enterprise, 32-bit and 64-bit

  • Windows 8.0 and 8.1 Professional or Enterprise, 32-bit and 64-bit

  • Windows 10 Professional or Enterprise, 32-bit and 64-bit

  • Windows Server 2012 R2 standard or Datacenter Edition (Supported as a Branch Reflector only)

  • Windows Embedded Point of Service (WEPOS), 32-bit

  • Windows Embedded POSReady 2009, 32-bit

  • Windows Embedded POSReady 7, 32-bit and 64-bit

Important:
  • only supports updating WEPOS to POSReady 2009 as part of a base layer update procedure.

  • Enable virtual memory on Windows Embedded POSReady7 images before installing Mirage.

Mirage server

  • Windows Server 2008 R2 with SP1 Standard or Enterprise Edition, 64-bit

  • Windows Server 2012 Standard Edition, 64-bit

  • Windows Server 2012 R2 Standard or Datacenter Edition

  • Windows Server 2016 Standard or Datacenter Edition

  • Domain membership required.

Mirage Management server

  • Windows Server 2008 R2 with SP1 Standard or Enterprise Edition, 64-bit

  • Windows Server 2012 Standard Edition, 64-bit

  • Windows Server 2012 R2 Standard or Datacenter Edition

  • Windows Server 2016 Standard or Datacenter Edition

  • Domain membership required

Mirage file portal

  • Windows Server 2008 R2 with SP1 Standard or Enterprise Edition, 64-bit

  • Windows Server 2012 Standard Edition, 64-bit

  • Windows Server 2012 R2 Standard or Datacenter Edition

  • Windows Server 2016 Standard or Datacenter Edition

  • Domain membership required

Mirage Web Management

  • Windows Server 2008 R2 with SP1 Standard or Enterprise Edition, 64-bit

  • Windows Server 2012 Standard Edition, 64-bit

  • Windows Server 2012 R2 Standard or Datacenter Edition

  • Windows Server 2016 Standard or Datacenter Edition

  • Domain membership required

Mirage Management console

  • Windows XP Professional with SP3, 32-bit

  • Windows Vista Business or Enterprise, 32-bit and 64-bit

  • Windows 7 Professional or Enterprise, 32-bit and 64-bit

  • Windows 8.0 and 8.1 Professional or Enterprise, 32-bit and 64-bit

  • Windows 10 64-bit

  • Windows Server 2008 R2 with SP1 Standard or Enterprise Edition, 64-bit

  • Windows Server 2012 Standard Edition, 64-bit

  • Windows Server 2012 R2 Standard or Datacenter Edition

  • Windows Server 2016 Standard or Datacenter Edition

Mirage reference machine

  • Windows XP Professional with SP3, 32-bit

  • Windows 7 Professional or Enterprise, 32-bit and 64-bit

  • Windows 8.1 Professional or Enterprise, 32-bit and 64-bit

  • Windows 10 64-bit

Mirage Gateway server

The Mirage Gateway server runs on the SUSE Linux Enterprise Server 12 operating system. The OS is deployed during the Mirage Gateway installation.

Note:

Mirage Web Management is recommended over Mirage Image Service Management Console. The Mirage Web Management provides a modern and intuitive user experience and is generally recommended over the legacy Mirage Management Console.

Note:

Windows XP Fast User Switching mode must be disabled if the computer is not an AD domain member.

The following actions on a Windows 8 device are blocked:

  • Assign App layers (not as part of OS migration)

  • Assign Base Layers

  • Enforce layers (assigned as part of the migration process)