When upgrading NSX Intelligence using NSX Manager Unified Appliance 2.5.x, the upgrade process might sometimes fail at the UI plugin registration step.
Problem
nsx-intelligence> get upgrade progress-status ...output snipped... Upgrade step status: Name: update_plugin_registration State: TASK_FAILURE Errors: Registration of node failed with status code 400 Status file: wait_for_intelligence_server: resp_status: 200, body: b'{"results":[{"_links":[],"_revision":0,"_create_user":"admin","_create_time":1581934303820,"_last_modified_user":"admin","_last_modified_time":1581934303820,"_system_owned":false,"id":"default","path":"endpoints/default","end_point_address":"20.20.0.11","protocol":"https","thumbprint":"2d7efed079858e3b9d8b83647f38e48c177d56cbb1ab6669a8d63899be0a5206"}]}' Node Registration response - 400, b'{"error_code":400,"module_name":"common-service","error_message":"I/O error on GET request for \\\\\\"https://20.20.0.11/api/v1/node/version\\\\\\": No route to host (Host unreachable); nested exception is java.net.NoRouteToHostException: No route to host (Host unreachable)"}'
...output snipped... 2020-03-26 15:26:07,291 - Playbook failed at step update_plugin_registration. Run the command 'set debug-mode' followed by 'start upgrade-bundle VMware-NSX-Intelligence-appliance-1.1.0.0.0.15898874 step get_upgrade_task_history' for more info. { "info": "[MUS] UpgradeError: Playbook failed at step update_plugin_registration. Run the command 'set debug-mode' followed by 'start upgrade-bundle VMware-NSX-Intelligence-appliance-1.1.0.0.0.15898874 step get_upgrade_task_history' for more info.", "state_text": "CMD_ERROR", "state": 2, "body": null }
Cause
This problem can happen if the information about the NSX Manager Unified Appliance node is different from what is saved in the NSX Intelligence appliance. The NSX Manager Unified Appliance node's IP address or certificate might have changed since the last time the NSX Intelligence appliance was installed.
Solution
Update the information about the NSX Manager Unified Appliance node's IP address, certificate, and certificate thumbprint before resuming the NSX Intelligence upgrade process. Use the information provided in the VMware Knowledge Base article https://kb.vmware.com/s/article/78505 to resolve this problem.