The NSX Intelligence appliance deletion failed to complete.

Problem

An attempt to delete the NSX Intelligence appliance did not complete successfully.

Cause

If while the NSX Intelligence appliance's VM host is being powered off or deleted, a connectivity issue occurred between NSX Manager and vCenter Server, the deletion can fail.

Solution

Try to perform one or both of the follow suggested solutions.
  • Verify that the connectivity between the NSX Manager and the vCenter Server is intact.
  • Try deleting the NSX Intelligence appliance using the Force Delete option. After the delete operation is complete, verify that NSX Intelligence appliance's VM got deleted from vCenter Server. If the NSX Intelligence appliance's VM does not get deleted successfully, manually delete the VM from vCenter Server using the following high-level information. For more details, consult the documentation for your specific vCenter Server version.
    1. Log in to the vCenter Server that manages the VM host for the NSX Intelligence appliance.
    2. Power off the NSX Intelligence VM.
    3. Delete the NSX Intelligence VM from the datastore in the VM host.