An attempt to deploy the NSX Intelligence appliance resulted in the error message The credentials were incorrect or the account specified has been locked.

Problem

After the NSX Intelligence appliance installer was run, the error message The credentials were incorrect or the account specified has been locked is displayed when the installer was attempting to register the NSX Intelligence server with the NSX Manager

Cause

The registration step might have failed for one of the following reasons.
  • The Management Plane token might have expired. The token is only valid for 30 minutes.
  • The system time is not synchronized between the NSX Intelligence server host and the NSX Manager host.

Solution

  1. Ensure that the system time is synchronized between the NSX Intelligence server host and the NSX Manager host.
  2. If system times are synchronized, verify if there is any network latency.
  3. Remove the NSX Intelligence appliance and retry installing it again after synchronizing the system times or when the network latency is resolved.