An error is displayed after an attempt to log in directly to the NSX Intelligence appliance.

Problem

After a successful deployment of the NSX Intelligence appliance, the following error is displayed after trying to log in directly to the NSX Intelligence appliance using the IP address displayed on the NSX Intelligence appliance card.

The application server is unable to fulfill your request due to insufficient privileges. 
You do not have the privileges to access NSX Intelligence. (403 Forbidden)

Cause

You cannot access the NSX Intelligence appliance directly using the IP address assigned to the appliance. You can only access the NSX Intelligence user interface (UI) and features by logging in to the NSX Manager UI and clicking the Plan & Troubleshoot tab.

Solution

  1. From your browser, log in with the required privileges to an NSX Manager at https:<nsx-manager-ip-address>.
    Ensure that you have the required privileges to access the NSX Intelligence UI. See "Role-Based Access Control in NSX Intelligence" in the Using and Managing VMware NSX Intelligence document for more information.
  2. Navigate to the NSX Intelligence home page by clicking Plan & Troubleshoot tab.
  3. In the Discover & Plan section, select either Discover & Take Action or Recommendations.
  4. To learn more about the NSX Intelligence user interface and features, see "Getting Started with NSX Intelligence" in the Using and Managing VMware NSX Intelligence document.