The NSX Intelligence appliance deployed successfully, but there are some degraded services that exist.

Problem

The NSX Intelligence appliance deployed successfully, but the appliance's health is reported as Degraded. This Degraded health status is reported either immediately after the NSX Intelligence appliance is deployed or at a later stage in the appliance's life cycle .

Cause

The cause can be any of the following reasons.
  1. Service startup on NSX Intelligence depends on the receipt of specific configuration information from the NSX Manager Unified Appliance. During the initial NSX Intelligence startup, this configuration might take some time to finish and the NSX Intelligence appliance is expected to remain in the Degraded state for approximately 15 minutes.
  2. If this problem is observed during a different time in the NSX Intelligence appliance's life cycle, the problem might be due to one of the following reasons.
    1. A resource contention on the NSX Intelligence appliance occurred.
    2. There is not enough disk space available on the NSX Intelligence appliance.
    3. The NSX Intelligence appliance was recently rebooted.
    4. One or more NSX Intelligence services were shut down.
  3. The NSX Intelligence appliance's certificate is incompatible with the certificate on the NSX Manager Unified Appliance.

Solution

The following possible solutions correspond accordingly to the problems listed in the preceding Problems section.
  1. After the initial NSX Intelligence appliance deployment, you must wait for the initial configuration synchronization to finish. Wait for approximately 30 minutes after the system is powered on for the appliance to reach the Stable state. Refresh your web browser after the NSX Intelligence appliance is no longer in the Degraded state.
  2. The following are possible solutions for the preceding second cause.
    1. If the problem is due to a resource contention, allow about 30 minutes for the NSX Intelligence appliance's self-healing process to start.
    2. If the problem is due to a disk space allocation, examine the NSX Intelligence appliance alarms to locate partitions with a high latency or high usage. Take the appropriate actions to mitigate the problem or contact VMware technical support for further assistance.
    3. If the problem is due to a recent reboot, wait for the NSX Intelligence appliance to become stable. It can take 15–30 minutes for the NSX Intelligence appliance to stabilize depending on the underlying hardware.
    4. If the problem is due to a manual shutdown of one or more NSX Intelligence services, restart those services and their dependent services. Allow the NSX Intelligence appliance to become stable in the next 10–15 minutes after all the services have been restarted.
  3. Ensure that the certificates used for the NSX Manager Unified Appliance node or cluster are compatible with the certificate types listed in the "Preparing for NSX Intelligence Installation" topic in the Installing and Upgrading VMware NSX Intelligence document.

In none of the above solutions work, contact your VMware representative for assistance.