If your RHEL host is unsupported, manually upgrade your RHEL host to the supported version.

RHEL 7.5 requires the following dependencies for the LCP package and host components to work properly.

PyYAML, c-ares, libev, libunwind, libyaml, python-beaker, python-gevent, python-greenlet, python-mako, python-markupsafe, python-netaddr, python-paste, python-tempita

Prerequisites

Verify that the RHEL host is supported. See Supported Hypervisor Upgrade Path.

Procedure

  1. Navigate to the /etc/yum.conf file.
  2. Assign the upgrade to Red Hat 7.5.

    subscription-manager release --set=7.5

  3. Clear the YUM cache.

    yum clean all

  4. Update the YUM packages.
    yum update redhat-release-server
    yum update
  5. Download the Red Hat 7.5 Link Control Protocol (LCP) bundle.

    wget <RHEL_7.5_NSXT_23_LCP_URL>

  6. Unzip the downloaded tar LCP bundle.

    tar zxvf nsx-lcp-*rhel75_x86_64.tar.gz

  7. Install the RPM packages.
    yum install -y -v <Path-to-rpm-directory>/*.rpm && /etc/init.d/openvswitch force-reload-kmod && READ_INTERFACES=no /etc/init.d/openvswitch stop && /etc/init.d/openvswitch start && /etc/init.d/openvswitch start && /etc/init.d/nsxa restart