NSX Container Plug-in (NCP) has the following compatibility requirements for a Kubernetes environment and a Pivotal Cloud Foundry (PCF) environment.

Table 1. Compatibility Requirements for a Kubernetes Environment
Software Product Version
NSX-T Data Center 2.3, 2.4
Hypervisor for Container Host VMs
Container Host Operating System
  • RHEL 7.5, 7.6
  • Ubuntu 16.04
  • CentOS 7.4, 7.5
Container Orchestrator Kubernetes 1.12, 1.13
Container Host Open vSwitch 2.9.1 (packaged with NSX-T Data Center 2.3.x), 2.10.2 (packaged with NSX-T Data Center 2.4.0)
Table 2. Compatibility Requirements for a Cloud Foundry Environment
Software Product Version
Hypervisor for Container Host VMs
Container Orchestrator
  • Pivotal Application Service 2.3.x and Pivotal Operations Manager 2.3.x
  • Pivotal Application Service 2.4.x (except 2.4.0) and Pivotal Operations Manager 2.4.x (except 2.4.0)