NSX Container Plug-in (NCP) has the following compatibility requirements.

Software Product

Version

NSX-T Data Center

2.3, 2.4

Hypervisor for Container Host VMs

Container Host Operating System

RHEL 7.4, 7.5, 7.6

Platform as a Service

OpenShift 3.10, 3.11

Container Host Open vSwitch

2.10.2 (packaged with NSX-T Data Center 2.4)