NSX Cloud components need to be reinstalled if you are upgrading from versions 2.3 or earlier to versions 2.4 or later. If upgrading from versions 2.4 onwards, follow the upgrade workflow.