The NSX Network Detection and Response activation wizard failed to retrieve information about the available cloud regions.

Problem

NSX Network Detection and Response integrates with the NSX Advanced Threat Prevention cloud service for processing detection event data. Before you can activate the NSX Network Detection and Response feature, you must select a supported cloud region to which information about suspicious or malicious detection events is sent for processing. If the activation wizard fails to obtain the information about the available cloud regions, the feature activation is blocked from progressing.

Cause

The NSX Network Detection and Response activation service must connect to nsx.lastline.com on TCP port 443 to retrieve the list of available cloud regions. If the connection is unavailable, the activation wizard cannot retrieve this list.

Solution

  1. If your NSX Manager appliance is configured to use a web proxy for Internet-bound connections, ensure that the web proxy is configured correctly and is reachable from the workloads running in the Kubernetes cluster used for NSX Application Platform.
  2. Ensure that NSX Application Platform is deployed correctly and is reported as STABLE on the Systems > NSX Application Platform UI page.
  3. Close the NSX Network Detection and Response wizard and refresh your web browser to force the UI to reinitialize the list of available cloud regions.