You are unable to collect the NSX Application Platform support bundles using the NSX Manager UI.

Problem

You attempted to deploy or delete the NSX Application Platform but it failed before finishing the deploy or delete operation. Since the NSX Application Platform is no longer accessible, there is no way to access the support bundles using the NSX Manager UI to find out what caused the operation to fail.

Cause

There can be multiple reasons as to why the deploy or delete operation failed.

Solution

To find out the reason for the deploy or delete operation failure, use the following information to collect the support bundles using the NSX Manager CLI.
  1. Log into the NSX Manager appliance CLI as an admin user.
  2. Before generating the support bundle, enter the following command at the CLI prompt.
    set napp kubeconfig
  3. Enter the kubeconfig file content and press Ctrl+D.

    This action overrides any existing kubeconfig file used by the NSX Application Platform.

  4. Get the support bundle file using the following command, where support-bundle-filename is the filename that you want the system to use for the generated support bundle file.
    get support-bundle file support-bundle-filename.tgz
    

    If you entered a valid kubeconfig file content, you can find the NSX Application Platform support log files in the /napp folder after you unpack the support-bundle-filename.tgz file.

    If the kubeconfig file content that you entered is invalid, the /napp folder is empty.

  5. To transfer the support bundle file securely from the NSX Manager host to a remote host location, use the following command.
    copy file support-bundle-filename.tgz url remote-host-url

    The remote-host-url has the format scp://<username>@<ip-address>:<dir>, where <username> is a valid user account that has an access to the remote host, <ip-address> is the IP address of the remote host, and <dir> is the file folder to where the support bundle file is to be transferred.