NSX-T Container Plug-in has the following compatibility requirements related to Kubernetes and Ubuntu.

Software Product

Version

Hypervisor for Container Host VMs

  • ESXi 6.5

  • ESXi 6.5 Update 1

  • RHEL KVM 7.3

  • Ubuntu KVM 16.04

Container Host Operating System

  • RHEL 7.3

  • Ubuntu 16.04

Container Runtime

Docker 1.12

Container Orchestrator

Kubernetes 1.5, 1.6

Guest vSwitch

OVS 2.6, 2.7