The supported hypervisor upgrade paths from NSX-T 1.1 to NSX-T 2.0.

NSX-T 1.1

NSX-T 2.0

vSphere 6.0 Update 2 and Update 3

vSphere 6.5 U1

Ubuntu 14.04

Ubuntu 16.04 64-bit with KVM 4.4.0.x