The version of vCloud Director determines whether or not you should upgrade vShield Edge.

About this task

If you are using vCloud Director earlier than 8.10, you must not upgrade vShield Edge.

Additionally, if you are using vCloud Director 5.x, you must make a configuration change in the vCloud Directordatabase to prevent vCloud Director from upgrading the Edges on redeploy. See Prevent Legacy vShield Edge Redeployment in a vCloud Director Environment.

Starting in vCloud Director 8.10, NSX Edge 6.x is supported, and you can upgrade vShield Edge to NSX Edge 6.x. See Upgrade vShield Edge to NSX Edge in a vCloud Director Environment