NSX Manager is unable to deploy Endpoint Protection and an alarm error is displayed.

Problem

Attempting to install Endpoint Protection (EPP) will cause the alarm error “Installation of deployment unit failed, please check if ovf/vib URLs are accessible. This error occurs quickly after attempting installation.

Cause

The NSX Manager is unable to deploy or install a EPP VM and no VM is deployed.

Solution

  1. Verify if ESX Agent Manager (EAM) is up and running. After logging in to the NSX Manager, navigate to Home → Alarms tab, the installation status of the EAM connection appears as Not Ready after the NSX Manager or EAM service is restarted. Click Resolve.
  2. If EAM is not running, or if the EAM page has issues loading and rendering, restart EAM service.
  3. Check EAM logs for authentication issues. See Network port requirements for VMware NSX for vSphere 6.x (2079386) and ESX Agent Manager solution user fails to log in after replacing the vCenter Server certificates in vSphere 6.0 (2112577).
  4. Verify that all required ports are open between ESXi hosts, vCenter Server and NSX Manager, and are not being blocked by a Firewall. See TCP and UDP Ports required to access VMware vCenter Server, VMware ESXi and ESX hosts, and other network components (1012382).
    vSphere 6.x supports VIB downloads over port 443 (instead of port 80). This port is opened and closed dynamically. The intermediate devices between the ESXi hosts and VMware vCenter must allow traffic using this port.