Wrong product upgrade sequence causes an upgrade failure.

Problem

Upgrading Tanzu Kubernetes to version 1.23 before upgrading NSX Application Platform and NSX results in an upgrade sequence error.

Cause

The upgrade sequence error occurs due to a compatibility issue. NSX Application Platform and NSX must be first upgraded to the 4.1.1 release version for proper compatibility with the Tanzu Kubernetes 1.23 version.

Solution

  1. On each NSX Manager within a cluster, create a destination directory /tmp/oci-patch.
  2. Download the Kubernetes tools to the newly created directory.
  3. Use admin privileges to SSH into an NSX Manager.
  4. Install the packages.
    cd /tmp/oci-patch
    dpkg -i unified-appliance-oci-patch_3.2.x.nn15.deb
    dpkg -i kubectl_1.21.9-00_amd64.deb
    dpkg -i helm_3.8.0-1_amd64.deb

    After the packages are installed the impacted NSX services are restarted and OCI support becomes available.

  5. Change the default NSX Application Platform URLs to use the OCI support.
  6. Verify that the packages are installed properly and the directory contains backup rollback files.
    ls /image/add_oci_support_patch_old_files_backup/
  7. Redeploy NSX Application Platform 4.1.1 version.