An attempt to upload a version of the Kubernetes Tools failed.

Problem

The system was unable to complete the upload of the Kubernetes Tools bundle.

Cause

There can be multiple reasons for the upload failure. The following are some possible causes.

  • The Kubernetes Tools bundle filename is not in the correct format.

  • If you uploaded the Kubernetes Tools bundle file using a remote URL, the NSX Manager is unable to access that remote server.

Solution

  • Ensure that you have download the Kubernetes Tools bundle from the Broadcom support portal and that after the download, there is no tampering performed on the bundle. Do not rename the downloaded Kubernetes Tools bundle file.

  • If you uploaded the Kubernetes Tools bundle file to a remote server location using the Upload Remote File option to upload bundle, ensure the NSX Manager is able to connect to that remote server.