NSX Edge Transport Node connectivity to controller is down.
Problem
Cause
This issue is seen when connectivity to manager is up but connectivity to controller is down. Admin cmd ‘get managers’ returns active manager node while cmd 'get controllers’ does not return any active controller for this transport node with status connected and/or session-state UP.
Solution
- Verify transport node is not in NSX Maintenance Mode using admin cli get maintenance-mode or run the API, GET api/v1/transport-nodes/<tn-uuid>| state | status.
- Verify if FQDN property (used by transport-nodes to talk with NSX Manager/Controller) is set by running API, GET /api/v1/configs/management and view value for publish_FQDNS.
- If FQDN set, verify the controller FQDN is reachable and FQDN value is being used to by TN to talk to controller by first running ICMP ping to controller FQDN followed by admin cli get controllers to verify controller FQDN value is getting populated correctly.
- Verify node agent services are running by following node agent troubleshooting step outlined before.
- If edge transport node is in NSX Maintenance Mode, run admin cli set maintenance-mode false or API POST /api/v1/transport-nodes/<node-id>?action=exit_maintenance_mode to take node out of NSX Maintenance Mode
- If FQDN is set and ICMP ping works for controller FQDN then try unsetting and setting the FQDN property again by running API PUT /api/v1/configs/management with value for publish_fqdns false followed by true.
- Verify that agent services are running on the NSX Edge node by running get edge diagnosis config. If any service shows as failed, restart by running admin cli start service <service-name> or root cli etc/init.d/<service-name> start.