Error in a single or multiple network IP address results in a Tanzu Kubernetes Grid deployment failure.

Problem

Incorrect Management, Workload, or Frontend CIDR notations or DNS server information in a Tanzu Kubernetes Grid deployment causes failure.

Cause

Inaccurate Management, Workload, or Frontend CIDR notations CIDR notations or DNS server details cause the Tanzu Kubernetes Grid deployment to fail.

Solution

  1. In the NSX Application Platform Automation Appliance deployment wizard, stop the Tanzu Kubernetes Grid deployment.
  2. Wait for all the deployments to stop.
  3. Click Cleanup to remove the previous deployment tasks.
  4. Click Back to navigate to the Environment Configuration tab.
  5. Enter the correct Management, Workload, or Frontend CIDR notations and DNS server information.
  6. Navigate to the Deploy TKG tab and click Update & Redeploy.
    Note: If you update the Management, Workload, or Frontend CIDR notations or other network information after you start the Tanzu Kubernetes Grid deployment, these changes do not get applied to the ongoing deployment.

    With the accurate network configuration details, the Tanzu Kubernetes Grid deployment completes successfully.