Release 14.4.0

Release Date: June 21st, 2022

This topic describes the changes in VMware Postgres v14.4.0.

Supported Platforms

VMware Postgres is supported on Red Hat Enterprise Linux (RHEL) version 7, Red Hat Enterprise Linux (RHEL) version 8, and CentOS 7. This applies both to the core database software, as well as client components such as ODBC and JDBC.

Each RPM file included with VMware Postgres automatically installs additional operating-system package dependencies as needed. However, no Extra Packages for Enterprise Linux (EPEL) repository packages are required for VMware Postgres.

Network connectivity is required between all PostgreSQL hosts and clients.

ODBC support requires either the UnixODBC or iODBC driver manager on each client machine.

JDBC support requires Java 8 or higher on each client machine.

IMPORTANT: For Red Hat Enterprise Linux 64-bit 8.x (RHEL8) deployments:

  • Customers upgrading from RHEL7 to RHEL8 need to reindex all non-numeric indexes due to a change in glibc.
  • RHEL8 supports Python 3. Existing PL/Python customers who upgrade from RHEL7 to RHEL8 need to verify all their existing Python functions with Python 3.

Software Component Versions

VMware Postgres Version Component Component Version
14.4.0 PostgreSQL 14.4
pgBackRest 2.38
pg_auto_failover 1.6.4
pgbouncer 1.16.1
Patroni 2.1.3
Clients psqlODBC 13.02.0000
pgjdbc 42.3.2
Extensions PL/Java 1.5.8
PL/R 8.4.5
Orafce 3.20.0
PostGIS with
geos (v3.8.1),
proj (v4.9.3),
gdal (v2.4.4)
3.2.1
pgAudit 1.6.1

VMware Postgres 14 includes all of the contributed modules listed in Appendix F. Additional Supplied Modules of the PostgreSQL documentation.

Features

  • VMware Postgres 14.4.0 updates the PostgreSQL database version to 14.4. Postgres 14.4 resolves one key issue that could cause silent data corruption when using the CREATE INDEX CONCURRENTLY or REINDEX CONCURRENTLY commands. For more details on this issue, review the first entry in E.1.2 Changes.

    For details on the PostgreSQL 14.4 release, see Release Notes.

Upgrading to VMware Postgres 14.4

  • If you are using the PostGIS extension, you can only upgrade to 14.4 if you’re already on VMware Postgres 13.x. PostGIS customers on Postgres versions of 10, 11, or 12 cannot upgrade to 14.4.

    For upgrade details, see Upgrading VMware Postgres.

Known Issues and Limitations

  • 773 - In an HA configuration, a failover scenario overwrites the files that reside in the data directory. Therefore keep important read-only files outside the configured data directory. Common read-only files include SSL certificates, keys, or different configuration files for primary and mirrors.
  • Users of PostGIS on Postgres versions 10.x, 11.x, 12.x cannot upgrade to Postgres 14.4.0.
  • VMware does not support using the deprecated XML2 module.
  • All software components in this release, including the client ODBC and JDBC drivers, are supported only on Red Hat Enterprise Linux (RHEL) version 7 and CentOS 7 systems.

  • The xml2 extension is included in VMware Postgres, but it is deprecated and unsupported.
check-circle-line exclamation-circle-line close-line
Scroll to top icon