While rebooting your multi-node deployment, VMware Pulse IoT Center displays an error for various reasons.

Problem

While rebooting your multi-node deployment, a service failure error is displayed. After rebooting a node, the VMware Pulse IoT Center administrator can verify the service status by viewing the Services page of the VMware Pulse IoT Center Administrator console. It shows certain VMware Pulse IoT Center services as inactive or disabled.

When all the services are started and the UI is available, if a user logs in, a failure might occur because of an authentication error.

Cause

  • The nodes of a VMware Pulse IoT Center Server instance have not been shut down gracefully, and have been rebooted.
  • Node 2 or 3 have been powered on before Node 1 services are completely up and running.

Solution

  1. Ensure that you gracefully shut down all the nodes in the order Node 3, Node 2, and then Node 1 respectively.
  2. While you bring up the nodes, power on the VMs in the order Node 1 (wait until Node 1 services are up), followed by Node 2, and 3 accordingly. The VMware Pulse IoT Center administrator can verify whether all the services are up by logging into the VMware Pulse IoT Center Administration console, Services page.
  3. From the Services page, verify whether the Authentication Service (IAM) is up and running.