If you’re having trouble registering a Supervisor Cluster running in vSphere with Tanzu with Tanzu Mission Control, there are a number of steps you can take to identify the root cause and fix the problem.
Problem
You might suspect you’re having trouble registering your Supervisor Cluster if:
When registering your Supervisor Cluster, the verification step fails.
If you’re registering a Supervisor Cluster through the CLI, the operation times out.
If you’re registering a Supervisor Cluster through the API, the status of the cluster remains pending for longer than 7 minutes.
Cause
Cause
There are a few common reasons you might have trouble registering your Supervisor Cluster with Tanzu Mission Control. You can follow the solution described to identify which of these causes is the issue and help you correct it.
You might need to rerun the registration step if the agent installation failed. Common reasons for failure:
You might have tried to attach instead of register the Supervisor Cluster.
You might have tried to register a Supervisor Cluster using the Tanzu Kubernetes Grid procedure and seen a message like “no such resource found.”
You might have a resource scheduling issue or permission issue preventing the Tanzu Mission Control agent from installing successfully.
You might have a problem with connectivity or proxy configuration.
Solution
Example
The following tables contain examples of common errors and how to solve them.
Status |
Message |
Solutions |
|---|---|---|
INSTALLATION_IN_PROGRESS |
Installation in progress |
Wait until the installation completes. |
INSTALL_FAILED |
Registration link domain name verification failed |
Check the registration link. Make sure you see something like, |
INSTALL_FAILED |
Registration link is not an HTTPS link |
Check the registration link. Make sure you see something like, |
INSTALL_FAILED |
Get proxy options |
Verify the proxy configured in the cluster. |
INSTALL_FAILED |
Download manifest from link |
Make sure you downloaded and prepared the YAML from the Tanzu Mission Control Console as described in Complete the Registration of a Supervisor Cluster in vSphere with Tanzu. You might need to retry your registration procedure from the beginning. |
INSTALL_FAILED |
Parse manifest |
Make sure you downloaded and prepared the YAML from the Tanzu Mission Control Console as described in Complete the Registration of a Supervisor Cluster in vSphere with Tanzu. You might need to retry your registration procedure from the beginning. |
INSTALL_FAILED |
Apply manifest |
It's likely there aren't enough resources available for the agent to install successfully. Contact your vSphere administrator for help. |
Application |
Log |
Solutions |
|---|---|---|
Extension-Updater |
Failed to discover cluster metadata |
Make sure your cluster is CNCF conformant. You can check the CNCF site for a list of Platform Certified Kubernetes - Distribution Providers. |
Extension-Updater |
Failed to set up manager:get Tanzu Mission Control connection |
|
Extension-Updater |
Pre-flight checks failed Or something like tmc.extension-flag.register.tkg.version.block: 1.4.0 |
Make sure your cluster is using a version of kubernetes that is supported by Tanzu Mission Control. |
What to do next
If you can’t solve the issue on your own, you can create a log bundle to share with support. Run the following commands against your management cluster:
Get the logs of the extension-updater
kubectl logs -n svc-tmc-aN -l "tmc-extension-name=extension-updater"Get the logs of the extension-manager
<userinput> kubectl logs -n svc-tmc-aN -l "tmc-extension-name=extension-manager”Save the logs and create a bundle to share with support.
See How to Get Support if you need more information about contacting them.