For product versions and upgrade paths, see Upgrade Planner.

Breaking Change: As of Tanzu RabbitMQ v2.0, the format of the metrics emitted through the Loggregator system has changed. If you were using the Loggregator Firehose or Healthwatch to observe Tanzu RabbitMQ metrics in v1.x, you might need to alter any dashboards or queries previously configured to match the new metric names. For a list of the changes made in v2.0 to metric names, see Migrating Metrics from Tanzu RabbitMQ v1.x to v2.0.

Long-Term Support for VMware Tanzu RabbitMQ for VMs v2.0

Tanzu RabbitMQ v2.0 is a long-term supported (LTS) version. Tanzu RabbitMQ v2.0 is supported through April 2024.

Over the lifecycle of Tanzu RabbitMQ v2.0, VMware will release security patches that occasionally include feature enhancements and maintenance updates.

For more information about Tanzu RabbitMQ v2.0 LTS, please contact your Account Team.

v2.0.16

Release Date: June 24, 2022

Security Fixes

  • Important: Erlang has been updated to v24.3.4.2 to resolve CVE-2022-37026.

Resolved Issues

  • LDAP authentication no longer fails in some cases where connecting over TLS. For more information, see issue 4726 on GitHub.

Known Issues

This release has the following known issue:

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.3.4.2
HAProxy 1.8.30
OSS RabbitMQ* 3.8.34, 3.9.20
Stemcell 621.x
bpm 1.1.18
cf-cli 1.38.0
cf-rabbitmq 443.0.0
cf-rabbitmq-multitenant-broker 115.0.0
cf-service-gateway 75.0.0
cf-rabbitmq-smoke-tests 131.0.0
loggregator-agent 6.4.2
on-demand-service-broker 0.42.4
rabbitmq-metrics 79.0.0
rabbitmq-on-demand-adapter 211.0.0
routing 0.235.0
service-metrics 2.0.16

* For more information, see the v3.8.34 and v3.9.20 GitHub documentation.

v2.0.15

Release Date: May 24, 2022

Resolved Issues

This release fixes the following issues:

  • Updates RabbitMQ version to fix a CVE.

Known Issues

This release has the following known issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Service instances that use LDAP authentication over TLS can fail in some cases. This is fixed in v2.0.16. For more information about the issue, see issue 4726 on GitHub.
  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

Compatibility

The following components are compatible with this release:

\n
Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.3.4
HAProxy 1.8.30
OSS RabbitMQ* 3.9.18, 3.8.32
Stemcell 621.x
bpm 1.1.18
cf-cli 1.38.0
cf-rabbitmq 440.0.0
cf-rabbitmq-multitenant-broker 115.0.0
cf-service-gateway 74.0.0
cf-rabbitmq-smoke-tests 130.0.0
loggregator-agent 6.4.1
on-demand-service-broker 0.42.4
rabbitmq-metrics 79.0.0
rabbitmq-on-demand-adapter 210.0.0
routing 0.232.0
service-metrics 2.0.16

* For more information, see the v3.8.32 and v3.9.18 GitHub documentation.

v2.0.14

Release Date: May 12, 2022

Features

This release has the following change:

On-Demand instances using TLS now contain the static URL metrics.rabbitmq.pcf in the Subject Alternative Name of the RabbitMQ server TLS certificate.

Known Issues

This release has the following known issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.3.3
HAProxy 1.8.30
OSS RabbitMQ* 3.8.29, 3.9.15
Stemcell 621.x
bpm 1.1.17
cf-cli 1.38.0
cf-rabbitmq 433.0.0
cf-rabbitmq-multitenant-broker 114.0.0
cf-rabbitmq-smoke-tests 128.0.0
cf-service-gateway 71.0.0
loggregator-agent 6.3.13
on-demand-service-broker 0.42.4
rabbitmq-metrics 77.0.0
rabbitmq-on-demand-adapter 209.0.0
routing 0.232.0
service-metrics 2.0.16

* For more information, see the v3.8.29 and v3.9.15 GitHub documentation.

v2.0.13

Release Date: April 28, 2022

Resolved Issues

This release has the following fixes:

  • TLS no longer prevents metric exporting: Metrics can now be exported to the Firehose when TLS is enabled.
  • TLS no longer prevents metric scraping: Healthwatch v2 can now scrape metrics from on-demand instances when TLS is enabled.
  • RAFT log crashes no longer cause quorum queues to fail: If a RAFT log process crashes and a quorum queue member attempts to write to the log while it is unavailable, the quorum queue no longer crashes.

Known Issues

This release has the following known issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.3.3
HAProxy 1.8.30
OSS RabbitMQ* 3.8.29, 3.9.15
Stemcell 621.x
bpm 1.1.16
cf-cli 1.38.0
cf-rabbitmq 433.0.0
cf-rabbitmq-multitenant-broker 114.0.0
cf-rabbitmq-smoke-tests 128.0.0
cf-service-gateway 71.0.0
loggregator-agent 6.3.11
on-demand-service-broker 0.42.4
rabbitmq-metrics 77.0.0
rabbitmq-on-demand-adapter 207.0.0
routing 0.231.0
service-metrics 2.0.15

* For more information, see the v3.8.29 and v3.9.15 GitHub documentation.

v2.0.12

Release Date: April 19, 2022

Resolved Issues

This release has the following fixes:

  • Process leak fix: Routing release v0.231.0 fixes a process leak caused by constant reloading of HAProxy. For more information, see the release notes in GitHub.
  • Updated OpenSSL to v1.1.1n: Updated OpenSSL to v1.1.1n to address CVE-2022-0778.
  • Deleting pre-provisioned RabbitMQ v3.9 no longer causes failures: Deleting a pre-provisioned RabbitMQ v3.9 service instance no longer causes every other attempt when running cf delete-service to fail.

Known Issues

This release has the following known issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • TLS can prevent metric exporting: Metrics can’t be exported to the Firehose when TLS is enabled.
  • TLS can prevent metric scraping: Healthwatch v2 can’t scrape metrics from on-demand instances when TLS is enabled.
  • RAFT log crash can cause Quourm Queues to crash: If a RAFT log process crashes and a quorum queue member attempts to write to the log while it is unavailable, the quorum queue also crashes, causing further unavailability.
  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.3.2
HAProxy 1.8.30
OSS RabbitMQ* 3.8.28 3.9.14
Stemcell 621.x
bpm 1.1.16
cf-cli 1.38.0
cf-rabbitmq 428.0.0
cf-rabbitmq-multitenant-broker 112.0.0
cf-rabbitmq-smoke-tests 126.0.0
cf-service-gateway 69.0.0
loggregator-agent 6.3.8
on-demand-service-broker 0.42.4
rabbitmq-metrics 75.0.0
rabbitmq-on-demand-adapter 205.0.0
routing 0.231.0
service-metrics 2.0.15

* For more information, see the v3.8.28 and v3.9.14 GitHub documentation.

v2.0.11

Release Date: March 9, 2022

Features

New features and changes in this release:

  • RabbitMQ v3.9 pre-provisioned support: Pre-provisioned users can use RabbitMQ v3.9 for their service instances.
  • Extra vhost metrics: It is now possible to collect additional metrics about specific vhosts by using Loggregator. For more information, see Gather additional detailed metrics.

Known Issues

This release has the following known issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • Failure after deleting pre-provisioned RabbitMQ v3.9: Deleting a pre-provisioned RabbitMQ v3.9 service instance causes every other attempt when running cf delete-service to fail. This is fixed in v2.0.12 and later patches and in v2.1.0 and later patches.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.2.1
HAProxy 1.8.30
OSS RabbitMQ* 3.8.27 and 3.9.13
Stemcell 621.x
bpm 1.1.16
cf-cli 1.37.0
cf-rabbitmq 422.0.0
cf-rabbitmq-multitenant-broker 109.0.0
cf-rabbitmq-smoke-tests 121.0.0
cf-service-gateway 64.0.0
loggregator-agent 6.3.8
on-demand-service-broker 0.42.4
rabbitmq-metrics 71.0.0
rabbitmq-on-demand-adapter 201.0.0
routing 0.229.0
service-metrics 2.0.15

* For more information, see the v3.8.27 and v3.9.13 GitHub documentation.

v2.0.10

Release Date: February 18, 2022

Resolved Issues

This release has the following fixes:

  • Metrics when TLS is enabled: When TLS is enabled, the Prometheus endpoint is now correctly configured and metrics are now available.

Known Issues

This release has the following known issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.2.1
HAProxy 1.8.30
OSS RabbitMQ* 3.8.27 and 3.9.13
Stemcell 621.x
bpm 1.1.16
cf-cli 1.36.0
cf-rabbitmq 420.0.0
cf-rabbitmq-multitenant-broker 108.0.0
cf-rabbitmq-smoke-tests 120.0.0
cf-service-gateway 63.0.0
loggregator-agent 6.3.8
on-demand-service-broker 0.42.3
rabbitmq-metrics 70.0.0
rabbitmq-on-demand-adapter 196.0.0
routing 0.228.0
service-metrics 2.0.15

* For more information, see the v3.8.27 and v3.9.13 GitHub documentation.

v2.0.9

Release Date: January 20, 2022

Features

New features and changes in this release:

Resolved Issues

This release has the following fixes:

  • TLS support: The on-demand broker now communicates with the Cloud Foundry Cloud Controller over TLS.
  • OAuth2 errors are fixed: OAuth2 identification no longer hits errors when configured.

Known Issues

This release has the following issue:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Metrics unavailable when TLS enabled: When TLS is enabled, the Prometheus endpoint is misconfigured, resulting in metrics being unavailable.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.2
HAProxy 1.8.30
OSS RabbitMQ* 3.8.27, 3.9.12
Stemcell 621.x
bpm 1.1.15
cf-cli 1.36.0
cf-rabbitmq 413.0.0
cf-rabbitmq-multitenant-broker 106.0.0
cf-rabbitmq-smoke-tests 117.0.0
cf-service-gateway 60.0.0
loggregator-agent 6.3.7
on-demand-service-broker 0.42.3
rabbitmq-metrics 67.0.0
rabbitmq-on-demand-adapter 194.0.0
routing 0.228.0
service-metrics 2.0.15

*For more information, see the v3.8.27 and v3.9.12 GitHub documentation.

v2.0.8

Release Date: December 6, 2021

Resolved Issues

This release has the following fixes:

  • TLS v1.2 support is restored.

  • Improved network partition detection.

  • Instances running RabbitMQ v3.8 now emit disk and memory alarm metrics to the Loggregator subsystem.

Known Issues

This release has the following issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • OAuth2 errors: Enabling OAuth2 identification for RabbitMQ causes errors. This is fixed in v2.0.9.

  • TLS support: The on-demand broker does not support secure communications with the Cloud Controller over TLS. This is fixed in v2.0.9.

  • Metrics unavailable when TLS enabled: When TLS is enabled, the Prometheus endpoint is misconfigured, resulting in metrics being unavailable.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.1.5
HAProxy 1.8.30
OSS RabbitMQ* 3.8.25, 3.9.9
Stemcell 621.x
bpm 1.1.15
cf-cli 1.35.0
cf-rabbitmq 406.0.0
cf-rabbitmq-multitenant-broker 104.0.0
cf-rabbitmq-smoke-tests 115.0.0
cf-service-gateway 58.0.0
loggregator-agent 6.3.5
on-demand-service-broker 0.42.3
rabbitmq-metrics 65.0.0
rabbitmq-on-demand-adapter 191.0.0
routing 0.226.0
service-metrics 2.0.14

* For more information, see the v3.8.25 and v3.9.9 GitHub documentation.

v2.0.7 - Withdrawn

This release has been removed from Pivotal Network due to an issue in Erlang OTP v24.1.2 that causes TLS 1.2 to be unsupported.

This issue is fixed in Tanzu RabbitMQ v2.0.8.

Release Date: November 10, 2021

Features

New features and changes in this release:

Resolved Issues

This release has the following fix:

  • Smoke tests for the pre-provisioned offering no longer fail if mTLS is enabled: Smoke tests with mTLS enabled require additional configuration. For more information, see Provide SSL Certificates.

Known Issues

This release has the following issue:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • TLS 1.2 unsupported: Due to an issue in Erlang OTP v24.1.2, when TLS is enabled, only TLS 1.3 is supported.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • OAuth2 errors: Enabling OAuth2 identification for RabbitMQ results in errors.

  • TLS support: The on-demand broker does not support secure communications with the Cloud Controller over TLS. This is fixed in v2.0.9.

  • Disk and memory alarm metrics: Instances running RabbitMQ v3.8 do not emit disk and memory alarm metrics to the Loggregator subsystem.

  • Metrics unavailable when TLS enabled: When TLS is enabled, the Prometheus endpoint is misconfigured, resulting in metrics being unavailable.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x, 2.12.x
Erlang 24.1.2
HAProxy 1.8.30
OSS RabbitMQ* 3.8.23 and 3.9.8
Stemcell 621.x
bpm 1.1.15
cf-cli 1.34.0
cf-rabbitmq 404.0.0
cf-rabbitmq-multitenant-broker 103.0.0
cf-rabbitmq-smoke-tests 113.0.0
cf-service-gateway 57.0.0
loggregator-agent 6.3.4
on-demand-service-broker 0.42.2
rabbitmq-metrics 64.0.0
rabbitmq-on-demand-adapter 190.0.0
routing 0.225.0
service-metrics 2.0.14

* For more information, see the v3.8.23 and v3.9.8 GitHub documentation.

v2.0.6

Release Date: September 17, 2021

Resolved Issues

This release has the following fixes:

  • Management UI logs are rotated: This release re-introduces a cron job that rotates logs from the Management UI. This prevents old logs piling up and using all available disk space.
  • Prometheus endpoint with TLS no longer breaks the prom_scraper job: Configuring the Prometheus endpoint to use TLS no longer breaks the prom_scraper job.

Known Issues

This release has the following issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • Smoke tests for the pre-provisioned offering fail if mTLS is enabled: This is fixed in v2.0.7, but requires additional configuration. See Provide SSL Certificates for details.

  • OAuth2 errors: Enabling OAuth2 identification for RabbitMQ results in errors.

  • TLS support: The on-demand broker does not support secure communications with the Cloud Controller over TLS. This is fixed in v2.0.9.

  • Disk and memory alarm metrics: Instances running RabbitMQ v3.8 do not emit disk and memory alarm metrics to the Loggregator subsystem.

  • Metrics unavailable when TLS enabled: When TLS is enabled, the Prometheus endpoint is misconfigured, resulting in metrics being unavailable.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x
Erlang 23.3.4.6
HAProxy 1.8.30
OSS RabbitMQ* 3.8.22
Stemcell 621.x
bpm 1.1.13
cf-cli 1.33.0
cf-rabbitmq 388.0.0
cf-rabbitmq-multitenant-broker 101.0.0
cf-rabbitmq-smoke-tests 106.0.0
cf-service-gateway 55.0.0
loggregator-agent 6.3.4
on-demand-service-broker 0.42.1
rabbitmq-metrics 62.0.0
rabbitmq-on-demand-adapter 185.0.0
routing 0.223.0
service-metrics 2.0.14

* For more information, see the v3.8.22 GitHub documentation.

v2.0.5

Release Date: August 27, 2021

Resolved Issues

This release has the following fixes:

  • Queues with per-message TTL failing to recover indexes after a restart:
    This release sets the origin field to p-rabbitmq for metrics in the Loggregator subsystem and upgrades RabbitMQ to v3.8.21.
    These changes enable queues with per-message TTL to recover indexes after a restart. For more information, see issue 3272 in GitHub.
  • Metrics in the Loggregator subsystem lack an origin tag:
    This release enables configuration of arbitrary labels, which means labels can be specified when deploying cf-rabbitmq-release.

Known Issues

This release has the following issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • HTTP access logs can build up on disk and are not rotated as expected: This is fixed in v2.0.6.

  • Smoke tests for the pre-provisioned offering fail if mTLS is enabled: This is fixed in v2.0.7, but requires additional configuration. See Provide SSL Certificates for details.

  • TLS support: The on-demand broker does not support secure communications with the Cloud Controller over TLS. This is fixed in v2.0.9.

  • Disk and memory alarm metrics: Instances running RabbitMQ v3.8 do not emit disk and memory alarm metrics to the Loggregator subsystem.

  • Metrics unavailable when TLS enabled: When TLS is enabled, the Prometheus endpoint is misconfigured, resulting in metrics being unavailable.

Compatibility

The following components are compatible with this release:

Component Version
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, 2.11.x
Erlang 23.3.4.5
HAProxy 1.8.30
OSS RabbitMQ* 3.8.21
Stemcell 621.x
bpm 1.1.13
cf-cli 1.32.0
cf-rabbitmq 385.0.0
cf-rabbitmq-multitenant-broker 100.0.0
cf-rabbitmq-smoke-tests 105.0.0
cf-service-gateway 53.0.0
loggregator-agent 6.3.3
on-demand-service-broker 0.42.1
rabbitmq-metrics 61.0.0
rabbitmq-on-demand-adapter 184.0.0
routing 0.221.0
service-metrics 2.0.14

* For more information, see the v3.8.21 GitHub documentation.

v2.0.4

Release Date: July 14, 2021

Maintenance Changes

Maintenance change in this release:

  • Updated RabbitMQ to v3.8.18 and Erlang to v24: For more information, see RabbitMQ 3.8.18 in GitHub.

Resolved Issues

This release has the following fixes:

  • Smoke tests: This version fixes an issue that caused the smoke tests to fail with a buildpack error on the latest TAS versions.
  • Grafana Dashboards for on-demand instances: This version fixes a issue which caused Grafana dashboards for on-demand instances to fail rendering.

Features

New features and changes in this release:

Known Issues

This release has the following issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • Duplicated RabbitMQ server metrics when both the Healthwatch Exporter for TAS and the Healthwatch tile are installed: For v2 of the Healthwatch tile, installing the Healthwatch Exporter for TAS along with the Healthwatch tile results in duplicated metrics. This is because Heathwatch scrapes the metrics from both the Prometheus port of the RabbitMQ service instance and from the Loggregator system of TAS.

  • HTTP access logs can build up on disk and are not rotated as expected: This is fixed in v2.0.6.

  • Smoke tests for the pre-provisioned offering fail if mTLS is enabled: This is fixed in v2.0.7, but requires additional configuration. See Provide SSL Certificates for details.

  • TLS support: The on-demand broker does not support secure communications with the Cloud Controller over TLS. This is fixed in v2.0.9.

  • Disk and memory alarm metrics: Instances running RabbitMQ v3.8 do not emit disk and memory alarm metrics to the Loggregator subsystem.

  • Metrics unavailable when TLS enabled: When TLS is enabled, the Prometheus endpoint is misconfigured, resulting in metrics being unavailable.

Compatibility

The following components are compatible with this release:

Component Version
Erlang 24.0.2
HAProxy 1.8.30
OSS RabbitMQ* 3.8.18
Stemcell 621.x
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x
bpm 1.1.12
cf-cli 1.32.0
cf-rabbitmq 382.0.0
cf-rabbitmq-multitenant-broker 98.0.0
cf-rabbitmq-smoke-tests 103.0.0
cf-service-gateway 51.0.0
loggregator-agent 6.3.3
on-demand-service-broker 0.42.0
rabbitmq-metrics 59.0.0
rabbitmq-on-demand-adapter 180.0.0
routing 0.216.0
service-metrics 2.0.13

* For more information, see the v3.8.18 GitHub documentation.

v2.0.2

Release Date: May 26, 2021

Breaking Changes: The breaking changes listed for v2.0.0 also apply if you are upgrading from v1.21 to v2.0.2. See Breaking Changes below.

Security Fixes

This release includes the following security fix:

  • High CVE-2021-30465: runc v1.0.0-rc94 and earlier allows a container file system breakout through directory traversal.

Known Issues

This release has the following issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • HTTP access logs can build up on disk and are not rotated as expected: This is fixed in v2.0.6.

  • Smoke tests for the pre-provisioned offering fail if mTLS is enabled: This is fixed in v2.0.7, but requires additional configuration. See Provide SSL Certificates for details.

  • TLS support: The on-demand broker does not support secure communications with the Cloud Controller over TLS. This is fixed in v2.0.9.

  • Disk and memory alarm metrics: Instances running RabbitMQ v3.8 do not emit disk and memory alarm metrics to the Loggregator subsystem.

Compatibility

The following components are compatible with this release:

Component Version
Erlang 23.3.4
HAProxy 1.8.30
OSS RabbitMQ* 3.8.16
Stemcell 621.x
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, and 2.11.x
bpm 1.1.11
cf-cli 1.32.0
cf-rabbitmq 375.0.0
cf-rabbitmq-multitenant-broker 95.0.0
cf-rabbitmq-smoke-tests 101.0.0
cf-service-gateway 50.0.0
loggregator-agent 6.2.1
on-demand-service-broker 0.41.1
rabbitmq-metrics 58.0.0
rabbitmq-on-demand-adapter 176.0.0
routing 0.213.0
service-metrics 2.0.13

* For more information, see the v3.8.16 GitHub documentation.

v2.0.1

Release Date: May 21, 2021

Breaking Changes: The breaking changes listed for v2.0.0 also apply if you are upgrading from v1.21 to v2.0.1. See Breaking Changes below.

Maintenance Changes

Maintenance change in this release:

  • Updated RabbitMQ to v3.8.16: For more information, see RabbitMQ 3.8.16 in GitHub.

Resolved Issues

This release has the following fix:

  • Compatible with Ruby buildpack v1.8.33 and later: This version fixes the incompatibility with Ruby buildpack issue found in Tanzu RabbitMQ v2.0.0.

Known Issues

This release has the following issue:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • This release does not contain the fix to CVE-2021-30465: VMware recommends upgrading to v2.0.2 or later.

  • HTTP access logs can build up on disk and are not rotated as expected: This is fixed in v2.0.6.

  • Smoke tests for the pre-provisioned offering fail if mTLS is enabled: This is fixed in v2.0.7, but requires additional configuration. See the TLS documentation for details.

  • TLS support: The on-demand broker does not support secure communications with the Cloud Controller over TLS. This is fixed in v2.0.9.

  • Disk and memory alarm metrics: Instances running RabbitMQ v3.8 do not emit disk and memory alarm metrics to the Loggregator subsystem.

  • Metrics unavailable when TLS enabled: When TLS is enabled, the Prometheus endpoint is misconfigured, resulting in metrics being unavailable.

Compatibility

The following components are compatible with this release:

Component Version
Erlang 23.3.2
HAProxy 1.8.30
OSS RabbitMQ* 3.8.16
Stemcell 621.x
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, and 2.11.x
bpm 1.1.9
cf-cli 1.32.0
cf-rabbitmq 372.0.0
cf-rabbitmq-multitenant-broker 94.0.0
cf-rabbitmq-smoke-tests 98.0.0
cf-service-gateway 50.0.0
loggregator-agent 6.2.0
on-demand-service-broker 0.41.1
rabbitmq-metrics 56.0.0
rabbitmq-on-demand-adapter 175.0.0
routing 0.213.0
service-metrics 2.0.13

* For more information, see the v3.8.16 GitHub documentation.

v2.0.0

Release Date: April 14, 2021

Breaking Changes

Breaking changes in this release:

  • RabbitMQ Server Metrics: RabbitMQ Server metrics for both pre-provisioned and on-demand are now served using the rabbitmq_prometheus plugin. This changes the metrics emitted by the RabbitMQ Server component.

    In Tanzu RabbitMQ v1.x, queue depth and queue consumer metrics were emitted for every queue.
    In Tanzu RabbitMQ v2.0, queue metrics are aggregated by default.

    For more information about the aggregation, see the RabbitMQ documentation. For more information about the plugin, see Prometheus Plugin. For the full list of metrics now emitted, see the rabbitmq-server repository in GitHub.

  • Updated Firehose Metrics format: The underscore character has replaced all punctuation characters in the metric name. For example, the metric /on-demand-broker/p.rabbitmq/single-node/total_instances has become _on_demand_broker_p_rabbitmq_single_node_total_instances.

  • TLS v1.0 and v1.1 are no longer supported: Before upgrading to Tanzu RabbitMQ v2.0, update apps that use TLS v1.0 or v1.1 to use TLS v1.2 or v1.3.

Features

New features and changes in this release:

  • Expert users only — overriding the RabbitMQ server configuration: You can override the configuration applied by the Tanzu RabbitMQ broker or provide your own additional configuration to apply on RabbitMQ service instances. For more information, see Expert Mode - Overriding RabbitMQ Server Configuration.

  • Additional RabbitMQ server plugins for on-demand: These plugins are available for on-demand services:

    rabbitmq_auth_backend_cache, rabbitmq_auth_backend_http, rabbitmq_auth_backend_ldap, rabbitmq_auth_mechanism_ssl, rabbitmq_jms_topic_exchange, rabbitmq_tracing, rabbitmq_trust_store, rabbitmq_web_mqtt, rabbitmq_web_mqtt_examples, and rabbitmq_web_stomp_examples

    The plugins are disabled by default. For the complete list of plugins and for information about how to enable them, see RabbitMQ Server Plugins in Installing and Configuring the On-Demand Service.

  • TLS versions: TLS v1.2 and v1.3 are supported.

Known Issues

This release has the following issues:

Important: This version contains a release of Erlang that is affected by CVE-2022-37026. VMware strongly recommends upgrading to VMware Tanzu RabbitMQ for VMs v2.0.16 or later as soon as possible.

  • Changing the Erlang cookie can cause failed deployments: Changing the Erlang cookie value requires cluster downtime and can result in failed deployments. For more information, see Changing the Erlang Cookie Value Known Issue.

  • This release is incompatible with Ruby buildpack v1.8.33 and later: Upgrades to this version of Tanzu RabbitMQ fail the smoke test errand. This is fixed in v2.0.1.

  • This release does not contain the fix to CVE-2021-30465: VMware recommends upgrading to v2.0.2 or later.

  • HTTP access logs can build up on disk and are not rotated as expected: This is fixed in v2.0.6.

  • Smoke tests for the pre-provisioned offering fail if mTLS is enabled: This is fixed in v2.0.7, but requires additional configuration. See Provide SSL Certificates for details.

  • TLS support: The on-demand broker does not support secure communications with the Cloud Controller over TLS. This is fixed in v2.0.9.

  • Disk and memory alarm metrics: Instances running RabbitMQ v3.8 do not emit disk and memory alarm metrics to the Loggregator subsystem.

  • Metrics unavailable when TLS enabled: When TLS is enabled, the Prometheus endpoint is misconfigured, resulting in metrics being unavailable.

Compatibility

The following components are compatible with this release:

Component Version
Erlang 23.2.7
HAProxy 1.8.29
OSS RabbitMQ* 3.8.14
Stemcell 621.x
VMware Tanzu Application Service for VMs 2.7.x, 2.8.x, 2.9.x, 2.10.x, and 2.11.x
bpm 1.1.9
cf-cli 1.32.0
cf-rabbitmq 366.0.0
cf-rabbitmq-multitenant-broker 93.0.0
cf-service-gateway 48.0.0
cf-rabbitmq-smoke-tests 94.0.0
loggregator-agent 6.2.0
on-demand-service-broker 0.40.0
rabbitmq-metrics 55.0.0
rabbitmq-on-demand-adapter 174.0.0
routing 0.213.0
service-metrics 2.0.13

* For more information, see the v3.8.14 GitHub documentation.

View Release Notes for Another Version

To view the release notes for another product version, select the version from the dropdown at the top of this page.

check-circle-line exclamation-circle-line close-line
Scroll to top icon