You can upgrade the existing Workload Kubernetes Cluster version to the latest versions of Kubernetes supported in the current version of the VMware Telco Cloud Automation.

The following table lists the Kubernetes upgrade compatibility for the Workload cluster when upgrading from VMware Telco Cloud Automation.
VMware Telco Cloud Automation Existing Kubernetes Versions 1.20.15 1.21.11 1.22.9
2.0.0/2.0.1 1.19.8 Yes No No
2.0.0/2.0.1 1.19.9 Yes No No
2.0.0/2.0.1 1.19.12 Yes No No
2.0.0/2.0.1 1.19.16 Yes No No
2.0.0/2.0.1 1.20.4 Yes Yes No
2.0.0/2.0.1 1.20.5 Yes Yes No
2.0.0/2.0.1 1.20.8 Yes Yes No
2.0.0/2.0.1 1.20.14 Yes Yes No
2.0.0/2.0.1 1.21.2 No Yes Yes
2.0.0/2.0.1 1.21.8 No Yes Yes
2.1.0 1.20.15 No Yes No
2.1.0 1.21.11 No No Yes
2.1.0 1.22.9 No No No